Posts by Tuxer

    Alzo, immer mit der Ruhe...


    Du hast also jetzt erstmal VDR installiert, soweit so gut.
    Wie stehts mit einer DVB Karte?
    Hast du eine Budget- oder FF-Karte?


    Falls du eine FF Karte (diese hat einen Videoausgang) hast, kannst du dort direkt einen TV anschließen. Auf diesem wird dann das TV Bild, sowie das VDR OSD ausgegeben.


    Falls du keine FF Karte hast, dann würde ich dir folgendes empfehlen.
    Bau dir erst einmal eine kleine Basis auf.
    VDR + xine plugin + vdradmin-am
    Damit kannst du das TV Bild auf deinem PC Monitor ausgeben incl. VDR OSD.
    Anschließend kannst du dann versuchen die Geschichte mit der MediaMVP ans laufen zu bekommen.


    Deine Konstellation ist für den Anfang vielleicht etwas ungünstig. Du musst erstmal ein bisschen laufen lernen, bevor du voll einsteigen kannst.

    Hi,
    also ich gehe jetzt mal davon aus, dass du dir die "fertigen" VDR Pakete mit apt-get install <Paketname> installiert hast, oder?


    Falls ja, dann schau mal was passiert, wenn du folgenden Befehl ausführst:


    /etc/init.d/vdr start


    Unter /etc/init.d/ liegen normalerweise die init-Scripts mit deren Hilfe man services kontrollieren (also starten, stoppen, restarten, reloaden) kann.


    Habe VDR leider noch nie über apt-get installiert, aber hier ist es sicherlich ähnlich.

    Kurz und knapp, ja!


    Quote

    Original von hansp
    ich verwende zum ansehen der File ausschließlich die haupauge Media MVP (mit der mvpmc Software) soviel ich gesehen habe geht das mit VDR auch ?


    http://vdr-wiki.de/wiki/index.php/Vompserver-plugin


    Quote

    Original von hansp
    Das Programmieren der Aufnahmen mache ich über ein Webinterface , der Server steht im Keller und so kann das jedes Familienmitglied mit seinem PC machen.
    Geht das mit VDR auch ?


    http://vdr-wiki.de/wiki/index.php/Vdradmin_AM

    Quote

    na, alle halbe jahr einfach ne groessere hdd kaufen und die zu kleine wandert in den fileserver fuers archiv. smile -- randy


    Das ist bei mir langsam ein echtes Problem...
    Habe inzwischen schon zweimal meine Platten komplett getauscht, weil die Filme immer mehr werden. Immer zu Platten reinstecken ist ja auch doof, wegen Stromverbrauch und so.
    Ich mache es inzwischen so, dass ich gute Filme im VDR Format auf DVD brenne, die ich mir dann bei Bedarf angucke, dann muss ich das Zeug nicht ständig auf den Platten halten.
    Blöd ist hald nur, dass man dann immer öfter DJ spielen muss.
    Hier wäre ne Art Autoloader ne geniale Sache...
    Gibts sowas für DVD's eingeltich fertig, mit Laufwerk und linuxkompatibel?


    Noch was zum eigentlichen Thema:
    Ich setze mich inzwischen schon ca. 4 oder 5 Jahre mit VDR auseinander.
    Wenn sich die Frickelei im Rahmen hält, ist eine VDR Umgebuch bei mir inzwischen in relativ kurzer Zeit aufgesetzt, sodass man schnell wieder Fernsehen kann und seine Ruhe von der Bastelei hat.
    Einmal ist mit ne Platte kaputt gegangen, bei der Gelegenheit hab ich gleich mal auf die neue VDR Version upgedatet. Ansonsten fasse ich die Kiste im Wohnzimmer nicht mehr an.


    Ein Plugin Entwickler wird sicher weniger zum TV schauen kommen als ein Otto-Normal-VDR-User der seinen VDR mit fünf Plugins vllt noch selbst übersetzt.


    BTW:
    Seit ich das neue streamdev-plugin (mit der externremux.sh) am laufen habe gucke ich wieder viel mehr TV, da dieses Script das Tv gucken ja von fast überall aus möglich macht.
    Echt genial, wenn man auf der Arbeit nen TV Kanal nebenbei mitlaufen lassen kann, natürlich nur in der Mittagspause ;-)

    Also ich bediene meinen Streamdev-Server hauptsächlich über vdradmin-am -> Watch TV.
    Super zum Timer programmieren bzw. als Digitale TV Zeitschrift.
    Und zur Not kann man auch mal was an den Eisntellungen des VDR über das OSD ändern, ist zwar nicht so komfortabel, da das Bild nur alle paar Sekungen refresht, aber zu Not geht das schon.

    Also nochmal zur Ergänzung.


    Das Problem hatte nichts mit der FB oder der remote.conf bzw. remote-plugin zu tun.
    Die Plugins wurden schon gar nicht gestartet über mein runvdr script.


    Dort habe ich die Parameter wie folgt angegeben:


    "$VDRPROG \
    --cmd1 \
    --cmd2 \
    --cmdN"


    Aus irgendeinem Grund funktionierte das mit den Backslahses nicht, wenn ich alle Parameter in eine Zeile schreibe geht alles.


    Ich denke das Thema ist damit erledigt.


    Trotzdem Danke für eure Hilfe.

    Hallo,


    danke für deine schnelle Antwort!
    Ich glaube inzwischen, dass mein Problem ganz wo anders liegt...
    Ich nutze natürlich das Remote plugin, da habe ich mich vorhin etwas verwirrend ausgedrückt.
    Nur sehe ich gerade, dass meine Plugins überhaupt nicht geladen werden, wenn ich VDR über das runvdr Script starte.
    Da kann ich natürlich lange probieren :D
    Über die Shell funktioniert es ohne Probs.


    Mal gucken ob ich das hinbekomme...
    Ich muss heute unbedingt mal wieder früher ins Bett ;)

    Hallo liebes Forum,


    ich habe irgendwie das Gefühl, dass ich mich heute mal wieder besonders dumm anstelle...


    Folgendes Problem (wahrscheinlich wieder nur ne Kleinigkeit):


    Habe mir gerade meinen VDR neu ausgesetzt.
    Debian Lenny
    VDR 1.6.0
    Nexus-s Rev. 2.1 + angeschlossener IR Empfänger
    keine weiteren Plugins


    Nun kriege ich es nicht hin, meine Hauppauge FB beim Start von VDR anzulernen, es erscheint sofort das TV Bild wenn VDR startet und nicht der "Anlern" Dialog.
    Schön und gut, dass Problem hatten hier wohl schon mehrere User.
    Lösungsvorschlag: VDR stoppen, eine leere remote.conf erstellen und VDR wieder starten.
    Bringt nur leider irgendwie nüchts ;-(
    Selbes Spiel wie vorher.


    Der Witz ist aber, dass ich auf meinem Notebook die gleiche Konfiguration laufen habe (Lenny mit VDR 1.6.0 und zusätzlich das xine-plugin). Wenn ich hier die remote.conf lösche, dann geht VDR beim nächsten Start brav in den Lernmodus.
    Warum geht es bei der anderen Kiste nicht?


    Hier noch ein paar Logs (mit erstellter remote.conf).
    Leider keine besonderen Fehler zu sehen:


    Könnt ihr mir helfen?

    Da die onboard Controller eigenltich auch nix anderes sind als SoftRAIDs, stimme ich dir da zu.
    Gibt zwar Linuxtreiber für die Dinger, aber damit hast du nur Stress und Probleme.


    Das mit den beiden Platten gleichzeitig sollte natürlich die Ausnahme bleiben ;)
    Viel öfter kommt es zu logischen Fehlern, z.B. du (versehentlich) oder ein Virus löscht wichitge Files, dein FS klappt zusammen, soll auch schon vorgekommen sein, dass das RAID nach nem Stromausfall einfach weg war.


    Quote

    ch meine damit, dass ich glaube mit dem Raid erstmal "sicher" bin...zumindestens sicherer als ganz ohne. Mir ist btw. noch nie ne Festplatte abgeraucht *toi toi toi* Augenzwinkern


    Sicherer als ohne sind sie auf jeden Fall, jo :)


    Quote

    An LVM traue ich mich ehrlich gesagt nicht so dran. Mache das vielleicht irgendwann mal wenn ich ne Kiste zum testen habe aber so ist mir das zu heikel glaube ich.


    Ja das ganze ist ne Sache für sich, damit sollte man in ner VM erstmal ein bisschen spielen, da man sich mit ein paar Befehlchen schnell mal von ein paar Daten erleichtern kann. ;)


    Quote

    Ich möchte Debian 64-bit als Distri benutzen.


    Das ist schonmal ne gute Entscheidung, ich nehme mal an du verwendest Lenny, also Debian5?
    Verwende ich selbst auch.


    Quote

    Vielleicht könntest du mir im Näheren kurz erklären, wie ich das System nun zu installieren habe.
    Was wähle ich dann im Setup aus, wenn es darum geht die Festplatte zu partitionieren?


    Es gibt im Grunde zwei Wege ein SoftRAID anzulegen.
    1. Bei der Installation von Debian
    2. Nach der Installation, das heißt du installierst ganz normal, ohne spezielle RAID Einstellungen


    In deinem Fall würde ich Möglichkeit 2 für sinnvoll halten, da du zum Zeitpunkt der Installation noch nicht beide Platten verfügbar hast. Diese Möglichkeit bedeutet allerdings, dass du dein RAID von Hand konfigurieren musst.


    Hier würde ich dir folgende Anleitungen ans Herz legen:
    Für Möglichkeit 1 (Dieses Howto ist für eine etwas ältere Debian Version geschrieben worden, bei Lenny brauchst du die md-Module nicht von Hand laden, dass heißt du brauchst den expert26 Mode nicht, einfach Standardinstallation auswählen sollte reichen, alles andere geht wie beschrieben):
    =1]http://iomem.com/index.php?archives/7-Installing-Debian-Sarge-with-software-RAID.html&serendipity[entrypage]=1


    Für Möglichkeit 2 (habe ich selbst allerdings noch nicht getestet):
    http://www.fam.tuwien.ac.at/~schamane/sysadmin/ctsrvraid/


    Gerade wenn es um RAID und um kritische Daten geht, solltest du das ganze einmal in einer VM ausprobieren (sofern du die Möglichkeit hast), da kannst du sehen wie alles funktioniert und du kannst nichts kaputt machen.
    Auch kannst du einen Plattenausfall sowie einen Rebuild simulieren.
    Denn es wäre schon doof, wenn dir ne Platte abraucht und du dann am "offenen Herzen" versuchst zum ersten Mal einen rebuild zu machen.
    Könnte auch in die Hose gehen,


    Dazu gibt es hier noch ein paar Infos:
    http://tldp.org/HOWTO/Software-RAID-HOWTO-6.html


    Fragen? fragen!

    Hi,


    zu deinen Fragen:


    Quote

    Zur Verfügung habe ich eine 1TB WD Green und eine 1,5TB Samsung Festplatte. Nun ist mir die Idee gekommen, dass ich ja theoretisch ein Raid1 für meine Filme und die root Partition anlegen könnte und die Aufnahen, welche nicht so wichtig sind, auf den übrig gebliebenen Teil auslagere...


    Mit nem Linux Software RAID sollte das kein Problem sein, denn dort kannst du Teile deiner Platte als RAID oder als ganz normale Partition mit z.B. ext3 anlegen und auch beides gleichzeitig. Das Array wird hier aus Partitionen gebildet und nicht aus den Platten selbst, wie z.b. bei Hardware RAID.
    Wie es bei Hardware Raidcontrollern in Verbindung mit ungleichen Plattengrößen aussieht, kann ich dir leider nicht genau beantworten. I.d.R. ist es so, dass du mit nem RAID Controller im RAID1 immer die Kapazität der kleinsten Platte im Array zur Verfügung hast. Der Rest der größeren Platte ist für den User normal nicht sichtbar/nutzbar.


    Quote

    Ist sowas sinnvoll in punkto Ausfallsicherheit? (Mir ist klar, dass die Aufnahmen futsch sein können wenn die 1,5er ausfällt smile )


    Na wenn dir das klar ist, dann gibts ja eignetlich kein Problem ;)
    Was die Ausfallsicherheit angeht musst du am besten selbst entscheiden...
    Ist dir eine 99%ige Verfügbarkeit wichtig, oder macht es nix, wenn die Kiste mal 2 Tage down ist, wenn du nach dem Hardware crash neu installieren musst?
    Ich persönlich habe seit ich hier meinen Server betreibe die Platten im RAID laufen, der Speicher kostet ja auch fast nichts mehr. Es kommt hald auch immer auf den Anwendungsbereich an.


    Am Rande sei noch gesagt, das RAID sowieso niemals ein Backup ersetzt, denn:
    -dir können beide Platten gleichzeitg abrauchen
    -bei Hardware Raid kann dir der Controller abrauchen
    -Filesystemcrash
    -Virus
    -logische Fehler
    -usw.


    Ich würde dir folgendes empfehlen:
    Kauf dir noch ne zweite 1,5TB Platte und mach dir ein RAID1 aus den beiden 1,5ern.
    Die 1TB kannst du dann als Backup nutzen. Damit wären deine Daten+Filme erstmal ausfallsicher aufgehoben, denn mich würde es schon ein bisschen stören, wenn ich wegen ner kaputten HDD 500GB Filme verlieren würde ;)
    Die Filme brauchst du ja nicht mitsichern, dann würde der Platz der 1TB Platte für den Rest deines Arrays als Backup auch ausreichen.


    Quote

    Ein weiteres Problem dürfte darin bestehen, dass ich nur die 1TB Festplatte frei von Daten habe und auf dieser die Installation machen würde. Kann ich hinterher die 1,5er in das Raid einfügen und die Daten vorher rüber schaufeln?


    Jo, das ist kein Thema


    Quote

    Wie würde es aussehen, wenn ich später mal noch weitere Festplatten hinzufüge?


    Da stehen dir viele Möglichkeiten offen...
    Du kannst z.B. ein zusätzliches RAID1 Array hinzufügen, bestehend natürlich aus 2 zusätzlichen Platten.
    Dieses kannst du dann ganz normal als zusätzliche Partition mounten.
    Oder du baust von Anfang an alles mit LVM auf, dann kannst du dein bestehendes Array über ein weiteres Array erweitern. Du baust also soetwas wie ein RAID0 über zwei RAID1 Arrays und fügst diese damit zu einem größen Array zusammen.


    Hoffe ich konnte dir etwas weiterhelfen.


    Grüße


    Michael

    Hallo miteinander,


    hab mal wieder ne kleine Frage an euch ;-)
    Möchte mir ein Script schreiben, welches nachts um eine bestimmte Zeit Daten von einem auf den anderen Server kopiert. Das ganze realisiere ich mit Secure Copy und es haut soweit auch alles hin.
    Allerdings möchte ich nun das Script durch eine Log-Datei erweitern, bzw. alles was per SCP kopiert wird, soll in eine Logdatei geschrieben werden.


    Dazu habe ich mir überlegt, die Ausgabe von SCP mittels tee oder anderen Filedescriptoren (>, >>) in eine Datei umzuleiten. Normalerweise geht das bei herkömmlichen Befehlen auch problemlos.
    Doch SCP scheint sich dagegen irgendwie zu wehren, die Log-Datei bleibt leer.


    Aber da ja unter Linux bekanntlich nichts unmöglich ist, bin ich mir sicher, das es auch dafür eine Lösung gibt. Im Netz habe ich dazu leider nicht viel gefunden.


    Könnt ihr mir weiterhelfen??


    Gruß


    Tuxer

    Hi,
    habe das selbe bzw. ein änliches Problem mit einem AVBoard 1.4.
    Die LED leuchtet durchgehend rot.
    Zu Anfangs hat alles mal funktioniert.
    Der IR Empfänger geht seit dem nicht mehr.


    Diesen Zustand habe ich schon sehr lange, bin der Sache aus Zeitmangel aber noch nicht genauer auf den Grund gegangen.


    Es hat mich auch nicht weiter gestört, da ich den IR Empfänger zwar angeschlossen, aber nicht benutzt habe.


    Am AVboard, bzw. am Anschluss habe ich nichts weiter geändert.
    Alles was mir an dem Teil negativ aufgefallen ist, ist die Buchse zum Anschluss eines externen IR Empfängers.
    Diese hat bereits nach der Auslieferung Probleme gemacht (Taste für Wakeup ließ sich nicht programmieren).
    Hat sich dann herausgestellt, das die Buchse Schrott war, das heißt sie hat einen Kontakt überbrückt, der eigentlich nur bei eingestecketem Klinkenstecker überbrückt sein dürfte.
    Problem war durch umbiegen der Kontakte leicht behoben.


    Nun ist mir aber noch was total dummes passiert.
    Habe das AVBoard mit Slotblech eingebaut und beim einstecken eines svideo Steckers hats durch den Druck das Gewinde der Buchse aus dem Slotblech gerissen bzw. das Gewinde hats aus der Buchse gerissen.
    Könnte sein, das dadurch wieder irgendein Kontakt hergestellt wurde, welcher diesen Fehler verursacht.
    Aber wie gesagt, habe ich noch nicht weiter untersucht, da es mich bis jetzt nicht gestört hat.
    Schön ist die Sache natürlich trotzdem nicht.


    Lange Rede - kurzer Sinn, was ich damit sagen will, vllt liegts ja an deiner Buchse, das ist eigetnlcih die einzige Schwachstelle an dem Teil.


    STB kann da sicher mehr dazu sagen.


    Gruß


    Tuxer

    Ja, vielen Dank LordJaxom
    hab ja gesagt ich hab keine Ahnung von dem sch***. :doof


    schmirl , blazko
    ok, ich denke das reicht erstmal fürs erste.
    Wichtig ist für mich, das es schon mal jemand ohne viel Probleme geschafft hat VDR unter 64Bit zum laufen zu bekommen und das diese alten Probleme mit EPG,... geschichte sind.


    Was die VM angeht, werde ich wohl einfach ausprobieren müssen, und falls die Leistung nicht reicht, dann wird hald die Hardware gegen ne Dual-Core CPU getauscht, die ist in meiner WS sowieso überflüssig.
    Mein Board ist für Linux ja auch nicht das optimale (VIA Chipset, lag damals hald so rum...).

    Quote

    Original von schmirl


    Das hört sich eher nach einem 1. April-Beitrag von heise an. 64Bit ist die Registergröße mit der die CPU-Befehle arbeiten - und man kann ein Register nicht zwischen zwei Prozessen teilen :schiel


    Die Info hab ich von nem Bekannten bekommen, offensichtlich hat er auch nicht mehr Ahnung als ich...
    Ich weis nicht wie VMware die CPU nutzt, aufteilt oder verwaltet, deshalb hab ich hald das geschluckt, was er mir erzählt hat :-D


    Aber jetzt wo du das sagst, leuchtet mir das irgendwie ein, denn die CPU wird von VMware ja nicht emuliert, sondern die CPU selbst wird der VM (in-)direkt zur Verfügung gestellt (Befehle werden "durchgereicht", das ist wohl der richtíge Ausdruck). Bei VirtualPC glaube ich kann man eine CPU emulieren und für diesen Fall müsste die Aussage meines Bekannten allerdings zutreffen.


    Im Internet hab ich leider auch nirgens was gefunden, was sich mit diesem Thema auseinandersetzt.


    Nochmal zurück zu VDR:
    Die oben genannten Probs mit EPG und OSD sind bei dir also nicht aufgetreten?

    Hallo,


    so, jetzt muss ich auch mal wieder nachfragen, wie der aktuelle Stand der Dinge ist, bezüglich VDR und Athlon64 bzw. 64 Bit Umgebungen.


    Da mein damals erwähnter AMD64 mit dazugehöriger Hardware nun gut ein Jahr sauber und stabil seinen Dienst getan hat (mit 32 Bit) habe ich mir überlegt demnächst ein kleines Upgrade auf ein aktuelles Betriebssystem zu machen.


    Dabei ist mir natürlich auch die Überlegung gekommen, nun endlich auch die vollen 64Bit der CPU auszunutzen.


    Hauptgrund für die ganze Aktion ist, das ich meinen Server um einen VMware Server erweitern möchte, bzw. dies schon getan habe (aktuell auf dem 32Bit System).
    Allerdings leidet die Performance des Systems etwas darunter.


    Nun habe ich erfahren, das der VMware Server seine Fähigkeiten besser entfalten kann, wenn er unter einem 64Bit Wirtsystem läuft. Wenn ich z.B. zwei 32Bit VMs darunter laufen habe, würde der Server die Arbeit quasi auf die 64Bit verteilen, so wurde mir gesagt.


    Der VDR soll in meinem Fall auch nur als Streaming/Aufnahme Server laufen, das heißt, auf Plugins muss ich keine große Rücksicht nehmen.
    Alles was ich brauche ist VDR, streamdev, VDRadmin und vllt noch femon.


    Bin mir sicher, das einige von euch den VDR schon unter 64Bit nutzen ;-)


    Wäre klasse wenn mir da jemand noch ein kleines Feedback/Erfahrungsberichte zur Stabilität geben könnte, sollte das ganze denn funktionieren.


    Damit mich niemand falsch versteht, der VDR soll nicht in einer VM laufen!


    Danke


    Gruß


    Tuxer

    Hallo,


    leifg
    da nimmst du mir die Worte aus dem Mund, genau diese Probleme hatte ich zu meinen http-streaming-Zeiten auch.


    Seit dem verwende ich nur noch VTP in Verbindung mit dem VDR MediaClient von Onur.
    Da sind seit gut einem Jahr keine derartigen Probleme aufgetreten.
    Läuft superstabil!


    Da es aber den VDR MediaClient leider nicht für Linux gibt, brauche ich letztendlich wieder den mplayer.


    Den gepatchen MPlayer für VTP von http://xmltv.free.fr/mplayer-vtp/ habe ich bis heute nicht zum laufen gebracht, und ich hab nicht mal ne 64 Bit Architektur, bin entweder zu blöd, oder es ist wirklich nicht einfach.


    Was mich nun interessieren würde ist, ob der Tipp von ollir mit dem Cache abhilfe bei oben genannten Fehlern bringt.


    leifg
    Wäre toll, wenn du mir da ein kleines Feedback geben könntest, wie das ganze mit dem Cache läuft.
    Habe momentan leider nicht die Möglichkeit das ganze selbst zu testen.


    Danke schonmal im Voraus.


    Gruß


    Tuxer

    Hi,
    mit dem neuen VDR Filter geht alles perfekt.
    Habe das Ganze in Verbindung mit dem MediaPlayer Classic ausprobiert. Alle Probleme sind nun weg, keine zu schnelle Wiedergabe, keine Tonprobs und Spulen ist auch kein Problem mehr.


    Auch der Windows Media Player funktioniert einwandfrei.


    Echt ne klasse Arbeit!! :)
    Bin schon auf die nächsten Versionen gespannt.


    Vielen Dank für die Hilfe


    Gruß


    Tuxer