Posts by Hemonu

    Heute war einer von Unitymedia da, hat gemessen, hat die TV Dose gegen eine mit weniger Dämpfung getauscht. Vorführeffekt, alles bestens. Jetzt gerade, wieder am Abend, geht gar nichts mehr. Gut, Eins Festival HD, aber sonst nix. Das ist doch echt zum kotzen...

    Ich habe neben der Octopus C einen Sundtek-Stick und eine DD DVB-C im Einsatz. Mit der Octopus habe ich leider auch den schlechtesten Empfang und einige Transponder-Frequenzen sind komplett "tot". Das liegt bei mir nicht am Pegel, sondern an den Intermodulationen. Ich wohne auf dem Dorf und das Signal hat schon viele Verstärkerkaskaden durchlaufen. Jeder weitere Verstärker hebt zwar den Pegel an, aber verschlechtert das Intermodulations-Niveau. Zum Schluß machen dann schon minimale Unterschiede in der Empfänger-Hardware oder ein weiteres Rückkanal-Signal im Haus massiv etwas aus. Ich habe einen Meßempfänger mit Pegel, Spektrum etc., aber das Intermodulationsniveau lässt sich damit auch nicht messen. Evt. hilft es, wenn du die Tuner in der Octopus tauscht. Die Eingänge können unterschiedlich gut sein. Das hat bei mir auch schon mal geholfen.

    Argus :


    Ich habe ein kleines Gehäuse mit zwei 2.5" Festplatten im Einsatz (FANTEC MR-25DRE) . Archlinux ARM mit dem aktuellen Wandboard-Kernel 3.10.17 oder dem alten 3.0.35 kann beide Festplatten via eSATA ansprechen . Diesen Kernel gibt es auch für diverse andere Distris.

    Ich habe mir mitte März eine CuBox-i4 bestellt. Die Lieferung hat fast drei Monate gedauert inkl. 15 Tage für den Zoll bei der Einfuhr. Mittlerweile hat sich die Liefersituation aber wohl verbessert. Seit einigen Tagen bin ich dabei von einem Wandboard auf das neue Spielzeug umzuziehen. Endlich mal ein gutes Board in einem dekorativen Gehäuse. Die verbaute i.MX6 Hardware kenne ich schon von dem Wandboard. Für XBMC gibt es gute Unterstützung durch Stefan Rafin et al., unter ARCH Linux ARM direkt installierbar. Für VDR hoffe ich darauf, daß Copperhead in absehbarer Zeit armv7 unterstützen wird. Was fehlt ist ein Ausgabe-Plugin für den i.MX6. Also VDR zur Zeit nur headless oder via XBMC möglich.


    Herbert

    Ich hatte mal das gleiche Problem mit einer DD CT. Einige Sender gingen partout nur mit einem der beiden Tuner. Das Problem waren hochfrequente Einstrahlungen des PC in den Tuner der Karte. Sowohl ein Wechsel des Slots als auch ein wenig Alufolie zur Schirmung, haben das Problem damals beseitigt.


    Herbert

    It seems that ONet decryption requires client to specify the PMT pid via an extra parameter (x_pmt) - that's an special API extension by DD. Now, the VDR doesn't provide the PMT pid information of channels and implementing a PAT parser in the plugin is total overkill and therefore the VDR core should be modified to provide the required information.



    After having thought about it a while and looking into your code a bit, it seems to me that one feasible way would be to define an additional parameter with the PMT pid in the channels.conf. E.g.:


    ORF1 HD;ORF:11302:HC23M5O35P0S1X107: ...


    That would allow to calculate the extended uri and send the correct command. But it would be an additional parameter for a very special situation.


    Herbert

    Danke für den Tipp. Gleich getestet :). Ich kann dann auf der Octopus über das Webinterface sehen, dass der Tuner locked und ein rtp-Stream gestartet wird und dauerhaft läuft. Aber der VDR bleibt leider weiter dunkel. Vielleicht muss ich mich noch etwas gedulden. Das Plugin ist ja noch in einer sehr frühen Phase.


    Erstmal Danke an alle


    Herbert

    Du meinst eher ein CAM, oder?


    Das CI im Octopus Net ist noch nicht unterstützt, so mein letzter Kenntnisstand. Daher überrascht mich das es mit VLC bei Dir tun soll ... hmm, mal testen, hab auch ein AC Classic hier liegen ...


    Regards
    fnu

    Das CI der Octopus Net wird seit Firmware 1.0.17 unterstützt. In der Doku oder im Menü findet man allerdings nichts. Aber wenn ich das CAM (wo du Recht hast, hast du recht :) ) stecke, wird entschlüsselt und ich kann den Stream via VLC abspielen. Es geht also grundsätzlich.


    Herbert

    Ich teste momentan das Plugin zusammen mit einer Octopus Net und yaVDR 0.5 /VDR 2.0.3. In der Octopus Net steckt ein Alphacrypt Classic, welches ich für den ORF Empfang einsetze. Via VLC kann ich alle ORF Kanäle von der Octopus per rtsp streamen und die Kanäle werdern mit dem CI korrekt entschlüsselt.


    Wenn ich mit dem VDR einen verschlüsselten Kanal auswähle und im Kanal-Editor "frei empfangbar" einstelle, erscheint nach kurzer Zeit "Kanal nicht verfügbar" und im Kanal ist wieder "verschlüsselt" eingetragen. Der VDR versucht also selber zu entschlüsseln, was natürlich scheitert, weil das CI ja in der Octopus steckt.


    Hat schon jemand erfolgreich ein CI im Octopus Net in Betrieb?


    Herbert

    Du musst im satip/Makefile eine Anpassung vornehmen:

    Danke für den Tipp. Das hat aber leider nichts geändert


    Herbert

    Bist Du sicher, dass Du 'depmod -a' ausgeführt hast? Versuch einfach mal die Schritte im script von Hand auszuführen: Kopier das Kernel Modul an eine Stelle die passen könnte (z.B. /lib/modules/3.2.0-59-generic/kernel/drivers/media/common/tuners), führe 'depmod -a' aus und versuche dann mal ein 'modprobe vtunerc'.

    Ja, das hatte ich bereits so versucht:

    Code
    1. root@vdr-cube:~# modprobe -v vtunercinsmod /lib/modules/3.2.0-59-generic/kernel/drivers/media/dvb/vtunerc.koFATAL: Error inserting vtunerc (/lib/modules/3.2.0-59-generic/kernel/drivers/media/dvb/vtunerc.ko): Invalid argument
    2. root@vdr-cube:~# dmesg | grep dvb[ 4.539880] v4l-dvb-saa716x: 0dab24906ff057b72537b01605bdf06c4dbb1c62 saa716 x: i2c_del_adapter() fix[ 14.065811] v4l-dvb-saa716x: 0dab24906ff057b72537b01605bdf06c4dbb1c62 saa716 x: i2c_del_adapter() fix[ 544.828963] vtunerc: disagrees about version of symbol dvb_dmxdev_init[ 544.828971] vtunerc: Unknown symbol dvb_dmxdev_init (err -22)[ 544.829016] vtunerc: disagrees about version of symbol dvb_register_adapter[ 544.829021] vtunerc: Unknown symbol dvb_register_adapter (err -22)[ 544.829042] vtunerc: disagrees about version of symbol dvb_dmx_swfilter_packe ts



    Ich habe allerdings nicht linux-media-dkms sondern media-build-experimental-dkms aus dem Gandalf ppa installiert, da ich eine recht neue DVB-C DD-karte habe.

    Ergänzung 28.2.:
    Wenn ich media-build-experimental rausnehme, geht es. Natürlich funktioniert meine DD Karte dann nicht mehr. Mit media-build-experimental wird der Treiber gegen den Kernel korrekt kompiliert, passt aber nicht zu dem geladenen dvb-core aus dem media-build-experimental




    Herbert



    Hallo Snorre,


    erst mal Danke für die Mühe, die Du Dir gemacht hast. Ich habe das Skript getest, aber leider ohne Erfolg.


    Umgebung:


    YAVDR 0.5 mit Linux-media-dkms


    Kernel 3.2.0-59-generic


    Das Kopieren des Treibers funktioniert, aber loadmod.sh scheitert, weil das Zielverzeichnis für vtunerc.ko bei mir nicht existiert. Wenn ich das korrigiere, kommt es beim Laden des modules zu dem Fehler 'invalid argument' und im syslog sehe ich, dass diverse Symbole nicht aufgelöst werden können.


    Ich habe ein wenig gegoogelt und gefunden, dass das ein Problem mit den Kernel-Headern ist.


    Welchen Kernel und welches Treiberpaket verwendest Du?


    Gruss


    Herbert

    Würde ein einfaches Beispiel-Programm zum Empfang eines TS von der OctopusNet helfen? Ich habe hier eins rumliegen, mit dem ich getestet habe.

    Ich würde gerne auf dieses Angebot zurück kommen. Über http ist ein Zugriff wohl nicht möglich. Könntest Du das Programm zur Verfügung stellen?


    Danke vorab


    Herbert

    Ich hatte einige Zeit einen ACER Revo 3600 Nettop mit NVIDIA ION Chipsatz in Betrieb. Der war nicht viel größer und hatte auch eine VESA Halterung. Der Intel Atom war zwar nicht sehr fix, aber der Chipsatz unsterstützt VDPAU. Leider sterben die Nettops allerdings allmählich aus, aber vielleicht gibt es noch was aktuelleres.Mit einem USB DVB-C Stick müsste alles gehen, was Du wünschst.


    Gruß


    Herbert

    Neben meinen Haupt-VDR (siehe Signatur) habe ich noch eine Seagate Goflex Net als File-Server und Medien-Server im Betrieb. Dank Geralds Repository und eines übriggebliebenen Sundtek-Sticks war ein zusätzlicher VDR schnell aufgesetzt, den ich nutze, wenn ich mal schnell mit PC oder Tablet via Streaming fernsehen möchte. Ein nettes Extra-Feature wäre es nun, wenn ich die Goflex noch als reinen Audio-Zuspieler für den Verstärker nutzen könnte.


    D.h. ich würde gerne den Ton des momentan eingetellten Kanals über den SPDIF-Ausgang der an der Goflex angeschlossenen USB-Soundkarte ausgeben. Das ganze mit möglichst wenig Belastung der nicht gerade üppigen Ressourcen meiner Goflex. Ich habe versucht, das bitstream-plugin zu kompilieren, aber das wird wohl schon länger nicht mehr gepflegt und blieb mit einem Fehler hängen. Natürlich könnte ich xineliboutput und vdr-sxfe nutzen, aber das erscheint mir dann doch etwas "überschossen".


    Habe ich noch eine einfache Möglichkeit übersehen ??


    Herbert


    Hallo Oliver,


    ich komme noch einmal auf dieses Problem aus dem alten Thread zurück. Ich habe jetzt endlich mal wieder (nach nur drei Monaten :rolleyes: ) den Treiber aktualisiert und gestern trat der Fehler wieder einmal auf. Nach Entladen und Neuladen des Treibers war der Fehler behoben.


    Gruß


    Herbert

    Quote

    Sieht nach einem Problem mit dem I2C-Bus aus.
    Prüfen, ob das Datenkabel richtig sitzt bzw. ungünstig verlegt ist.


    Der darauf folgende Kernel Bug deutet auf einen Fehler im Treiber hin. Muß ich mir mal anschauen. Ist aber nur die Folge, nicht die Ursache des Problems.


    CU
    Oliver


    Kabelfehler kann nicht sein. Ist ja die neue kompakte Karte mit integriertem Tuner.


    Gruß


    Herbert