Posts by Zwickel

    Hi,
    hat sich vielleicht der Parameter geändert? Rufe einfach mal das Modul mit 'modinfo modulname' auf.


    Du erhält's dann alle möglichen Optionen und deren Werte.


    Gruß
    Zwickel

    Nun gehts weiter,


    Nun erzeuge zwei neue Verzeichnisse, wo später die Partitionen 'eingehängt' werden.


    /video0 <- als Ersatz für /video
    /video1 <- neuer Einhängepunkt für die neue Partition der neuen Platte


    Linux mountet (oder auch montiert) sich seine Laufwerke (egal ob lokal oder Netzwerklaufwerke) über eine Datei namens /etc/fstab.


    Diese Datei ist eine reine Textdatei, diese kannst du mittels eines beliebigen Texteditors bearbeiten. Ich nutze meist den Midnight Commander (mc) - wenn nicht vorhanden kannst du diesen mit 'apt-get install mc' nachinstallieren.


    Gebe den Befehl 'mc' an der Console ein, und navigiere in der anschließenden grafischen Darstellung nach /etc, gehe mit dem Cursor auf die Datei fstab und drücke 'Bearbeiten'.


    Suche in der Datei nach der Zeile mit /video. Ändere diese in '/video0' und füge eine neue Zeile darunter ein, mit der gleichen Syntax (ja auch die Nullen dahinter sind wichtig), ändere diese nun in '/dev/hdb1' und '/video1'.


    Vergewissere dich, dass du Zeile richtig geschrieben hast. Es könnte sonst passieren, dass Linux nicht startet, da der Inhalt der Datei nicht richtig ist. Speichere die Datei und verlasse sie.


    Nun musst du noch unter /etc/default in der Datei vdr den Pfad auf das /video-Verzeichnis anpassen. Ändere den dortigen Eintrag 'VIDEO_DIR="/video"' auf /video0. Füge NICHT das neue zusätzliche Verzeichnis /video1 dazu - VDR erkennt das selbst.


    Nun einmal neu starten, wenn du keinen Fehler in der fstab gemacht hast, sollte dein Rechner durchstarten und VDR den zusätzlichen Platz anzeigen.


    Viel Spaß
    Zwickel

    Hallo madle,


    so eine Schritt für Schritt-Anleitung für "Dumme" (ist nicht bezogen auf deine Intellegenz, jeder von uns hat 'klein' angefangen) ist recht umfangreich, vor allen Dingen dann, wenn dir die Standardbegriffe wie u.a. 'mount' nichts sagen. D.h. heißt dann, ganz klein anfangen.


    Legen wir mal los.
    Ich gehe davon aus, daß die Platte als Slave-Platte am primären IDE hängt (sollte entsprechend am BIOS-Startbildschirm zu sehen sein).


    Die Platte sollte von Linux erkannt werden, dies kannst du prüfen, indem du am Linux-Prompt (du solltest für die folgenden Aktionen als root angemeldet sein) 'dmesg | grep /dev/hdb' eingibts.


    Zur Erklärung (gilt für Linux allgemein, sofern kein devfs aktiviert - dies ist bei der ct-Distri standardmässig nicht der Fall):
    Primärer IDE 1.Platte - /dev/hda
    Primärer IDE 2.Platte - /dev/hdb
    Sekundäre IDE 1.Platte - /dev/hdc
    Sekundäre IDE 2.Platte - /dev/hdd


    Nun muss die Platte ersteinmal vorbereitet, sprich partitioniert und formatiert werden.


    Ich nutze an der Console zum partitionieren 'cfdisk', ist meines Wissens bei der ct-Distri standardmässig mit enthalten, ansonsten mittels 'apt-get install cfdisk' installieren.


    'cfdisk /dev/hdb' lautet der Befehl zum starten des Programm's. In der nun folgenden 'grafischen' Darstellung siehst du deine Platte mit den evtl. vorhanden Partitionen. Sofern es eine neue Platte ist und du dir sicher bist, dass du davon nichts mehr brauchst, würde ich alle vorhanden Partitionen löschen (mittels 'Delete') und bei null anfangen.


    Eine neue Partition anlegen geschieht mittels 'Create', wenn es die ganze Platte sein soll, kannst du die folgenden Vorgaben übernehmen. Anschließend noch den Typ (mittels 'Type') setzen. Wähle dort '83' - Linux aus. Anschließend mittels 'Write' die neue Konfiguration auf die Platte schreiben, mit 'Quit' raus und sicherheitshalber den Rechner einmal neu starten, damit du sicher sein kannst, dass die Platte ihre Konfiguration neu einliest. Wenn du willst kannst du nach dem Neustart ja nochmals mit cfdisk dir deine Konfiguration ansehen.


    Nun erzeuge ein Dateisystem auf der neuen Partition. Wenn du die ganze Platte als eine Partition eingeteilt hast, so ist der neue Name /dev/hdb1, wenn du sie unterteilt hast /dev/hdb2, usw...


    Als Dateisystem kommen eigentlich mehrere in Betracht, bei der ct-Distri solltest du aber besser beim Standard bleiben und der ist 'ext3'.


    'mkfs.ext3 /dev/hdb1' <- achte hier besonders darauf, dass du die richtige Partition neu formatierst, es droht sonst Datenverlust!!!


    Der Rest in der zweiten Nachricht...

    erweitere Mal deine mplayersources.conf um folgenden Eintrag (ohne den Inhalt der Klammern):


    /etc/vdr/plugins/DVD-VCD;DVD-CD;0 (<-- die '0' für 'nicht mounten' ist richtig!!)


    in diesem Verzeichnis /etc/vdr/plugins/DVD-VCD/ legt's du mit 'touch DVD' und 'touch VCD' sei leere Dateien an. Dann sieh mal in der vdrmplayer.sh.conf (normalerweise in /etc/vdr/plugins) nach. Dort gibt es einen Eintrag DVDFiles. Denn dortigen Pfad ggfs. an den obigen Pfad anpassen. Evtl. auch den Eintrag für DVD, dieser muss auf das /dev/... verweisen und nicht auf /mnt/dvd (ich hoffe du hast aufgrund meines vorigen Beitrages dann auch ein Verzeichnis in /mnt für die dvd angelegt).


    Die Vorgehensweise ist dann wie folgt:
    für DVD-Filme (gekauft oder in dem Format wie normale DVD-Player es erwarten) wählt's du aus dem Verzeichnis DVD-VCD den Eintrag DVD, für VCD's den Eintrag VCD.
    Für CD's oder DVD's mit z.B. DIVX-Filmen trägt's du Dir jeweils einen weiteren Eintrag in die mplayersources.conf ein. Dann jeweils mit einer '1' dahinter, damit die CD gemountet wird. Dort wählts du dir dann deine gewünschte Datei aus.


    Problem DVD Wiedergabe über MPlayer:
    die DVD-Menü Steuerung geht meist (bei mir immer) daneben, eine andere Tonspur als in der vdrmplayer.sh.conf ist nicht auswählbar und Untertitel gehen auch nicht.


    Gruß
    Zwickel

    Wenn kein devfs aktiviert ist:


    Primäres IDE 1. Platte: /dev/hda
    Primäres IDE 2. Platte: /dev/hdb
    Sekundäres IDE 1. Platte: /dev/hdc
    Sekundäres IDE 2. Platte: /dev/hdd


    Von daher passt der Link von /dev/dvd auf /dev/hdc schon.


    Versuch es mal mit (so läuft es bei mir, evtl den Pfad abändern):
    /dev/dvd /mnt/dvd udf defaults,ro,user,exec,noauto,gid=cdrom 0 0


    Wichtig ist, daß du das 'udf' Modul geladen hast (das Speicherformat auf einer DVD ist anders als auf einer CD).


    Das ganze macht aber nur mit dem MPlayer Sinn, da das DVD-Plugin ebenso wie das VCD-Plugin direkt auf das Gerät gehen.


    Mein Rat:
    benutze den MPlayer für auf der Platte liegende, bzw. auf CD liegende DIVX oder ähnliche, Filme und das jeweilige Plugin für DVD's bzw. VCD's. Die jeweiligen 'spezialisierten' Plugins kommen z.Z. damit besser klar.


    Gruß
    Zwickel

    Hallo noamx,


    das Frontend hast du aber geladen? Der Treiber (saa71xx) allein reicht nicht, sondern der entsprechende Teiber für's Frontend (bei meiner Siemens-DVB-C 'ves1820') gehört noch dazu. Dann kann der VDR das Primary Device finden.


    Gruß
    Zwickel

    Das hängt so bisschen davon ab, was du machen möchtest.


    Generell sind eigentlich Intel-Chipsätze zu empfehlen.
    Grundsätzlich auch VIA-Chipsätze (diese sind meist stromsparender), ich persönlich hatte etwas Ärger mit diesen. Probleme sind dann zu erwarten, wenn eine hohe Last auf dem PCI-Bus in Verbindung mit vielen DMA-Zugriffen entsteht. Dies war bei mir in Verbindung einer PVR-Karte für den analogen Fernsehempfang.


    Als weitere Quelle kann ich Dir die LinVDR-Homepage empfehlen. Dort steht unter Dokumentationen eine Board-Kompaktibilitätsliste.


    Gruß
    Zwickel

    Hallo Gustav,


    eine Lösung habe ich leider auch nicht, sondern nur das gleiche Problem.


    Mit ivtv-0.1.9 und Kernel 2.4.27 (mit den i2c-Treiber aus dem Orig.Kernel) läuft sie (benutze den CT-VDR) - mit den aktuelleren ivtv-Treiber unter Kernel 2.6.x nicht. Gleiches Problem - der Tuner wird nicht erkannt, weder automatisch, noch wenn ich die entsprechenden Parameter vorgebe.


    Die ivtv-0.1.10 unter Kernel 2.4.x habe ich noch nicht probiert. (Doch, ich glaube ich habe das im laufe der Zeit mal - die Treiber kompilieren nicht, da sie die aktuelleren i2c-Treiber voraussetzen)


    Meine Karte ist ca. ein halbes Jahr alt und ich habe den Eindruck, daß Hauppauge da einen etwas anderen Chipsatz verwendet hat. Mit den ivtv-0.1.9-Treibern meldet sich die Karte als iTV15, mit den 0.1.10 als iTV16.


    Vielleicht kauft sich 'ck' ja mal eine neuere Karte (oder der ursprüngliche Maintainer wird mit seinem nächsten Release mal fertig). Die Treiber sind halt leider Alpha...


    Gruß
    Zwickel

    Hallo champpain


    >Konsolen scheint es nun auch nicht mehr zu geben (keine reaktion ALT+Fn).
    >Die Maus funzt übrigens.


    Bei gestarteten X-Server musst du STRG+ALT+Fn drücken, um an die Console zu kommen.
    Sobald du auf der Console bist, geht wieder nur ALT+Fn. Zurück zu X kommst du normalerweise mit ALT+F7 (unter Debian läuft die Console normalerweise auf der 7.Console).


    Gruß
    Zwickel

    Hi,

    es kommt darauf an, daß du den Treiber deiner DVB-Karte recht früh laden musst und dann das gepatchte test_stillimage mit deinem gewünschten Bild (in einem MPEG-Image) ausführst.


    d.h.
    1. als erstes die benötigten DVB Treiber laden
    2. test_stillimage ausführen (wie in den Threads beschrieben)
    3. die restlichen Module laden
    4. den VDR starten


    Gruß
    Zwickel

    Hallo,


    seht mal unter http://secure.netroedge.com/~lm78/supported.html nach, ob der ChipSatz unterstützt wird.


    Wenn ja, steht hinter dem Chip der benötigte lm-driver und ab welcher lm-sensors-Revision der ChipSatz drin ist. Ebenfalls ab welchem Kernel.


    Zum kompilieren auf LinVDR kann ich nichts sagen, da ich diese Distri nicht benutze. Habe nur schon öfter gelesen, dass man die Entwicklungsumgebung nachinstallieren kann. Einfach mal die Boardsuche benutzen.


    Gruß
    Zwickel

    Hallo zusammen,


    gibt es eine Möglichkeit, nur den AudioAnteil eines Kanales zu streamen?


    Streamdev funzt super (klappt auch einwandfrei mit dem MPlayer unter Mac OS X), nur über den UpLink einer DSL-Verbindung komplett (Bild und Ton) zu streamen klappt ja aufgrund der Bandbreite nicht. Hintergrund: möchte auch 'unterwegs' (auf Arbeit) die Berichterstattung zu Olympia hören. Daher würde mir ein AudioStream reichen (oder kennt jemand ein InternetRadio, daß ständig berichtet?).


    Gibt es dafür eine Möglichkeit? Könnte ich das Streamdev-Plugin dafür anpassen?


    Gruß
    Zwickel

    Hallo Cehawe,


    suche mal nach analogtv und nach pvr-karten.


    Die Treiber sind meines Wissens nicht im LinVDR enthalten. Wirst dir also die Entwicklungsumgebung im LinVDR aufbauen müssen - oder auf eine andere VDR-Distri umsteigen (z.B. Ct-VDR)...


    Gruß
    Zwickel

    ----------------------------
    Wofür das ganze?
    Die ALSA-Soundtreiber klingen meist besser, als die alten OSS-Treiber. Zudem bieten viele
    Karten über ALSA zusätzliche Möglichkeiten, wie z.B. SPDIF oder Equalizier.
    ----------------------------


    In die /etc/apt/sources.list die folgende zusätzliche Download-Resource eintragen:


    deb http://debian.cli.unipi.it/debian/ woody sherpya


    anschließend 'apt-get update', 'apt-get install alsa-modules-2.4.24-ctvdr-2'
    (bzw. bei der CT gibt es mittlerweile auch einen aktualisierten Kernel, dann 'alsa-modules-2.4.26-ctvdrskas-1').


    Dabei werden zusätzlich das 'alsa-base' und die 'alsa-utils'-Package mitgeladen, da die ALSA-Soundmodule
    davon abhängen.


    Nun wird es ein wenig Tricky, da die Konfiguration des 'alsa-base'-Packages fehlschlägt.


    Zur Erklärung: die 'alsa-base'-Konfiguration will die aktuellen Soundkarteneinstellungen wiederherstellen.
    Da aber noch kein Treiber geladen wurde (die Soundkarten-Module werden erst anschließend über die Abhängigkeiten
    installiert und konfiguriert) wird das ganze fehlschlagen.


    1. nach /var/cache/apt/archives wechseln
    2. dort 'dpkg -i --force-depends alsa-utils_xxx' (=xxx durch den vollen Paketname ersetzen)
    3. anschließend 'dpkg -i --force-depends alsa-modules-2.4.xxx'
    4. 'modconf' aufrufen und in der Rubrik 'alsa' (steht ganz unten) den passenden Treiber auswählen
    Solltest du keine Ahnung habe, wie dein benötigtes Treiber-Modul bezeichnet wird, versuche folgendes:
    Bei PCI-Karten (bei modernen Boards auch Onboard-Chips):
    'lspci -v', dort sollte dann die Soundkarte auftauchen, suche in modconf nach einem ähnlich lautendem Treiber
    Bei ISA-PNP-Karten (bei alten Boards evtl. auch Onboard):
    'cat /proc/isapnp', suche dort hinter 'Card 1' nach einer ähnlichen Bezeichnung in modconf
    Weitere Info's (auch zu ISA-Karten ohne PNP) und evtl. zusätzliche weitere ModulOptionen siehe unter
    http://www.alsa-project.org/
    5. wenn der Treiber geladen wurde (siehe 'lsmod' dann Modulname, oder auch 'dmesg'), rufe 'dselect' auf
    und wähle Punkt '4. Konfiguriere' (bzw. '4. Configure'). Nun sollte auch diese Konfiguration durchlaufen.
    6. Die Default-Konfiguration schaltet den Ton der Karte aus. Dies muss anschließend über 'alsamixer' geändert
    werden (es erscheint ein semigrafisches Menü auf der Konsole, das doppelte 'MM' über der Level-Anzeige
    steht für 'Mute'. Die Steuerung erfolgt über die Richtungstasten, 'Mute' kann über die 'M'-Taste an/ab-
    geschaltet werden)
    7. Nun noch ein 'alsactl store', damit werden die Einstellungen über den nächsten Neustart hinaus gespeichert


    Für den VDR selbst muß dann nichts weiter mehr gemacht werden.


    Wird das analogTV-Plugin benutzt, muß/sollte es gemäß Anleitung im Plugin umgestellt werden.
    Problem hierbei: wird eine reine Analogkarte (keine PVR) und damit dann der 'mp1e' zum
    komprimieren des Datenstroms benutzt, wird das ganze fehlschlagen. Der mp1e wurde ohne
    ALSA-Unterstützung kompiliert und benötigt daher die alten OSS-Devices. Hier müssen dann noch
    die OSS-Emulations-Treiber ('snd-pcm-oss' und 'snd-mixer-oss') geladen werden.


    Viel Spaß mit ALSA
    Zwickel

    Dr. Seltsam


    Quote

    Original von Dr. Seltsam
    wie kriegst Du denn den Ton eigentlich über die onboard-Sound"karte"? VDR nimmt doch die DVB-Karte. Oder ist die Siemens an den Soundeingang des Boards angeschlossen? Ich habe den onboard-Sound noch nie gehört....


    Ja, die Siemens wird intern an den CD-Eingang angeschlossen und dann über die Kabelpeitsche am Line-Out der Soundkarte wieder abgegriffen.


    Quote

    Original von Dr. Seltsam
    der ivtv-Treiber ist noch im Alpha-Stadium, und das analogtv-Plugin würde ich auch nicht unbedingt als stable bezeichnen. Am Board liegen die Abstürze sicher nicht! Von Chris Kennedy gibt es Patches am ivtv-Treiber 0.1.10pre2, die in Bezug auf Via und dma irgendwas fixen:
    http://kmos.org/~ckennedy/ivtv/


    Habe ich auch schon versucht, leider bekomme ich dann überhaupt kein Bild mehr über das AnalogTV-Plugin


    Quote

    Original von Dr. Seltsam
    PS: Die C3 ist eine Nehemia? wie kühlst Du die? es passen wegen der Elkos ja leider nur wenige Kühler auf das Board.


    Ja, ist sie. Ich benutze als Kühler den HT-101 von AeroCool (bei http://www.dirkvader.de unter Reviews), zwar etwas teuer. Allerdings wenn du über Kernel 2.6 und 'powernowd' die Taktfrequenz dynamisch regeln läßt, funktioniert das ganze auch rein passiv (es sei denn der Prozessor läuft ständig auf voller Last ;D ).


    sdu
    es wird Dir leider nichts mehr helfen, aber ich habe mein Board vor ca. 4 Wochen bei Alternate gekauft. War dort auch lange Zeit nicht lieferbar, dann kam wohl eine neue Lieferung - nun ist es ganz aus der Liste genommen worden.


    Gruß
    Christian

    Hallo zusammen,


    ich habe mir vor ein paar Wochen obiges Board mit einem C3-1100MHz zugelegt. Dazu habe ich eine FS-DVB-C 1.5 und eine PVR 250 iTVC 16-ChipSatz. Das ganze läuft (oder auch nicht) unter dem ct-vdr2 Stable, als auch unter Debian unstable.


    Nun zu meinem Problem(en):
    - Der Onboard-Sound ist eher als mässig zu bezeichnen. Weder ALSA, OSS noch der binäre OSS-Treiber von VIA klingt wirklich gut. Alles mit sehr viel Bass, kaum Höhen und leucht verzerrt.


    - Wenn ich über die PVR fernsehe oder aufnehme kommt es immer wieder zu unmotivierten Abstürzen des kompletten Rechner's. Ab und an erhalte ich die Fehlermeldung des ivtv-Treibers 'waiting for DMA to pending clear' (oder so ähnlich).


    Jemand eine Idee?


    Zwickel

    Hi,


    wechsle in nach /var/cache/apt/... (habe gerade den genauen Pfad nicht im Kopf - suche dort mal in den Unterverzeichnissen nach den DEB-Paketen).


    Wenn du in dem Ordner angekommen bist, der das Kernel-Header-Paket beiinhaltet, führe den folgenden Befehl aus:


    dpkg -i --force-overwrite kernel-header-xxxx


    Mittels --force-overwrite überschreibt's du auch Dateien aus anderen Paketen - ist daher also mit VORSICHT zu benutzen!!!


    Gruß
    Zwickel