Posts by TheAlamo

    komisch, bei mir hat das "checkout Dharma-pvr" geklappt, allerdings bleibe ich inzwischen auf dem master.


    stimmt, mit den german translations ist das dort nicht so weit.


    aber was solls! wir sind auf dem aktuellen xbmc trunk mit pvr-funktionalität.
    zwar nicht absolut stabil, aber mindestens so stabil wie pvr-testing2.


    bemerkenswert finde ich, dass es in den letzten wochen, in denen so alle zwei tage gemerged wurde, immer fehlerfrei durchcompiliert hat.

    erstens
    musik geht einwandfrei


    zweitens
    pvr funktioniert nicht eindeutig besser


    drittens
    wenn - wie befürchtet - das xbmc-projekt in so eine kommerzielle abhängigkeit zu geraten droht (ich sag nur boxee box), ist dann nicht jede alternative zu begrüssen? vielleicht entsteht da ein fork?


    also wünsche ich mir mehr enthusiasmus, und nicht jedesmal ein "ie, bäh, des funktioniert ned richtig"

    Quote

    Original von BJ1
    Naja, Pingpong hat schon ewig nicht mehr gemergt. Aber ich gebe die Hoffnung nicht auf, dass er das mit dem final Release von Dharma mal nachholt. Für mein gefährliches Halbwissen ist die Hürde zu hoch...
    BJ1


    na, aber dafür gibt's doch das Repository von Lars Opdenkamp.
    mit

    Code
    1. git clone https://github.com/opdenkamp/xbmc.git

    haben wir den aktuellen trunk mit pvr (zuletzt vor 2 Tagen gemerged).
    Das läuft hier mindestens so stabil wie der pvr-testing2 branch.
    Dann könnten man noch, wenn man unbedingt will

    Code
    1. cd xbmc; git checkout Dharma-pvr

    auf dharma mit pvr wechseln. das geht auch.

    Hi,


    hm, ja, Gentoo ... das ist eine längere Geschichte.


    Bei mir lief Xine auch nicht mit den 260er Treibern - xbmc allerdings funktionierte. Dann ging die Sucherei los. Was mich schon immer gewundert hatte, war, dass die Durchflieger-Patches auf meinem System nicht zum Laufen zu bringen waren - Xine blieb damit beim Start sofort hängen.


    Dieses Problem konnte ich eingrenzen, das liegt daran dass der Patch den "define LOCKDISPLAY" auskommentiert.


    "if you have a buggy libX11/xcb*" steht da zu lesen. Aber was genau ist der Bug? Anderswo ist zu lesen, dass dieser Fehler ab einer bestimmten Version im Ubuntu gefixed ist. Hm, dann müsste es doch eigentlich einen Patch dafür geben ... Dazu habe ich nix gefunden.


    Möglicherweise ist das nur ein übler Würgaround:
    USE="-xcb" emerge libX11
    Danach alle verdächtigen Kandidaten neu generiert: xorg-server, xine-lib, xine-ui, libvdpau ...
    Und siehe da: Xine läuft mit Durchflieger-Patch und 260er Treibern.


    Aber Obacht geben: Ich sage "läuft", ich sage nicht "läuft rund".


    Die ganze Zeit habe ich mit "xinit -e xine", "kill", "xinit -e xbmc.bin" hin und her geschaltet. Der xorg-server wurde also jedesmal runter und rauf gefahren. Das scheint sich aber gelegentlich mit UVESAFB-splashutils-fbcondecor zu beissen. Jedenfalls blieb ab und zu der xorg-server hängen und v86d war auf 100% CPU.


    Also habe ich mich für nodm als Displaymanger entschieden - dabei bleibt der xorg-server immer oben und xine und xbmc werden abwechselnd gestartet.


    Das läuft so weit, ABER jetzt habe ich noch das Problem mit den sporadisch auftretenden "Schnee-Artefakten in schwarzen Bildbereichen".


    Von einem, der auszog, um mit Gentoo das Gruseln zu lernen ...

    hm, weiss nicht, ob das was hilft:


    Vor einigen Wochen wollte ich mal sehen, was passiert, wenn ich xbmc mit --enable-external-libraries baue. Danach wurden AC3-Tonspuren als DTS angezeigt - ob das nur beim Live-TV so war, daran kann ich mich nicht mehr erinnern. Jedenfalls war der Fehler mit --disable-external-libraries wieder weg.

    Quote

    Original von jobit
    werden schon seit SVN 27961 in /usr/share/xbmc/addons/visualizations/ProjectM/presets abgelegt,
    brauchen also nicht mehr manuell entpackt werden


    das war mir nicht aufgefallen


    Quote


    AddFemonV1 patch im Streamdev-plugin ?


    mfg
    jobit


    hm, mein streamdev ist aus dem "bigpack" - da geht der patch nicht. im streamdev-cvs müsste doch schon alles drin sein, wenn ich mir den ziehe?

    Hi,


    so gehts bei mir mit projectm:


    das presets.zip, welches unter /usr/share/xbmc/addons/visualizations/ProjectM/resources steht, manuell auspacken nach /usr/share/xbmc/addons/visualizations/ProjectM/presets, Das ging bei mir nur unter Windows, auf dem VDR gabs Speicherschutzverletzung.


    dann noch den diff einspielen http://trac.xbmc.org/attachment/ticket/8552/projectM.diff


    danach sind die presets verfügbar, und projectm läuft "in schön".

    Die w32codecs habe ich. Auf der Kommandozeile - also einfach "vlc <url aus dem Wiki>" - funktioniert das auch. Da wird dann xvideo und alsa für die Ausgabe benutzt und der Stream im Fenster abgespielt.

    Hi,


    irgendwas fehlt mir hier. Mit dem Beispiel aus dem WIKI (livemedia.omroep.nl) bekomme ich beim Testen immer nur:


    Das sieht für mich so aus, als ob VLC den Stream zwar dekodieren kann, dass aber das Enkodieren nach mp2v bzw. mpga nicht klappt.
    VLC habe ich unter Gentoo installiert, es ist "VLC-Version 0.8.6c Janus". Dabei habe ich alle USE-Variablen gesetzt, die auch nur im Entferntesten den Anschein machen, als könnten sie dazu beitragen.


    Hat vielleicht jemand eine Idee, woran es liegt?