Posts by reini-at

    Hi, habe jetzt mal in meiner grub die fixe 1920x1080 rausgenommen und die edid raus, das war ja irgendwie nur für X interessant denke ich, und neu gestartet. Habe nun leider kein Ton mehr, aber darum kümmere ich mich nachher, wenn ich auf den Astra UHD Channel schalte, zeigt mir der Fernseher 1080i HDR/HLG an, was ja schon mal richtig wäre denke ich.


    edit: hatte bis jetzt das plugin mit -g 1920x1080 gestartet, das kann ja nix werden :) habe das jetzt wieder rausgenommen und neu gestartet, jetzt zeigt der fernseher auch korrekterweise 2160/hdr/hlg an. Allerdings läuft es schon nach kurzer Zeit nicht mehr. Angezeigt wird dass der Kanal mit 60Hz läuft, wie ändere ich das auf 50?



    Ich schaue mal wie lange das Bild durchläuft...

    seahawk1986 - danke - damit konnte ich nun erfolgreich Bild und Ton zum leben erwecken :) Selbes Problem wie vorher im thread schon beschrieben mit dem Skindesigner habe ich auch, bei shady_KISS z.B. habe ich schwarze Flächen statt ein schönes Design wie vorher, und auch die Scrollbalken sind nicht sichtbar, also mal ein wenig blind durchgescrollt und getippt um das skin nun mal auf metrixHD zu wechseln.


    Kann ich irgendetwas beitragen um herauszufinden warum der Skindesigner das nicht so möchte wie ich?


    Eingestellt ist aktuell mal alles auf 1920x1080, inkl. OSD.

    CKone oder seahawk1986 - was habt Ihr denn gemacht unter yavdr ansible unter ubuntu 18.04 um Bild zu bekommen, bzw. um das X am starten zu hindern? Über apt das softhddrm plugin installieren funktioniert bei mir, ton bekomme ich auch damit, allerdings habe ich wohl eben ein schwarzes Bild vom XServer im Vordergrund mit einem Mauszeiger. Über die Commandline den X Prozess zu killen ginge, allerdings ist dann trotzdem etwas anderes im vordergrund im weg :)


    Bzw. gibt es dafür eventuell schon ein playbook oder irgendwas oder eine Anleitung wie man dies verwendet? Ohne X würde vermutlich die systemressourcen sparen und damit auch meine NUC weniger strom verbrauchen lassen?


    Danke im Voraus für jegliches Feedback dazu!

    Hi,


    habe irgendwie das selbe Problem bei mir, EPG scan timeout ist auf 0 gesetzt, Update channels auf 0, und das vaapidevice wird beim ausschalten des fernsehers detached. Der Tuner wird aber anscheinend nie freigegeben. Gibt es eine Möglichkeit herauszufinden, von was der Tuner genau verwendet wird, bzw. warum das satip-plugin meint den tuner nicht freigeben zu müssen?


    LG

    Reini

    Hi,


    erstmal die wireless-tools installieren, und dann mit iwconfig den namen von deinem wlan gerät auslesen, entweder wlan* oder irgendwas anderes, bei mir ist es

    wlx5c4979eef66e


    Dann: in /etc/netplan gibt es die 01-netcfg.yml

    für Wlan habe ich folgendes eingefügt (wichtig, abstände etc. sind wohl genauestens vorgegeben):


    Code
    network:
      version: 2
      renderer: networkd
      wifis:
        wlp2s0:
          dhcp4: yes
          dhcp6: no    
          access-points:
             "DEINE_ESSID":
               password: "DEIN_PASSWORT"

    In diesem Fall verwende ich dhcp und keine fixed IP adresse, und WPA-PSK2 verschlüsselung.


    LG

    Hi,

    manchmal ist es dann im Endeffekt doch einfacher als gedacht... Habe mir länger das syslog mit den cec-ausgaben angeschaut, und habe nun für mich folgende Lösung erarbeitet:


    in der cecremote.xml habe ich folgende onceccommand Befehle konfiguriert:


    Code
    <onceccommand command="STANDBY" initiator="TV">
                <commandlist>
                         <exec>svdrpsend plug softhddevice DETA</exec>
            </commandlist>
        </onceccommand>
        <onceccommand command="135" initiator="TV">
            <commandlist>
                <exec>svdrpsend plug softhddevice ATTA</exec>
            </commandlist>
        </onceccommand>

    Damit wird beim auslösen das standby das fronted detached, und wenn der TV wieder eingeschaltet wird werden eine Reihe von Befehlen abgeschickt, da habe ich mir den 135er Befehl ausgesucht um eben genau das Einschalten zu erkennen, und kann damit das frontend wieder attachen lassen.


    Vielleicht braucht es ja ausser mir noch jemand :)

    achso, na dann sind diese edid Abfragen eh nicht anwendbar für diesen Fall :)


    Mir ist aber etwas anderes aufgefallen - mittels den Befehl in der cecremote.xml kann ich ja bei poweroff ein Skript laufen lassen, welches jetzt ein svdrpsend plug softhddevice DETA macht. Was mir aber im Tool von seahawk1986 aufgefallen ist, der vermutlich etwas anderes ausführt, dort kommt nämlich im OSD eine Meldung mit Frontend detached, press a key to start. Den Befehl - vermutlich frontend-dbus-send stop könnte ich ja verwenden statt dem vorigen. Allerdings scheint damit auch das cecremote plugin deaktiviert zu werden, da das System auf keine Taste der Fernbedienung für das Starten des Frontends reagiert... Für mich wäre es auch der gangbare weg das frontend zu stoppen - solange die Fernbedienung weiter reagieren würde :) Jemand dorthin vielleicht ein Ansatz?

    Hi,

    tatsächlich gibt ein sudo i2cdump -y 4 0x50 mehr Informationen aus und erkennt auch den Fernseher. Allerdings wird beim ausschalten des Fernsehers nur für einen kurzen moment das 50er byte entfernt - über i2cdetect -y 4 verschwindet das byte, und ist dann aber beim nächsten Aufruf auch schon wieder vorhanden.


    seahawk1986 : ja auch get-edid wirft eine Antwort zurück wenn der TV im Standby ist. Ich vermute mal dass Standby bei Panasonic wohl irgendwie nur bedeutet dass das Panel abgeschaltet wird, alles andere läuft anscheinend ganz normal weiter. Werde mal schauen ob ich dem Fernseher ein "härteres" Standby beibringen kann :)

    bei ausgeschaltete fernseher:


    bei eingeschaltetem fernseher ist die ausgabe ident..

    Code
    sudo i2cdetect -l
    i2c-3    i2c           DPDDC-A                             I2C adapter
    i2c-1    i2c           i915 gmbus dpc                      I2C adapter
    i2c-8    i2c           ddbridge_00.0.3                     I2C adapter
    i2c-6    i2c           ddbridge_00.0.1                     I2C adapter
    i2c-4    i2c           DPDDC-B                             I2C adapter
    i2c-2    i2c           i915 gmbus misc                     I2C adapter
    i2c-0    i2c           i915 gmbus dpb                      I2C adapter
    i2c-7    i2c           ddbridge_00.0.2                     I2C adapter
    i2c-5    i2c           ddbridge_00.0.0                     I2C adapter

    ich tippe mal auf 0 oder 1 als korrektes device


    jedenfalls kommt bei beiden devices bei fernseher an und aus dieselbe antwort (auch bei allen anderen devices übrigens):


    das habe ich befürchtet, gibt es einen umgekehrten weg mit dem cec-remote plugin - das ausschalten und detachen geht ja, nur für einschalten und attachen habe ich noch keine saubere lösung gefunden :/


    einzige andere möglichkeit wäre den tv zu pingen in regelmässigen abständen - am besten irgendwie erst dann wenn vorher das frontend detached wurde, und bei einer ping-antwort wieder zu attachen und dann das pingen auszusetzen?


    Leider habe ich nur die theoretische möglichkeiten - jedoch nicht die praktische fähigkeiten sowas auch umzusetzen :( Irgendjemand vielleicht praktische Ansätze dazu?

    Hi,

    hast du hierfür bereits eine Lösung gefunden? Ich scheitere mehr oder weniger am selben problem - würde gerne mein fronttend detachen wenn der fernseher aus ist, und wieder attachen wenn dieser angeht -> damit die SATIP ressourcen nicht unnötig geblockt werden.


    In der cecremote.xml kann ich mit folgendem Befehl bei einem poweroff vom Fernseher den detach befehl schicken:


    Code
    <onceccommand command="STANDBY" initiator="TV">
            <commandlist>
                <exec>svdrpsend plug softhddevice DETA</exec>
            </commandlist>
        </onceccommand>

    Allerdings fehlt mir die Möglichkeit zu erkennen ob der Fernseher wieder eingeschalten wird, um dann das softhddevice wieder zu attachen.


    Falls Du bereits eine Lösung gefunden hast - bitte her damit :)