Posts by 'gb'

    Nachtrag...

    es könnte sein, daß du beim ersten mal in Kodi keinen Sound hast. In dem Fall zuerst in Kodi den gewünschten Ausgang einstellen und nach Auswahl Kodi beenden, dann wieder starten.


    Was noch passieren kann wäre, wenn du in Kodi etwas mit Passthrough abspielst und danach zu VDR wechselst, hat VDR keinen Ton mehr. Hier müsste man mit dem User vdr den Befehl "pulseaudio -k" ausführen. Darum kümmern wir uns, sobald etwas produktives bei Kodi raus kommt.

    Hallo Schwabe


    Pulseaudio ist im Moment bei Version 15, aber auf Verdacht eine beta aufs System zu prügeln, kann ich nur abraten.


    Zum Thema:

    Unter /usr/sbin gibt es die easyvdr-runkodi diese modifizieren wir geringfügig.

    Zeile 112 anpassen mit folgenden Befehlt pasuspender -- env KODI_AE_SINK=ALSA


    alt:

    Code
    kodiCmd="$(which kodi) --lircdev /var/run/lirc/lircd"

    neu:

    Code
    kodiCmd="pasuspender -- env KODI_AE_SINK=ALSA $(which kodi) --lircdev /var/run/lirc/lircd"


    Das Gleiche machen wir mit Zeile 116


    alt:

    Code
    kodiCmd="$(which kodi)"

    neu:

    Code
    kodiCmd="pasuspender -- env KODI_AE_SINK=ALSA $(which kodi)"

    Das war es eigentlich schon...


    Nun zu Kodi:

    Sobald die Anpassungen durch sind und wir Kodi über VDR oder PChanger starten, solltest du unter Einstellungen>System>Audio neue Auswahlmöglichkeiten haben. Hier ist dann der HDMI Ausgang interessant, wo dein AVR angeschlossen ist. Weiter unten das gleiche bei Passthrough.


    Ich bin gespannt...


    Gruß Aaron

    Hallo Schwabe


    Bleifuss2 hat mich da noch auf einen alternativen Weg gebracht, er hält genauso wie ich nicht viel von Multichannel, da es Ressourcen frisst und die bessere Wahl daher immer Passthrough ist.


    Wir könnten mit alsa tricksen, ist nur die Frage, wie gut bist du um Skripte ein wenig anzupassen, bzw traust du dir das zu?


    Ich habe es bei mir getestet, kodi arbeitet jetzt über alsa und der Rest wzB vdr mit pulseaudio.

    In Kodi selbst habe ich nun einiges was ich an Audio Ausgabegeräte wählen könnte.


    Gruß

    Gut, also scheint Multichannel 5.1 schon mal zu laufen.


    Kurze Erklärung:

    Bei Passthrough wird der Audio Stream ungefiltert durchgereicht, dadurch bekommt dein AVR einen Datenstrom und er selbst entscheid was ist es, wie mische ich ( zB DTS, AC3 > Dolby )


    Bei Multichannel übernimmt deine easyvdr Hardware diesen Part ( höhere Rechenleistung ), teilt die einzelnen Lautsprecher auf und sendet diese als 6 Kanäle ( PCM ) zum AVR.

    Dadurch sagt nun dein AVR "Multichannel Input".


    Die Info bei pavucontrol "ausgesteckt" nimm nicht zu wörtlich, es handelt sich um Profile, die nicht zugewiesen sind.


    Im Endeffekt ist das Thema für mich recht interessant und dank deinem Problem, lernt man mal was dazu :)


    Ich versuche erstmal nachzulesen, wie man 7.1 zuweisen kann.

    Vielleicht finde ich ja was brauchbares.


    Gruß Aaron

    Ich hab mir das nochmal genauer angeschaut und die gute Nachricht, ich hab auch ein GK208 Controller im Zweitsystem, das macht es für mich ein wenig einfacher. Die schlechte Nachricht, ich besitze kein AVR der TrueHD unterstützt.


    Als erstes hab ich im easyVDR PulseAudio Setup auf HDMI Surround gewechselt, da du für TrueHD Multichannel PCM benötigst, dann sieht das in pavucontrol schon mal so aus.

    Jetzt müsste man schauen, wie es nun in Kodi aussieht wenn du folgende Einstellungen vornimmst


    Ich denke aber, das wir pulse noch irgendwie beibringen müssten, das nicht 5.1 sondern 7.1 verwendet werden muss. Hier wäre dann googlen und viel lesen angesagt.


    Gruß

    Quote

    GK208 HDMI/DP Audio Controller Digital Stereo (HDMI 2), HDMI / Diplayport 2 (Pulseaudio

    nächster Schritt wäre diesen in Kodi auszuwählen, Kanäle auf 5.1, dann testen und Kanäle auf 7.1, dann testen.


    Geht das auch nicht, könntest du Kodi in Anzeige>Anzeigemodus auf Fenstermodus stellen, rechte Maustaste auf den x Desktop und terminal aufrufen, dann pavucontrol eingeben. Wichtig wäre, pavucontrol mit dem x Desktop User vdr starten, also kein Wechsel auf easyvdr, oder root User. Pulseaudio läuft mit Benutzer vdr.

    In pavucontrol ruhig ein wenig mit den Einstellungen spielen, Veränderungen in pavucontrol sind ohnehin nur temporär, sobald man einen Wechsel zwischen Kodi zu vdr und zurück macht, oder einen Neustart, dann wird Pulseaudio vom easyVDR System wieder fest definiert.

    Ich hatte gerade Rücksprache mit Bleifuss2 und habe zusätzlich mal beim Kodi Wiki nachgeschaut.


    Wir haben folgendes Problem:

    Quote

    Passthrough Mode Used if you want to passthrough (bitstream) AC3, DTS, and EAC3 to an AVR or other device. In order to allow passthrough to work with PulseAudio then it MUST be set to use a 2.0 channel configuration, despite the 2.0 setting this will still allow 5.1 audio from AC3, DTS, and EAC3.


    Note: PulseAudio does not currently allow TrueHD or DTS-MA passthrough, this is a PulseAudio limitation and not a limitation of the Kodi implementation, in order to get 7.1 audio Multichannel Mode must be used

    TrueHD geht bei Passthrough nicht. Du könntest versuchen dein eigenes Audioausgabegerät und individuelle Einstellungen auszuwählen. ( wichtig: Experte sollte eingestellt sein )

    Schau mal unter Kodi > Einstellungen > System > Audio > Audioausgabegerät


    Default ist unser vorkonfiguriertes Audioprofil PULSEAUDIO und dort mal schauen, was dir noch angeboten wird.

    Manuelle Einstellungen die du dort machst, blieben auch nach beenden in kodi gespeichert.

    Hi, ich hatte das puleaudio Setup so gebaut:


    Abfrage Gerät > Welcher Ausgang > Passthrough ja/nein > Auswahl pcm ac3 eac3


    Bei der zweiten Auswahl nach Abschluss handelt es sich um ein gaming Profil was man dann zB bei Steam verwenden kann.


    Beim Auswahlpunkt Multiausgabe und Auswahl zweier Geräten geht kein Passthrough und digital wäre damit nicht möglich.


    Ob nun Atmos oder true HD läuft, kann ich dir aus dem jetzt auf gleich auch nicht sagen, da müsste man mal bei puleaudio nachlesen.


    Gruß

    Hallo Ralf


    Ruhig mal das Netzwerk Setup checken und bei der Netzwerk Konfiguration bei 'weiter' prüfen ob nun in den Confs unter /etc/vdr und etc/vdr/plugins folgende Einträge erscheinen, wenn du Berechtigung für das lokale Netzwerk frei gibt's.


    ZB bei mir lokal der vdr mit 192.168.200.60 dann sollte nach der Konfiguration folgender Inhalt auftauchen:


    192.168.200.0/24 #inserted by easyvdr


    Gruß Aaron