Posts by 'gb'

    Hallo Aaron & Helmut,

    Bitte 5-others-testng PPA aktivieren da liegt nee Version des Addons das mit

    Nvidia funktioniert. ...noch nicht Published!

    Hallo Wolfgang


    perfekt, auch hier läuft nun Projectm auf dem Intelgrafik System wieder.


    Dankeschön 😁


    Grüße Aaron

    Mal eine Frage in die Runde,


    bei der Visualisierung ProjectM und Intelgrafik schmiert bei mir Kodi20 sofort ab.

    Ist das nur bei mir, oder auch bei euch?


    Gruß Aaron

    /var/lib/vdr/.kodi/userdata/advancedsettings.xml

    Code
    <advancedsettings>
    <cputempcommand>sensors | tail -n 21 | sed -ne "s/Core 0: \+[-+]\([0-9]\+\).*/+\1 C/p"</cputempcommand>    
    <gputempcommand>echo $(sensors | tail -n 21 | sed -ne "s/Core 0: \+[-+]\([0-9]\+\).*/+\1 C/p")</gputempcommand>
    </advancedsettings>

    Jawohl, das funktioniert!

    In der "sysinfo.sh" hab ich dies für GPU-Temp

    sensors | grep -i 'Core 0' | tr -s ' ' | cut -d ' ' -f3

    Ausgabe hier ->+40.0°C


    da wird bei mir auch etwas ausgegeben.


    Quote from Wolfi.m

    In der sysinfo.sh für Grafikkarte(Intel-GPU)

    inxi -G --display | grep -i 'renderer:' | tr -s ' ' | cut -d ' ' -f5-8

    Ausgabe bei mir "Intel HD Graphics 4400"


    Dies klappt aber nicht mit GPU 2000/2500.


    Jup, hier mal zwei Versuche um was herauszufinden:

    Gruß Aaron

    Hallo Helmut,


    habe nun folgendes probiert:

    Code
    sudo sensors-detect

    Hier alle Fragen mit "yes" bestätigt.

    Danach noch ein:

    Code
    sudo service kmod start

    Dann ein Reboot und nun gibt mir sensors folgendes aus:

    Ändert allerdings nichts an den Messwerten in Kodi. Daher bin ich im Moment auch überfragt, wo man den Hebel ansetzen müsste.


    Gruß Aaron

    Hallo Helmut


    Nachtrag:

    Folgendes wird mir zB bei dem Befehl "sensors" ausgegeben..

    Im Verwendeten

    Blackholefrodo und Estury4vdr Skin fehlt mir die Anzeige der Temperatur der GPU

    Ebenso in Kodi SYSTEM/Systeminformationen. Und im VDR Modus glaub ich auch im Plugin Systeminformation.

    Hallo Helmut,


    das gehört hier nicht in den Beitrag, ich werde es mal in ein separaten Beitrag splitten.


    Zur Antwort auf deine Frage:

    Hier wird es auch nicht angezeigt, lege allerdings auch keinen Wert drauf.

    Vermutlich geht es irgendwie, allerdings müsste man hier erstmal auseinander puzzlen, wo die Werte wie bezogen werden.


    Gruß Aaron

    Neu in 5-vdr-unstable
    vdr-plugin-softhddevice-vaapi-2.0.6+git20231106

    Hallo Wolfgang,


    ..hab mal testing übersprungen und bin gleich auf unstable eingegangen.

    Hier läuft alles bei vaapi stabil, in den Einstellungen bin ich von 576i bis 1080i auf "Skalierung" = "HighQuality"

    "Deinterlace" = "MotionAdaptive"

    "A/V Sync Start" = "early audio"

    "Schwarz während Kanalwechsel" = "ja"

    Der Rest steht auf default.


    Edit:

    Einen kleinen Bug habe ich in Kombination mit dem skindesigner ( mich persönlich stört es nicht! )

    Wenn ich die OSD Senderliste durch rechts drücken aufrufe und den selben Kanal wähle wie aktiv, ist die untere Info leist transparent.

    Ob das mit den Vorgängern auch schon so war, keine Ahnung, aber man sucht ja förmlich schon nach Fehlern 😁


    Gruß Aaron

    Hallo Wolfgang,


    bin endlich dazu gekommen, um mal auf Fehlersuche zu gehen. Das Flackern und ruckeln kam durch eine falsche xorg.conf, die wohl fälschlicherweise getauscht wurde, als ich auf dem Intelgrafik System das softhddevice für NVidia installiert hatte.

    Bin nun wieder auf den Stand softhddevice vaapi aus dem testing ppa und alles i.O.

    Also von mir aus kann das softhddevice-vaapi nach stable wandern.


    Gruß Aaron

    Hallo Wolfgang..

    Habe unterdessen mal alle Pakete geholt und jetzt habe ich beim umschalten im OSD ein kurzes mehrfaches Flackern.

    Weiß aber noch nicht genau, ob es am neuen skindesigner, oder am softhddevice liegt.

    ..das Flackern im OSD kommt weder vom skindesigner, noch vom softhddevice.

    Bin unterdessen auf Version 1:1.12.1-0easyVDR0~focal zurück und es bleibt beim Flackern. Jetzt frag ich mich, was für Pakete seit dem dist-upgrade mitgeliefert wurden, die den Intelgrafik Treiber dermaßen runter ziehen. Auch hab ich seitdem im vdr und Kodi20 im online Stream Ruckler.


    Gruß Aaron

    Hallo Wolfgang


    vdr-plugin-softhddevice (4:2.0.3-0easyVDR0~focal) ist nun installiert.

    Aber wie sagt man so schön "never touching system" ^^

    Da hast du mir eine ordenliche Herausforderung gestellt, irgendwas ist entweder am Paket oder an meinem System vermurkst.


    Zu Erklärung:

    Nach der Installation lief das Frontend im VDR ganz normal, allerdings lief der Frontend-Daemon nicht mehr. Das ist nicht gut, denn wechsel ich nun per pchanger nach KODI oder zum Desktop, wird das Frontend nicht detached.

    Bei Befehlen wie:

    /usr/share/easyvdr/easyvdr-start/easyvdr-frontend start

    gab's eine Fehlermeldung, Zuweisung zum System Prozess also der pid lief gegen die Wand.

    Auch ein /usr/sbin/easyvdr-runfrontend gab die gleiche Meldung, was ja normal ist, da easyvdr-frontend die easyvdr-runfrontend bedient.

    Auch nach einem System Neustart gleiches verhalten.


    Im Endeffekt und nach langer Fehlersuche musste ich ins easyvdr Setup und die Monitor_Layout & Video_Details ( Hardwarebeschleunigung ) durchlaufen ( was ich auch witzig fande, das mir hier bei Intelgrafik vdpau & vaapi angeboten wurde ) gewählt habe ich natürlich vaapi.

    Zusätzlich brauchte ich ein

    "dpkg-reconfigure lightdm" um auf lightdm umzustellen.


    Nun funktioniert wieder alles ;)


    Edit:

    Hier ist übrigens der Fehler, du hast mich rein gelegt und das falsche softhddevice installeren lassen :D

    Quote

    Hallo Aaron, kannst du Bitte mal die Version aus 5-vdr-testing installeren? Wenn das Testing-PPA aktiviert ist mit

    apt install vdr-plugin-softhddevice=4:2.0.3-0easyVDR0~focal installieren. Sollte das Umschaltverhalten nicht schlechter sein.kommt diese Version nach stable.

    Folgendes ist mir noch aufgefallen..


    Habe unterdessen mal alle Pakete geholt und jetzt habe ich beim umschalten im OSD ein kurzes mehrfaches Flackern.

    Weiß aber noch nicht genau, ob es am neuen skindesigner, oder am softhddevice liegt.


    Gruß Aaron

    funktioniert das Plugin und wie ist das Umschaltverhalten?

    Folgendes Frontend ist nun installiert:

    vdr-plugin-softhddevice-vaapi (1:2.0.3-0easyVDR1~focal)


    Umschaltzeiten sind unverändert, keine Probleme jeglicher Art feststellbar, auch beim Wechsel zwischen Kodi <> VDR alles i.O.


    PS: Habe allerdings auch noch keine weiteren Einstellungen im Frontend durchgeführt, ist alle noch default zu den Einstellungen des Vorgängers, ob ich da Anpassungen gemacht habe, weiß ich nicht mehr.


    Ob es Sinn macht was zu verändern, wenn es perfekt läuft, ist jetzt eine gute Frage?


    Gruß Aaron

    Diese dann unter var/lib/vdr ablegen. Hier müsste auch schon eine abgelegt sein, welche bei der Neuinstallation und nach Auswahl des Fernbedienungstyps angelegt wurde.

    Hat bisher immer funktioniert.

    Hab schon lange nicht mehr in den Setup Algorithmus rein geschaut aber genau, vom Prinzip ist ja die beschriebene key_irmp in den jeweiligen Fernbedienungsordnern in Wirklichkeit die "irmp_keymap", nur das vermutlich beim einrichten der Fernbedienung ein Symlink mit Namen irmp_keymap auf die jeweilige key_irmp gesetzt wird.

    Ich kann dir nur raten nicht in der remote.conf Anpassungen vorzunehmen, denn das wäre nichts beständiges. Einmal im Setup eine kleine Änderung, oder durch ein Update neue Pakete und die remote.conf ist wieder auf original.


    Besser wäre hier die Fernbedienung, die du verwendest individuell anzupassen.


    Beispiel:

    Du nutzt irmp & ms_mce, solltest du unter /etc/vdr/remotes den Ordner ms_mce mit anderen Namen ( zB: ms_mce_user ) nach /etc/vdr/remotes kopieren. Dann editierst du die key_irmp nach belieben ( Taste zu ir code ) und in der remote.conf siehst du ja, welche Taste welche Funktion im vdr hat.

    Danach einmal ins Setup, die Fernbedienung ms_mce_user gewählt und vdr nimmt nun diese.

    Vorteile, diese Ordner unter /etc/vdr/remotes/ms_mce_user wird nicht vom System angefasst und ist beständig.

    Kann mir jemand (idealerweise) bei der Möglichkeit 1 helfen und mir sagen, welche Dateien / Verzeichnisse ich kopieren muss?

    Die richtige Vorgehensweise wäre, du schaust unter easyvdr3.x welche Fernbedienung du gewählt hattest.

    Das kannst du im OSD sogar sehen unter System&Einstellungen>Einstellungen>System-Einstellungen>Fernbedienung

    In meinem Fall war zB der Ir Empfänger irtrans und die dazugehörige Fernbedienung ms_mce gewählt. In deinem Fall würde sicher anstelle von irtrans > irmp stehen, da du diesen ja verwendest.


    Das finde ich dann hier:


    Also müsstest du in easyVDR5 nun ins easyvdr Setup und die gleiche Fernbedienung wie du in easyVDR3.x hattest auswählen.

    Wenn es dann weiterhin nicht mit den Tasten passt, müsstest du in easyVDR3.x irgendwas individuell angepasst haben, oder die Inhalte haben sich im Fernbedienungsordner, zB die Datei key_irmp geändert. Einfach mal vergleichen.


    Gruß

    vdr-plugin-softhddevice-vaapi sollte noch getestet werden.

    Hallo Wolfgang, was brauchst du alles für Funktionstests mit dem Frontend?

    Da hier mit vaapi produktiv im Wohnzimmer geschaut wird, könnte ich das mal nebenbei machen.


    Gruß Aaron

    Kann auch hier bestätigen, daß es nun mit dem Skindesigner aus unserem ppa und der OpenGL Einstellung funktioniert.


    Habe die Gelegenheit gleich genutzt und das Kodi ppa wie im ersten Beitrag beschrieben hinzugefügt, Kodi erneuert und läuft. :)


    Gruß Aaron