Beiträge von woggle

    Hab's mir mal angeschaut.
    Ich habe es fast befürchtet: das ist kein Poti sondern ein Drehimpulsgeber.
    Deshalb springt die Lautstärke nach dem Aus- und Einschalten wieder auf einen normalen Wert zurück.
    Leider sagt das Service-Manual nichts über den Typ des Gebers aus. Die gibt es mit verschiedenen Rastungen und Impulsen pro Umdrehung (einfach mal bei Reichelt nach Drehimpulsgeber suchen).
    Das bekommst du vermutlich nur heraus indem du die Kiste zerlegst und guckst ob auf dem Drehimpulsgeber eine Typenbezeichnung aufgedruckt ist.
    Natürlich muss nicht unbedingt der Drehimpulsgeber defekt sein! Aber es ist ein Ansatz...

    4. Ja, einen Quattro-LNB habe ich, aber was genau ist ein Stammausgang eines Multischalters? Kann ich die 4 freien Ausgänge meines Multischalters als Stammausgang betrachten?


    Die Stammausgänge sind die vier Ausgänge deines Quattro-LNB.


    Wenn du die Signale an die Max-S8 anschließen möchtest und noch normale Sat-Geräte via Multiswitch brauchst, dann benötigst du einen kaskadierbaren Multiswitch. Ein kaskadierbarer Multiswitch hat vier Eingänge für die Signale vom LNB und vier Ausgänge (Stammausgänge) an die die Signale vom LNB durchgereicht werden.


    Falls du keine normalen Sat-Geräte brauchst, könntest du die Max-S8 auch direkt an deinen Quattro-LNB anschließen. Dann allerdings mit fmode=2.

    Danke an alle für die Info!
    Den von mini73 erwähnten Thread hatte ich gefunden. Allerdings hatte ich die Lösung in dem Thread anders verstanden. Da hatte wohl die vdr-essential gefehlt.


    Mir geht es eigentlich eher um die Ästhetik als um den Plattenplatz. ;-)
    Ich finde es halt nicht besonders angenehm wenn mir das apt-get bei jeder Aktion diesen "Schwall" um die Ohren haut...

    Hallo zusammen,
    ich haben eben einen yaVDR 0.5.0a neu aufgesetzt. Komplette Neu-Installation.
    Nach der erfolgreichen Installation habe ich ein
    sudo apt-get update
    und ein
    sudo apt-get dist-upgrade
    ausgeführt.
    Beim nächsten apt-get install z.B.
    sudo apt-get install yavdr-hardware-sundtek
    bekomme ich dann die Meldung

    Code
    1. Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
    2. vdr-plugin-skinpearlhd libhal-storage1 vdr-tft-anthraize vdr-skin-anthra-1920-fse libmagickcore4 libsdl-mixer1.2 libmagickwand4 vdr-tft-standard libmagick++4 liblqr-1-0 vdr-tft-pearlhd python-qt3 imagemagick-common python-sip libhal1 libmikmod2
    3. vdr-skin-narrowhd libgraphicsmagick++3 vdr-skins-anthra libjpeg62 vdr-plugin-text2skin libcxxtools7 libtntnet9 libqt3-mt vdr-plugin-graphtft vdr-plugin-extrecmenu vdrsymbols-ttf
    4. Verwenden Sie »apt-get autoremove«, um sie zu entfernen.


    Frage: kann ich das autoremove gefahrlos laufen lassen oder ist das ein Bug in der Paketverwaltung?
    Mich verwundern die vielen vdr-Pakete die plötzlich überflüssig sein sollen...

    apt-get sagt leider nur ich möchte doch bitte
    dpkg --configure -a
    ausführen.
    Und täglich grüßt das Murmeltier... ;-)


    Das syslog gibt leider auch keinen richtigen Hinweis.
    Da steht nur
    NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
    (aber diese Meldung kommt auch wenn's normal läuft)


    Also habe ich mal in dieses Verzeichnis geschaut. Dort fand ich drei Unterverzeichnisse und die Dateien
    .etab.lock
    etab
    rmtab
    state
    xtab


    Hmmm, eine übrig gebliebene Lock-Datei ist immer verdächtig ;-)
    Also einfach mal gelöscht. Die vier anderen Datei auch gelöscht (vorher natürlich gesichert).


    Nun läuft es wieder!

    Nach einem reboot


    Tja, und so steht es bis zum nächsten reboot... :-(

    Bei mir bleibt das dist-upgrade auch mit der Meldung
    * Starting NFS kernel daemon
    einfach stehen. :-(


    Und jetzt?


    Reboot


    Dann meckert das update und dist-upgarde das der letzte dpkg-Prozess unterbrochen wurde ich doch bitte dpkg --configure -a ausführen soll.
    Doch das bleibt genauso wieder hängen.


    Wie komme ich denn aus dieser Endlosschleife wieder heraus?

    KLar, ist kein Geheimnis.
    HW ist komplett selbst gebaut auf Lochraster mit einem ATmega328p mit 20 MHz.
    Gelegentlich muss ich mal einen Schaltplan Zeichnen alleine um nicht den Überblick zu verlieren.
    Die Firmware habe ich um das irsnd-Modul von IRMP erweitert. Dann natürlich noch den HID-Report-Descriptor und die entsprechenden Routinen erweitert um einen IR-Sende-Code übertragen zu können.
    IRMP habe ich auch erweitert damit ich das RC-MM Protokoll empfangen kann. So kann ich meine geliebte Fernbedienung vom Activy weiterbenutzen.
    Alle Versuche RC-MM mit LIRC oder auch dem yaUSBIr zu empfangen sind gescheitert oder waren nicht sehr befriedigend. Mit dem IRMP geht das jetzt sehr gut.


    Hier noch ein paar Links auf die benutzten Code-Teile:
    IRMP von Frank M.
    USB IR Remote Receiver von Hugo Portisch
    V-USB von objective development


    Um die Lizenzen habe ich mir bisher noch keine Gedanken macht da ich im Moment ja nur für mich privat bastle.

    Hier mal mein Patch für das ir_control:


    Ich habe mir auch mal kurz den irmplircd angeschaut. Die Einstellung der Repeat-Rate dort ist ja etwas ganz eigenes. Es gibt also zwei Möglichkeiten, die Repeat-Rate einzustellen:
    im irmplircd und per ir_control direkt in der Hardware. Hmmm...
    Auf jeden Fall braucht man das ir_control um z.B. einen neuen On/Off-Code anzulernen.


    Meine "IRMP USB" Hardware und Firmware habe ich sowieso erweitert. So kann ich auch IR-Code senden (via ir_control), einen On/Off-Code per ir_control setzen und die Repeat-Rate abfragen.


    Mit dem IR-Senden wollte ich z.B. automatisch den Fernseher einschalten wenn ich den VDR einschalte. Aber das geht im Moment ja nicht weil bei Benutzung von ir_control der irmplircd seinen Dienst einstellt. :-(
    Naja, wird's auch nicht langweilig... :-)

    Hallo ihr zwei,
    erst mal vielen Dank fürs Testen und Erstellen der Pakete.
    Ich bin auch gerade am spielen mit dem IRMP USB Receiver und yaVDR .Da kam mir dieser Thread sehr gelegen ;-).


    Der Empfang über irmplircd klappt prima,


    Probleme habe ich noch mit ir_control.
    Zum einen geht das Einstellen der Repeat-Rate überhaupt nicht (Segfault).
    Ich habe den Source angeschaut. Das kann so gar nicht gehen! Einfach Murx programmiert. ;-)
    Zum anderen verabschiedet sich bei Benutzung von ir_control der irmplircd mit

    Code
    1. Error processing event from hidraw0: Input/output error


    Da wird dem irmplircd vermutlich von ir_control das USB-Device unter den Füßen weggezogen. Oder so...


    Die Repeat-Rate habe ich schon gefixt. Da kann ich seahawk gerne den Source schicken.
    Zum Ausstieg von irmplircd habe ich leider keine Idee.

    Die Befehle sind nur für die alten Sticks (pollrc, -l)


    Ok, kein wunder das es mit dem neuen Stick nicht funktioniert. Sollte aber irgendwo dokumentiert werden! Hätte mit stundenlanges herumprobieren erspart!


    Das alte Gerät konnte nur 4 vordefinierte Protokolle, der neue Stick kann so ziemlich alle Protokolle unterstützen da die IR Daten Roh übergeben werden und in Software dekodiert werden.


    In welcher Software wird es dekodiert? Im sundtek-Treiber? Bzw. wo klinkt sich der sundtek-IR-Empfänger in die yavdr-IR-Struktur ein?


    Derzeit wird nur das NEC Protokoll unterstützt, für alternative Fernbedienungen musst du noch etwas abwarten (sie funktionieren aber auf jeden Fall).


    NEC würde mir reichen ;-)


    Du kannst es versuchen, ich weiß aber jetzt nicht in wiefern das derzeit klappt
    http://support.sundtek.com/index.php/topic,615.0.html (ab setrcmap, voreingestellt ist ja NEC, der RC5/6 dekoder ist noch nicht freigeschalten)


    Ok, muss ich mal testen wenn ich mal wieder an Daddys VDR bin oder den Stick zum "spielen" hier habe.

    Danke für die Antwort!
    Geht da nur die mitgelieferte Fernbedienung?
    Oder geht vielleicht auch eine andere Fernbedienung mit NEC-Protokoll? Wäre cool, weil da ist noch ein "übrig" (mit Farbtasten).


    Was definitiv nicht geht:
    mediaclient -l
    liefert nur die Überschriften...
    mediaclient --pollrc
    macht auch nicht unbedingt das was es soll bzw. wie man es hier und da beschrieben findet.
    Deshalb bin ich davon ausgegangen, dass der IR-Support für die neuen Sticks noch nicht funktioniert.

    Diesen Skript unter yaVdr nicht installieren! Wer lesen kann der stellt fest, das die Pakete vom 19. Januar sind. Siehe 2. Post.


    Als ich über die Feiertage daran gebastelt habe gab es nur den uralt Treiber vom September. Deswegen das Script. Und das läuft prima. Habe zumindest bis jetzt noch keine Nebenwirkungen festgestellt ;-)


    Falls es mittlerweile im Paket einen neueren Treiber gibt ist das natürlich prima. Allerdings gibt es bei sundtek im Moment wohl fast täglich eine neue Version ;-)


    Der neue Stick läuft übrigens gut


    Auch Infrarot? Das kriege ich nämlich noch nicht hin :-(

    Habe für meinen Daddy die Tage daran "gebastelt". Er will unter yavdr damit DVB-C empfangen.
    Das ist recht schnell zum Laufen zu bringen.


    Einfach die sundtek-Pakete für yavdr nachinstallieren

    Code
    1. sudo apt-get install yavdr-hardware-sundtek


    und am besten gleich noch den 3.8er Kernel

    Code
    1. sudo apt-get install linux-image-generic-lts-raring linux-headers-generic-lts-raring


    Da die sundtek-Pakete einen uralt Treiber vom September installieren habe ich ein kleines Script geschrieben das den Treiber aktualisiert:


    Das Script kann man immer dann laufen lassen wenn im sundtek-Forum ein neuer Treiber freigelassen wurde.


    Das Einzige was noch nicht funktioniert ist der IR-Empfänger des Sticks...