Posts by davie2000

    Habe jetzt noch ein sudo apt-get install --reinstall nvidia*390 nachgelegt, was offenbar einiges repariert hat:



    Reboot und hoffen ...

    Hallo!


    Wir haben ich eine kleine SSD bestellt auf der ich Ubuntu Server 22 und dann yaVDR-Ansible installieren möchte.


    Da meine Hardware schon etwas betagt ist, wollte ich euch VORHER fragen, ob das überhaupt klappen kann?

    Speziell die Grafikkarte mag nur mit dem alten Nvidia390 und dem Ausgabeplugin "softhhddevice mit OpenGL und FFMPEG 2.8".


    Prinzipiell würde ich gerne Ubuntu Server 22 auf der neuen SSD installieren und weiterhin zwischen den Installationen auswählen können -

    durch Booten von (dann) einer der drei "Festplatten": HDD = Ubuntu14, SSD1 = Ubuntu18, SSD2 = Ubuntu22


    Dann prüfen, ob der Nvidia-390-Treiber installiert ist.

    Dann meine Ansible-localhost Einstellungen analog zur jetzigen Ubuntu18 treffen und wohl die Paketquellen auf "jammy" ändern.
    Dann das Ansible Install-Skript laufen lassen.


    Seht ihr da jetzt schon Probleme auf mich zukommen?

    Sollte ich besser Ubuntu Server 20 nehmen?

    Dank Multiboot konnte ich jetzt das alte Ubuntu 14 System starten und frau kann erst mal wieder gucken.

    Aber halt nicht wie gewohnt. Irgendwie muss ich das Problem lösen - bitte helft mir.


    Ggf. die Packages für Kernel und X11 nochmals "in-place-updaten", und die Festplatte kontrollieren

    Bin gerade im Panikmodus und kann nicht klar denken :(
    Kannst du mir bitte genau sagen, wie ich Kernel und X11 "drüberbügeln" muss?


    Festplatte ist übrigens eine SSD auf der ich vor ca. 20 min ein sudo fstrim -v / abgesetzt habe.

    Nein, der Kernel wurde meines Wissens nicht geupdatet.

    Der Fehler (nur Konsole) war ja auch vor dem Updatelauf schon da.


    Code: nano /var/log/apt/history.log
    Start-Date: 2023-09-28  10:02:18
    Commandline: /usr/bin/apt-get -y -o Dpkg::Options::=--force-confdef -o Dpkg::Options::=--force-confold dist-upgrade
    Requested-By: daniel (1000)
    Upgrade: ubuntu-advantage-tools:amd64 (28.1~18.04, 29.4~18.04)
    End-Date: 2023-09-28  10:02:27


    Ja, der Adler versorgt mich (und andere?) seit Jahren zuverlässig mit den Bionic PPAs.


    Ich sollte schon längst upgraden auf mind. Ubuntu 20, aber das ist nicht so einfach.
    Und jetzt muss die Kiste wieder laufen, bevor meine Frau alle Serien versäumt =O

    Code: uname -a
    Linux myVDR 4.15.0-213-generic #224-Ubuntu SMP Mon Jun 19 13:30:12 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux


    Code: df -h
    Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
    udev            1,9G       0  1,9G    0% /dev
    tmpfs           393M    2,4M  391M    1% /run
    /dev/sdb1        97G     26G   67G   28% /
    tmpfs           2,0G       0  2,0G    0% /dev/shm
    tmpfs           5,0M    4,0K  5,0M    1% /run/lock
    tmpfs           2,0G       0  2,0G    0% /sys/fs/cgroup
    /dev/sda4       2,6T    2,3T  164G   94% /srv
    tmpfs           393M       0  393M    0% /run/user/1000

    Es ist immer noch (seit langem) der Nvidia 390 installiert.


    Hallo!


    Von gestern auf heute bleibt unser yaVDR (siehe Signatur) immer auf der Konsole stehen - es kommt kein TV-Bild oder Menü.

    Ich kann mich an der Konsole anmelden.

    Beim Durchführen des Ansible-Updates (sudo -H ./install-yavdr.sh) kommt jetzt immer der Fehler:

    "Inconsistency detected by ld.so: ../sysdeps/x86_64/dl-machine.h: 540: elf_machine_rela_relative: Assertion `ELFW(R_TYPE) (reloc->r_info) == R_X86_64_RELATIVE' failed!"

    Code
    fatal: [localhost]: FAILED! => {
    "changed": false
    }
    
    MSG:
    Unable to start service x-verbose@vt7.service: Job for x-verbose@vt7.service failed because the control process exited with error code.
    See "systemctl status x-verbose@vt7.service" and "journalctl -xe" for details.



    Ich hatte den Fehler schon einmal, aber damals ging TV einwandfrei und "nur" Kodi funktionierte nicht.


    Ich habe jetzt schon mehrmals das Ansible-Skript laufen lassen und reboots gemacht, lande aber immer wieder in der Konsole und bekomme kein Bild.


    Bitte dringend um eure Hilfe - Danke!

    OT: Mir graut auch schon vor dem Zeitpunkt, wenn die Fernbedienung eingeht.
    Die ist zwar kaum mehr lesbar, aber man weiß/spürt nach Jahren ja eh alle Tasten auswendig.

    Ich habe jetzt wirklich viele USB-Sticks zwischen 256GB und 1TB probiert, von USB 2.0 bis 3.2.
    Alle waren entweder langsam oder wurden sauheiss oder beides - eine einzige Katastrophe.

    Dann habe ich von einigen Kollegen diesen Tipp bekommen und beherzigt und möchte ihn mit euch teilen:
    Samsung Evo 970 Pro NVME SSD in die Icy Box (Raidsonic) IB-1817M-C31 stecken und über einen ultraschnellen und relativ kühl bleibenden Alu-"USB-Stick" freuen.

    Kostete letzte Woche insgesamt nur € 77,- (bei einem großen Dschungelfluss).

    Ahhh sorry!

    Das waren die Klassennamen, nicht die Rückgabetypen 🙈


    Wenn die Implementierungen wirklich exakt gleich sind, müsste man das in eine eigene Klasse auslagern können und die drei bisherigen Aufrufstellen rufen dann alle die neue Methode.


    Viel Erfolg!