Posts by minixjr

    Alles klar, wenn ich vielleicht irgendwann was testen kann, gib Bescheid.

    Bei mir läuft es jetzt ja mit den Berechtigungen über policykit.

    Ein Snippet, um die vdr.service entsprechend zu erweitern würde in etwa so aussehen

    Ersetzt das dann die headless-session? Die läuft ja auch auf tty7.

    Ich weiß ja nicht wie andere eine headless-Installation nutzen, aber bei mir steht der Rechner ohne Monitor, Tastatur usw. in der Ecke.

    Eine Möglichkeit zur Bedienung über Tastatur wäre da nur nice to have.

    Oder bringt das auch Vorteile bei einer ssh Verbindung?

    An den angelegten Berechtigungen kann es aber eigentlich nicht liegen.

    OK, das nehme ich mal zurück und behaupte das Gegenteil:mua

    Das Problem liegt doch in der 10-udisks.pkla.

    Scheinbar ist die Session des Users vdr für polkit inaktiv, es muss also explicit mit ResultInactive=yes die Standardeinstellung überschrieben werden.

    Anbei die aktualisierte Datei.10-udisks.pkla.txt

    Die tatsächlich notwendigen Berechtigungen Action=org.freedesktop.udisks2.* kann man sicher noch etwas feiner aufschlüsseln.


    Gruß

    Frank

    Ja, die ist da.

    Code
    1. root@vdrslz:~# loginctl list-sessions
    2. SESSION UID USER SEAT TTY
    3. 3 0 root
    4. 1 666 vdr seat0 tty7

    Hatte vorhin ohne udiskie zu killen als User vdrudiskie-mount -a probiert und das hat auch funktioniert.

    Für focal ist der Start von udiskie in der der headless-Session schon mit drin

    Ich habe mir mal die notwendigen Rollen aus focal kopiert und bin dabei auf Probleme gestoßen.

    Kopiert habe ich udiskie, session-common und headless-session

    Im Playbook rufe ich nur headless-session auf, der Rest ist abhängig.

    Probleme hatte ich mit:

    - udiskie.service.j2, hier musste das Description: dynamic ersetzt werden durch Description=dynamic

    - es wird zwar das Paket policykit-1 installiert, aber keine Berechtigungen. Ich hänge meine Datei mal an, kann man sicher noch verbessern10-udisks.pkla.txt

    Für mich nicht lösbar, udiskie wird unter den User vdr gestartet, das mounten funktioniert aber nicht.

    Fehlermeldung:

    Der Fehler sieht nach Berechtigung aus. An den angelegten Berechtigungen kann es aber eigentlich nicht liegen.

    Wenn ich udiskie kille killall udiskie und dann als User vdr neu starte, wird die Festplatte sofort gemountet.

    root@vdrslz:/root# su vdr

    vdr@vdrslz:$ udiskie -v &

    Bin (mal wieder) ratlos

    Frank

    Mit der Rolle yavdr-desktop wird nun udisk eingeführt, welches mit einem X System funktioniert.

    Leider mit einem headless System nicht, wegen fehlendem X.

    Ich hatte versucht dies in eine extra Rolle zu implantieren, aber leider ohne Erfolg.

    Mount funktioniert, unmount leider nicht.

    Vielleicht hat ja jemand eine Idee!?

    Anbei mein Versuch.

    seahawk1986 Murry  

    Hallo seahawk1986 ,


    mir ist aufgefallen, dass der Befehl "Aufnahmen-Liste aktualisieren" doppelt vorhanden ist.

    Einmal kommt er über ansible, Rolle vdr --> commands.yavdr.conf

    Und noch mal per VDR Paket --> commands.update-recordings.conf

    Code
    1. root@yavdrbox:/# apt-file search commands.update-recordings.conf
    2. vdr: /usr/share/vdr/command-hooks/commands.update-recordings.conf
    Code
    1. root@yavdrbox:/# apt policy vdr
    2. vdr:
    3. Installiert: 2.4.0-42yavdr0~bionic
    4. Installationskandidat: 2.4.0-42yavdr0~bionic
    5. Versionstabelle:
    6. *** 2.4.0-42yavdr0~bionic 500
    7. 500 http://ppa.launchpad.net/yavdr/experimental-vdr/ubuntu bionic/main amd64 Packages
    8. 100 /var/lib/dpkg/status
    9. 2.3.8-2 500
    10. 500 http://de.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages

    Vielleicht kannst Du den Befehl aus der commands.yavdr.conf löschen, geht vermutlich am einfachsten.


    Gruß

    Frank

    Habe es hinbekommen, jetzt läuft der Ubuntutreiber 440.59.

    Vermutlich lag es daran das ich vdr-plugin-softhdcuvid verwendet hatte, das hat noch Abhängigkeiten zum 390er Treiber.

    Code
    1. The following packages have unmet dependencies:
    2. vdr-plugin-softhdcuvid : Depends: libnvidia-compute-390 but it is not going to be installed
    3. Depends: libnvidia-decode-390 but it is not going to be installed

    Ich habe jetzt auf vdr-plugin-softhddevice umgestellt und noch mal alle nvidia Pakete entfernt apt remove --purge *nvidia*.

    Nun läuft ansible ohne Fehler durch.


    Danke für´s Gedanken machen und die Unterstützung.


    Gruß

    Frank

    So, habe das Skript noch mal laufen lassen.

    Ausgangspunkt ist ein laufendes System mit nvidia-driver-390 (390.132-0ubuntu0.18.04.1).

    Im Gegensatz zur yaVDR Standardinstallation führe ich Ansible nicht direkt auf dem VDR aus, sondern auf meinem Hauptrechner.

    Ansible greift dann als root per ssh auf den Client zu.

    Die Rolle pulseaudio habe ich deaktiviert, da ich unter Kodi Dolby ATMOS benötige.


    Der erste Durchlauf endet mit diesem Fehler (nvidia-driver-440 wurde installiert):

    Code
    1. TASK [yavdr-xorg : create xorg.conf (for nvidia driver)] ******************************************************************************************************************************************************
    2. fatal: [yavdrbox]: FAILED! => {
    3. "changed": false
    4. }
    5. MSG:
    6. AnsibleUndefinedVariable: 'dict object' has no attribute 'primary'

    Nach eine Reboot und erneutem Durchlauf:

    Code
    1. TASK [yavdr-desktop : enable and start yavdr-xorg for the vdr user] *******************************************************************************************************************************************
    2. fatal: [yavdrbox]: FAILED! => {
    3. "changed": false
    4. }
    5. MSG:
    6. Unable to start service yavdr-xorg: A dependency job for yavdr-xorg.service failed. See 'journalctl -xe' for details.

    Ich nehme mal an es liegt hieran

    NVIDIA: Failed to load module "glxserver_nvidia" (module does not exist, 0)

    aber was muss ich tun, bzw. warum nur ich?


    Gruß

    Frank

    HI,

    das ist das System, also GT1030.

    Code
    1. System: Host: yavdrbox Kernel: 4.15.0-101-generic x86_64 bits: 64 Console: tty 1 Distro: Ubuntu 18.04.4 LTS
    2. Machine: Device: desktop System: ASUS product: All Series serial: N/A
    3. Mobo: ASUSTeK model: H97M-E v: Rev X.0x serial: <filter>
    4. UEFI: American Megatrends v: 2702 date: 03/28/2016
    5. CPU: Dual core Intel Celeron G1840T (-MCP-) cache: 2048 KB
    6. clock speeds: max: 2500 MHz 1: 1552 MHz 2: 1469 MHz
    7. Graphics: Card: NVIDIA GP108 [GeForce GT 1030]

    Per autoinstall-ubuntu-drivers wurde die Version 440.59-0ubuntu0.18.04.1 installiert.


    Ich werde es morgen nochmal versuchen und dann die Logs posten.

    Ohne Fehlermeldungen ist es ja nur Handauflegen ;)


    Gruß

    Frank

    Hallo zusammen,


    ich habe heute das ansible (bionic) Skript mal wieder laufen lassen.

    Hierbei wurde durch die Rolle "autoinstall-ubuntu-drivers" der Nvidia Treiber auf Version 440 (nvidia-driver-440) upgedatet.

    Danach startete die X-Session nicht mehr.

    Also kein Bild, kein Ton!:§$%

    Workaround für mich:

    - alles von nvidia deinstallieren und purgen

    - in yavdr07.yml den Eintrag - autoinstall-ubuntu-drivers auskommentieren

    - den Treiber nvidia-driver-390 manuell per apt installieren

    - den/die Nvidia Eintrag in /etc/yavdr/autoinstalled löschen

    - Skript noch mal laufen lassen

    - Reboot, alles prima


    Fehlermeldungen kann ich leider grad nicht liefern, ich musste die Kiste zur besten Sendezeit wieder zum Laufen bekommen.

    WAF8o


    Die X Session konnte wegen dependencies nicht gestartet werden, was auf Fehler bei xorg zurückzuführen sein dürfte, irgendwas mit gl.


    Kann es gern die Tage noch mal versuchen und die genauen Fehlermeldungen posten.


    Gruß

    Frank

    Kann ich bestätigen, nachdem ich meine MCE überzeugt hatte per Taste zwischen VDR und KODI umzuschalten, habe ich auch diese Probleme.

    Dachte es liegt an der FB (ansible-bionic).

    Code
    1. cat /var/lib/vdr/.lircrc
    2. begin
    3. prog = irexec
    4. button = KEY_PROG1
    5. config = frontend-dbus-send switchbetween kodi vdr
    6. end

    Eine sinnvolle Fehlermeldung habe ich im syslog usw. nicht entdecken können :-(

    Sieht irgendwie nach einem Problem mit dem Frontend aus, tlw. bekomme ich ein Bild vom VDR, aber wenn ich irgendeine Taste drücke wird sofort auf Kodi umgeschaltet, very strange.


    Gruß

    Frank

    Habe ich installiert und sieht gleich besser aus.

    Timer per WebIf deaktivieren --> funktioniert

    Timer per Vdr deaktivieren --> funktioniert

    Timer per WebIf verschieben --> funktioniert

    Timer per Vdr verschieben --> jein

    Der Timer wird verschoben, aber das Verzeichnis wird nochmal hinzugefügt.

    aus Serien~MacGyver~Episode wird Serien~Serien~MacGyver~Episode

    Das Verzeichnis Serien ist im Suchtimer vorgegeben.

    Den select leicht modifiziert, damit nur der eine Timer abgefragt wird

    Code
    1. select id, from_unixtime(timers.updsp), vdruuid, vdrs.name, active, timers.state, action, info from timers, vdrs where vdrs.uuid = timers.vdruuid and timers.state != 'F' and file like '%Albtraum%'order by state;

    Leider ist nichts zu erkennen. Ablauf wie in Post #6 beschrieben.

    Pakete sind aktuell 1.1.111 und 1.1.159