Posts by Pancetto

    Hurra, seit dem 27.12.2017 sind viele Pakete von Tobias wieder aktuell!


    Vielen Dank dafür, und es wäre schön, wenn auch noch nach und nach die

    fehlenden Plugins, wie z.B. skindesigner, skinelchi, svdrpservice, markad, etc.

    noch upgedated würden.


    in diesem Sinne Tobias und allen anderen einen guten Rutsch ins Neue Jahr!

    @ gelhajo:
    das ist mir klar, das ist doch eines der Dinge, die ich selbst
    anpassen kann und auch bereits getan habe. Es geht mir um die
    Dinge, die ich NICHT beeinflussen kann.


    seahawk1986 :
    eject auf der Konsole (als root, weil ich vdr nicht als sudoer
    starten kann) geht, ich probier dann also mal deinen Link auf ein Paket.


    Ergänzung: der letzte Halbsatz war natürlich überflüssig!

    Hallo,
    habe keine große Hoffnung in dieser Sache Hilfe zu bekommen, da mir scheint,
    dass für das dvdswitch-plugin kein großes Interesse da ist, im übrigen wohl ebenso
    wenig wie für das burn-plugin.
    Wie dem auch sei, das Problem: (mindestens) seit Ubuntu 14.04 wird für das DVD-Laufwerk
    als Device /dev/sr0 angelegt, und nicht mehr /dev/dvd. Die von yavdr gepflegten Skripte
    sind jedoch noch nicht angepasst worden, im übrigen auch nicht der Link /var/cache/dvd.
    Ich kann zwar selbst in einigen Skripten die entsprechenden Stellen anpassen. leider geht
    das aber nicht beim dvdswitch-Plugin für die Befehle "Schublade öffen/schließen"!
    Weiß hier jemand vlt. mehr?

    Hallo Ihr,
    ich mache seit dem VDR 2.0.x an dem Problem rum, dass die Menüeeinträge im VDR-Menü nur von 1 bis 9 nummeriert sind, danach erscheinen nur noch die Text. Also kann man die Einträge nach "9" per FB nicht mehr direkt anwählen.


    Das Problem ist hier offenbar auch schon vor mehrern Jahren diskutiert worden, damals wurde aber als Lösung nur ein Patch vorgeschlagen. Aber nachdem ja seit etlichen Jahren in dieser Richtung alles soweit ok war, wundere mich etwas, dass das jetzt wieder auftritt. Habe bisher keine Lösungshinweise gefunden, so dass ich hier das Thema mal einstellen will.


    Das kann ich dir sagen. Wenn du mit yavdr-Pakete Pakete meinst deren Name mit yavdr- beginnt, dann haben die auf einem reinen Ubuntu nichts verloren, das geht in die Hose.
    Wenn du mit yavdr-Pakete Pakete meinst die aus dem yaVDR-Repository stammen, aber nicht mit yavdr- beginnen, dann wird der vdr dort eben doch /var/lib/video.00 verwenden, weil diese Pakete eben dem Debian-Standard entsprechen und das erst durch die yaVDR-Pakete geändert wird,


    Gerald


    Na ja, war wohl auch nichts anderes zu erwarten, oder? Ich hab's mal so gemacht: ich habe *nur* stable-vdr aus dem yavdr-Repo unter Ubuntu 12.04 eingebunden, so dass also keine yavdr-*-Plugins installiert wurden, mit der Folge also, so wie Du sagst, dass Debian-Standard verwendet wird, mit den Pfaden, wie ich sie bisher immer verwendet hatte. Das Ergebnis war so - im übrigen auch von mir - wie erwartet: ich kann zumindest ein Image ohne Menü erstellen, mit Menü crasht das Plugin nach wie vor. Ich kann's leider nicht nachvollziehen, ich habe auch keine Nerven mehr dazu, habe Script für Script versucht nachzuvollziehen, es bleibt dabei: keine Erklärung und damit auch eine Lösung in Sicht!


    Ich frage mich nur eins: wenn es in yaVDR-0.5 geht, und "da wie auch mit Ubuntu 12.04 mit yavdr-Repo" dieselben vdr-plugins verwendet werden, aber beides Mal unterschiedliche Ergebnisse erzielt werden, dann muss es doch eine Erklärung dafür geben!


    Ich geb's jetzt jedenfalls hier (vorerst) auf, trotzdem vielen Dank an Euch alle, die Ihr Euch an diesem Post beteiligt habt und weiterhin viel Erfolg mit Eurem yavdr!


    Heinz

    Das wird vom vdr-Paket angelegt, aber vom VDR unter yaVDR nicht genutzt.

    Aha, das ist doch mal eine interessante Aussage, die erste jedenfalls, die auf einen Unterschied zwischen "Standard-VDR" und yaVDR hinweist!
    Liegt da vielleicht der Hund begraben, weil ich bisher die burn-Plugin-Pfade auf die "Standard-VDR"-Pfade angepasst habe (liegt einfach daran, weil ich z.B. auf einer extra Partition meine alten Test-VDR-Aufnahmen habe, die ich nach "altem Brauch" nach /var/lib/video.00 gemountet habe)?


    Morgen werde ich jedenfalls mal den VDR unter Ubuntu 12.04 mit den yavdr-Paketen neu installieren und dabei die "yavdr-Standard"-Pfade so belassen und meine Partition mit den Aufnahmen nach /srv/vdr/video.00/ mounten, mal sehen, was dann dabei rauskommt...


    Gute Nacht wünscht
    Heinz

    Ok, nachdem sich seit meinem letzten Post niemand mehr gemeldet hat, ein paar Ergänzungen:


    Ich habe inzwischen FireFlys Vorschlag realisiert und die einzelnen Befehle in der vdrburn-dvd.sh im Abschnitt render) manuell als User vdr getestet. Danach habe ich folgende Seltsamkeiten entdeckt: 1. Die Datei menu-bg-0.png im Arbeitsverzeichnis (bei mir ein temporäres Unterverzeichnis von /var/lib/video.00, welches das burn-Plugin erstellt), ist nicht lesbar, also offenbar ein Rechteproblem und 2. wird die Datei menu-silence.mp2 nicht dort erstellt, so wie es yavdr-0.5 macht.


    Mit diesen Erkenntnissen bin ich nun allerdings am Ende meines Lateins, weil ich die davor ablaufenden Schritte nicht kenne und deshalb auch nicht nachvollziehen kann. Hier wäre also dann wirklich jemand von Euch vom yavdr-Team gefragt, der sich auskennt, und ich würde mich wirklich freuen, wenn das jemand mal ernsthaft prüfen würde.


    Ansonsten danke erst mal
    Heinz

    Ansonsten musst Du mal per Hand die Befehle ausprobieren, so wie sie im Skript hinter "render)" stehen, vermutlich liefert da eines keinen Output und spumuks crasht dann. Das wäre typisch für die Programme aus dvdauhtor...


    Ok, ich habe mir mal hinter jeder Zeile eine Log-Ausgabe gemacht, hat soweit alles geklappt, ohne Fehlerhinweis. Danach habe ich mal ins Ausgabe-Verzeichnis geschaut, da waren die entsprechenden Dateien zur Menüerstellung (menu-*.*) alle leer oder zumindest auffällig klein. Also mal probiert, in den Einstellungen des burn-Plugins die "Art der DVDs" auf "keine Menüs" eingestellt, und siehe da: es hat geklappt, nur eben ohne Menü halt. Immerhin schon mal einen entscheidenden Schritt weiter, natürlich ist das dennoch unbefriedigend, weil dann praktisch DVDs mit mehr als einem Titel praktisch nicht zu handhaben sind.


    Ich muss übrigens erwähnen, dass ich die ganzen Tests bisher nur mit der Variante "nur Image erzeugen" gemacht habe, ob das Brennen auf DVD auch klappt, muss ich noch prüfen, aber da würde auf jeden Fall dann wenigstens das Plugin dvdswitch funktionieren, das ist bisher immer ordentlich gelaufen.

    Nein, wenn der Kernel Probleme hat gibts ganz andere Fehlermeldungen :D
    Lt. Log bricht aber das spumux ab (war aus dem ersten Post nicht ganz ersichtlich). Dann fehlt im Homeverzeichnis ~/.spumux/arial.ttf was ein Link auf den entsprechenden Truetypefont ist.

    Danke für den Hinweis, FireFly, aber das Homeverzeichnis des Users vdr ist /var/lib/vdr und dort gibt's kein Unterverzeichnis .spumux, auch im "Orignal"-yavdr0.5 nicht, und bei dem funktioniert das burn-plugin ja bekanntlich! Ich komme selbst einfach nicht mehr weiter mit dem Problem, aber irgendwo muss ja das Problem liegen...

    Deine Fehlermeldung kommt beim Rendern der Menüs, dort wird png2yuv etc. benutzt. Wenn das fehlt könnte so eine Fehlermeldung kommen. Ansonsten mal in die vdrburn-dvd.sh gucken, ob alle Programme aus dem Abschnitt render vorhanden sind.

    Danke für Deine Antwort.


    Aber das wäre zu schön um wahr zu sein, wenn es nur ein fehlendes Binary wäre! Ich hab's überprüft: alle Programme sind da.


    Liegt es vielleicht daran, dass der in yavdr0.5 verwendete Kernel nicht der standardmäßige von Ubuntu, sondern vom yavdr-Team mit "extra Einstellungen" neu kompiliert ist? Darauf könnte m.E. der entsprechende syslog-Auszug hindeuten:


    Hallo, wenn ich yavdr0.5 direkt installiere, funktioniert das burn-plugin anstandslos. Wenn ich jedoch ubuntu 12.04 (64bit) installiere, das yavdr-ppa einbinde und von da den VDR installiere, dann bricht das burn-plugin gleich am Anfang ab mit einem Kernel-Error:


    Die Plugins haben sowohl im "Original"-yavdr als auch bei der Variante Ubuntu/yavdr:ppa die selbe Version, auch die Binaries sind gleich.
    Kennt jemand diesen Effekt oder besser noch: ist eine Lösung dafür bekannt?