Posts by kingmarco050

    Hallo,
    ich hatte mal nen ähnlichen Effekt da beim start die NFS Mounts nicht richtig ausgeführt wurden. Ursache war das beim Boot das Netzwerk nach den Laden des Modules und erhalt des DHCP Leases nochmal die IP verlor. Das Problem hatte sich aber mit einer neuen Distribution von selbst erledigt. Als Übergangslösung hatte ich eine fest IP eingesteltl, löste das Problem nicht direkt aber das Netzwerk war schneller wieder UP und die Anwendung lief nicht in einen Timeout.


    Gruß Marco

    Hallo,
    meine Antwort kommt zwar etwas spät.... aber ich habe auch interesse. Abgesehen davon das der VDR an sich die geilste Erifidung seit des TV's ist, suche ich nen Client der irgendwo zwischen vollwertigem PC (z.B. Zotac) und dem VompClient liegt. Ich selber bin schon auf den VOMP Client von MLD für den Raspberry umgestiegen. Läuft auf 2 TV's wirklich super, könnte aber ein Tick mehr sein. Eben lokaler VDR mit LIRC einfacher Theme und dann ist fertig.


    P.S. Hat jemand kontakt zum MLD Forum. Bekommen mich dort sein 2 Wochen nicht angemeldet und erhalte aber auch keie Antworten. Ich hoffe da ist nichts passiert.


    Gruß Marco

    Hallo,
    ich verzweifel so langsam an einem Thema an dem ich jetzt nicht weiter komme.
    Ich habe einen Server mit Debian und aktuell mit dem VDR 1.7.21 mit dem Streamdev-Server 0.5.1 aus dem Git.
    Dies war bis vor kurzem noch ein VDR 1.6 mit dem Streamdev-Server (0.5.0). Alle Clients hatten den yaVDR 0.3.0
    Diese Konstellation lief einwandfrei, bis ich auf dei Idee kam einen Client upzudaten, danach bekam ich den Stremdev-Client auf dem neuen yaVDR nicht mehr zum laufen. Weil ich dem Fehler nicht so auf die schliche kam habe ich kurzer Hand auf dem Server die Distribution und VDR samt dem Streamdev-Server Upgegraded. Ich bin der Meinung es läuft auch alles korrekt. Mein Media MVP funktioniert wieder. Der noch alte Client mit dem yaVDR 0.3.0 funktioniert bedingt. Er kann zwar auf die Streams zugreifen aber es ruckelt ab und zu
    Ich habe bloß auf dem Client mit der Version yaVDR (0.4.0) ein Problem. Ich bekomme den Stremdev-Client nicht zum laufem.
    SVDRP und Stremdevhosts Berechtigungen habe ich schon 1000 mal gescheckt, alles OK. Auf dem neuen Client habe auch andere SVDRP Plugins wie z.B. RemoteOSD, RemoteTimer und EPGSync. Diese funktionieren auch einwandfrei.
    Auch wenn es nicht mehr sein muss habe ich auf beiden Systemen die gleiche channels.conf und sources.conf.


    Natürlich habe ich auch die Logs studiert.
    Ich kann auf dem Server sehen das sich der Client einloggt. Auf dem Client erscheint aber immer nur Kanal nicht verfügbar.
    Hier nun die Logs:


    Server:

    Code
    1. Nov 20 19:30:06 Server1 vdr: [6006] connect from 192.168.0.38, port 39578 - accepted
    2. Nov 20 19:30:07 Server1 vdr: [6006] closing SVDRP connection
    3. Nov 20 19:30:18 Server1 vdr: [6609] Streamdev: Accepted new client (VTP) 192.168.0.38:38644
    4. Nov 20 19:30:18 Server1 vdr: [6609] streamdev: closing streamdev connection to 192.168.0.38:38644


    Client:
    Leider komme ich da gerade nicht mehr ran, aber so oder so ähnlich:

    Code
    1. ERROR: Streamdev: Couldn't check if 192.168.0.251:2004 provides channel Das Erste
    2. LinVDR-Client user.info vdr: [1506] info: Kanal nicht verfügbar



    Einen habe ich noch..... wenn ich mit Telnet auf dem Stremdev Port einklinke kann ich den Status des Kanals abfragen. Aber dies geht nur mit der Kanalnummer und nicht mit dem Namen. Ich habe gelesen das das aber auch gehen soll. Könnte das ein Ansatz sein oder ist etwas an meiner Schreibweise nicht richtig?


    Z.B.:

    Code
    1. 220 Welcome to Video Disk Recorder (VTP)
    2. prov -1 23
    3. 220 Channel available
    4. prov -1 1
    5. 220 Channel available
    6. prov -1 N24
    7. 550 Undefined channel "N24"


    Bitte, Bitte helft mir.


    Danke und Gruß Marco

    Sooo, ich bin jetzt schon mal ein bischen schlauer.
    Alle meine Budget Karten haben die Fehlerhafte ID. Die FF Karten sind i.O.
    Die Budget Karten sind die gleichen wie die FF nur ohne den TV-Out Teil, das können dann nur noch die


    13c2 1012 Technotrend-Budget-T-CI-1500 DVB card (budget-ci)


    sein.

    Hallo Wirbel,
    alles klar, das ist der Hinweis den ich brauchte. Da wäre ich nie im Leben drauf gekommen, dass sich der ID der Karte verändert hat.


    Naja, wollte den Kernel sowieso selber nochmal anpassen und kompilieren. Ich habe mich an die Anleitung der Datei fix_eeprom.c gehalten und mit in die Quellen eingefügt. Allerdings war ich mir nicht so sicher wo. Für meinen Fall hatte ich die fix_eeprom.c in ./drivers/media/dvb/ttpci/ eingefügt wo auch die budget.h liegt und das entsprechende Makefile angepasst.


    - Anschließend den Kernel neu kompiliert und installiert.
    - mit lspci -v war jetzt auch die fix_eeprom für die DVB Karten geladen.
    - alle DVB Module entladen
    - fix_eeprom mit den entsprechenden Parametern geladen.
    - leider war es morgens um 3:30 und mir ist das passiert was unter keinen Umständen passieren sollte: Ich hatte einen Zahlendreher im neuen ID.
    - neustart und alles Module erneut entladen.
    - den ID nochmals angepasst und wieder neu gestartet.
    - Fertig ---> geht.
    :grinzs


    Hier der Auszug von lspci ALT:


    02:02.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
    Subsystem: Device 00a1:a1a0
    Flags: medium devsel, IRQ 24
    Memory at f7ef0000 (32-bit, non-prefetchable) [size=512]
    Kernel modules: fix_eeprom


    05:01.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
    Subsystem: Technotrend Systemtechnik GmbH Device 1017
    Flags: medium devsel, IRQ 22
    Memory at f7ff0000 (32-bit, non-prefetchable) [size=512]
    Kernel modules: budget-ci, fix_eeprom


    05:02.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
    Subsystem: Device 00a1:a1a0
    Flags: medium devsel, IRQ 20
    Memory at f7fe0000 (32-bit, non-prefetchable) [size=512]
    Kernel modules: fix_eeprom


    und lspci NEU:


    02:02.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
    Subsystem: Technotrend Systemtechnik GmbH Device 1017
    Flags: bus master, medium devsel, latency 64, IRQ 24
    Memory at f7ef0000 (32-bit, non-prefetchable) [size=512]
    Kernel driver in use: budget_ci dvb
    Kernel modules: budget-ci, fix_eeprom


    05:01.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
    Subsystem: Technotrend Systemtechnik GmbH Device 1017
    Flags: bus master, medium devsel, latency 64, IRQ 22
    Memory at f7ff0000 (32-bit, non-prefetchable) [size=512]
    Kernel driver in use: budget_ci dvb
    Kernel modules: budget-ci, fix_eeprom


    05:02.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
    Subsystem: Technotrend Systemtechnik GmbH Device 1017
    Flags: bus master, medium devsel, latency 64, IRQ 20
    Memory at f7fe0000 (32-bit, non-prefetchable) [size=512]
    Kernel driver in use: budget_ci dvb
    Kernel modules: budget-ci, fix_eeprom



    VIELEN DANK FÜR DIE HILFE.


    Gruß Marco

    Hallo, Danke für den Hinweis.


    37.161352] device-mapper: ioctl: 4.13.0-ioctl (2007-10-18) initialised: dm-devel@redhat.com
    [ 37.201189] PM: Starting manual resume from disk
    [ 37.272009] kjournald starting. Commit interval 5 seconds
    [ 37.272009] EXT3-fs: mounted filesystem with ordered data mode.
    [ 38.392004] udevd version 125 started
    [ 39.862263] Linux agpgart interface v0.103
    [ 40.062599] input: Power Button (FF) as /class/input/input1
    [ 40.092188] ACPI: Power Button (FF) [PWRF]
    [ 40.551788] piix4_smbus 0000:00:0f.0: Found 0000:00:0f.0 device
    [ 41.470835] saa7146: register extension 'budget_ci dvb'.
    [ 41.470964] ACPI: PCI Interrupt 0000:05:01.0[A] -> GSI 22 (level, low) -> IRQ 22
    [ 41.471146] saa7146: found saa7146 @ mem f88de000 (revision 1, irq 22) (0x13c2,0x1017).
    [ 41.471293] saa7146 (0): dma buffer size 192512
    [ 41.471366] DVB: registering new adapter (TT-Budget/S-1500 PCI)
    [ 41.499635] input: PC Speaker as /class/input/input2
    [ 41.536536] adapter has MAC addr = 00:d0:5c:64:b1:ec
    [ 41.537073] input: Budget-CI dvb ir receiver saa7146 (0) as /class/input/input3
    [ 41.984142] input: ImExPS/2 Logitech Explorer Mouse as /class/input/input4
    [ 42.062595] DVB: registering frontend 0 (ST STV0299 DVB-S)...
    [ 42.124520] parport_pc 00:07: reported by Plug and Play ACPI
    [ 42.124667] parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
    [ 42.158882] Error: Driver 'pcspkr' is already registered, aborting...
    [ 43.328321] Adding 7349696k swap on /dev/sda5. Priority:-1 extents:1 across:7349696k
    [ 43.574682] EXT3 FS on md0, internal journal
    [ 43.904050] loop: module loaded
    [ 44.464006] kjournald starting. Commit interval 5 seconds
    [ 44.475111] EXT3 FS on sda1, internal journal
    [ 44.475111] EXT3-fs: mounted filesystem with ordered data mode.
    [ 46.084315] RPC: Registered udp transport module.
    [ 46.084438] RPC: Registered tcp transport module.
    [ 46.337277] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
    [ 46.689833] NET: Registered protocol family 10
    [ 46.690699] lo: Disabled Privacy Extensions
    [ 46.691544] ADDRCONF(NETDEV_UP): eth1: link is not ready
    [ 47.260019] tg3: eth1: Link is up at 100 Mbps, full duplex.
    [ 47.260019] tg3: eth1: Flow control is off for TX and off for RX.
    [ 47.260019] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
    [ 57.624019] eth1: no IPv6 routers present
    [ 82.264636] NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
    [ 82.274981] NFSD: starting 90-second grace period
    [ 95.465986] mtrr: no more MTRRs available
    [ 95.492694] mtrr: no more MTRRs available
    [ 358.994204] Linux video capture interface: v2.00
    [ 359.029919] saa7146: register extension 'dvb'.
    [ 361.523643] saa7146: unregister extension 'dvb'.
    [ 369.628530] saa7146: register extension 'dvb'.
    Server1:~#


    Server1:~# lsmod
    Module Size Used by
    dvb_ttpci 81672 0
    saa7146_vv 38496 1 dvb_ttpci
    videobuf_dma_sg 11140 1 saa7146_vv
    videobuf_core 16100 2 saa7146_vv,videobuf_dma_sg
    videodev 27520 1 saa7146_vv
    v4l1_compat 12260 2 saa7146_vv,videodev
    ipv6 235396 48
    nfsd 186672 17
    auth_rpcgss 33952 1 nfsd
    exportfs 3936 1 nfsd
    nfs 214280 1
    lockd 54568 2 nfsd,nfs
    nfs_acl 2912 2 nfsd,nfs
    sunrpc 162528 17 nfsd,auth_rpcgss,nfs,lockd,nfs_acl
    loop 12748 0
    snd_pcm_oss 32800 0
    snd_mixer_oss 12320 1 snd_pcm_oss
    parport_pc 22500 0
    parport 31084 1 parport_pc
    snd_pcm 62660 1 snd_pcm_oss
    lnbp21 1920 1
    snd_timer 17800 1 snd_pcm
    snd 45636 4 snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
    soundcore 6368 1 snd
    snd_page_alloc 7816 1 snd_pcm
    serio_raw 4740 0
    stv0299 8680 1
    psmouse 32336 0
    pcspkr 2432 0
    budget_ci 14596 2
    firmware_class 6816 2 dvb_ttpci,budget_ci
    budget_core 9252 1 budget_ci
    dvb_core 66528 4 dvb_ttpci,stv0299,budget_ci,budget_core
    saa7146 15048 4 dvb_ttpci,saa7146_vv,budget_ci,budget_core
    ttpci_eeprom 2240 2 dvb_ttpci,budget_core
    ir_common 39620 1 budget_ci
    container 3456 0
    i2c_piix4 7216 0
    i2c_core 19828 7 dvb_ttpci,lnbp21,stv0299,budget_ci,budget_core,ttpci_eeprom,i2c_piix4
    button 6096 0
    sworks_agp 6720 0
    agpgart 28808 1 sworks_agp
    evdev 8000 3
    ext3 105576 2
    jbd 39476 1 ext3
    mbcache 7108 1 ext3
    dm_mirror 15136 0
    dm_log 8452 1 dm_mirror
    dm_snapshot 14340 0
    dm_mod 46216 3 dm_mirror,dm_log,dm_snapshot
    raid1 18016 1
    md_mod 67100 2 raid1
    ata_generic 4676 0
    libata 140448 1 ata_generic
    dock 8304 1 libata
    sg 26964 0
    sd_mod 22200 5
    serverworks 4932 0 [permanent]
    floppy 47844 0
    ide_pci_generic 3908 0 [permanent]
    ide_core 96168 2 serverworks,ide_pci_generic
    tg3 84676 0
    aic7xxx 117592 3
    scsi_transport_spi 19840 1 aic7xxx
    scsi_mod 129548 5 libata,sg,sd_mod,aic7xxx,scsi_transport_spi
    thermal 15228 0
    processor 32576 1 thermal
    fan 4196 0
    thermal_sys 10856 3 thermal,processor,fan
    Server1:~#



    Danke für die Hilfe

    Hallo Ich habe folgendes Problem und komme einfach nicht mehr weiter.
    Ich habe bereits diverse Anleitungen und Foren durchforstet komme aber nicht auf die Lösung.


    Ich habe einen Server mit debian :
    Linux Server1 2.6.26-2-686 #1 SMP Thu Sep 16 19:35:51 UTC 2010 i686 GNU/Linux
    und einem VDR:
    CTVDR 1.6.0-17ct
    mit Dummy Device


    Ich habe 3 DVB-S Karten. 2 davon Budget und eine davon Full Featured.


    Meine Ausgabe von lspci -v ist folgende:
    02:02.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
    Subsystem: Device 00a1:a1a0
    Flags: bus master, medium devsel, latency 64, IRQ 3
    Memory at f7ef0000 (32-bit, non-prefetchable) [size=512]


    05:01.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
    Subsystem: Technotrend Systemtechnik GmbH Device 1017
    Flags: bus master, medium devsel, latency 64, IRQ 22
    Memory at f7ff0000 (32-bit, non-prefetchable) [size=512]
    Kernel driver in use: budget_ci dvb
    Kernel modules: budget-ci


    05:02.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
    Subsystem: Device 00a1:a1a0
    Flags: bus master, medium devsel, latency 64, IRQ 11
    Memory at f7fe0000 (32-bit, non-prefetchable) [size=512]


    Ich bekomme leider kein Log oder einen Hinweis auf das Laden der Firmware beim booten...... Ich habe die Firmware in den üblichen Ordnern für die dvb-ttpci.
    Was kann ich noch tun.....?


    Gruß Marco