Posts by osz

    ich habe mit

    Code
    sudo killall -9 xbmc.bin


    den prozess beendet, wenn ich aus VDR den XBMC gestartet und wieder beendet habe. Habe aber auch zweimal einen kompletten PC Neustart gemacht. Wenn ich mich als user osz im Terminal anmelde, dann kann ich XBMC ohne Probleme ins VDR verlassen.


    OsZ

    Hi, hoffe ihr habt ein schönes Osterwochenende genossen. Bin auch wieder zurück und habe gleich mal getestet - hab die ganze Woche noch frei ;)


    Also ich konnte noch folgendes zusätzlich beobachten. Anbei 2 xbmc.log dateien. Der Anfang der dateien kennzeichnet den user mit dem ich xbmc gestartet habe. Aus dem VDR Menü heraus - also als user vdr - bleibt XBMC beim beenden wie üblich hängen. Öffne ich im VDR ein Terminal und logge mich als user osz ein, starte von dort XBMC und beende es wieder -> kein Hängenbleiben ! Mehrmals ausprobiert. Vom Terminal als user osz funzt es, aus dem Menü als user vdr nicht. Beim ersten drüberschauen über die beiden Log dateien fällt auf, dass das anfängliche SDL Setup unterschiedlich ist.


    Da es ja unter user osz bei mir ohne Probleme läuft, Cybso schon erwähnte, dass andere XBMC builds laufen, einer den user vdr schon aus der gruppe Video entfernt hat und es lief usw. drängt sich im Moment bei mir der Verdacht auf, dass XBMC im prinzip doch ok ist und das Problem irgendwo in der yaVDR Umgebung liegt.


    evtl können andere user mal bestätigen, ob es aus dem Terminal bei denen auch geht. Achtung: alle Konfigurationen sind dann in ~/.xbmc anstatt /var/lib/vdr/.xbmc


    OsZ

    Könntest du das ganze etwas genauer beschreiben.
    Wie ist der Umgang mit avidemux 2.6? wie kopiere ich ton und Bild dann in eine mkv?


    da würde ich dich doch glatt mal auf das Wiki von avidemux verweisen. Das hat nämlich nichts mehr mit VDR oder gar yaVDR zu tun... hier trotzdem noch ein screenprint ;) auf der linken seite findets du die gewünschten Einstellungen.



    PS: die vers 1.6 ist noch in der Entwicklung hat aber schon gute Fähigkeiten bzgl. H264 Bearbeitung. Vor allem bildgenaue (zeitgenaue) Darstellung und setzen der Schnittmarken im H264 stream.


    OsZ

    Ich bin mit meiner TeVii S470 sehr zufrieden in meinem HTPC. die gibts auch als dual tuner (S480), ich nutze allerdings deren FB nicht (außen liegender IR Sensor mit Kabel - anfangs auch noch inkompatibel). Da ich einen IR sensor ins Gehäuse gebastelt habe, kann ich meine universal FB mit LIRC (home-brew serial) perfekt nutzen. So habe ich immer noch nur eine einzige FB für TV, Amp, DVD, Sat und HTPC im Wohnzimmer rumliegen.


    OsZ

    Hi, also bei Aufnahmen, die ich behalten möchte, nutze ich immer avidemux auf meinem 2. Rechner (der "etwas" leistungsfähiger ist, als mein HTPC).


    Aufnahmen in SD:
    Werbung rausschneiden mit DVBCUT (hab noch kein besseres Prog gefunden - ist sehr simpel und effektiv) -> mpg als zwischenschritt erstellen.
    Mit Hilfe von Avidemux 2.5 das zwischengespeicherte mpg Video nach H264 standard convertieren (manchmal auch mit Deinterlace filter) / Audio copieren und in mkv container speichern.
    Gut, das dauert dann meist so ne Stunde...


    Aufnahmen in HD:
    in Avidemux 2.6 schneiden, video und audio kopieren in mkv container speichern.
    Das ist nur ein kopieren und geht daher schnell.


    Am Ende habe ich aus beiden Methoden jeweils ein Matroska file mit H264 conformen video und meist AC3 Ton, den ich zurück auf den HTPC kopiere. In XBMC dann ne schöne Spielfilme Datenbank und alles ist prima archiviert für Fersehabende... . SD Inhalte sind dann ca. 1.5GB und HD (720p) meist ca. 4GB groß. Aus irgendwelchen Gründen haben die mkv dateien nur die halbe Größe der entsprechenden *.ts dateien.


    Osz

    Wie heinbloed hab ich jetzt auch das 'problem' (kann auch sein das ich das vorher nie getestet habe) das, wenn ich xbmc direkt wieder beende, also keinen Film abspiele, xbmc hängt. Spiel ich einen Film oder Serie, kann ich xbmc ohne Problem beenden.


    Wie ist das bei dir mit dem beenden aus "Bilder" oder "Musik"? Habe in meinem post hier schon erwähnt, dass selbst wenn ich nach dem LiveTV oder Video nur im Hauptmenü zu einem der anderen Menüpunkte wechsle, das Beenden dann nicht mehr sauber klappt. Kannst Du das bei dir auch feststellen ?


    Gruß,
    OsZ

    hier also die dritte Variante wie man die installierte Treiber version erfährt (s. post #50) ;)


    Code
    sudo apt-cache policy nvidia-current
    nvidia-current:
      Installiert: 270.41.06-0ubuntu1
      Kandidat:    270.41.06-0ubuntu1
      Versionstabelle:
     *** 270.41.06-0ubuntu1 0
            500 http://de.archive.ubuntu.com/ubuntu/ natty/restricted amd64 Packages
            100 /var/lib/dpkg/status


    Ich habe aber auch noch folgendes getestet, nach dem ich diesen post hier gelesen habe....


    Das gute - wenn ich das Youtube Plugin Nutze, ein Video damit schaue und dann danach XBMC beende - Dann beendet sich XBMC einwandfrei und der VDR startet bzw TV-Bild is da :]


    Wenn ich XBMC aus Video oder LiveTV beende funzt es meistens - ich hatte nur einmal von gut 10 Versuchen einen schwarzen Bildschirm. Wenn ich aus Fotos oder Musik heraus XBMC verlasse, dann ist VDR eigentlich immer schwarz. Selbst wenn ich LiveTV ins XBMC Menü verlasse und nur im Haupt-Menü auf "Bilder" rüber scrolle (ohne ins Bildermenü reinzugehen) und dann XBMC verlasse -> schwarz im VDR.


    OsZ

    @ fnu


    Code
    apt-cache policy xbmc
    xbmc:
      Installiert: 2:11.0-pvr+odk70-eden~git20120325.37d89f7-0yavdr2~ppa1+odk70~natty
      Kandidat:    2:11.0-pvr+odk70-eden~git20120325.37d89f7-0yavdr2~ppa1+odk70~natty
      Versionstabelle:
         2:11.0-pvr+pipelka-eden~git20111022.1788033982-0yavdr0~natty 0
            500 http://ppa.launchpad.net/yavdr/stable-xbmc/ubuntu/ natty/main amd64 Packages
     *** 2:11.0-pvr+odk70-eden~git20120325.37d89f7-0yavdr2~ppa1+odk70~natty 0
           1002 http://ppa.launchpad.net/yavdr/testing-xbmc/ubuntu/ natty/main amd64 Packages
            100 /var/lib/dpkg/status


    ich hatte weiter vorne schon erwähnt, dass ich testing-xbmc nach post 1 hier im thread, schon drin hatte. testing-vdr habe ich nur dazugenommen, da ich nicht genau weiß, ob ihr nur xbmc gepatcht habt oder auch noch was im vdr, siehe dein post hier (der mir die leichte verwirrung unterjubelte):


    ... Wir haben diesen mal in die xbmc Pakete aus "testing-vdr" eingebaut, morgen früh/vormittag könnte ihr mal testen, der build dauert noch etwas.


    egal, ich habe offensichtlich die richtige XBMC version ... hilft leider nichts.


    Danke für Eure Hilfe das Problem zu lösen und das schnelle update. Bin gerne bereit weiter zu testen...


    Gruß,
    OsZ


    Das hört sich vielversprechend an :)


    Regards
    fnu


    Habe testing-vdr repo als paketquele hinzugefügt und VDR + XBMC upgedated. Danach reboot (da auch gleich ein kernel update von Ubuntu dabei war) und getestet. Gleich die ersten beiden male, die ich XBMC gestartet und beendet habe, der gleiche Fehler, das übliche killall -9 xbmc.bin hilft ins VDR xine frontend zurück zu kommen. habs auch in XBMC->Systeminfo gecheckt, die Version ist die am 2.4.12 compilierte. Schade das.


    in welchem paket ist denn der patch zu finden und welche version ? dann prüfe ich das nochmal um sicher zu gehen.


    OsZ

    Ich hatte grade eine Unterhaltung im IRC, es scheint ein Problem des 295er nvidia Treiber zu sein, wenn jemand die Möglichkeit hat das zu testen mit einer älteren nvidia-current Version und das bestätigen könnte, wäre es super. Auf Precise komme ich mit der Version nicht einfach runter :)


    Hi, ein


    Code
    apt-cache showpkg nvidia-current


    gibt mir diese Ausgabe:



    Das sollte für die meisten user der Standardtreiber nach der installation der version 0.4.0 sein.


    Überprüft mit:


    Code
    nvidia-settings -g | grep "OpenGL version"


    gibt Ausgabe:


    Code
    OpenGL version string: 3.3.0 NVIDIA 270.41.06


    Der Fehler beim beenden von XBMC (schwarzer Bildschirm mit Mauszeiger) tritt bei mir trotzdem auf. Ein killall xbmc - wie hier schon mehrfach beschrieben - startet die xine Ausgabe des VDR auf dem Bildschirm wieder.


    Habe die 3 stable repos (vdr, xbmc, yavdr) plus das testing-xbmc repo, wie im ersten post hier beschrieben, hinzugefügt.


    PS: Außer dem Beenden muss ich aber sagen, dass diese XBMC version einfach spitze ist. Kein Absturz, alle plugins, die ich brauche funktionieren, auch die Umschaltung des TVs bei 1080p_24 Wiedergabe usw.


    Gruß,
    OsZ

    Für 1) ich sehe das gleiche Verhalten mit yaVDR 0.4 auch. Allerdings ist "oftmals" bei mir nur ca. 1 mal von ca. 20 Schaltvorgängen. Einmal hin und her gezappt und der Ton ist auf dem HD Sender da. Spiele gerade mit den Audio Puffer, scheint aber immer noch nicht 100% in Ordnung zu sein. Für mich ist das kein großes problem aber manchmal nervts halt doch.


    Für 2b) könnte das der Grund sein ?
    http://xbmc.org/natethomas/201…0/weekend-weather-update/
    http://xbmc.org/theuni/2011/12…nsor-weather-underground/
    Wird wohl erst mit XBMC 11.0 Eden endgültig gelöst sein.


    Gruß,
    OsZ

    Ja, die meisten Stationen die bei listenlive.eu gelistet sind, funktionieren gut - über deren webseite, wie übers XBMC plugin. Es gibt immer mal wieder defekte links aber nicht mehr als gewöhnlich ... Allerdings höre ich nur eine Auswahl und nicht alle zig Stationen - kann es also nicht mit Gewissheit sagen, wie sich das möglicherweise verändert hat.


    Ich habe auch ein Verzeichnis mit eigenen *.strm dateien für XBMC, in denen ich Stationen gelistet habe, z.B. von Hirschmilch.de (so jetzt kennt Ihr auch meinen Musikgeschmack). Icecast in XBMC mag ich nicht wirklich - das ist nur eine wirre Kollektion.


    Ich werde mich mal daran versuchen, den record button, der ja witzigerweise immer noch im MusikOSD von XBMC drin ist, dafür zu nutzen, den aktuell gespielten Shoutcast an streamripper zu übergeben. Allerdings brauch ich dafür etwas Zeit, weil ich mich erst in die Materie einarbeiten muss. Alternativ gibts immer noch die Möglichkeit Dharma beta4 zu nutzen (lief ja bei mir ne ganze Weile recht gut).


    Das hat dann primär aber nichts mehr mit yaVDR zu tun. Es sei denn, die yaVDR distri Entwickler sehen keinen rechtlichen Konflikt und möchten die Funktionalität - über ein plugin möglicherweise - implementieren ...


    Gruß,
    OsZ

    Hallo zusammen,


    1) also das Aufnehmen über VDR direkt ist zwar prinzipiell so möglich aber praktisch nicht zu gebrauchen.


    2) Ich habe mal getestet und auf meiner Suse Box (also völlig unabhängig von yaVDR) die letzten pre-Dharma und den aktuellen stable release mit Standardeinstellungen compiliert.


    Ergebnis:
    mit Dharma beta4 habe ich noch die Möglichkeit shoutcasts aufzunehmen. Die Funktionalität ist ähnlich streamripper, der mp3 stream wird also schön in einzelne mp3 dateien mit ID3 tags und ordentlicher Dateibenennung auf der HDD abgelegt. Die RC und final Dharma kann das aus irgend einem Grund nicht mehr. Werde das dann mal im XBMC Forum weiter diskutieren, falls jemand folgen möchte ....


    So sollte das dann aussehen, im MusikOSD ist der record knopf selektierbar und oben links blinkt rot "rec" auf.



    Grüße,
    OsZ

    Hallo atgis,
    kommt ja immer drauf an was du machen willst. Ich weiß, ist abgedroschen, aber es stimmt. Ich habe eine OneForAll im Einsatz, mit der ich TV, DVD, Sat, Verstärker und auch meinen HTPC steuere. Keine andere FB mehr auf dem Tisch ;) Den IR Sensor habe ich bei ebay günstig bekommen und mir vorn in die Gehäuseblende gebastelt - hinter einen Lüftungsschlitz ... Die Kombination funktioniert in fast allen Winkeln und auf 6m Entfernung top. Alle Tasten sind gut brauchbar belegt für VDR und XBMC. Außerdem sieht die FB gut aus und liegt gut in der Hand - beides natürlich wieder individuell verschieden und reine Geschmacksache. Nur per FB einschalten geht bei diesem Sensor nicht. Dann solltest Du schon den Atric nehmen. In meinem kleinen Gehäuse war dafür aber kein Platz mehr ...


    IR Sensor: http://www.ebay.de/itm/190314963018
    FB: http://www.amazon.de/One-All-U…rnbedienung/dp/B003737Y2O


    Gruß,
    OsZ

    Vielen Dank für die Antworten bis dahin....


    steffen_b:
    screenshot von XBMC ist angehängt. Zeigt XBMC's Audiovisualisierung mit laufendem web-radio und das Menü. Oben rechts der Knopf für die Aufnahme. Bei meinem vorigen System (hatte eine pre-Dharma pvrtesting Variante von Lars Op den Kamp compiliert - fragt mich nicht, welche revision nummer) war der auch schön rot, wie ein record knopf eben sein sollte. In yaVDR's XBMC ist der aber grau und nicht selektierbar.



    Midas:
    das wäre wohl auch eine Lösung direkt VDR zu benutzen. Ich mag eben die einheitliche Oberfläche fürs Wohnzimmer zu haben und daher verwende ich XBMC auch als Frontend für VDR. Und Musik dort wo sie hingehört, unter Musik eben. Ist wohl reine Gewöhnungssache, dass ich Musik dann über Life-TV aufnehmen müsste. Werds auf alle Fälle mal ausprobieren. Dennoch, einfach mal bei laufendem Radio Programm in XBMC's Musik Bereich den record knopf zu drücken wäre die beste Wahl ;) Zumal ich auch etliche Kanäle aus dem listenlife.eu plugin höre, das ich als Musik plugin drin habe. Ich müsste also von allen potentiellen Web-Radiokanälen die Adressen in die channels.conf einpflegen ?!


    Werde in Kürze mal berichten, wie unter XBMC die VDR Aufnahme von web-radio so läuft. Ich vermute etwas weniger komfortabel aber wenn es läuft ist's auch erst mal gut.


    OsZ

    Hallo zusammen.
    ich hatte nach einigen Versuchen mit openSuse irgendwann auf Ubuntu 10.04 umgestellt und ffmpeg, xine, vdr, xbmc etc selbst compiliert. Das lief auch alles sehr gut, bis zu einem relativ umfangreichen systemupdate :(


    Jedenfalls bin ich jetzt mit yaVDR 0.3 sehr gut gefahren, die Installatin und einrichtung ist ja relativ einfach. Nur ein "Problem" konnte ich bis jetzt nicht lösen...


    Wenn ich mit XBMC online radio (von listenlive.eu oder über eigen angelegte .strm dateien) aufnehmen möchte, geht das einfach nicht. Beim Anhören des Radiosenders gehe ich ins Menü und der eigentlich rote "record" Knopf ist ausgegraut. Ich habe vorher (selbst compiliert) genau so aufnehmen können. Habe außerdem mit streamripper auf der Konsole versucht, das geht auch. Nur eben nicht unter XBMC.


    Ich habe im wesentlichen die Standardeinstellungen von yaVDR was Funktionalität, plugins, skins etc. angeht.


    Weiß jemand Rat ?


    PS: Notlösung ist im Moment, dass ich mit Amarok auf meinem Hauptrechner aufnehme. Allerdings gönnt der sich 150W und mein HTPC gerade mal 30W. Ich würde diese simple Aufgabe gern meinem HTPC überlassen...


    Danke,
    OsZ

    Das ist so klasse. Hab gar nicht mitbekommen, dass nvidia einen neuen Treiber released hat. Damit funktionierts jetzt auch bei mir sauber. Leider hilft das nicht duckdiver, da er kein nvidia chip einsetzt. Aber alternativ den mplayer als media player in XBMC zu verwenden kann er trotzdem mal versuchen. Das wollte ich eigentlich auch machen - hat sich ja jetzt aber zum glück erledigt.


    Hier der link ins XBMC Wiki für die Verwendung externer player in XBMC
    http://wiki.xbmc.org/index.php…Player_for_media_playback


    Gruß,
    OsZ