Posts by atgis

    Wem es interessiert kann sich VMware, Virtualbox etc auch als eigenen Launcher-Eintrag zum Aufruf der GUI anlegen:

    # Menüeintrag in menuorg.xml anlegen

    Code
    1. sudo nano /var/lib/vdr/plugins/menuorg.xml


    Code
    1. <menu name="VMware">
    2. <command name="VMware" execute="/usr/share/vdr/menuorg-appswitcher standalone=yes app=vmplayer &amp;> /dev/null " />
    3. </menu>


    # oder nur das Kommando in einen Bestehenden Eintrag einfügen

    Code
    1. <command name="VMware" execute="/usr/share/vdr/menuorg-appswitcher standalone=yes app=vmplayer &amp;> /dev/null " />


    # Launcher Eintrag erzeugen (Bsp. Menüpunkt Spiele)

    Code
    1. sudo nano /etc/wmdrawer/games


    # als Letzte Zeile einfügen

    Code
    1. (VMPLAYER) (vmplayer_icon.png) (/usr/share/vdr/menuorg-appswitcher standalone=yes app=vmplayer)


    # init Skript zum starten anlegen

    Code
    1. sudo nano /etc/init/vmplayer.conf


    # Einfügen:


    # Bildchen ablegen

    Code
    1. /usr/share/yavdr/images/vmplayer_icon.png


    Danke! Kenn ich ;) aber etwas oversized...so gehts auch siehe Anhang... :) (Vorerst noch zum Test in der VM Workstation)

    Hi,


    ich hatte schon damals bei yavdr 0.4 öfters Probleme, dass das System nach einiger Zeit einfach einfror oder nicht mehr reagierte. Seit dem wechsel auf yavdr 0.5 ist die Stabilität merklich besser geworden.
    Gestern hats mich aber wieder erwischt. Beim booten steht kurz im yaVDR Splash:

    Code
    1. CX24123: wrong demod revision: 87


    dmesg: http://pastebin.com/ySKmnLKg

    Code
    1. [ 9.244164] b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital TV receiver chip loaded successfully
    2. [ 9.245071] flexcop-pci: will use the HW PID filter.
    3. [ 9.245074] flexcop-pci: card revision 2
    4. [ 9.245235] ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 17
    5. [ 9.245250] b2c2_flexcop_pci 0000:01:0a.0: PCI INT A -&gt; Link[LNKC] -&gt; GSI 17 (level, low) -&gt; IRQ 17
    6. [ 9.260183] DVB: registering new adapter (FlexCop Digital TV device)
    7. [ 9.261855] b2c2-flexcop: MAC address = 00:d0:d7:0c:0a:db
    8. [ 9.262303] CX24123: cx24123_i2c_readreg: reg=0x0 (error=-121)
    9. [ 9.262306] CX24123: wrong demod revision: 87


    Der VDR hat sich zunächst nicht mehr per Fernbedienung bedienen lassen. Dann:
    -> Kaltstart = selbes Problem
    -> mit Tastatur ins OSD und VDR Neustart = selbes Problem
    -> mit Tastatur ins OSD und Rechner Neustart = nun geht das VFD Display nicht mehr und selbst die Tastatur reagiert nicht mehr...


    nach einigen Minuten reagiert die Tastatur wieder:
    -> mit Tastatur in die Konsole und "shutdown -h now" eingegeben = VDR geht immer noch nicht, Tastatur hängt nach wie vor...


    Dann habe ich den VDR wieder via Konsole herunterfahren lassen und den Netzstecker für paar Sekunden gezogen. Dann neu starten lassen und der VDR läuft wieder!


    Ich lege den Rechner sonst immer in den S3 schlafen. Kann es sein, dass das irgendwie auf Dauer, also ohne echten Reboot Probleme verursacht? Ich hab ja irgendwie schon immer solche Probleme.

    Dann ist aber ein Falsches Device eingestellt, wenn bei Filmen kein Ton kommt. Es müsste auch eine Fehlermeldung beim Abspielen angezeigt werden, wenn das Device nicht funktioniert.
    Was ist in XBMC eingestellt? Analog oder HDMI? Wie ist dein TV angeschlossen? Mit HDMI? Oder DVI-HDMI Adapter?


    Test mal welches das richtige Ausgabegerät ist:

    Code
    1. aplay -D hw:0,3 /usr/share/sounds/alsa/Front_Center.wav


    (hw: ggf. durchprobieren 0,7 0,8 0,9)


    Yavdr kann normalerweise selbst die richtige /etc/asound.conf generieren. Du kannst im WFE die Tonausgabe nochmal verändern und Neustarten.


    Im XBMC kontrolliere ist gut, wo sollte es denn stehen? Nur HDMI funktioniert nicht und HDMI 7 (mal so als Vermutung aus der asound.conf) tuts auch nicht. Egal ob HDMI passthrough auf den selben Werten steht oder ausgeschalten ist.


    EDIT: das HDMI Passthrought ist auch nur zum Durchschleifen auf andere Audioausgaben, wie z.b. Klinke.

    Mh mit XVDR hatte das auch jemand:

    Bei mir kann ich keine Aufnahmen abspielen! In vdr syslog erhalte ich folgende Einträge:



    Was könnte die Ursache sein? Hier läuft yavdr0.4 mit allen neuesten Updates. Deine Einschätzung zu Raspbmc kann ich zu 100% bestätigen.


    Edit1:
    -------
    Ist anscheinend von der Aufnahmelänge abhängig. Kurze Aufzeichnungen werden einwandfrei abgespielt! Mal sehen wo da die Grenze liegt.


    Sieht gut aus :)
    Du benutzt ein PicoPSU oder? Die TBS, ist die mit einer Flex-Riser Card da oben befestigt?

    Ich hab schon einige Zeit gesucht wie ich alle Tasten meiner Zotac Fernbedienung nutzen kann.
    [Blocked Image: http://techreport.com/r.x/zotac-zbox-nano/remote.jpg]
    Die Ferni wird wie folgt erkannt:

    Code
    1. xbmc@ubuntu:/$ lsusb
    2. Bus 003 Device 002: ID 0471:20cc Philips (or NXP)


    Das Problem läst sich mit einer gepatchten LIRC Version lösen: (getestet mit Ubuntu 12.10. / 12.04. Kernel 3.5 & 3.17.4 / XBMC Frodo / Gotham)


    *** Wichtig für yaVDR > 0.5 ***
    für yaVDR ist dieser Thread hier zu beachten:


    Ist wenig verwunderlich - das ist ein dummes HID-Gerät...
    Es gibt einen Würgaround über lirc:
    PHILIPS MCE USB IR Receiver- Spinel plus: Nicht alle Tasten funktionieren



    Major references:
    http://ben.periton.co.uk/2012/…otac-zbox-remote-control/
    Note: I had some frustrating issues with the Howto above, so i'll provide the same version with some important mentions and corrections
    http://forum.xbmc.org/showthread.php?tid=133071&page=2


    Follow carefully theses steps:
    Plug the external USB IR receiver
    If "LIRC" is already installed

    Code
    1. sudo dpkg -l | grep lirc


    , uninstall it:

    Code
    1. sudo apt-get autoremove --purge lirc


    Nachtrag: Bei installierten LIRC bsp.: von yaVDR muss der Befehl 2x abgesetzt werden

    Code
    1. sudo apt-get autoremove --purge lirc / bzw.: sudo apt-get autoremove


    IMPORTANT TO AVOID ISSUES: Ensure the original LIRC init script does not exist:

    Code
    1. sudo rm /etc/init.d/lirc


    Install some requirements:

    Code
    1. sudo apt-get install automake dialog libtool


    Nachtrag: im FernetMenta GIT gibt es eine neuere Version die noch sudo apt-get install make help2man pkg-config erfordert



    IMPORTANT TO AVOID ISSUES: Avoid the kernel from loading the module "ite_cir" that manages the internal IR
    Note: On some systems (i had the case under Xubuntu 12.04) if you don't do that you may go in great troubles with latency and crazy repeating keys when using the remote.


    Edit "/etc/modprobe.d/blacklist.conf" and add the following line at the end of the file:

    Code
    1. blacklist ite_cir


    Download and extract Fermenta's LIRC:

    Code
    1. wget https://github.com/FernetMenta/lirc/tarball/master -O lirc.tar.gz
    2. tar -xvf lirc.tar.gz
    3. cd <EXTRACTED DIR>


    Configure and install, when running setup.sh, select driver zotac under usb, save & configure:

    Code
    1. ./autogen.sh
    2. ./setup.sh
    3. make
    4. sudo make install


    Nachtrag: Ich bekomme das neue LIRC leider nicht gebaut. make install wird bei mir nicht erfolgreich ausgeführt.
    Es werden zwar die neuen Dateien kopiert, LIRC aber nicht installiert.
    Das ist aber soweit kein Problem da die neuen Dateien lircrcd, lircd und lircmd trotzdem erzeugt werden und funktionieren.
    Hier zum Querlesen eine andere herangehensweise für yaVDR: http://www.vdr-portal.de/board…2-plus-mit-fernbedienung/


    Create links in /usr/sbin:

    Code
    1. cd /usr/sbin
    2. sudo ln -s ../local/sbin/lircd lircd
    3. sudo ln -s ../local/sbin/lircmd lircmd


    Set LIRC to launch at system startup (with good options) :
    Create "/etc/udev/rules.d/85-xbmc.rules":

    Code
    1. #Remote Control
    2. SUBSYSTEM=="usb" , ATTRS{idVendor}=="0471", ATTRS{idProduct}=="20cc", SYMLINK+="remote", ACTION=="add", RUN+="/sbin/initctl --quiet emit --no-wait ir-ready"


    Nachtrag: bei neueren Kernel >3.5.x muss SUBSYSTEM=="usbmisc" eingesetzt werden (bei mir geht es nur so unter Kernel 3.17.4)


    Create "/etc/init/lirc.conf":



    Stop X11 from registering the device as a keyboard:


    *** IMPORTANT REMARK ***
    Xorg upgrades will break this!
    In case you later upgrade your system, you really should ensure the file "/usr/share/X11/xorg.conf.d/10-evdev.conf" hasn't been overwritten.
    If it has been overwritten, simply re-do the step bellow. (if you don't you will go in troubles)


    Edit "/usr/share/X11/xorg.conf.d/10-evdev.conf" and add the following section at the beginning of the file:

    Code
    1. Section "InputClass"
    2. Identifier "PHILIPS MCE USB IR Receiver- Spinel plus"
    3. MatchProduct "PHILIPS MCE USB IR Receiver- Spinel plus"
    4. MatchIsKeyboard "true"
    5. Option "Ignore" "true"
    6. EndSection


    Configure several files as follow:


    Replace "/etc/lirc/hardware.conf":


    Replace "/etc/lirc/lircd.conf":


    Create "~/.xbmc/userdata/Lircmap.xml" as your XBMC user:


    REBOOT
    And finally test your remote control, everything should be working like a charm!


    Quelle: http://youresuchageek.blogspot…nfig-howto-for-linux.html
    Und hier der Thread dazu: http://forum.xbmc.org/showthread.php?tid=133071