Posts by ekur

    Hallo Gerald,


    ja, das mit dem Mounten ist nicht so einfach wie ich jetzt festgestellt habe. Jetzt überlege ich mir ernsthaft einen Mailserver mit auf meinen Datenserver zu legen, allerdings habe ich mich bisher immer ein bisschen gescheut wegen der schier endlosen Konfiguration (zumindest kam mir das so vor). Welche Programme nützt du denn für das holen der Mails vom Provider, als Mailserver und zum Versenden der Mails?


    Gruß


    Elmar

    Hallo Dirch,


    der ganze VDR muss einen möglichst hohen waf haben, und den hat er leider nicht wenn ich Internet und Mail aus zwei verschiedenen Menüs heraus aufrufen muss, deswegen der Weg über den externalplayer.


    Gruß


    Elmar

    Hallo zusammen,


    erstmal ein dickes LOB an die Entwickler von yavdr, ein super Ding habt Ihr da zusammengestellt. Ich nutze den vdr schon länger, aber bisher war es nie so einfach wie jetzt.


    Jetzt zu meinem Thema:
    Ich habe das Applicationsmenü mit einem Zusatz für Thunderbird erweitert, funktioniert auch super mit den custom_templates, wenn man sich mal durch die Pfade gewühlt hat.
    Meine Thunderbirddaten liegen jetzt auf einem Server, auf das Verzeichnis mounte ich in der fstab mit noauto und users und will dann beim Aufruf von Thunderbird das Verzeichnis mounten, danach wieder unmounten, also ist das Startscript für Thunderbird (von Firefox-Script abgeleitet) wie folgt:


    Code
    export PATH=/usr/local/bin:/usr/bin:/bin 
    export HOME=/var/lib/vdr  
    export DISPLAY=:1`dbget vdr.tempdisplay`
    /sbin/stop vdr-frontend
    /bin/mount /mnt/elmar
    /usr/bin/openbox & 
    thunderbird 
    killall openbox
    /bin/umount /mnt/elmar
    /sbin/start vdr-frontend


    sooo, jetzt wird's komisch, wenn ich über das OSD den Punkt anwähle öffnet er auch brav Thunderbird, aber er führt den mount-Befehl nicht aus.
    Wenn ich das startscript in der Shell, also vorher ins Terminal gewechselt, starte geht es mit sudo.
    Wenn ich in der Shell das mounten ohne sudo ausführe geht es auch (wie gewünscht, da users angegeben).
    Muss ich das start-script von thunderbird mit besodneren Rechten ausstatten?


    Schon mal im voraus Danke für die Hilfe.


    Gruß


    Elmar

    Hallo Berndl,


    kvdr ist ein Quellcodepaket unter Lucid, das bedeutet dass Du das nicht als Paket direkt installieren kannst sondern erst das tar.gz - Paket herunterladen, entpacken, kompilieren und installieren musst.


    Viele Grüße


    Elmar

    Edit:


    Das Problem hat sich gelöst, es war ein anscheinend nicht richtig installiertes Plugin. Den bei der Deinstallation des Paketes habe ich eine nicht richtige Verknüpfung mit einem anderen Paket festgestellt. Nach Herstellen der Zuordnungen über aptitude und Neuinstallation des Plugins geht es wieder. Komisch war nur dass er bei der Erstinstallation keine Fehler gemeldet hatte.


    Gruß


    Elmar



    Hallo zusammen,


    ich habe mit dem letzten Update von meinem Ubuntu 10.04 (Server mit vdr und Client) auf Kernel 2.6.32-22 auch gleich ein paar Updates vdr und des Plugins Xineliboutput mitinstalliert bekommen. Da ich meinen vdr über das ppa testing-vdr vom “yaVDR” team installiert habe nehme ich an dass diese von dort kamen.
    Seitdem kann ich nicht mehr über vdr-sxfe auf mein vdr zugreifen, obwohl es vor den Updates funktionierte und ich nichts geändert hatte.
    Der vdr läuft auch, aber beim Versuch mit vdr-sxfe auf dem Client eine Verbindung aufzunehmen kommt folgende Meldung:



    Es sieht aus wie ein Berechtigungsfehler, aber selbst wenn ich in der allowed_hosts.conf und in der svdrphosts.conf alle Rechner zulasse bekomme ich diesen Fehler.


    Habe ich noch irgendwas anderes übersehen?


    Viele Grüße


    Elmar

    Hallo,


    zwei Fragen:
    1.) Bei der ursprünglichen Installation hattest Du keinen Abbruch wegen der fire-Karte oder?
    2.) Die alten Installation hast Du erst deinstalliert bevor du die neue Installation gemacht hast?


    Gruß


    Elmar

    Hallo Gerald,


    mein vdr läuft auf einem ATOM330 Board, beim Booten (egal ob Festplatte oder CF-Karte) hat mein damaliges System (Alternativ Installation von 9.10 ohne GUI) nach Verwendung des dmks-Modules aus dem Repository an der Stelle immer 4 bis 5 Sekunden "gehangen", so als müsste die Hardware erst initialisiert werden.
    Ich muss aber auch sagen, dass ich unter 10.04 es noch nicht ausprobiert habe.



    Gruß


    Elmar

    Hallo leonie,


    ich hatte auch mal eine Skystar2 HD, die funktionierte allerdings nicht mit den von Ubuntu mitinstallierten DVB-Modulen. Ich musst hier immer erst die Module über s2-liblianin selber generieren, ich denke dass musst Du auch.
    Das yavdr-Team hat inzwischen in Ihrer Repository ebenfalls die Module als dmks, Nachteil ist hier die größere Bootzeit, Vorteil das nach einem Kernelupdate nicht erst die Module auf den neuen Kernel installiert werden müssen.
    Zum installieren suche hier mal in dem Forum zum Thema TT1600 Treiber/Module, die Vorgehensweise ist identisch.


    Gruß


    Elmar

    Hallo Netvista-Fan,


    das war es wirklich. Ich habe die libxine1-xvdr und die xineliboutput-sxfe von der Repo des yaVDR Team deinstalliert, danach das Repo rausgenommen und die 1.0.4 aus den Ubuntuquellen installiert. Und es funktioniert !!!!
    Ich wäre nicht darauf gekommen, dass die Repos vom yaVDR Team verschiedene Versionen für Karmic und Lucid führen.


    Wie immer prompte und gute Hilfe hier im Forum. Sehr gut und weiter so.


    Gruß


    Elmar

    Hallo Wilderigel,


    danke für die schnelle Antwort.
    bei mir ist es eigentlich egal ob ich

    Code
    xvdr:tcp://IPServer


    oder

    Code
    xvdr+tcp://IPServer


    eingebe, geht beides oder auch beides nicht, je nach Version.


    Versionen auf dem Server


    Versionen auf dem Client (10.04):


    Gruß


    Elmar

    Hallo zusammen,


    ich habe einen Server, auf dem VDR als Aufnahmeserver sowie als Streaming-Server über xineliboutput läuft. Der Server läuft auf Ubuntu 9.10 (wird in ein paar Monaten auf 10.04 wegen LTS gewechselt), als Client ist/war bisher ein 9.10 Ubuntu Desktop vorhanden, es funktionierte auch alles.
    Ich habe bei meinem Desktop jetzt als zweites BS Ubuntu 10.04 aufgespielt und die üblichen Verdächtigen (also vdr-sxfe) für den Client installiert, am Server wurde nichts verändert. VDR wurde über die Repositorys von The VDR Team bzw yaVDR Team installiert, sowohl Serverseitig als auch bei beiden Clientversionen.
    Jetzt habe ich folgende Problematik:


    1.) Booten des Ubuntu 9.10, kein Problem beim Fernsehen über vdr-sxfe.
    2.) Booten des Ubuntu 10.04, kein Bild und VDR unterbricht den Austausch zwischen Client und Server.


    In beiden Fällen ist der Aufruf auf dem Client gleich:


    Code
    vdr-sxfe --post tvtime:method=Linear,cheap_mode=1,pulldown=0,use_progressive_frame_flag=1 xvdr:tcp://IPServer


    Ich bekomme ein schwarzes Bild, in dem ich noch das Menü aufrufen kann, je nachdem wie schnell ich bin, denn nach ein paar Sekunden kappt VDR die Verbindung und es kommen folgende Meldungen:


    Code
    [3486] [input_vdr] Control stream disconnected 
    [3477] [input_vdr] write_control aborted 
    [3477] [input_vdr]    (ERROR (xine_input_vdr.c,772): Resource temporarily unavailable) 
    [3477] [vdr-fe]    fe_send_input_event: message KEY d lost 
    [3488] [vdr-fe]    Keyboard thread terminated [3477] [input_vdr] write_control aborted 
    [3477] [input_vdr]    (ERROR (xine_input_vdr.c,772): Resource temporarily unavailable)


    wobei die untere das Drücken einer Taste betrifft.


    Vertragen sich die VDR Module von 9.10 und 10.04 nicht? Hat jemand eine ähnliche Erfahrung gemacht?


    Viele Grüße


    Elmar

    Hallo Steffenforever,


    die TT1600 läuft unter 9.10 ohne Probleme wenn Du die Treiber von s2-liplianin installierst.


    Vorgehensweise (Dank an Eishailiga aus dem ubuntuusers Forum)


    Code
    sudo apt-get install mercurial gcc make build-essential linux-headers-`uname -r`
    hg clone http://mercurial.intuxication.org/hg/s2-liplianin/ 
    cd s2-liplianin 
    make 
    sudo make install 
    sudo reboot


    Überprüfen mit


    Code
    dmesg | grep -i dvb


    Falls das kompilieren der Treiber bei irgendwas mit firedtv abbricht


    installieren von


    Code
    sudo apt-get install libncurses5-dev


    und ausführen von


    Code
    sudo make menuconfig


    vor dem make.
    In dem Menü dann durchhangeln bis zu den dvb Treibern und dort die firedtv deaktivieren.


    Falls Du mal ein Kernelupdate machst musst Du die alte Installation bereinigen und das gleiche Spiel mit dem neuen Kernel machen.


    Gruß


    Elmar

    Hallo Batesman,


    aufgrund des Chaos habe ich das irgendwan auch ad acta gelegt. Da WOL auch bei Rechner in PowerOFF funktioniert habe ich damit auch kein Problem, acpiwakeup sollte auch funktionieren, kann ich aber nicht mit Bestimmheit sagen, da ich es momentan nicht nutze.


    Gruß


    Elmar

    Hallo batesman,


    Du schreibst von einem vdr-Server, meinst Du damit einen wirklichen Server, also ohne GUI, bei dem der VDR als Backend dient?
    Dann würde ich Dich nämlich bitten mal die Zeit eines neuen Reboots mit einem Suspend zu vergleichen.
    Bei mir braucht ein Suspend to RAM im Server nur unwesentlich kürzer als ein Neuboot und ein Suspend to Disk wegen dem cecachtem Arbeitsspeicher sogar länger als ein Neuboot.


    Da mir der Suspend to RAM zu unsicher ist mache ich inzwischen nur Neuboots.


    Gruß


    Elmar

    cactus-online


    Quote

    /etc/init.d/vdr stop -> Ruhezustand geht


    Wenn es nur am vdr liegt ist die Lösung einfach, über Scripte den vdr vor suspend stoppen und nach suspend wieder starten.


    Da Du hier postest gehe ich mal von Ubuntu aus, hier eine gute Erklärung wie es geht:


    http://wiki.ubuntuusers.de/pm-utils


    HenriMaddox
    In dem Link steht auch was über Module die Probleme bereiten, bei mir (Asus ION Board) hatt ich z.B. die Probleme mit den Standard Netzwerktreibern, wenn ich die vorher entladen habe gings.


    Gruß


    Elmar

    Quote

    Original von Morone


    2) Egal. Hier USB-Stick zum Booten und System liegt auf Server (NFS over root)


    @Morone: Kannst Du das mit dem System auf dem Server näher erklären? Wenn ich vom Stick boote ist das System doch auf dem Stick? (Vielleicht Dau-Frage, aber ich stelle mich auch nicht zu den Linux-Cracks)


    Quote

    Original von Nostradani


    Ich hab sehr gute Erfahrungen mit Ubuntu Minimal gemacht (das nötigste nachinstalliert). Da hatte ich gefühlt deutlich unter 30s Bootzeit (in Fluxbox) und hab dazu noch ein komfortables System (was Installation etc. betrifft).


    Nostradani: Gute Idee, ich habe mal die Bootzeiten meines Desktops (Ubuntu 9.10, Desktop) und meines Servers (Ubuntu 9.10, Alternate-Install nur mit Textzeile) mitgestoppt
    Desktop: BIOS-Boot 17 Sek. :tdw; Ubuntu von Grub bis Anmeldung 20 Sek, bis Desktop fertig 30 Sek
    Server: BIOS-Boot 4 Sek, Gesamtbootzeit bis Anmeldung 20 Sek (ich denke keine schlechte Zeit, da Samba, VDR, NTP mitgestartet werden)
    Ich denke, hier kann mit einer Minimalinstallation noch was getan werden.


    Nix: Ich habe in Deiner Signatur gesehen, dass Du einen ION 230 verwendest, reicht der für HD?


    Viele Grüße und schönes Fasten nach Weihnachten


    Elmar

    Hallo zusammen,


    nachdem mein Fileserver mit Aufnahmefunktion nun funktioniert möchte ich über kurz oder lang das nächste Projekt angehen, einen HTPC.
    Bezüglich der Hardware überlege ich noch, ob dieser eine eigene Sat-Karte bekommen soll oder ob ich eine weitere Karte in meinen Server einbauen soll und der HTPC nur als Streaming-Client agieren soll. Als Hardwaregrundkomponente möchte ich ein ION-Board einsetzen mit 9400 Graphikprozessor.
    Nun fangen aber schon die Fragen an:
    1.) Mein Server ist ebenfalls ein ION-Bord (330) mit einer TT-S 1600 und hat keinen Steckplatz mehr frei (Mini-ITX). Kann eine weitere Sat-Karte an USB ohne Probleme zur Steckplatzkarte betrieben werden?
    2.) Ich möchte den HTPC ohne Festplatte betrieben, welches ist das beste Alternativmedium, USB-Stick, CF-Karte, etc? Wer hat so einen HTPC laufen und kann ein bischen aus seinem Nähkästchen plaudern?
    3.) Der HTPC soll möglichst schnell bereitstehen, also d.b. ich möchte keine 30 Sec. Bootzeit in Kauf nehmen nur um mal Fernsehen zu sehen. Was sind so Eure Erfahrungen hinsichtlich der Bootzeiten? Mit welcher Distribution/Installation bekommt man hier ein schnelles System zusammen?


    Das sind so die ersten Fragen, weitere werden bestimmt noch kommen...


    Gruß


    Elmar

    Hallo cduerr und alle anderen,


    ich setze das Thema mal auf gelöst, da ich das Problem jetzt umgangen habe, indem ich eine andere Sat-Karte eingebaut habe. Aber gut, dass Du mir noch einen Hinweis gegeben hast, denn ich wollte die alte Skystar2 HD schon wegwerfen, da ich dachte die Karte sei hinüber. Aber jetzt hebe ich Sie mal auf bis zur nächsten Servererweiterung, dann ist das Problem hoffentlich gefixt.
    Hoffentlich darum, weil die Karte hatte bei mir unter Windows nämlich die Macke nach Installation von Treibern im Zusammenspiel mit dem Firefox immer mal wieder zu einem Blue-Screen zu führen, das war damals mein Grund warum ich zu Ubuntu wechselte :lol2


    Auf jeden Fall nochmals danke an alle, die sich der Problematik angenommen haben, ich denke ich werde Eure Geduld auch in Zukunft brauchen....


    Gruß


    Elmar