Posts by dwoe

    Hallo TheChief,


    ich denke, das geht in die richtige Richtung.


    Wenn ich die Ergebnisse meiner bisherigen Test richtig deute, startet der (manuell aufgerufene) XBMC nicht, da kein X11 läuft.


    Der manuelle Start von X11 scheitert m.E. an den nicht vorhandenen Treibern für die Grafikkarte.


    Um mich langsam da ran zu tasten, müssten also wohl als erstes Grafikkarten-Treiber installiert werden. Ich versuche mal zu verstehen, was in deinem Link erklärt wird.


    Vielen Dank,


    Dirk

    @hebi: zeige mir bitte die Stelle, wo ich darum gebeten habe XBMC mit auszuliefern. Seit dem ersten meiner Beiträge ist mir bewußt, dass XBMC elementarer Bestandteil von yaVDR ist!!! Verwundert war ich nur über das Fehlen des Menü-Eintrags, da ich nicht wusste, ob es an einem Problem bei der Installation liegt oder an der mangelden VDPAU-Unterstützung.


    Keine_Ahnung : genau das ist mein Anliegen und die Frage, ob es überhaupt ohne VDPAU-Unterstützung läuft (natürlich ohne HD-Video und mit der Ausgabe über die Grafik-Karte!!!) :]


    gda : Habe absolut Verständnis dafür, dass Ihr wichtigeres bei der Entwicklung zu tun habt - zumal meine Konfiguration ja auch nicht der Grundidee von yaVDR entspricht! ich möchte auch nicht unnötigerweise hier die Threads vollmüllen. Ich hatte halt gehofft ein (weniger beschäftigter) Anwender von yaVDR könnte mir ein wenig helfen. Macht weiter so - super Arbeit!

    Hallo hepi,


    ich nehme mal an, dass Du Deinen Thread unter anderem auf meine Fragen beziehst, wobei ich auch nichts gegen eine persönlich "Ansprache" haben, wenn Du mich wirklich meinst.


    zu 1) S2-6400-Support ist wirklich schon absolut super und läuft direkt nach Installation!!!


    zu 2) Brauche ich unter Linux wirklich VDPAU damit XBMC läuft? Ich dachte das dient nur der Decodierung der Videoströme? Ohne geht dann halt kein HD-Video, aber Musik und Bilder...?


    zu 5) Ich bitte meine Fragen nicht als Forderung zu verstehen. Ich bin sehr glücklich, darüber wie es bisher läuft - nur: wenn ich nicht daran rumspielen wollte, hätte ich mir einen PVR beim Saturn gekauft. Wenn niemand (insbesondere die Entwickler) Zeit hat mir zu antworten, ist es auch ok.
    Bzgl. der Hardware wurde ich schon oft gebeten die Signatur zu nutzen, damit jeder direkt weiß was los ist (und im Thread ist die FF-HD auch erwähnt). Ich habe auch kein Problem zuzugeben, wenig Ahnung von Linux zu haben - wo meine Fragen aber eine hinreichende Portion an technischem Unverständnis offenbaren verstehe ich nicht ganz. Ich habe nie behauptet XBMC über die FF-HD ausgeben zu wollen!

    Hallo und danke Keine_Ahnung,


    im Prinzip stimmt es natürlich so, wie du es beschreibst.


    Vielleicht noch ein paar Gedanken zu meiner Motivation:


    im Prinzip bin sehe ich den VDR-Rechner immer noch als Ersatz für meinen guten alten VHS-Videorekorder. Sprich VDR ist das HERZ und Aufnehmen und Wiedergeben von TV-Signalen ist die Hauptaufgabe des Rechners. Das klappt ja auch mit der 0.4 pre1 schon absolut super ootb (riesen Lob an alle Beteiligten).


    Irgendwann kam dann mal der Wunsch Fotos und Musik auch mit dem VDR abzuspielen, was aber meist nicht sehr kompfortabel oder schön gelingt. XBMC ist hierfür die beste Lösung, die ich je unter Linux (oderWindows) gesehen habe. Daher die Idee, XBMC quasi als Ersatz für das mp3-plugin oder image-plugin des VDRs zu nutzen.


    Das explizite Aufrufen von XBMC aus dem VDR heraus empfand ich als die sauberste Lösung (warum soll XBMC im Hintergrund laufen, wenn ich nur TV schauen will). Außerdem dachte ich, dass man so Wechselwirkung bei der FB vermeiden kann...


    Ich glaube es gibt ja auch ein PlugIn zum Aufrufen externer Programme (external...???).


    Vielen Dank,


    Dirk

    Ok, getestet:


    High-Level OSD abgeschaltet -> Narrow-Skin läuft
    (True Color scheint keine Auswirkung zu haben).


    Mit ein wenig Anpassung passt das OSD jetzt auch auf den TV.


    ...mit ein paar Ausnahmen: wenn ich bei einer Wiedergabe OK drücke oder den VDR runterfahren möchte, sitzen die Einblendungen so weit unten, dass sie abgeschnitten werden (die Einblendung: "Herunterfahren abbrechen..." kann man gar nicht lesen. Woher kommt das? Die Einblendung der Infos zum laufenden Programm (OK-Taste bei TV-Betrieb) sitzt perfekt!


    Dirk

    Hallo schneisa,


    das hatte ich ja auch so geschrieben, glaube ich:


    Die Ausgabe erfolgt dann natürlich nicht über meine FF-HD sondern über die Onboard-Grafikkarte (HDMI-Out) und ich muss den TV auf die entsprechende Quelle umschalten.


    Nochmal zum verdeutlichen:
    XBMC soll nicht über die ff-HD-Karte laufen sondern über meine Grafikkarte! Ich möchte lediglich am VDR auswählen können, dass der XBMC gestartet werden soll (und wenn XBMC beendet wird, solls wieder zurück gehen). Wenn im Hintergrund der VDR auch noch Aufnahmen durchführt wäre es natürlich schön.


    Die Frage ist: was muss ich installieren (bzw. tun), dass ich XBMC auf diesem beschriebenen Weg starten kann.


    Vielen Dank,


    Dirk

    Hallo zusammen,


    mein erster yaVDR läuft quasi ootb. Und alle Funktionen eines PVR funtionieren: Gucken und Aufnehmen in HD!, Abschalten und Aufwachen, FB, Streaming, EPG... Macht schon mal wirklich Spaß und vielen Dank den Entwicklern und Helfern hier im Forum.


    Nur: wo ist der XBMC - laut Beschreibung müsste der XBMC ja im Menü vom VDR auftauchen. Tut er aber nicht. Kann das daran liegen, dass ich keine Unterstützung für VDPAU (und somit kein XORG) habe? Ist er installiert worden und wird nur nicht angezeigt?


    Ich würde den XBMC gerne als reinen Mediaplayer für Musik, Bilder und Videos nutzen, die beim mir im NAS rumfliegen. Eine Integration der TV-Bilder/Aufnahmen ist nicht nötig. Nach dem Booten kann ruhig erstmal der VDR erscheinen und ich möchte dann per Fernbedienung den XBMC starten und steuern können. Die Ausgabe erfolgt dann natürlich nicht über meine FF-HD sondern über die Onboard-Grafikkarte (HDMI-Out) und ich muss den TV auf die entsprechende Quelle umschalten.


    Kann mir jemand ein paar Tipps zum Vorgehen bei meiner Hardware geben (siehe Signatur).


    Vielen Dank,


    Dirk

    Hallo und vielen Dank,


    das Problem war wirklich der Skin:
    - Klassisch oder ST:.... laufen problemlos (sollte für den Anfang ausreichen)
    - PearHD etc. teilweise
    - Narrow liefert die abgeschnitte Schrift


    Wo würde ich denn den SD Skin von Anthra bekommen und wie kann ich den nachträglich installieren?


    Danke,


    Dirk


    1. bis 4. Richtig ! Ist natürlich nur ne Zwischenlösung bis das Finanzministerium die 42'' genehmigt...


    Die TV hängt über den Mini DIN Anschluss der Karte am Scart-Anschluss.


    Warum kann XBMC denn nicht funktionieren - später mal wenn ich den LCD mit vielen HDMI-Eingängen habe. Die FF-HD hat einen HDMI-Ausgang und XBMC läuft über die Grafik-Karte (die hat auch einen HDMI-Ausgang). Klar, dass ich dann umschalten muss...

    Hallo zusammen,


    wegen neue Hardware (siehe Signatur) wird mein VDR komplett neu aufgesetzt. Bisher hatte ich yaVDR gemieden, da kein VDPAU. Jetzt aber mit Unterstützung für die TT S2-6400 habe ich mich doch mal dran gewagt:


    Installation lief problemlos durch (auch wenn es einige Zeit gedauert hat) und es kam auch direkt Bild (3sat Stream) und Ton. Leider zeigt das OSD jede Zeile nur zur Hälfte an (siehe angehängte Bild). Ist das ein Bug oder kann ich das noch irgendwo durch Einstellungen beheben? Ich habe als Besonderheit das ganze aber auch noch am analogen Röhrenbildschirm hängen...


    Eine Frage noch:
    Wie funktioniert das jetzt überhaupt mit der Ausgabe, wenn ich keine NVIDIA Grafik habe sondern nur die FF-HD. Und was passiert, wenn ich XBMC nutzen möchte.


    Vielen Dank,
    Dirk

    Hallo und danke,


    ja, das habe ich gemacht:



    Das hier haste auch sicher gemacht, oder?

    Code
    1. sudo su -
    2. make && make install


    Zuerst kam der beschrieben Fehler mit FireDTV, dann habe ich den den Adapter abgewählt und das ganz nochmal aufgerufen. Der Rechner hat bestimmt 10 Minutenn gerödelt und ein Fehler war für mich nicht erkennbar.


    Ich habe die Treiberinstallation auch mittels ls -l geprüft - es erschien so etwas:


    Code
    1. -rw-r--r-- 1 root root 49096 2011-06-04 17:45 budget-av.ko
    2. -rw-r--r-- 1 root root 44768 2011-06-04 17:45 budget-ci.ko
    3. -rw-r--r-- 1 root root 21696 2011-06-04 17:45 budget-core.ko
    4. -rw-r--r-- 1 root root 34016 2011-06-04 17:45 budget.ko
    5. -rw-r--r-- 1 root root 20344 2011-06-04 17:45 budget-patch.ko
    6. -rw-r--r-- 1 root root 197296 2011-06-04 17:45 dvb-ttpci.ko
    7. -rw-r--r-- 1 root root 5720 2011-06-04 17:45 ttpci-eeprom.ko


    Mit aktuellem Datum !! Nur die Größen unterscheiden sich - gibt's dafür eine Erklärung?


    Wenn ich das richtig interpretiere hat das Kompilieren dann doch wohl geklappt.


    Erst beim modinfo bzw. modprobe gibt's dann die Probleme...


    Was soll ich tun?


    Viele Dank,


    Dirk

    Hallo zusammen,


    ich habe jetzt zum 3 Mal alles nach HowTo nachgespielt und ich denke, dass ich keine Fehler gemacht habe (Copy/Paste). Trotzdem schaffe ich das mit den Treibern irgendwie nicht.


    Alle Schritte (Firmeware, Treiber kompilieren, ...) scheinen zu funktionieren.


    Beim

    Code
    1. sudo modinfo saa716x_ff

    kommt dann aber

    Code
    1. ERROR: modinfo: could not find module saa716x_ff


    und bei

    Code
    1. sudo modprobe saa716x_ff

    kommt

    Code
    1. FATAL: Module saa716x_ff not found.


    Wie gesagt: das kompilieren scheint zu klappen und


    Code
    1. cd /lib/modules/$(uname -r)/kernel/drivers/media/dvb/ttpci
    2. ls -l


    liefert mir auch die richtigen Ergebniss (Datum stimmt) - allerdings unterscheiden sich die Größen beim mir vom HowTo.


    Könnt Ihr mir Tipps geben, warum es nicht funktioniert bzw. wie ich testen kann warum es nicht funktioniert...


    Vielen Dank,


    Dirk

    Also während dem make kommt folgendes:



    Den Mittelteil habe ich mal gekürzt - kann damit jemand etwas anfangen?


    Danke,


    Dirk

    Hallo zusammen,


    ich habe alles genau nach HowTo gemacht und bis zum Kompilieren des VDR hat auch alles geklappt.


    Leider endet der Aufruf von


    Code
    1. make REMOTE=LIRC && make plugins && make install


    mit einem Fehler:


    Code
    1. make[1]: Verlasse Verzeichnis '/usr/local/src/vdr-1.7.18/PLUGINS/src/svdrpdemo'
    2. *** failed plugins: dvbhddevice
    3. make: *** [plugins] Fehler 1


    Allerdings habe ich am Anfang Probleme mit dem Übersetzen der Treiber gehabt - daher habe ich es nach folgender Anleitung gemacht:


    http://www.aregel.de/vdr/30/s2-6400-trei…638-uebersetzen



    Kann es damit etwas zu tun haben oder hat jemand eine Idee woran es liegen könnte?


    Vielen Dank,


    Dirk


    Du auch das E35M1 hast. Falls Du da das HW-Monitoring mit lm_sensors zum laufen bekommst sag mal bitte wie - ich habe noch keine Weg gefunden, der Chip hat wohl bisher keine Unterstützung ...


    Oje, aber so weit bin ich noch gar nicht. Ich bin vorest mal froh, wenn ich die Ubuntu-Anleitung hinbekomme, so dass der VDR überhaupt erstmal läuft. Dann geht's erst ans "spielen".