Posts by OleS

    Falls du noch EPG-Bilder und Senderlogos haben möchtest... da habe ich auch etwas tüfteln müssen.


    Auf dem VDR:


    Picons im srp-Format herunterladen (von https://www.picons.eu - Achtung, viel Werbung auf der Seite...), z.B. srp-full.400×240-370×210.light.on.transparent…..hardlink.tar.xz und nach /var/lib/vdr/logos/picons entpacken.


    /etc/vdr/plugins/robotv/robotv.conf editieren:

    Code
    1. PiconsURL = http://<IP des VDR>/picons/
    2. EpgImageUrl = http://<IP des VDR>/epgimages/%d_0.jpg


    Cheers,

    Ole

    Du musst das in der Live Channels App der Shield einrichten.

    Da gibt es dann einen neuen Provider roboTV.


    Bevor du aber die App (Live Channels, oder roboTV recordings) das erste mal startest, solltest du in den Einstellungen

    der roboTV App unter Einstellungen-Apps-roboTV-Berechtigungen die Erlaubnis zum Speichern erteilen, sonnst gibt es Probleme in den Aufnahmen, wenn du Poster ändern oder zuweisen willst.


    Cheers,

    Ole

    Ein ppa-purge von ppa:yavdr/experimental-main ist aber nicht sehr empfehlenswert:



    Cheers,

    Ole

    Anscheinend gibt es da eine Unstimmigkeit in Ubuntu: https://answers.launchpad.net/…/systemd/+question/287454


    So geht es dann:


    Cheers,

    Ole

    Zusammengefasst würde ich folgendes machen:
    - xorg.conf: 2. Display entfernen

    - osd2web-Plugin entfernen/deaktivieren

    - systemd-Service für den Kioskbrowser deaktivieren


    Letzteres mag bei mir irgendwie nicht:

    osd2web.service läuft im user-666.slice, wenn ich den Service als Benutzer vdr aber deaktivieren möchte, schlägt es fehl.


    Code
    1. root@htpc:/lib/systemd# su - vdr
    2. vdr@htpc:~$ systemctl --user disable osd2web.service
    3. Failed to connect to bus: Datei oder Verzeichnis nicht gefunden
    4. vdr@htpc:~$ systemctl --user status
    5. Failed to connect to bus: Datei oder Verzeichnis nicht gefunden


    Irgendwie stehe ich mit systemd auf Kriegsfuß.


    Cheers,

    Ole

    Ok, das kommt davon, wenn man ewig keinen eigenen Kernel mehr gebacken hat...


    Anscheinend wurde bei Ubuntu einiges im Ablauf dafür umgebaut und diese Dokumentation ist nicht mehr aktuell.

    WIe und ob das überhaupt noch so einfach möglich ist, kann ich nicht mit Sicherheit sagen, aber so kommst du an

    die aktuellen Sourcen: sudo apt-get source linux


    Code
    1. root@htpc:~/tmp# ll
    2. insgesamt 162808
    3. drwxr-xr-x 3 root root 4096 Mai 8 14:22 ./
    4. drwx------ 17 root root 4096 Mai 8 14:22 ../
    5. drwxr-xr-x 29 root root 4096 Mai 8 14:20 linux-4.15.0/
    6. -rw-r--r-- 1 root root 9030833 Apr 3 23:03 linux_4.15.0-48.51.diff.gz
    7. -rw-r--r-- 1 root root 8333 Apr 3 23:03 linux_4.15.0-48.51.dsc
    8. -rw-r--r-- 1 root root 157656459 Feb 8 2018 linux_4.15.0.orig.tar.gz


    Damit hast du dann den original tarball linux_4.15.0.orig.tar.gz und unter linux-4.15.0/ liegt dann das ganze entpackt und mit eingespielten Patches aus linux_4.15.0-48.51.diff.gz.


    Anschließend musst du noch deine zu bauenden Module integrieren und dann konfigurieren und bauen, wie es S:oren bereits weiter oben erwähnt hat.

    Grunsätzlich würde ich es mal hiermit versuchen:

    https://wiki.ubuntu.com/Kernel/BuildYourOwnKernel


    1. Schritt: die entsprechenden auskommentierten deb-src Zeilen in /etc/apt/sources.list aktivieren

    (bei meinem Bionic wären das deb-src http://de.archive.ubuntu.com/ubuntu/ bionic main restricted und

    deb-src http://de.archive.ubuntu.com/ubuntu/ bionic-updates main restricted)


    2. Schritt: die passenden Sourcen zum aktiven Kernel holen (z.B. per sudo apt-get source linux-image-$(uname -r))


    3. Schritt: Build-Umgebung aufbauen: sudo apt-get build-dep linux-image-$(uname -r)


    Und dann entsprechend weiter.


    Cheers,

    Ole

    Das Log vom epgd oder vom VDR? Muss ich mal schauen.

    Ehrlich gesagt weiß ich aber nicht genau, ab wann die Bilder nicht mehr da waren.


    Mein System wacht nachts um 3 Uhr zum Abgleich auf und rennt dann ca. 1 Stunde durch.

    Bisher hatte das immer gereicht, um die EPG-Daten zu aktualisieren. Gestern Abend zur TV-Zeit

    hatte ich keine Bilder und heute Morgen waren immer noch keine da.


    Cheers,

    Ole

    Moin zusammen,


    ich habe hier ein ganz seltsames Problem: von gestern auf heute habe ich keinerlei epgimages mehr im VDR (OSD sowie osd2web).

    Da ich epgd einsetze, lagen unter /var/cache/vdr/epgimages sonst immer Symlinks auf die geladenen Bilder in /var/cache/vdr/epgimages/images,

    jetzt sind diese aber nicht mehr vorhanden - nein, ich habe da nichts gelöscht. :-)


    Gibt es eine Möglichkeit, diese Verlinkung wieder zu erzeugen, oder muss ich alle EPG-Daten, also die DB von epgd sowie epg.data im VDR neu erzeugen lassen?


    Cheers,

    Ole

    seahawk1986 da ist jetzt was in deinem PPA verstrubbelt:


    Wenn ich libplacebo-dev installieren möchte, bekomme ich ein


    Code
    1. Die folgenden Pakete haben unerfüllte Abhängigkeiten:
    2.  libplacebo-dev : Hängt ab von: libplacebo7 (= 1:1.18.0-1yavdr0~bionic) aber 1:1.18.0-0yavdr0~bionic soll installiert werden
    3. E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


    Cheers,

    Ole