Posts by stmeyer

    Hi,
    hmm, scheinbar bin ich zu blöd. Das yavdr-hardware-sundtek Paket ist installiert, der Stick (der ja nicht direkt im VDR steckt, sondern über's Netzwerk eingebunden werden soll), taucht im Webinterface unter "System-System Information-DVB Adapters" nicht auf.
    Wenn ich auf der Kommandozeile "mediaclient --mount=192.168.0.54:0" ausführe, taucht er auf. Wo muß ich hinklicken bzw. welches Config-File muß ich bearbeiten, dass das nach einem Neustart automatisch passiert???


    Gruß
    Stefan

    Hallo zusammen,
    nachdem ich viel Gutes über die Sundtek-Sticks gelesen habe, habe ich mir 2 davon besorgt. Diese sind nun auf einer GoflexNet im Keller angestöpselt und im Netz bekannt gemacht.


    Wie kann ich die nun in einen bestehenden yavdr einbinden, so dass diese beim booten automatisch erkannt und genutzt werden?


    Grüße
    Stefan

    Hallo zusammen,
    ich habe meinen Fehler gefunden, es war ein einfacher Tippfehler ;( (vdrshutdown.wrapper statt vdr-shutdown.wrapper), d.h. mit meiner Methode zuerst das extb-poweroff aufzurufen und danach den vdr-shutdown.wrapper funktioniert nach wie vor prima.


    Nichts desto trotz habe ich versucht, mit den Original-Files das extb-Board zu programmieren. Ich habe S91.extb ind S80.extb umbenannt, so dass das wirklich als erster shutdown-hook ausgeführt wird. Leider kommt der Timer nicht beim extb-poweroff.pl nicht an, da stimmt wohl die Syntax nicht. Damit kenne ich mich aber leider null aus, ich habe nicht den Hauch einer Ahnung, wie der Parameter korrekt übergeben werden muß.


    Hab es also erst mal so wie seither laufen, falls aber jemand eine Idee hat, wie man das "richtig" macht, bin ich für alle Tests zu haben.


    Danke an alle.
    Gruß
    Stefan

    Hallo Ihr zwei,
    Erst mal vielen Dank dass Ihr mir helfen wollt.
    Nun zu meinem Vorgehen:
    An den Rechten kann's nicht liegen, da ich in der extb-poweroff.pl ja ein shutdown-Kommando definiert habe, nämlich den originalen shutdown-wrapper und der wird ja auch gestartet. Leider bleibt der nach dem detachen des frontends hängen.


    Wenn ich die Originalfiles nehme, sieht es lt.Log so aus, dass der shutdown-wrapper den anstehenden Timer nimmt,ihn irgendwo hin schreibt und damit für den extb-shutdown-hook nicht mehr zur Verfügung steht.
    Oder bin ich auf der falschen Fährte?


    Gruß
    Stefan

    Hi,
    seither hat das immer funktioniert (yavdr0.4, 0.5alpha)... Ich sehe nicht, woran das hängen kann.


    Ich habe nun nochmal die Original-Config eingespielt, dann fährt der VDR sauber runter, aber das extb-Board wird nicht programmiert. :(
    Hier das log:


    Gruß
    Stefan

    Hallo,
    so hier die /etc/init/vdr.conf und das log:

    Code
    1. # Set shutdown command
    2. test "$ENABLE_SHUTDOWN" = "1" && VDRSHUTDOWN="/usr/bin/vdrpoweroff.sh"


    vdrpoweroff.sh:

    Code
    1. #
    2. # extb shutdown hook script
    3. # -------------------------
    4. #
    5. /usr/bin/perl /usr/lib/vdr-plugin-extb/extb-poweroff.pl "$@"
    6. exit 0



    Gruß
    Stefan

    Quote

    ...Beim Ausführen der Shutdown-Hooks sollte er also noch verfügbar sein.


    Dann sehe ich nicht, warum das nicht funktionieren sollte. Ok, ich probier das nochmal mit den Originalfiles. Ich muß gestehen, dass ich das schon aus Gewohnheit einfach so wieder übernommen habe... ?(


    Gruß
    Stefan

    Hi,

    Quote

    Warum packst du das extb-poweroff.pl nicht ins Shutdown-Hook Directory
    (so das es als erstes vom shutdown-wrapper aufgerufen wird)? Dann sparst
    du dir schon mal das Gebastel mit dem Ändern des Shutdown Kommandos.


    So ist das schon standardmässig eingerichtet, aber das hat in der Vergangenheit nie funktioniert (vielleicht ist lirc zu dem Zeitpunkt schon weg???). Ich habe das nie genauer untersucht und die Änderung die ich dann gemacht habe ist kein Aufwand.


    Das log bzw. den Auszug aus der vdr.conf liefere ich heute Abend...


    Gruß
    Stefan

    Hallo zusammen,
    ich betreibe yavdr ja mit einem extb-Board und nutze das auch zum Ein-/Ausschalten etc... Dazu habe ich, wie in älteren Threads schon geschrieben, in der /etc/init/vdr.conf das shutdown-Kommando so abgeändert, dass als erstes das extb-poweroff.pl (weil nur so die aktuelle Konfig , wie z. B. Timer, in das extb-Board übertragen werden) aufgerufen wird und danach der shutdown.wrapper. Bis zur 0.5 alpha hat das auch prima funktioniert.
    Nun kommt nach drücken der Power-Taste "nur" das detachen das Frontends und der VDR schaltet nicht ab. In der Ankündigung zur Version 0.5 steht ja:


    D.h. es macht was es soll, nur wie schalte ich jetzt den VDR aus? Ein andere Taste wie KEY_POWER2 zuordnen???


    Gruß
    Stefan

    Hallo,
    habe nun auch yavdr 0.5 installiert, bekomme aber meine FB und das extb nicht mehr gemeinsam zum funktionieren.
    Das Problem liegt darin, dass das extb-plugin den lircd-socket beim vdr-Start als Parameter braucht.
    seahawk1986 schrieb dazu schon mal folgendes:


    In der alpha-Version habe ich mir damit beholfen, in der "/etc/init/lircd.conf" einen statischen socket einzutragen (/var/run/lirc/lircd.extb). Wenn ich das mit der Final mache, geht mein extb-Board aber nicht mehr meine Fernbedienung. Wenn ich den Socket dynamisch lasse, geht die Fernbedienung aber das extb-Plugin kennt den Socket nicht.


    Hat jemand eine Idee, wie ich seahawks Lösung (siehe Zitat) umsetzen kann?


    Gruß
    Stefan