Posts by somebody

    Ich habe mir epgsync gerade mal angesehen. Es kann auch auf einem einzeln laufendem VDR verwandt werden. Dazu müssen die Kanäle, deren EPG kopiert werden soll, einer anderen Kanalgruppe angehören (Digital), als die, die die Daten kriegen sollen (Analog).


    Die Kanäle die EPG-Daten kriegen sollen müssen so benannt werden, wie ihre digitalen Spender. Die Einstellung für das EPG-Syncplugin sind dann:
    Server IP: 127.0.0.1
    Serverport: 2001
    Kanalweise Synchronisieren ja
    Kanäle zuordnen nach: Name,ID
    Zielkanäle: Analog (der Name der Kanalgruppe)


    EPG sync beim Start funktioniert bei mir nicht. Daher habe ich Hauptmenüeintrag verstecken auf nein Gesetzt und löse das synchronisieren selber aus.

    Hallo,
    ich konnte das Problem jetzt eingrenzen:
    XBMC hängt sich auf dem vdr immer dann beim Aktivieren der TV Funktion auf, wenn Aufnahmen im Aufnahmeverzeichnis des VDR liegen. Das tritt auch bei meinem eigenem Build auf. Gestern hatte ich versehentlich die /etc/default/vdr mit der Standardversion überschrieben.
    Das xbmc log gibt leider nicht hilfreiches her, außer dass das Einlesen der Aufnahmen schon bei der ersten Aufnahme aufhört.
    Ein entferntes xmbc funktioniert problemlos. Ich glaube, dass es mit der neuen Option, Aufnahmeverzeichnisse direkt einzulesen zusammen hängt. Es tritt aber unabhängig davon auf, ob diese an oder aus ist. Und es betrifft sowohl den Streamdev, als auch den vnsi Client.

    Da xbmc, die Daten vom vdr holt, bleiben dir die üblichen Verdächtigen für den vdr.
    Das wären:
    vdr-addon-tvmovie2vdr - da weiß ich leider nicht, ob das noch funktioniert
    nextvtepg mit xmltv2vdr - keine Ahnung ob xmltv2vdr schon für vdr-1.7.xx angepasst wurde
    xmltv2vdr mit Daten von zb. xmltv.info - s.o.
    vdr-plugin-epgsync - habe ich aber noch nicht versucht

    Hallo, hab das heute mal getestet. Der aktuelle XBMC-Karmic-Build von Hepi stürtzt beim Aktivieren des PVRClients ab. Ein selbst gebauter svn Snapshot funktioniert ganz gut. Ab und zu sagt er: "Kanal nicht verfügbar" und bei pvrinput Kanälen kommt nur der Ton richtig. Das Problem wir aber schon in einem anderen Thread behandelt.

    Eine Idee hab ich schon, nur nicht die Zeit es richtig auszuformulieren, bzw. im selber im Code nach zusehen. Grundsätzlich ist es so, dass die Codetabelle zwar in die ir-keymaps.c gehört, aber dann besser gleich als neue Tabelle (nicht vergessen im header (ir-common.h?) den Prototypen mit anzulegen den Prototypen mit anzulegen).
    Die zuweisung, welche Tabelle verwendet wird findet irgendwo im Treiber unter linux/drivers/media/dvb/... statt. Da musst du mal suchen, welcher Treiber verwendet wird. Und es dann dort ändern.

    hubsif :
    Ich muss dich leider enttäuschen. Die umgelötete TS35ai funktioniert mit dem mantis empfänger nicht vernüftig. Viele Tasten erkennt gar nicht - das heißt man kann auch mit der leeren Liste keine Codes für die ir-keymaps.c ermitteln. Am besten funktioniert diese Fernbedienung mit dem Seriellen empfänger, den Technisat mitgeliefert hat oder mit dem RC5-fähigen Empfängern an Haupaugekarten.


    Mit dem Patch für den mantis-v4l-dvb Treiber dauert es leider noch etwas. Ich bin dafür grad keine Zeit. Ungefähr zwei bis drei Wochen brauche ich noch.

    Hallo,
    hast du tatsächlich die längliche TS35ai oder die TS35 (sieht aus wie hier: http://www.amazon.de/Ersatzfer…S35-TTS35AI/dp/B001BX55B4)? Welchen Mantis-Treiber verwendest du denn? Von TS35AI gibt es inzwischen auch eine Variante ohne den Widerstand. Umlöten ist da leider nicht. Ansonsten könntest du mal folgende Scancodes probieren. Die hab ich für die TS35 zusammengestellt. Sie sollten weitestgehend identisch sein.


    Quote
    Code
    1. Apr 12 18:37:11 yavdr kernel: [ 7.412543] Mantis VP-2040 IR Receiver: unknown key for scancode 0x0000
    2. Apr 12 18:37:11 yavdr kernel: [ 7.412555] Mantis VP-2040 IR Receiver: unknown key: key=0x00 down=1


    Das wird so nicht gehen. Der Mantistreiber enthält eine falsche Codetabelle für die Terratecfernbedienung. Ich hatte mal einen Patch für die Fernbedienung, die Technisat mit der Baugleichen Skystar HD2 ausliefert geschrieben. Der wird so aber nicht bei euch Funktionieren. Ich komm leider auch frühestens nächste Woche dazu mir das mal anzusehen. Was ihr machen könnt, ist mal eine Liste zu machen:
    Welche Taste funktioniert nicht, dann mit dem Passenden Syslogauszug (Taste x: IR Receiver: unknown key: key=0x00 down=1) und welche Taste, welche Eingabe auslöst.

    Kann vielleicht die Ausgabe von Xrandr genutzt werden? Ich habe leider werder einen Rechner noch Fernsher mit HDMI zur Hand, aber xrandr zeigt zumindest am VGA, ob der Bildschirm verbunden (an) ist oder nicht.


    xrandr
    Screen 0: minimum 320 x 200, current 1280 x 800, maximum 8192 x 8192
    VGA1 disconnected (normal left inverted right x axis y axis)

    Also ich habe mit der baugleichen Technisat Cablestar HD2, von der es hier auch Berichte über diese Abstürze gibt, und einem ASUS P5N7A (also NVIDIA Chipsatz) keine Probleme. Ich glaube immer noch, dass dieses Problem vom S2-Liplianin-Mantis Treiber stammt. Der aus dem offiziellen v4l-dvb Quellen (und Kernel ab 2.6.33) ist ein Anderer, mit dem das nicht passiert!

    Das Problem ist weniger der Streamdevserver, als der Client. Ich habe die libavformat, die mWn sowohl der VLC-Player als auch xbmc zur dekodierung der Streams verwenden, im Verdacht. Leider habe ich weder das Wissen über die Formate, noch die Zeit mihc einzuarbeiten, um da produktive Beiträge zu liefern.