Posts by jackfritt

    Keine Ahnung ob das hier ein Problem ist aber eben passiert hier folgendes:
    ARD HD dann Bild weg und kurz darauf im LOG folgendes. Umschalten ging nich mehr (to channel 2)


    ein reboot hat noch nicht geholfen. werde mal aus/einschalten.


    Is das bekannt? habe keine aktuellen Treiber bzw. kernel..
    Schreibs nur hier hin weil ichs sonst vergesse ;)

    Hier mal die angepasste segmenter.c aus istreamdev damits auch auf aktuellen distros läuft (getestet mit debian wheezy 64bit)
    Damit konnte ich nach Anleitung endlich wieder auf meinen Apple Produkten meine HD-Videos,HD-Aufnahmen und HD-Live-TV gucken.
    Bitte noch die Datei von segmenter.c.txt in segmenter.c umbenennen da die Forensoftware das ja nich will ;)
    Bei mir kam noch eine Linker warnmeldung die aber bisher keine Auswirkungen hatte

    Code
    1. vdr:/var/www/istreamdev/segmenter# make
    2. gcc -Wall -g segmenter.c -o segmenter -lavformat -lavcodec -lavutil -lbz2 -lm -lz -lfaac -lmp3lame -lx264 -lfaad -lpthread
    3. /usr/bin/ld: warning: libx264.so.132, needed by /usr/lib/gcc/x86_64-linux-gnu/4.7/../../../x86_64-linux-gnu/libavcodec.so, may conflict with libx264.so.138
    4. vdr:/var/www/istreamdev/segmenter#

    Files

    Kompiliert hier auf Arch Linux mit 3.10.7 ohne Probleme.


    Kannst du mir deinen include pfad nennen?
    Meiner ist
    -I/lib/modules/3.10.7/build/include -I/lib/modules/3.10.7/build
    vielleicht liegts ja daran.
    Ich nutze Ihn da ich ja die aktuellsten UFO Treiber nutze.


    /EDIT
    Und beim schreiben meinen Fehler erkannt.
    Make.config editiert und den pfad von UFO Treibern eingetragen.
    Jetz läufts

    Code
    1. #DVBDIR = /lib/modules/$(shell uname -r)/build
    2. DVBDIR = /usr/src/media_build_experimental/linux

    Habe gerade Urlaub und wollte mich mal wieder an aktuellen Dingen probieren.
    Kernel 3.10.7 und vdr 2.0.2
    Da gibs scheinbar jede Menge kernel header Probleme. Leider findet google auch nicht viel.
    Ich habe mal die aktuellen mit den alten getauscht und dann gehts. Aber ich denke das is nicht Sinn der Sache und wird nicht laufen.


    Kann jemand was dazu sagen? Sowas wie "Vergiss es und warte" oder "probier mal folgendes"


    Endlich Besitzer einer
    vdr:~# lspci -v -s 03:00.0
    03:00.0 Multimedia controller: Digital Devices GmbH Octopus DVB Adapter
    Subsystem: Digital Devices GmbH Cine S2 V6.5 DVB adapter
    Flags: bus master, fast devsel, latency 0, IRQ 19
    Memory at f7ef0000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: [50] Power Management version 3
    Capabilities: [70] MSI: Enable- Count=1/2 Maskable- 64bit+
    Capabilities: [90] Express Endpoint, MSI 00
    Capabilities: [100] Vendor Specific Information: ID=0000 Rev=0 Len=00c <?>
    Kernel driver in use: DDBridge


    Aktuellen kernel:
    uname -a
    Linux vdr 3.10.0 #2 SMP Fri Jul 12 23:36:26 CEST 2013 x86_64 GNU/Linux


    syslog:


    Code
    1. [ 5.814977] Digital Devices PCIE bridge driver, Copyright (C) 2010-11 Digital Devices GmbH
    2. [ 5.815086] DDBridge driver detected: Digital Devices PCIe bridge
    3. [ 5.815149] HW 0001000d FW 00010004
    4. [ 5.817005] [drm] radeon kernel modesetting enabled.


    Hmm ok. Gelesen alles alt,dicker Krach, kein Support, also mal rumprobieren.
    Installationsanleitung von UFO erste Seite. Bis make gekommen dann:



    Jetz steht er da und sieht nur Bäume ;)


    /EDIT
    Einfach in make menuconfig die anderen Treiber deaktivieren und nur meinen Treiber auswählen.
    Dann klappts auch mit dem compilieren ;) Sehen wir mal weiter...


    Leider nicht weiter gekommen. Nach Treiber laden kommt nur folgendes in syslog:

    Code
    1. [ 16.241749] Digital Devices PCIE bridge driver, Copyright (C) 2010-11 Digital Devices GmbH
    2. [ 16.241869] DDBridge driver detected: Digital Devices PCIe bridge
    3. [ 16.241878] HW 0001000d FW 00010004


    Tja.. Firmwareupdate von der Herstellerseite wird ja wohl nicht benötigt oder?


    Man sollte auch die original module vom kernel aus dem Weg räumen.
    Umbenennen des Verziechnisses hilft da nich.
    Also komplett verschoben und nochmal ein depmod -a drüber.
    modprobe ddbridge bringt dann auch


    Schaun mir mal weiter ;)


    /EDIT


    Gruss,


    Jörg

    Hiermit sollte es mit UUID und altem /dev/xxx gehen.



    Gruß,
    Jörg

    Ich bin mit meinem auch sehr zufrieden. Allerdings wie immer, nicht zuviel Tageslicht im Zimmer.Dann
    Klappt es auch mit dem Kontrast.(Ich gucke nur abends oder lasse die Rollos runter) Leinwand ist auch wichtig. Habe meine selbst gebaut.


    Gruß, Jörg

    Mal ein kleiner Nebenschauplatz:


    Schon mal jemand drüber nachgedacht was es für einen wirtschaftlichen Schaden für Europa etc. nach sich zieht ? Ich nenne nur ma Sony,Toshiba, Futschi,Toyota und deren Zulieferer (Elektronik,Mechanik....). Oder Entwicklungen die von elektronischen Bauteilen abhängen. Lieferzeiten die bis jetzt schon utopisch waren.


    Also ich könnte mir Zeiträume von 1-3 Jahre vorstellen bis sich wieder alles eingependelt hat.



    Wenn wir schon dabei sind Panik zu machen :)



    Gruss,


    Jörg

    Ok mal wieder falsch gedacht.


    Warum ging dann meine FB jeweils nicht mehr ? Diese Antwort werde ich wohl nicht mehr klären können. Außer ich baue meine beiden alten FF auf TS-Mod um und schaue mir noch das Problem mit der FB an. Dazu habe ich aber reichlich wenig Zeit und Muße.


    Investiere ich lieber hier wenn das vom kernel jemals
    richtig unterstützt werden sollte ;) Und ich habe ja schon gelesen das du
    erstmal warten willst bis das mit dem BKL "stabil" läuft ;)
    Gruss,


    Jörg

    Das bringt nur nix wenn man eine Woche lang Schrott aufnimmt :)


    Scheinbar gehen die aufnahmen auch durch den ARM und der merkt nicht das nur schrott vorliegt. Zumindest eine zeitlang nicht.


    So war es zumindest immer bei mir. Ich habe leider keine Testmöglichkeiten mehr da mir mein alter VDR durch meine Bastelversuche auf der Strecke
    geblieben ist :)


    Letzte Idee von Oliver(UFO) war der TS Mod und du hast seitdem ja keine Probleme mehr oder ?


    Siehe auch "unser" Thread dort hat UFO das Thema mit mir durchgespielt.


    Gruss,


    Jörg