Posts by raha

    Der Eintrag der svdrpservice.* Parameter in die setup.conf hats gebracht, das war es!

    So, nun nur noch die Autotimer-Suchfunktion und der streamdev-server-client ...

    Ich danke Dir für Deine Mühe und werde berichten ...

    OSD geht aber nicht weil das eine "head- und device-less" VM ist. Höchtens vielleicht mit xine Framebuffer Interface, das könnte vielleicht funktionieren.

    Hi TheChief,


    tja, genau das habe ich ja auch gelesen.


    Und funzt trotzdem nicht. Mich wundert, dass svdrpsend auf Befehlsebene in beiden Richtungen funktioniert (siehe oben) und ich habe außerdem nirgendwo mal einen Screenshot einer dokumentierten Konfiguration dieser beiden Plugins gefunden. Habe ja noch die Hoffnung dass der schmirl das mal sieht und mir hilft ...

    Hallo vdr'ler allesamt,


    mein "headless" und "device-less" VDR-Client mit nachfolgender Konfiguration


    Code
    1. ii vdr 2.2.0-6+b1 amd64 Video Disk Recorder for DVB cards
    2. ii vdr-plugin-epgsync 1.0.1-2 amd64 VDR plugin for EPG synchronization between VDR systems
    3. ii vdr-plugin-live 0.3.0+git20160123-1 amd64 Web administration plugin for VDR
    4. ii vdr-plugin-softhddevice 0.6.0+git20160108-1+b1 amd64 HD output device plugin for VDR
    5. ii vdr-plugin-svdrpservice 1.0.0-5 amd64 VDR plugin that provides a SVDRP service for other plugins


    soll die EPG Daten meines VDR Servers abfragen und synchronisieren, damit ich ihn über vdr-live zum Programmieren von Aufnahmen benutzen kann.


    Auf dem VDR-Client habe ich nachfolgendes konfiguriert


    Code
    1. #
    2. # svdrpservice VDR plugin arguments
    3. #
    4. [svdrpservice]
    5. 10.148.1.246:6419


    Selbiger Eintrag steht auch in der /etc/vdr/conf.d/50-epgsync.conf.


    Wenn ich die Synchronisation vom Client aus mit dem Befehl svdrpsend PLUG epgsync SYNC starte, erscheint im Logfile nachfolgende Meldung


    Feb 27 14:12:33 1073ab4c4a92 vdr[519]: [519] connect from 127.0.0.1, port 58716 - accepted

    Feb 27 14:12:33 1073ab4c4a92 vdr[519]: [535] epgsync thread started (pid=519, tid=535, prio=high)

    Feb 27 14:12:33 1073ab4c4a92 vdr[519]: [535] svdrpservice: Invalid server IP ''

    Feb 27 14:12:33 1073ab4c4a92 vdr[519]: [535] epgsync thread ended (pid=519, tid=535)

    Feb 27 14:12:33 1073ab4c4a92 vdr[519]: [519] ERROR: EpgSync: Verbindung zum Server fehlgeschlagen

    Feb 27 14:12:33 1073ab4c4a92 vdr[519]: [519] closing SVDRP connection



    Es scheint mir so, als hätte der VDR die Remote IP Adresse des VDR-Servers nicht erkannt, aber sowohl die Konfigurationsdatei wie auch der eingetragene Wert sind doch richtig, oder?


    Dann habe ich noch versucht, ob die beiden Rechner gegenseitig den Port 6419 öffnen können, was mit nmap wie auch svdrpsend funktioniert.


    Das ist die Abfrage vom VDR-Client zum VDR-Server:



    Das ist die Abfrage vom VDR-Server zum VDR-Client:



    So, und jetzt bin ich mit meinem Latein erstmal am Ende ...


    Vielen Dank für jegliche Hilfe und Tipps!

    Ich hab's gefunden:


    Die Ursache ist ein fehlendes Output Plugin, da habe ich vdr-plugin-softhddevice installiert und nun geht es.

    Was noch nicht funktioniert ist das Abrufen er EPG Daten vom VDR Server, da mach ich nochmal was auf ...

    Ach so, hier die Ausgabe vom Start ...


    Guten Morgen allesamt,


    vielen Dank für die Hinweise. Tja, da waren sie wieder, meine drei Probleme ...


    Also: Ich hatte ja bereits geschrieben, dass ich Probleme seit den letzten Debian-Updates meines VDR-Aufnahmeservers habe. Dieser hat die letzten - man kann schon fast sagen Jahre - seinen Dienst völlig beschwerdefrei verrichtet. Seit etwa zwei Wochen kommt es zu dem Symptom, dass gelegentlich beim Erstellen von Timern das vdr-plugin-epgsearch den VDR mit einer Modul-Schutzverletzung killt. Natürlich startet der dann über das systemd-Skript wieder neu und zumeist ist es dann damit auch getan. Aber schön ist es halt nicht.


    Nachdem ich zuerst an eine komplette Neu-Installation dachte - ist aber Stress, das Teil nimmt täglich mehrere Stunden auf - kam mir in den Sinn , dass es vielleicht am relativen "neuen" VDR 2.4 und dem "alten" vdr-plugin-epgsearch (2.2.+git20170911-2) liegen könnte. Ich weiss, dass es vom vdr-plugin-epgsearch eine neue Version 2.4 gibt, aber so ein Modul per Hand kompilieren und ein Debian-Paket zu machen das habe ich noch nie probiert und demzufolge diese Variante verworfen.


    Da ich momentan sowie ein bisschen rum-"dockere" kam mir dann die Idee, über den Streamdev-Server und den Streamdev-Client zwei Systeme zu koppeln. Das habe ich zunächst erfolgreich mit einem weiteren VDR-Aufnahmeserver mit einem DVB-T Device getestet, der so nebenbei "mitläuft". Nun wollte ich das "dockerisieren", nachdem ich im Docker-Hub gesehen habe, dass es da VDR Images gibt die ähnliches tun.


    Die VM an sich selbst funktioniert, aber der VDR startet nicht weil er halt meint dass er unbedingt ein DVB Device braucht.


    Hmmmh.

    Nee, der soll nix ausgeben sondern nur auf die Devices anderer VDR's zugreifen um bspw etwas aufzuzeichnen. Das geht ja prinzipiell mit dem vdr-plugin-streamdev-client

    Hallo mini73,


    welches Plugin ist denn das?


    vdr-plugin-dvbhddevice - Plugin that adds support for full featured HD-DVB cards to VDR

    vdr-plugin-dvbhddevice-dbg - Plugin that adds support for full featured HD-DVB cards to VDR

    vdr-plugin-dvbsddevice - Plugin that adds support for full featured SD-DVB cards to VDR

    vdr-plugin-dvbsddevice-dbg - Plugin that adds support for full featured SD-DVB cards to VDR

    vdr-plugin-softhddevice - HD output device plugin for VDR

    vdr-plugin-xineliboutput - VDR plugin for Xine based sofdevice frontends

    vdr-plugin-xineliboutput-dbg - VDR plugin for Xine based sofdevice frontends


    Mehr finde ich hier nicht ...

    Danke, das habe ich dann auch in der Doku gelesen.


    Das ging ganz gut, aber jetzt will ich noch ein bisschen mehr spielen und einen VDR ohne Hardware-Device als docker-image oder QEMU/VM konfigurieren. Der startet aber nicht weil er kein Device findet, kann er ja auch nicht. Braucht man da das softdevice Plugin?

    don-baba Das scheint mir die sinnvollste Variante, aber kann ich nachlesen wie das geht? Ich denke, ich muss einem VDR mit stream-dev client ja nur sagen wo der VDR mit dem Streamdev-server-plugin ist, oder?

    Hallo vdr'ler allesamt,


    bei mir spielen schon seit Jahren VDRs mit DVB-T/T2 und DVB-C rum. Ich verwende Debian mit deren aktuellen Paketen (vdr 2.4, epgsearch 2.2.0+git20170817-2, streamdev-server 0.6.1+git20170911-2


    Weil die Softwarekonfiguration einer Linux-Kiste den EPG zum Absturz bringt und ich momentan viel zu faul bin das alles neu zu installieren kam mir die folgende Frage in den Sinn: Ist es möglich, ein Aufnahme-Device eines VDR-Systems einem anderen Rechner im Netzwerk zu Verfügung zu stellen ODER kann man zwei VDR-Systeme miteinander so dass man bidirektional auf die jeweils anderen Aufnahme-Devices zugreifen kann?


    Mmmh, das wäre echt schön. Bin für jeden Hinweis dankbar.

    Viele Grüße

    Also zusammen fassend bekomme ich die besten Ergebnisse mit de kompilierten w_scan von wirbels Seite und habe mir auch eine funktionierende VLC.xspf bebastelt.



    mit diesem USB Stick


    Bus 003 Device 002: ID 0b48:3014 TechnoTrend AG TT-TVStick CT2-4400

    Hallo vdr-ler allesamt,


    hab mich erstmal durch verschiedene Foren, Anleitungen und Recherchens gefräst und einiges ausprobiert, deshalb hier meine verspätete Zusammenfassung. Soweit ich das verstanden habe bzw im Ergebnis meiner vielen Tests...


    Zur Hardware bzw. dem Streamzugriff:


    Wie vielfach zu lesen ist, benötigt man für die korrekte Darstellung eines HD Streams zumindest eine VDPAU unterstützte Grafikkarte. Das kann ich bestätigen. Ohne die korrekte Installation der NVIDIA Treiber habe ich es nicht geschafft den 1920x1080 Stream richtig darzustellen. Die CPU selbst muss IMHO nicht das Allerfeinste sein. Die auf openelec bzw linux.tv verfügbare Firmware für den TT Stick funktionierte bei mir fehlerfrei.


    Zum Stick selbst:


    Er funktioniert am USB-2 wie auch USB-3 Port. Wie hier auch schon geschrieben wurde, wird über die Frequenz 642000 kHz HEVC Video (1920x1080) und AC-3 Audio als Transportstream (neben Untertiteln und so weiter) zur Verfügung gestellt. Da der ganze Rotz hochkomprimiert ist, hält sich die Datenübertragungsrate am USB Port in Grenzen.


    Zu meinen Tests mit dem mplayer:


    Hier ist es mir nicht gelungen herauszufinden ob der mplayer den DVB-T2 Stream korrekt abspielen kann. Während die DVB-T Kanäle richtig abgespielt werden, crashed der Player immer bei einem DVB-T2 Kanal.


    Zum VDR:


    So wie ich das verstehe benötigt man den VDR 2.3.x um den HEVC Stream zu verarbeiten. Es ist mir sogar gelungen, den VDR selbst aus dem Quelltext zu übersetzen, aber es scheiterte dann beim Einbau der Plugins so dass ich mich entschlossen habe, auf die Version 2.3. aus einem Repo zu warten. Der benötigte Patch betrifft die direkte Aufnahmefunktion des VDR, also das "Parsen" des HEVC und das Abspeichern der Aufnahme. Da jedoch das VDR Plugin Streamdevserver in der aktuellen Version für vdr 2.2.x die "Umleitung" des HEVC Transportstreams bereits unterstützt kann man mit Hilfe von ffmpeg den DVB-T2 HD Stream über den Port 3000 abgreifen und direkt konvertieren. Dies brachte bei mir gute Ergebnisse.

    Hallo vdr-fans allesamt,



    ich versuche grad meine vorhandene DVB-T Lösung auf DVB-T2 umzustellen und verwende dazu den TT-TV USB Stick CT2-4400.


    Für alle SD-Kanäle funktionierte das problemlos, mplayer oder VDR spielen so wie sie sollen. Ich bekomme aber kein Tuning auf eine DVB-T2 Frequenz hin, obwohl ich hier sehr guten Empfang (Berlin-Nähe) habe und auch die Erkennung der Sender bspw. über w_scan funktioniert.
    Folgendes schreibt das ausführliche mplayer Log (ähnlich natürlich auch das VDR Log, das hier ist IMHO nur ausführlicher), hier zunächst mit einem SD-Kanal:



    und alles geht so wie es soll. Will ich auf einen HD Kanal umschalten, sieht das so aus ...



    Was ist hier falsch? Ist hier jemand in der Nähe, der das vielleicht schon hinbekommen hat?
    An der Rechner-Hardwarekonfiguration bzw. USB 2 kann es eigentlich nicht liegen, eine Aufzeichnung mit einem HD-Signal über Kabel funktioniert ohne Probleme.


    Würde mich über alle Hinweise freuen, vielen Dank im voraus!

    Hallo allesamt,


    ich kämpfe schon einige Tage erfolglos, o.a. Gerät unter Debian mit Kernel 3.12 zum Laufen zu bringen. Die Anleitung unter linuxtv.org bringt für mich keine funktionierende Firmware, das Gerät selbst wird mit der USB-ID 14f7:0003 korrekt erkannt. Meine Frage an jemanden, der diese USB Büchse zum Laufen bekommen hat: Kann man mir mal bitte mal einen Link für die funktionierende Firmware senden?


    Vielen Dank im voraus.