Posts by opunkt

    Für alle die, welche in dem Thread noch mitlesen: der Versuch, das XBMC mit einem geänderten Script zu beenden hat auch nicht funktioniert.


    Ich habe nun, wie hier beschrieben, das XBMC-Paket ausgetauscht.
    Mit dem Paket (ohne pvr) funktioniert das Beenden einwandfrei.


    Trotzdem danke an alle und an das Team für die Hilfe.



    opunkt

    Hallo fnu,


    ja die xbmc.conf existiert:



    Reicht es denn ein "killall -9 xbmc.bin" in das Script einzufügen?


    opunkt

    Hallo fnu,


    die pakete lassen sich jetzt installieren und das xbmc startet auch wieder. Jetzt habe ich aber leider das Problem, dass beim Beenden vom xbmc kein Bild beim VDR dargestellt wird.


    Ein Blick auf ps -aux und siehe da, xbmc läuft weiterhin.


    Code
    vdr       1605  0.0  0.0   2648  1120 ?        Ss   13:48   0:00 su -c /usr/bin/xbmc --standalone vdr
    vdr       1606  0.0  0.0   4316  1420 ?        S    13:48   0:00 /bin/sh /usr/bin/xbmc --standalone
    vdr       1615 10.9  4.4 176240 91748 ?        Sl   13:48   0:07 /usr/lib/xbmc/xbmc.bin --standalone



    Ich kann mich dunkel daran erinnern, dass dieses Problem schon mal da war.


    jetzt habe ich es gefunden:


    fnu: du schreibst hier von einem patch, der genau diesen Fehler beheben soll. Fehlt der vll. in dieser Version?



    opunkt

    Hallo fnu,


    nervös bin ich eigentlich nicht. Meine Frau kommt erst in einer Stunde nach Hause :)


    führe ich apt-cache policy für alle Pakete aus erhalte ich folgende Ausgabe:



    Wenn du mir jetzt noch einen Tip gibst, nach was ich da schauen muss ..???



    opunkt

    hallo fnu,


    mit apt-get install yavdr-essential vdr-plugin-iptv vlc vlc-nox


    erhalte ich dann:



    wenn ich dann noch libaavcodec52 bis einschl. xineliboutput-sxfe hinzufüge, wird es (für mich) noch unübersichtlicher:


    Code
    Die folgenden Pakete haben nicht-erfüllte Abhängigkeiten:
      libavcodec-extra-52: Hängt ab: libx264-98 ist aber nicht installierbar
                           Kollidiert: libavcodec52 aber 4:0.6.1-5ubuntu2~ppa1~lucid1 soll installiert werden
      libavformat-extra-52: Kollidiert: libavformat52 aber 4:0.6.1-5ubuntu2~ppa1~lucid1 soll installiert werden
      libva1: Stört: vlc-nox (< 1.1.5-3) aber 1.0.6-1ubuntu1.8 soll installiert werden
    E: Kaputte Pakete


    opunkt

    Hallo fnu,


    apt-get update habe ich gemacht.



    in /etc/apt/sources.lists.d/yavdr.list steht:


    deb http://ppa.launchpad.net/yavdr/stable-vdr/ubuntu lucid main
    deb http://ppa.launchpad.net/yavdr/stable-xbmc/ubuntu lucid main
    deb http://ppa.launchpad.net/yavdr/stable-yavdr/ubuntu lucid main


    apt-cache policy vdr-plugin-iptv gibt folgendes aus:


    vdr-plugin-iptv:
    Installiert: (keine)
    Kandidat: 0.5.2-0yavdr0~lucid
    Versions-Tabelle:
    0.5.2-0yavdr0~lucid 0
    500 http://ppa.launchpad.net/yavdr/stable-vdr/ubuntu/ lucid/main Packages



    opunkt

    Morgen,


    jetzt gibt er mir folgende Ausgabe, wenn ich yavdr-essential installieren möchte:


    Code
    Die folgenden Pakete haben nicht-erfüllte Abhängigkeiten:
      yavdr-essential: Hängt ab: vdr-plugin-iptv soll aber nicht installiert werden


    opunkt

    Oha, da ist noch eine libva1 in "stable-vdr", die IMHO nicht da sein sollte, hab ich wohl übersehen, sorry.


    Bitte installiert doch mal die die für XMBC aus "stable-xbmc" gedacht ist und schaut ob der Fehler dann weg ist:


    Code
    #/> sudo apt-get install libva1=1.0.14-1~lucid1


    Regards
    fnu


    ähm,


    wenn ich das mache entfernt er mir das Paket yavdr-essential. Füge ich dieses wieder hinzu, dann macht er wieder ein update vom libva1


    ???



    und


    Und ich schätze das Aufgrund einer XBMC Version YAVDR abkackt ist sehr zu vernachlässigen.


    Für mich nicht!


    opunkt

    Hallo fnu,


    die Ausgabe ergibt:


    libva1:
    Installiert: 1.0.31.1-1+sds4~odk2
    Kandidat: 1.0.31.1-1+sds4~odk2
    Versions-Tabelle:
    *** 1.0.31.1-1+sds4~odk2 0
    500 http://ppa.launchpad.net/yavdr/stable-vdr/ubuntu/ lucid/main Packages
    100 /var/lib/dpkg/status
    1.0.14-1~lucid1 0
    500 http://ppa.launchpad.net/yavdr/stable-xbmc/ubuntu/ lucid/main Packages


    ... und für xbmc gleich mit dazu:


    xbmc:
    Installiert: 2:11.0-pvr+yavdr2-odk73-eden-git20120402.0b73bfc-yavdr6~lucid
    Kandidat: 2:11.0-pvr+yavdr2-odk73-eden-git20120402.0b73bfc-yavdr6~lucid
    Versions-Tabelle:
    *** 2:11.0-pvr+yavdr2-odk73-eden-git20120402.0b73bfc-yavdr6~lucid 0
    500 http://ppa.launchpad.net/yavdr/stable-xbmc/ubuntu/ lucid/main Packages
    100 /var/lib/dpkg/status
    2:10.5-dharma+pvr~yavdr6 0
    500 http://ppa.launchpad.net/yavdr/stable-xbmc/ubuntu/ lucid/main Packages


    Habe auch schon mal testweise die Version 2:10.5-dharma+pvr~yavdr6 0 installiert, was aber den o. g. Fehler nicht beseitigt.



    opunkt

    Hallo fnu,


    Ich kann erst morgen nachmittags an meinen vdr, bin gerade ausser Haus. Ich liefere die Ausgabe morgen nach. Danke schon mal für die Antworten.



    Opunkt

    Hallo fnu,


    Ich hab das paket und zusammen mit yavdr-essentials mit apt-get remove entfernt und danach mit apt-get install wieder installiert.


    Gleicher Fehler.

    Hallo,


    Also die libvba ist installiert. Daran kann es nicht liegen, auch eine Deinstallation derselbigen bringt nichts, dabei wird das Paket yavdr-essentials auch entfernt...

    Guten Morgen,


    jetzt habe ich leider bei meinem yaVDR 0.3 den gleichen Fehler...


    Ich habe allerdings nicht wie der TE an meinem System rumgepfuscht, sondern alles im Original belassen. Seit dem letzten update erhalte ich auch den Fehler /usr/lib/libva-x11.so.1: undefined symbol: fool_postp.


    Gibt es dafür schon eine Lösung?

    Hallo kris,


    deine Probleme wundern mich ein bisschen, nachdem bei mir das alles so reibungslos verlaufen ist ...


    Quote

    Sobald ich das tool "glxinfo" bzw. "nvidia-settings -g" ausführe, bekomme ich ein segmentation fault. Hat einer noch eine Idee? Mir gehen Sie so langsam aus, MfG KRis


    Diesen Fehler hatte ich ebenfalls mit dem neuen Nvidia-Treiber, allerdings nur mit Dharma. Mit der XBMC-Version, welche mit yaVDR installiert worden ist, trat der Fehler nicht auf. Da ich aber lieber die aktuelle Version von XBMC verwenden wollte, bin ich auf den älteren Treiber (256.53) zurück, damit gibt es auch den bekannten Fehler "Schnee in dunklen Flächen" nicht.



    cu



    opunkt

    Quote

    Original von fnu
    Was ich aber nicht verstehe ist "noatime" bei tmpfs? Das ist es doch eigentlich wurscht, ob die Daten ständig aktualisiert werden. Oder gehst Du davon aus, das das etwas Performance bringt?


    Ich habs einfach so übernommen - hast Recht, bei tmpfs ist es egal. Die Daten sind ja beim nächsten Reboot wieder weg.



    cu



    opunkt

    Quote

    Original von kris
    Hast Du neben noatime und discard noch was in die fstab eingetragen?


    ich hab noch "nodiratime" mit drin, außerdem die Temps ausgelagert:


    Quote

    tmpfs /tmp tmpfs noexec,size=32M,defaults,noatime 0 0
    tmpfs /var/tmp tmpfs noexec,defaults,size=32M,noatime 0 0


    Ich hab aber auch 2 GB RAM, tmpfs kann man auch ruhig kleiner setzen



    Quote

    Gibt es mehr optimierungsmöglichkeiten?


    ich habe noch den noop-Scheduler eingesetzt (Tip aus einem anderen Forum, woher weiß ich nicht mehr) - soll noch bis zu 15% mehr Performance geben. Langsamer ist es auch nicht geworden :)


    cu



    opunkt