Posts by crow

    Problem habe ich gefunden, kaum zu glauben aber IPv6.

    Ich verwende Archlinux als distro und da (mein installation routine) disable ich immer ipv6 als kernel parameter (ipv6.disable=1)

    Libwebsocket ist aber mit "-D LWS_IPV6=On" als packages unter Archlinux gebaut (offizielle repo). Hinweiß dass etwas mit IPv6 zu tun haben konnte, habe ich auf der suche nach "libwebsocket ERROR opening socket$" gefunden und zwar beim folgende Ergebnis [1].


    Nehme an vdr-osd2web schickt an libwebsocket befehl um einen websocket zu erstellen und da libwebsocket mit ipv6 compiliert worden ist wird versucht damit einen websocket zu erstellen und da das nicht geht schlug der fail. Einen echten Hinweiß dafür sieht man nicht/habe ich nicht, weil eben kaum davon geloggt ist, einzige ist vdr-osd2web Meldung "WS: ERROR opening socket$".



    Nach dem compilieren von libwebsocket mit "-D LWS_IPV6=OFF", kann vdr-osd2web einen web socket aufmachen, lauscht auf dem port 4444 und per browser ist erreichbar.


    Code
    1. [1] https://libwebsockets.org/pipermail/libwebsockets/2014-July/001139.html

    Ich habe da wieder neue libwebsocket genommen, vdr-osd2web neue kompiliert und loglevel auf 4 gestellt, viel mehr info kommt da nicht. gibt es noch welche Möglichkeit mehr log zu bekommen? Bin leider kein developer und weiß nicht was in code zu ändern ist, um zu schauen was beim erstellen von websocket alles passiert und eventuell in log ausgeben.


    VDR full log mit nur vdr-osd2web plugin und loglevel 4

    Code
    1. https://cryptobin.co/v11167k4
    2. pass: vdr

    mit osd2web.LogLevel = 3 habe ich folgende Meldungen, wie schon erwähnt das versuche ich auf einem headless VDR (VM) server

    Ich habe jetzt alte libwebsocket compiliert und vdr-osd2web, leider leuscht auch nichts auf dem port 4444 und seite kann auch nicht gefunden werden. Bin ich mir nicht sicher ob es an libwebsocket oder was anderes liegt.



    was hast Du in setup.conf von VDR?

    Danke für den Tipp, jetzt steht zwar die Meldung nicht mehr da, aber trotzdem lauscht da nichts auf dem port 4444 (default) und per http kommt "This site can’t be reached"


    ja dann kannst du das Plugin auch gleich als default Skin einstellen. Mache ich mit meinem Server VDR auch so

    Kannst Du mir bitte Auszug von setup.conf für osd2web zukommen lassen. Bei mir klappt das irgendwie nicht, sind noch welche plugins dafür nötig, habe da neben VDR 2.4.4 die plugins installiert vdr-osd2web-0.2.48-2 vdr-remote-0.7.0-4 vdr-remoteosd-1.0.0-16 vdr-svdrposd-1.0.0-17 vdr-svdrpservice-1.0.0-16 vdr-vnsiserver-2:1.8.0.r0.g49003f0-2 (meisten sind die für OSD per telnet installiert)

    ?


    Ich habe auch folgende Logausgabe beim VDR start, kann es sein dass es deswegen über browser nichts sehe?:

    Code
    1. Aug 05 19:40:59 vdrserver vdr[39536]: osd2web: Listener at port (4444) established
    2. Aug 05 19:40:59 vdrserver vdr[39536]: osd2web: using libwebsocket version '4.0.20 unknown-build-hash'
    3. Aug 05 19:40:59 vdrserver vdr[39536]: osd2web: DEBUG: Unhandled 'callbackHttp' got (71)
    4. Aug 05 19:40:59 vdrserver vdr[39536]: osd2web: DEBUG: Unhandled 'callbackOsd2Vdr' got (71)

    Kann man osd2web auch beim einem headless VDR system mit vnsi/streamdev verwenden ? Würde gern VDR per OSD steuern bzw. ein paar Sachen anschauen/ändern falls nötig. Falls osd2web das nicht kann bzw. nicht dafür vorgesehen ist, gibt es etwas in der Richtung?

    Ich könnte bei mir das Problem lösen in dem ich bei VMs anstatt EFI den BIOS genommen habe. Das war ein zufällige test da ich es irgendwo gelesen habe dass das Passthrough besser im BIOS mode funktionieren soll. Karte habe ich auch den alten VM wieder hinzufügt, dort mag es einfach nicht (nicht mal mit: pciPassthru0.msiEnabled = "FALSE" ). Seltsam aber im BIOS mode funktioniert mit dem gleichen distro/kernel ohne irgendeinen anderen Treiber die zwei tage problemlos, hab sogar noch eine dritte VM genommen (auch BIOS) und dort das gleiche gemacht und es funktioniert. Hoffe das zu mindest bei mir das Problem nicht mehr auftritt.

    Gibt esvielleicht eine Low-profile PCIe karte die solche timeouts nicht hat und füreinen Einsatz unter VM (VMware ESXi) optimal ist?


    Nach Umsiedlung von Rackmacht mein headless VDR Server (VM) wieder Probleme, und habe vieles bis datoprobiert, auch das was ich damals hier geschrieben habe, mag aber nicht.. Werdejetzt wieder direkt ohne VM testen müssen (umbau), gewünscht ist das aber ineiner VM als passtrhough zu betrieben


    Übliche Fehlermeldung (Kernel5.7.7)

    Code
    1. I2C timeout, card 0, port 0, link 0

    kennt jemand hier eine Möglichkeit IPTV von LiveTV in Kodi zu trennen, am liebsten wären mir zwei Menü punkten. Verwende LibreELEC mit Kodi 17.3 auf einem ARM (siehe Signature) device.

    Main menu:

    LiveTV -> vinsi addon

    IPTV -> simple-iptv-addon

    manio meint es ist ci.c (nope, the code is in ci.c - it is VDR)

    vor ein paar tagen habe ich auch so was gehabt (seit lange Zeit nicht), bei mir wurde ein coredump erstellt, vielleicht sagt das etwas zu devs. Zur Info ich habe keinen Hardware CAM.


    log 30 Tage gültig:

    Code
    1. url: https://defuse.ca/b/grJQXnfZ
    2. pass: media