Posts by ozvdr

    Bei mir geht die DVBSky S952 mit Kernel 3.19RC2 ohne probleme.


    lscpi:


    07:00.0 Multimedia video controller: Conexant Systems, Inc. CX23885 PCI Video and Audio Decoder (rev 04)
    Subsystem: Device 4254:0952
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 32 bytes
    Interrupt: pin A routed to IRQ 19
    Region 0: Memory at f7800000 (64-bit, non-prefetchable)
    Capabilities: [40] Express (v1) Endpoint, MSI 00
    DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
    ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
    DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
    RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
    MaxPayload 128 bytes, MaxReadReq 512 bytes
    DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
    LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <2us, L1 <4us
    ClockPM- Surprise- LLActRep- BwNot-
    LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- CommClk+
    ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
    LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    Capabilities: [80] Power Management version 2
    Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold-)
    Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [90] Vital Product Data
    Product Name: "
    End
    Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
    Address: 0000000000000000 Data: 0000
    Capabilities: [100 v1] Advanced Error Reporting
    UESta: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
    UEMsk: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
    UESvrt: DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
    CESta: RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
    CEMsk: RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
    AERCap: First Error Pointer: 00, GenCap- CGenEn- ChkCap- ChkEn-
    Capabilities: [200 v1] Virtual Channel
    Caps: LPEVC=0 RefClk=100ns PATEntryBits=1
    Arb: Fixed+ WRR32+ WRR64+ WRR128-
    Ctrl: ArbSelect=WRR64
    Status: InProgress-
    Port Arbitration Table [240] <?>
    VC0: Caps: PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
    Arb: Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
    Ctrl: Enable+ ID=0 ArbSelect=Fixed TC/VC=01
    Status: NegoPending- InProgress-
    Kernel driver in use: cx23885


    Firmware:


    Jan 8 09:25:26 B85N-PHOENIX kernel: [ 15.098777] cx25840 33-0044: loaded v4l-cx23885-avcore-01.fw firmware (16382 bytes)
    Jan 8 09:25:29 B85N-PHOENIX kernel: [ 17.596583] i2c i2c-32: m88ds3103: downloading firmware from file 'dvb-demod-m88ds3103.fw'
    Jan 8 09:25:30 B85N-PHOENIX kernel: [ 18.508241] i2c i2c-32: m88ds3103: firmware version 3.B
    Jan 8 09:25:30 B85N-PHOENIX kernel: [ 18.522664] i2c i2c-31: m88ds3103: downloading firmware from file 'dvb-demod-m88ds3103.fw'
    Jan 8 09:25:31 B85N-PHOENIX kernel: [ 19.433874] i2c i2c-31: m88ds3103: firmware version 3.B

    Test bitte erneut mit dieser Version:
    http://wirbel.htpc-forum.de/w_…v/w_scan-20150101.tar.bz2

    Hallo,


    Ich habe die neue version jetzt erfolgreich getested.
    Es ist auf meinem Test System mit Ubuntu 14.04 LTS mit Kernel 3.19rc2 erfolgreich gelaufen.


    Die erzeugten channels.conf's haben jetzt den richtigen Eintrag fuer S156E.


    Ich habe mal gleich 3 verschiedene SAT Karten getested die uebrigens alle mit dem obigen Kernel OOTB laufen.
    Diese waren: Tevii S480 - DD Duoflex - DVBSky S952


    Mir ist dabei aufgefallen das alle drei verschiedene channels.conf's erzeugt haben.
    Habe diese und den installations & scan log mit der Tevii mal angehaengt.
    Danke auch nochmal fuer die neue Version von w_wcan.


    ozvdr

    Hallo,


    Das Problem is geloest. Hier eine Zusammenfassung:


    Beide, scr.conf & diseqc.conf waren richtig (wie im Wiki beschrieben) konfiguriert.


    Das Problem war w_scan mit der version 20140118.


    W_scan kann zwar richtig mit unicable umgehen und scannt auch beide Satelliten ohne Probleme allerdings wird
    fuer den einen Satelliten - S1560E - eine inkorrekte channels.conf erzeugt.
    Der Satellit wird als 156E0 anstelle von 156E in der channels.conf dargestellt.
    Deshalb kann VDR nichts von diesem Satellliten empfangen.
    Ich habe die channels.conf Eintraege dann mittels 'vi' geaendert und voila, es ging.


    Fuer den zweiten Satelliten - S160E wird die channels.conf richtig erzeugt und der Satellit als 160E richtig in der channels.conf eingetragen.
    Deshalb konnte VDR auch immer von diesem Satelliten empfangen.


    Ich habe allerdings noch Probleme mit den beiden neueren w_scan Versionen. Ich mache deshalb mal eine neuen Thread auf.

    Lars,


    Danke, damit lief es durch.


    Allerdings klappt der scan leider nicht. Hab die syntax auch schon and die neuere w_scan version angepasst.


    Output:


    root@server:/temp/w_scan-20141122# ./scan_dvb-s-unicable_s156
    ./w_scan -fs -sS156E0 -a0 --scr 0:1076:a -E 0 -F -t3 -o 2
    w_scan version 20141122 (compiled for DVB API 5.10)
    using settings for 156.0 east Optus C1/D3
    SCR: slot=0, userfreq=1076MHz, satpos=A, pin=-1
    scan type SATELLITE, channellist 6
    output format vdr-2.0
    WARNING: could not guess your codepage. Falling back to 'UTF-8'
    output charset 'UTF-8', use -C <charset> to override
    -_-_-_-_ Getting frontend capabilities-_-_-_-_
    Using DVB API 5.10
    frontend 'Montage DS3103/TS2022' supports
    INVERSION_AUTO
    DVB-S
    DVB-S2
    FREQ (0.95GHz ... 2.15GHz)
    SRATE (1.000MSym/s ... 45.000MSym/s)
    using LNB "UNIVERSAL"
    -_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
    trying 'S2 f = 11720 kHz H SR = 29455 3/5 0,AUTO 8PSK (0:0:0)'
    (time: 00:00.119) scr_cmd:517: FE_DISEQC_SEND_MASTER_CMD failed.


    initial_tune:2710: Setting frontend failed S2 f = 11720 kHz H SR = 29455 3/5 0,AUTO 8PSK (0:0:0)
    trying 'S f = 11762 kHz H SR = 27800 3/4 0,35 QPSK (0:0:0)'
    (time: 00:00.419) scr_cmd:517: FE_DISEQC_SEND_MASTER_CMD failed.



    Weiss jemand vielleicht woran das liegen kann ?


    ozvdr

    Hallo nochmals,


    Ob es denn an der Version von w_scan liegt ?
    Wollte gerade mal w_scan20141122 compilieren (unter Ubuntu 12.04.05 LTS - up to date mit allen updates), configure lief durch allerdings habe da folgenden fehler beim make:


    root@server:/temp/w_scan-20141122# make
    make all-am
    make[1]: Entering directory `/temp/w_scan-20141122'
    gcc -Wall -Wextra -Wno-comment -Wswitch-default -Wno-unused-parameter -g -O2 -lrt -o w_scan atsc_psip_section.o countries.o descriptors.o diseqc.o dump-dvbscan.o dump-vdr.o dump-xine.o dump-mplayer.o dump-vlc-m3u.o dvbscan.o lnb.o parse-dvbscan.o satellites.o scan.o section.o tools.o emulate.o dump-xml.o iconv_codes.o char-coding.o
    tools.o: In function `set_timeout':
    /temp/w_scan-20141122/tools.c:389: undefined reference to `clock_gettime'
    tools.o: In function `timeout_expired':
    /temp/w_scan-20141122/tools.c:400: undefined reference to `clock_gettime'
    tools.o: In function `get_time':
    /temp/w_scan-20141122/tools.c:381: undefined reference to `clock_gettime'
    collect2: ld returned 1 exit status
    make[1]: *** [w_scan] Error 1
    make[1]: Leaving directory `/temp/w_scan-20141122'
    make: *** [all] Error 2


    Weiss jemand vielleicht was da fehlt ?


    ozvdr

    Oh, ungewöhnliche Kombination.., w_scan, SCR und dann noch seltene Satelliten.
    Poste mal bitte deine gesamte gescannten channels.conf Daten, vielleicht kann man ja diese Sats damit in w_scan updaten.



    In der Zeile ist der Satellit falsch, es sollte statt "S1560.0E" "S156.0E" lauten. Gleiches gilt für die andere Zeile von Kanal 700.

    Danke dir - ich habe es mit vi auf "S156.0E" gestellt und es geht.


    Bleibt die Frage was da passiert ist.


    Dies sind die channels direct von w_scan:
    EPG Background Audio;Foxtel:12438:hC34M2O0S0:S156E0:27800:1081+8190=2:1172=eng@4:0:0:17017:4096:17:0
    AITV05;Foxtel:12278:hC34M2O0S0:S156E0:27800:1241=2:1242@4,1252,1262,1272,1243,1253,1263,1273:0:604,90B,96C:19005:4096:19:0


    Ich habe diese nochmals in die channels.conf eingesetzt und wie schon oben beschrieben, ging es nicht. Der VDR hat die channels dann so modifiziert:
    EPG Background Audio;Foxtel:12438:hC34M2O0S0:S1560.0E:27800:1081+8190=2:1172=eng@4:0:0:17017:4096:17:0
    AITV05;Foxtel:12278:hC34M2O0S0:S1560.0E:27800:1241=2:1242=@4,1252=@4,1262=@4,1272=@4,1243=@4,1253=@4,1263=@4,1273=@4:0:604,90B,96C:19005:4096:19:0


    Was koennte der Grund dafuer sein ? Ich habe mit folgender syntax w_scan aufgerufen:
    ./w_scan -fs -sS156E0 -a0 -u 0:1076:A -E 0 -F -t3 -o 2 >> ./channels.conf-dvb-s-29.12.2014-a0-156-FTA


    Daran sollte es ja nicht gelegen haben.


    Gescannte daten anbei.


    Danke nochmals.


    ozvdr

    Hallo,


    Ich benutze eine Unicable Anlage mit zwei Satelliten und Terrestrial TV. Leider habe ich Probleme mit dem Empfang
    eines Satelliten unter VDR.



    Die Anlage:


    Inverto IDLP-USS2OO-CUO1O-8PP Unicable Multiswitch angeschlossen an 2 Satelliten & Terestrial


    VDR 2.0.4 selbstgebaut auf Ubuntu 12.04 mit DVBSky S952 dual tuner card fuer den Satellitenempfang.


    Das Problem:


    Mit w_scan (20140118) kann ich beide Satelliten gleichzeiting scannen und die jeweiligen channels.conf werden
    auch erstellt. (Siehe unten).
    Ich scanne auch nur FTA channels um probleme mit den verschluesselten auszuschliessen.


    VDR kann allerdings nur Sender auf einem Satelliten empfangen und zwar nur auf dem S160.0E und keinen der FTA channels auf S156.0E



    Wenn ich auf die Sender des S156.0E umschalte steht folgendes im vdr log:


    Dec 29 16:21:05 server vdr: [6520] switching to channel 700
    Dec 29 16:21:06 server vdr: [6520] info: Channel not available!


    Die channels.conf hat den folgenden Eintrag fuer channel 700
    EPG Background Audio;Foxtel:12438:hC34M2O0S0:S1560.0E:27800:1081+8190=2:1172=eng@4:0:0:17017:4096:17:0


    Mit channel 701 passiert das gleiche:


    Die channels.conf hat den folgenden Eintrag fuer channel 701
    AITV05;Foxtel:12278:hC34M2O0S0:S1560.0E:27800:1241=2:1242=@4,1252=@4,1262=@4,1272=@4,1243=@4,1253=@4,1263=@4,1273=@4:0:604,90B,96C:19005:4096:19:0



    Die setup.conf hat DiSEqC = 1 was ja alles sein sollte damit VDR diseqc benutzt.


    Die derzeitige diseqc.conf ist wie folgt - abgeleitet aus dem VDR Wiki:



    # Full DiSEqC sequence for unicable:


    S156.0E 11700 V 9750 t V W10 S0 [E0 10 5A 00 00] W10 v
    S156.0E 99999 V 10600 t V W10 S1 [E0 10 5A 00 00] W10 v
    S156.0E 11700 H 9750 t V W10 S2 [E0 10 5A 00 00] W10 v
    S156.0E 99999 H 10600 t V W10 S3 [E0 10 5A 00 00] W10 v
    #
    S160.0E 11700 V 9750 t V W10 S4 [E0 10 5A 00 00] W10 v
    S160.0E 99999 V 10600 t V W10 S5 [E0 10 5A 00 00] W10 v
    S160.0E 11700 H 9750 t V W10 S6 [E0 10 5A 00 00] W10 v
    S160.0E 99999 H 10600 t V W10 S7 [E0 10 5A 00 00] W10 v



    Kann mir jemand weiterhelfen ? Ich bin fuer jeden Tipp dankbar.


    Gruss


    ozvdr



    w_scan output:



    root@server:/temp/w_scan-20140118# ./scan_dvb-s-unicable_s156
    w_scan version 20140118 (compiled for DVB API 5.10)
    using settings for 156.0 east Optus C1/D3
    SCR: slot=0, userfreq=1076MHz, satpos=A, pin=-1
    scan type SATELLITE, channellist 6
    output format vdr-2.0
    WARNING: could not guess your codepage. Falling back to 'UTF-8'
    output charset 'UTF-8', use -C <charset> to override
    -_-_-_-_ Getting frontend capabilities-_-_-_-_
    Using DVB API 5.a
    frontend 'Montage DS3103/TS2022' supports
    INVERSION_AUTO
    DVB-S
    DVB-S2
    FREQ (0.95GHz ... 2.15GHz)
    SRATE (1.000MSym/s ... 45.000MSym/s)
    using LNB "UNIVERSAL"


    "Findet den Satelliten und erstellt die channels.conf"



    #######################
    root@server:/temp/w_scan-20140118# ./scan_dvb-s-unicable_S160
    w_scan version 20140118 (compiled for DVB API 5.10)
    using settings for 160.0 east Optus D1
    SCR: slot=1, userfreq=1178MHz, satpos=B, pin=-1
    scan type SATELLITE, channellist 5
    output format vdr-2.0
    WARNING: could not guess your codepage. Falling back to 'UTF-8'
    output charset 'UTF-8', use -C <charset> to override
    -_-_-_-_ Getting frontend capabilities-_-_-_-_
    Using DVB API 5.a
    frontend 'Montage DS3103/TS2022' supports
    INVERSION_AUTO
    DVB-S
    DVB-S2
    FREQ (0.95GHz ... 2.15GHz)
    SRATE (1.000MSym/s ... 45.000MSym/s)
    using LNB "UNIVERSAL"


    "Findet den Satelliten und erstellt die channels.conf"

    Bei mir geht ein "Homebrew" receiver auf COM1 mit Openelec 4.2.1mit einer "autostart.sh" wie folgt:


    #!/bin/sh
    killall eventlircd
    killall lircd
    setserial /dev/ttyS0 uart unknown
    modprobe lirc_serial
    ir-keytable -p lirc
    lircd --driver=default --device=/dev/lirc0 /storage/.config/lircd.conf


    Die "autostart.sh" muss in /storage/.config/ abgelegt werden.


    Mit dem kernel und vdr.1.4.7 kann ich helfen, die libs habe ich leider nicht mehr gefunden. Was nicht ist kann aber noch werden.


    Viel Spass


    ozvdr

    Danke seahawk1986,


    Keyboard ist keins angeschlossen und media tasten sind am Gehaeuse nicht vorhanden.
    Hier noch einige details (haette ich wahrscheinlich schon im ersten post erwaehnen sollen):


    Ich benutze lirc mit einem homebrew serial reciever. Habe die lircd.conf zu meiner fernbedienung (TT, die kleine schwarze) angepasst aber die orginal vdr remote.conf und die Lircmap.xml von yaVDR nicht veraendert. VDR kann ohne probleme gesteuert werden und XBMC soweit auch, bis halt auf das oben genannte problem.


    Hab mal die lircd.conf angehangen.

    Files

    • lircd.conf

      (2.25 kB, downloaded 35 times, last: )

    Das Problem erscheint beim abspielen von musik oder videos in XBMC. Das menu schaltet immer zwischen "fullscreen/menu" hin und her.
    Ich habe mal den debug log eingeschaltet (siehe anhang). Es erscheint ein "OnKey: tab (f009) pressed" , dieser scheint zwischen menu und fullscreen hin und her zu schalten.
    Erst dachte ich meine Fernbedienung koennte dies verursachen, war aber nicht.
    Hat jemand ne idee was es noch sein kann ?


    ozvdr

    Ein ander Ansatz:


    Yavdr mit einer 2 oder 4GB partition installieren, mit dem recordings verzeichniss auf einer zweiten partition.
    Wenn alles eingestellt ist mit g4u (disk cloning), http://www.feyrer.de/g4u/ , die 2 oder 4GB partition mit g4u ueber ftp auf einen server hochladen und das wars. Das ganze dauert so 10 bis 15 minuten. je nach schnelligkeit des Netztes/Servers.


    Wenn updates gemacht wuden einfach eine neue revision hochladen.Geht super.
    Ich mounte meine recordings normarlerweise ueber samba auf meine NAS sodass es ganz einfach ist mal eben eine alte/neue oder test installation zu installieren.

    Falls jemand eventuell auch einen VDR in einem Rechenzentrum betreiben moechte , mal kurz ein paar Worte zu meiner Erfahrung damit.


    Es war schwer einen Betreiber mit TV Anschluss zu finden. Zuletzt hatte ich nur Surfplanet in Koeln auf meiner Liste, dieser konnte SAT und DVB-T anbieten.


    Ich habe nun mittlerweile einen VDR bei Surfplanet im Rechenzentrum stehen. Das ganze laeuft jetzt seit gut 6 Monaten ohne Probleme.
    Die SAT Anlage geht 1A und der Internet Anschluss von Surfplanet ist sehr gut, das heisst recht schnell. Den Preis finde ich auch in Ordnung.
    Alles in allem - bewertung sehr gut.

    Schau mal ob dein Player die *.vdr abspielt wenn du sie nach *.mpeg umbenennst. Geht das, dann installiere dir vdrnfosf, das ist ein daemon der das VDR Videoverzeichnis als virtuelles Verzeichnis mit mpeg Files ins Dateisystem einbindet. Damit sparst du dir dann die ganze Umwandelei.


    Keine_Ahnung - Kann leider vdrnfosf nicht finden, hast du einen link dazu ?


    Danke dir

    Habe probleme mit dem Alphacool USB display.
    Habe die threads zum thema gelesen und die modifikationen zu den UDEV rules etc gemacht. Soweit so gut.
    Das problem ist jedoch das im log folgendes steht:


    Dec 11 14:02:12 vdr-hd2 vdr: [1449] starting plugin: live
    Dec 11 14:02:12 vdr-hd2 vdr: SDCONNusb_open(): libusb is not loaded.
    Dec 11 14:02:12 vdr-hd2 vdr: serdisp: error: unable to open device usb:060c/04eb for display ALPHACOOL. (cDriver::Init)
    Dec 11 14:02:12 vdr-hd2 vdr: [1528] graphlcd plugin: ERROR: Failed initializing display



    libusb ist laut apt installiert und /lib/libusb-0.1.so.4 -> libusb-0.1.so.4.4.4


    ist auch vorhanden.


    Hat jemand eine idee wo und was das Problem sein koennte ?


    Danke auch

    Quote

    Originally posted by Razorblade
    Ich wollte Dich gerade auf diesen alten Thread verweisen: VDR Server co-location gesucht habe dann aber gesehen, dass Du ja ein und derselbe bist ;-)


    Schonmal bei Webhostlist im Forum gefragt welcher Hoster DVB-S anbietet?


    Ja habe ich, allerdings bis jetzt ohne erfolg. Letztes Jahr hatte ich auch keinen weiteren erfolg, allerdings konnte ich meinen standplatz bis jetzt behalten.


    Der Anbieter in Koeln scheint wohl der einzige zu sein der dies anbietet.

    Quote

    Originally posted by Mr.N!ce
    Hast Du keine Freunde die dem VDR per Strompauschale oder durch mitbenutzen Unterkunft gewähren?


    Guter Vorschlag aber leider im moment nicht moeglich. Deswegen die Suche nach einer kommerziellen Loesung