Posts by killernase

    Hallo,


    mein Thema hat nichts mit dem VDR zu tun, aber da ich nach zwei Tagen googeln mit meinem Latein am Ende bin und hier der ein oder andere Videofreak dabei ist, stelle ich meine Frage einfach mal hier.


    Ich habe hier diverser Mitschnitte (von http://new.livestream.com/) bzw. Webinar-Aufzeichnungen (GoToWebinar) und möchte ein Intro davor- und ein Outro (rechtliche Hinweise) dahinterhängen. In den Videos passiert im Prinzip nicht viel, da im wesentlichen nur irgendwelche Charts oder Powerpoint-Präsentationen zu sehen sind. Ich verwende eine aktuelle Version von FFmpeg unter Windows.


    Das Intro sieht folgendermaßen aus:

    Code
    1. Duration: 00:00:03.86, start: 0.000000, bitrate: 444 kb/s
    2. Stream #0:0(und): Video: h264 (Main) (avc1 / 0x31637661), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 274 kb/s, 25 fps, 25 tbr, 25 tbn, 50 tbc (default)
    3. Stream #0:1(eng): Audio: aac (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 178 kb/s (default)


    Das Outro so:

    Code
    1. Duration: 00:00:05.07, start: 0.000000, bitrate: 162 kb/s
    2. Stream #0:0(und): Video: h264 (Main) (avc1 / 0x31637661), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 160 kb/s, 15 fps, 15 tbr, 15 tbn, 30 tbc (default)


    Das eigentliche Video wurde per Handbrake von WMV (proprietärer Codec) in MP4 konvertiert und die Framerate auf 25 fps geändert (vorher 4.12 ?( ):

    Code
    1. Duration: 02:35:04.42, start: 0.000000, bitrate: 448 kb/s
    2. Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 306 kb/s, 25 fps, 25 tbr, 12800 tbn, 50 tbc (default)
    3. Stream #0:1(und): Audio: aac (mp4a / 0x6134706D), 44100 Hz, mono, fltp, 135 kb/s (default)


    Ich bin nach dieser Anleitung vorgegangen und habe den Concat-Demuxer und das Concat-Protokoll verwendet.


    Demuxer:


    Code
    1. ffmpeg -f concat -i concat.txt -c copy output.mp4


    concat.txt

    Code
    1. file intro_1920x1080.mp4
    2. file 02072014_25.mp4
    3. file outro_1920x1080_25.mp4


    Ausgabe:


    Laut VLC hat das Video eine Länge von 1300 Stunden und nach dem Vorspann springt das Bild nicht um (der Ton läuft aber weiter).


    Concat-Protokoll:


    Die einzelnen Videos habe ich mittels

    Code
    1. ffmpeg -i $INPUT.mp4 -codec copy -bsf:v h264_mp4toannexb -f mpegts -y $OUTPUT.ts


    in einen MPEG Transport Stream gewandelt und dann per

    Code
    1. ffmpeg -i "concat:intro_1920x1080.ts|02072014_25.ts|outro_1920x1080.ts" -c copy -bsf:a aac_adtstoasc -y output.mp4


    zu einem Video zusammengefügt. Ganz nach Anleitung eben ;D



    Das Video lässt sich zwar abspielen, ist aber nicht 100%ig synchron.


    Im Netz gibt es zwar einige Threads aus der FFmpeg-Mailingliste zur Verarbeitung von Streaming-Daten und den damit verbundenen Timestamp-Problemen, aber ich bin noch nicht fündig geworden.


    Kann mir vllt. jemand einen Tipp geben?



    Gruß,
    Marco

    Hast Du das Board schon mal angeschaut? Evtl. ist einer der Kondensatoren nicht mehr in Ordnung. Ich hatte mit meinem alten Desktop ein ähnliches Problem. Eigentlich lieft die Kiste ganz gut, hat aber sporadisch einfach neu gebootet.


    Um den Fehler einzugrenzen würde ich alles bis auf den Speicher entfernen (memtest laufen lassen schadet hier auch nicht) und schauen, ob der Fehler auch ohne die andere Hardware auftritt. Nach und nach dann die Komponenten wieder hinzufügen, bis der Fehler wieder auftritt.

    Hi,


    ich habe keine direkte Lösung für Dein Problem, aber zwei Dinge fallen mir noch ein:


    1. Du benutzt noch den Kernel von etobi (2.6.28). In Squeeze ist ein etwas Aktuellerer (2.6.32) enthalten - probier' diesen oder eine Version von http://backports-master.debian.org/ doch einfach mal aus.
    2. Dreh das Logging einfach mal hoch und poste dann die Ausgabe hier. Vllt. kann Dir irgendjemand anhand der Logs noch einen Tipp geben.



    VG
    Marco

    Die Dateisysteme werden beim booten eingehangen. Wenn Dein NAS noch nicht läuft während der VDR bootet, bekommt er irgendwann einen Timeout und macht weiter ohne das Dateisystem vom NAS gemountet zu haben.


    Wenn es auch nachträglich gehen soll, musst Du Dir selbst was basteln.

    Hi,


    ich weiß, dass Gen2VDR das Standardsystem für die Activy ist.


    Da es bei meinen Eltern in den letzten Jahren nicht so wirklich stabil lief, würde ich gerne mal Debian (+ etobi) ausprobieren.


    Leider scheitere ich schon bei der Installation. Die Lenny- und Squeeze-Installer booten zwar, quitieren aber an unterschiedlichen Stellen ihren Dienst.


    Hat jemand Erfahrung mit Debian auf der Activy?



    MfG
    Marco

    Hi,


    Quote

    Original von hsteinhaus
    wie wäre es, die Ports vom Web-Interface und dem Live-Plugin standardmäßig zu tauschen?


    Ich muss gestehen, dass ich yaVDR nicht kenne...


    Was spricht gegen das Anlegen eines Bookmarks? Das Live-Plugin kann zusätzlich noch so konfiguriert werden, dass aus dem internen Netz keine Anmeldung erforderlich ist.


    Für den Benutzer ist es dann egal, wie die URL aussieht, da er nur den Bookmark anklicken muss.



    MfG
    Marco

    Quote

    Original von hsteinhaus
    Preis pro GB ist mir dagegen egal, ob ich nun 90% oder 95% frei habe auf / ist recht unerheblich. Zum Aufnehmen gibts NFS. Genau genommen würden auch 4 oder 8GB locker reichen, den mehr als 2GB hab ich selten auf der Root-Platte.


    Ist sicher 'ne schöne Sache, wenn man die Festplatte(n) irgendwo hinverlagern kann, wo sie nicht stören.


    Wie verhält sich das Schneiden über's Netz?



    MfG
    Marco

    Hallo,


    für mich würde wohl im Moment nur die Sportschau in HD in Frage kommen ;)


    Ich kann aber leider kein HD empfangen, da ich in einem Mehrfamilienhaus mit einer Hausananlage wohne. Die Kanäle werden in mäßiger Qualität eingespeist :§$%


    Der Kabelanschluss von KD endet im Keller. Die Strippe in meine Wohnung (6. Stock) müsste ich selbst zahlen (500+ €).


    Einen Balkon hat die Wohnung nicht, so dass ich auch keine Schüssel aufstellen kann.


    Ich bleibe daher (erstmal) bei DVB-T und meinem Röhrenfernseher.



    MfG
    Marco

    Hi,


    da hilft eigentlich nur eins: Loglevel hochdrehen und die entsprechenden Einträge hier posten.


    Ohne mehr Informationen wird hier kaum einer brauchbare Lösungsvorschläge anbieten können.



    MfG
    Marco

    Hallo,


    zur Zeit betreibe ich o.g. Karte über über eine Zimmerantenne (Philips) . Eigentlich bin ich mit der Lösung ganz zufrieden. Die Sender, die ich oft aufnehme, laufen eigentlich stabil.


    Allerdings kommt es bei einigen Sendern immer mal wieder zu Aussetzern. Deshalb würde ich gerne schauen, ob es über die Hausantenne nicht besser geht.


    Meine DVB-T Karte versorgt die Antenne mit Strom.


    Kann ich die Karte trotzdem einfach an die Hausantenne hängen oder muss ich irgendwas dazwischenschalten?



    MfG
    Marco