Posts by micmac

    Wenn du wirklich openwrt hättest dann könntest Du tcpdump darauf installieren und mal den SIP traffic capturen auf Port 5060. Dann solltest du dann eigentlich sehen was aus der Bahn läuft. Ich würde das jetzt nicht auf die Telekom schieben. Ist wahrscheinlich eher Firewall- oder Telefonanlagenkonfiguration.


    Gruß
    mic

    Hallo VDR-Gemeinde,


    ich möchte einen Fernseher kalibrieren, an den ein VDR mit S2-6400 über HDMI angeschlossen ist. Als Colorimeter wird ein i1Display Pro dienen. Als Testbilder werden die vom AVS-Forum benutzt. Gemessen wird über einem Windows-PC mit der Software HCFR, und zwar gemäß dieser Anleitung.


    Man soll ja die Testbilder über das Gerät ausgeben, das hinterher auch zum fernsehen benutzt wird. In diesem Fall eben ein VDR. Ich frage mich wie ich VDR dazu überreden kann, die Testbilder abzuspielen. Es handelt sich um MP4-Dateien, in denen nur ein Video-Stream verpackt ist (H264, 1080p, 23,976 fps).


    Hat jemand eine Idee? Kann ich den Video-Stream einfach extrahieren, in einen MPEG Transport Stream verpacken und VDR als Aufnahme unterjubeln? Hat jemand sowas schon mal gemacht und kann sagen wie es am besten funktioniert?


    Danke und und viele Grüße!

    Ich habe da *vielleicht* was gefunden. Und zwar hab ich noch mal in älteren Syslog-Dateien gesucht.


    Am 17/04 um 15:15 Uhr hat eine Aufnahme auf einem anderen Transponder einwandfrei funktioniert. Am 18/04 um 13:25 Uhr klappte das aber dann nicht mehr. Am 17/04 zwischen 21:32 bis 21:54 war ich eingeloggt und habe drei Sachen aktualisiert:


    Tue Apr 17 21:45:50 2012 >>> dev-libs/expat-2.1.0
    Tue Apr 17 21:46:04 2012 >>> app-portage/gentoolkit-0.3.0.5
    Tue Apr 17 21:47:55 2012 >>> media-plugins/vdr-dvbhddevice-9999


    Die ersten beiden scheinen nichts mit VDR zu tun zu haben.


    dvbhddevice hatte ich davor zuletzt am 27/03 aktualisiert. Zwischen dem 27/03 und dem 17/04 liegen drei Änderungen in Andreas HG Repo.


    Die drei Änderungen bin ich jetzt mal zurück gegangen (HG REV 9e3c85deb331). Mal schauen ob das was bringt. Der VDR wird gerade anscheinend benutzt, deshalb kann ich das heute Abend nicht mehr probieren. Vielleicht morgen.


    Gruß
    mic

    Hallo liebe VDR-User,


    seit einer Weile habe ich auf einem VDR folgendes Problem: Wenn eine Aufnahme auf einem anderen Transponder als das gerade laufende Live-Programm gestartet wird, startet die Aufnahme und beendet sich dann sofort wieder, in einer endlosen Schleife.


    Bei Aufnahmen von Programmen auf dem selben Transponder, auf dem der eingestellte Sender läuft, gibt es kein solches Problemchen.


    Beispiele:


    1. Es wird ARD geschaut und dann startet eine Aufnahme von RTL -> Endlosschleife
    2. Es wird ARD HD geschaut und dann staŕtet eine Aufnahme von ARTE HD -> kein Problem


    Obwohl ich Debug-Meldungen eingestellt habe, finde ich nichts aussagekräftiges im Syslog.


    Leider kann ich auch nicht sagen, mit welchem Update das Problem aufgetaucht ist. Die alten Syslogs werden von "logrotate" ab und zu gelöscht.


    VDR läuft auf Gentoo (ZZams und HD_Brummys Ebuilds). Ich habe VDR-1.7.24 und 1.7.25 ausprobiert. Beide zeigen das gleiche Verhalten. VDR sollte ziemlich "vanilla" sein (ich habe auch keinen eigenen Patches eingespielt):


    Code
    1. [ebuild R ~] media-video/vdr-1.7.24-r1::vdr-devel USE="vanilla -alternatechannel -cutterlimit -ddepgentry -debug -dvlvidprefer -dxr3 -graphtft -hardlinkcutter -html -jumpplay -liemikuutio -lircsettings -mainmenuhooks -menuorg -nalustripper -noepg -pinplugin -rotor -setup -timerinfo -ttxtsubs -volctrl -wareagleicon -yaepg" 0 kB


    Plugins habe ich zwei installiert:


    a) dvbhddevice für die S2-6400 (hg)
    b) remote-0.4.0


    Gestartet wird das ganze über die Gentoo Init-Skripte, was dann wie folgt aussieht:


    Code
    1. ps aux|grep vdr
    2. vdr 3492 0.8 1.9 172640 73628 ? Ssl 19:01 0:16 /usr/bin/vdr -u vdr --watchdog=60 --device=0 --log=3 --video=/video0 --record=/usr/share/vdr/bin/vdrrecord-gate.sh --shutdown=/usr/share/vdr/bin/vdrshutdown-gate.sh --plugin=dvbhddevice --plugin=remote --input=/dev/input/event2 --daemon


    "--device=0" wird benutzt, weil nur ein Sat-Kabel an die DVB-Karte angeschlossen ist.


    Hardware ist ein normaler Desktop-PC mit einer DVB-Karte.


    Hat jemand eine Idee, woran das liegen könnte?


    Bevor ich einen Syslog-Abschnitt paste, verabschiede ich mich schon mal. Danke fürs Lesen!


    Gruß
    mic


    Guten Morgen!


    Ich hadere derzeit noch mit zwei Einstellungen beim dvbhddevice Plugin: Auflösung und Auflösungsanpassung. Ich verstehe Auflösungsanpassung so, dass bei Aktivierung (Einstellung "immer") das Video unverändert durchgereicht wird. Naja, das OSD muss halt auch noch irgendwie ins Bild, ein bischen verändern wird das Plugin/die Karte den Datenstrom schon.


    Allerdings meldet der Fernseher bei SD Kanälen immer 576p statt 576i. Bei Full HD (Anixe und Servus TV) zeigt er 1080 an. Dann weiß ich leider nicht, ob er damit 1080i oder 1080p meint.


    Ist die Geschichte mit 576p vs. 576i ein Fehler? Wenn ich die Auflösung im Plugin auf 576i einstelle und die Auflösungsanpassungen ausschalte, dann kommt ja auch 576i beim Fernseher an (getestet). Technisch scheint das also kein Problem zu sein.


    Ich würde mir halt wünschen, dass die Nachbearbeitung weitestgehen der Fernseher ausführt.


    Gruß
    micmac


    P.S.: Abgesehen davon funktioniert die Karte astrein, Danke an alle Beteiligten!

    Hallo liebe Leute,


    kann der eingebaute IR-Empfänger und das dvbhddevice-Plugin nur mit der mitgelieferten Fernbedienung umgehen oder kann man eine x-beliebige RC5-Fernbedienung benutzen?


    Danke und Gruß
    micmac

    Hallo!


    Weiß jemand von Euch, ob die Linux Edition *mit* IR-Empfänger ausgeliefert werden wird?


    Und weiß man schon, ob die neue FF womöglich das selbe Verhalten aufzeigt wie die alte bezüglich Video-Verbindung zum TV? Bei der alten FF muss man ja TV und PC vom Strom ziehen und eine Weile warten, bevor man das Kabel vom TV-Out abzieht, weil sonst der Fernseher und die FF kaputt gehen können. Ich würde mal spaßeshalber sagen, dass die alte FF somit nicht Plug'n'Play-kompatibel ist :) Wie sieht es mit der neuen FF aus?


    Viele Grüße!

    Code
    1. 1.1.10:
    2. - remove BPP usage
    3. - add compressibility check
    4. - delete INSTALL file (put content into README)
    5. - clean up README
    6. - (hopefully) last batch of quoting fixes
    7. - make scripting style more consistent
    8. - better sed scripts
    9. - use $HOME instead of "~" expansion
    10. - move command substitutions out of [tests]
    Code
    1. 1.1.9:
    2. - make sure muxing doesn't result in variable video frame rate
    3. - cleaned up quite a bit (quoting, brackets, ...)
    4. - better error detection
    5. - clean user configuration file before sourcing it
    6. - write initial configuration file
    7. - got rid of all evals
    8. - removed hardcoding of iPod-specific encoder options