Posts by Brougs78

    Hi!


    Danke für den Tipp.


    Also Segfault gibts in der dmesg-Ausgabe nicht. VDR stürzt ab und zu beim Start ab lt. /var/log/messages, aber da hilft leider auch kein Neustart dass dann Ton da wäre ...


    Analog-Ton funktioniert, allerdings kann das AFAIK der TV nicht, dass er das Bild vom HDMI nehmen soll und den Ton vom Chinch-Eingang.
    Ginge dann nur über die Stereoanlage, die wollte ich aber eigentlich garnicht anschließen ...


    Gruß,
    Brougs78

    Hi!


    Ich habe mir den Thread jetzt eigentlich nicht durchgelesen, nur das anfängliche Problem überflogen.


    Hab hier auch einen neuen LG-TV und hatte auch das Problem. Am Philips bekam ich immer ein Bild, nur am LG nicht.
    Bei mir hat es geholfen, dass ich den TV zusätzlich noch über VGA angeschlossen hatte. Dann war das auch in der xorg.conf.yavdr vermerkt. Dann konnte ich VGA wieder abschließen und bekam trotzdem ein Bild über HDMI.


    ... ev. bringts was ...


    Gruß,
    Brougs78

    Hallo!


    Ich habe mir vor einiger Zeit einen Asrock Nettop als VDR-Client gekauft. Damals habe ich den noch an einer Röhre betrieben was prinzipiell auch funktioniert hat.
    Jetzt habe ich mir aber einen LCD zugelegt und wollte dementsprechend das ganze über HDMI anschließen.
    Allerdings: Bild läuft einwandfrei, nur kommt kein Ton an ...


    Am TV kanns nicht liegen, denn ich habe auch an meinem HDMI-Receiver getestet und da funzen die anderen VDRs, nur bei dem Client bekomme ich keinen Ton.


    So wie ich das verstehe haben den Asrock Nettop mehrer Leute hier ... auch im YAVDR-Team wird der verwendet. Habe ich etwas triviales übersehen?


    Mal zu den Einstellungen:
    Im Bios unter Chipset Settings habe ich "Onboard HDMI HD Audio" --> "Auto" und "Onboard HD Audio" --> "Enabled", sonst bekomme ich unter Linux schon mal garkein HDMI gelistet bei "aplay -l". Denke das müsste passen.


    Im Web-Frontend von YAVDR habe ich alle Varianten von HDMI getestet: "Stereo", "Analog", "Pass Through"


    Die Ausgaben von aplay:



    yavdr.hdf (den 2. Monitor brauchte ich, da sonst nie ein Bild am LCD zu sehen war ...):


    asound.conf:

    Code
    root@yavdr2:~# cat /etc/asound.conf 
    pcm.!default {
    	type hw
    	card 0
    	device 3
    }


    alsamixer (seltsam sind irgendwie die 3 SPDIF ...):
    (siehe Bild im Anhang; das kopieren der Konsolenausgabe war nicht so ideal)


    Ich denke das müssten die wichtigsten Infos sein. Kann jederzeit gerne mehr posten.


    Hat hier zufällig jemand eine Idee? Wo kann ich noch ansetzen oder muss ich neu installieren?
    Achja bezüglich Alsa noch: Da sind die Backport-Module installiert? Ist ja bei 0.3 mittlerweile Standard und es werden keine dkms-Module mehr übersetzt richtig?


    Gruß,
    Brougs78

    Hi!


    rkp: Also die Modifikation, mit der auf den Ton gewartet wird, ist nicht von mir. Die habe ich aus einem anderen Thread wo es um die Tonprobleme mit der GT2xx geht.
    Aber schön wenn es geholfen hat ;)


    Ich werde das ganze jetzt auch so lassen, denn produktiv kann man das so ja durchwegs einsetzen. Dann braucht halt der Startvorgang etwa jedes 5. Mal 10 Sekunden länger. Das ist auch nicht so schlimm, denn das Board ist sowieso schon extrem langsam (über 30 Sekunden bis der Kernel geladen wird).


    Gruß,
    Brougs78

    Hi!


    CKone: Ja die Wartezeit hatte ich drinnen. Habe sie jetzt auch wieder aktiviert, wobei das auf das Hauptroblem leider keinen Einfluss hat.


    rkp: Danke für den Tipp. Da ich ja auf der Konsole den Start von vdr-frontend abbrechen muss, dachte ich mir ich versuche das anders und habe jetzt das Skript vdr-frontend so umgeschrieben (hier nur der pre-start-Teil):


    D.h. ich lasse maximal 10 Sekunden auf X warten und logge immer die Zeitpunkte mit, wann das Pre-Start-Script startet, das Display verfügbar ist und der Ton bereit ist.


    Für einen normalen Start sieht dann der Log so aus:

    Code
    Jun 19 11:36:57 michl logger: TEST frontend starten
    Jun 19 11:36:57 michl logger: TEST Abbruch nach 0
    Jun 19 11:36:57 michl logger: TEST Display vorhanden
    Jun 19 11:37:04 michl logger: TEST Ton vorhanden


    Auf das Display wird garnicht gewartet, aber auf den Ton.


    Wenn es nicht auf Anhieb klappt sieht das ganze so aus:

    Code
    Jun 19 11:44:09 michl logger: TEST frontend starten
    Jun 19 11:44:20 michl logger: TEST Display vorhanden
    Jun 19 11:44:20 michl logger: TEST Ton vorhanden
    Jun 19 11:44:26 michl logger: TEST frontend starten
    Jun 19 11:44:26 michl logger: TEST Abbruch nach 0
    Jun 19 11:44:26 michl logger: TEST Display vorhanden
    Jun 19 11:44:26 michl logger: TEST Ton vorhanden


    Beim ersten Versuch läuft also die Zeit ab, ohne dass ein Display gefunden wird und das Frontend startet auch nicht. Beim 2. Durchgang sieht es wieder wie oben aus, ohne dass auf den Ton gewartet werden muss.
    Dass es überhaupt 2 Durchgänge gibt liegt an "respawn" im Upstart-Skript richtig? Kenne mich mit Upstart nicht aus.


    So funktioniert das ganze jetzt also. Vielleicht hat aber doch noch jemand eine Idee an was da grundsätzlich liegen kann. Ist ja irgendwie eine sehr unbefriedigende Lösung ...


    Gruß,
    Brougs78

    Nachtrag:


    Das ganze ist schräg.


    Wenn kein Bild da ist und ich dann "sudo start vdr-frontend" eingebe passiert im ersten Moment nichts und der Befehl hängt.
    Erst durch drücken von <strg>+<c> wird der Aufruf abgebrochen, wonach das Frontend aber dann trotzdem startet (mit dem Log von meinem 2. Beitrag).


    Die Datein /etc/init/vdr-frontend.conf sieht ja so aus:


    Warum funktioniert das dann überhaupt? Die Abrage, ob X bereit wird nicht erfüllt, weshalb ich wahrscheinlich auch <strg>+<c> drücken muss damit es weitergeht.
    Aber wenn ich auf der Konsole dann unten den Skriptteil mit "/usr/bin/start-xineliboutput" starte, dann funktioniert das auch nicht, da sich vdr-sxfe beschwert dass kein Display vorhanden ist ... was auch logisch ist.
    Warum funktioniert es dann über das upstart-Skript?


    Ich blicke hier irgendwie nicht durch und weiß nicht woran ich drehen muss dass X zuverlässig startet ... ;(


    Gruß,
    Brougs78

    Hi!


    Cool, dann funktioniert es wirklich. Das habe ich vorher manuell garnicht hinbekommen.


    dmesg liefert dann:


    Wie bringe ich das jetzt zu Wege dass das automatisch passiert? Muss ich hier irgendwo einen Delay einbauen?


    Interessant dabei ist, dass dabei scheinbar ein "HDMI hot plug event" ausgelöst wird, ohne dass ich das Kabel angefasst habe ...


    Gruß,
    Brougs78

    Hi!


    Ich habe hier ein riesen Problem. Habe für 2 Kollegen VDR-Hardware gekauft und dann meine VDR-Installation (yavdr-0.3) darauf geklont.


    Es läuft prinzipiell alles wunderbar, nur kommt es ca. bei jedem 5. Bootvorgang vor, dass kein X gestartet wird, d.h. ich sehe nur einen schwarzen Bildschirm.
    Auch wenn ich mich einlogge und openbox neu starte tut sich nichts.
    VDR läuft dann zwar und erledigt ggf. Aufnahmen usw. aber so kann ich den VDR nicht weitergeben, denn das würde schon ziemlich nerven wenn man immer wieder mal einen Reboot durchführen muss damit man ein Bild hat.


    Ich habe mal die Auszüge aus /var/log/messages für beide Zustände angehängt. Nach den Auszügen kommen dann die VDR-Meldungen vom Start.


    Interessant dabei: Wenn das Bild da ist, dann bekomme ich noch eine längliche Warnmeldung die damit beginnt:

    Code
    WARNING: at /build/buildd/linux-2.6.32/lib/vsprintf.c:1100 vsnprintf+0x3f2/0x410()


    Die ist nicht vorhanden wenn kein Bild angezeigt wird. Das scheint mit der HDMI-Verbindung zu tun zu haben, wobei ich hier schon 3 verschiedene Varianten (und 2 Grafikkarten) ausprobiert habe und eigentlich ausschließen kann dass es am TV liegt. Habe 2 TVs und einen Receiver getestet, an denen ich den VDR angeschlossen habe. Bei allen kommt es vor dass mal das Bild nicht aufscheint.


    Folgende Meldung kommt zeitlich gesehen auch früher, wenn nachher ein Bild zustande kommt:

    Code
    vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem


    Noch zur Hardware:
    Motherboard: Asus P5KPL-AM EPU
    Grafikkarte: Gainward GeForce 210 512 MB


    Aufgrund der Grafikkarte musste ich gegenüber meinem VDR den Backport-Treiber für Alsa verwenden, wie es hier im Forum empfohlen wird. Ansonsten habe ich keinen Ton.
    Das dürfte aber auch der Hauptunterschied sein zu meinem VDR, der einwandfrei funktioniert ..


    Hat hier irgendjemand einen Rat für mich in welche Richtung ich hier noch weiter probieren kann ohne anzufangen Hardware auf Verdacht zu tauschen?
    Kann das was mit ACPI oder ähnlichem zu tun haben?


    Gruß,
    Brougs78

    Hi traxanos!


    Vielen Dank für den Tipp. Das hat geholfen.
    Habe dann die busid in /var/lib/yavdrdb.hdf angepasst und die xorg.conf.yavdr neu erstellen lassen.


    Gibt es eigentlich einen Weg die Datei yavdrdb.hdf komplett neu erstellen zu lassen?
    Habe nur gesehen dass man mit create-initial-database eine relativ leere neue Datei erstellen kann.


    Gruß,
    Brougs78

    Hi!


    Ich habe hier ein Problem mit dem Nvidia-Treiber.


    Ich verwende einen VDR mit Onboard-Nvidia-Grafik. Dieses Setup wollte ich nun für einen Kollegen auf eine neue Hardware spiegeln. Da ist eine GT210-Grafikkarte verbaut.
    Jedoch bekomme ich nach dem Aufspielen des Images keine Bild.


    Im xorg-Log steht:


    Infos zur Karte:


    Habe bis jetzt folgendes versucht:
    sudo apt-get install --reinstall nvidia-current


    sowie
    sudo apt-get install --reinstall dkms


    Das waren so die Tipps, die ich bis jetzt gefunden habe. Man liest noch davon, dass man nvidia-current komplett entfernen soll (mit purge) und dann neu installieren, allerdings würde bei yavdr da einiges mit deinstalliert (yavdr-essentials).


    Hat da jemand einen Tipp für mich?


    Gruß,
    Brougs78

    Hi!


    Das selbe Problem habe ich hier auch mit [0.3a].


    Es scheint da auch noch ein anderes Problem mit dem Skript /etc/rc6.d/S61force-fschk zu geben dass ein deaktivieren des Scans über tune2fs nicht greift.
    fsck beim herunterfahren


    Schöner wäre natürlich wenn das Scannen beim Herunterfahren funktionieren würde. Eine feine Ergänzung noch aus dem 1. Post des Threads wäre:
    fsck beim herunterfahren


    BTW, beim Überprüfen ob ein Check notwendig ist wird auch nur der "mount count" berücksichtigt, nicht aber die maximale Zeit zwischen den Mounts. D.h. dann kann immer noch ein Check beim Boot durchgeführt werden.


    Gruß,
    Brougs78

    Hi!

    Quote

    Muss ich mir mal genauer anschauen.
    Für mein besseres Verständnis: möchtest Du eine neue Option "verhalten wie VDR" oder soll sich die vorhandene Option nur auf eine Taste auswirken?
    Eine neue Option ist IHMO zu viel, ich persönlich würde sogar die vorhandene Option wieder entfernen, da ich den Vorteil nicht sehe. Mal schauen, ob Einwände kommen...

    Also ich denke auch dass es hier keine Option braucht. Ideal ist IMHO das Verhalten des VDR-Aufzeichnungsmenüs:
    Wenn man aus der Wiedergabe ins Menü möchte drückt man EXIT, wenn man zum Live-Bild möchte drückt man BLAU.

    Quote


    Darüber zerbreche ich mir auch schon den Kopf. Ich hätte das auch ins Befehle-Menü verschoben. Außerdem würde ich dann auch die Bearbeitungsfunktionen nicht mehr an die Farbtasten legen, sondern ein neues Bearbeiten-OSD anzeigen, in dem man dann die Funktionen aufrufen kann. Da hätte man dann auch Platz für mehr als die jetzigen vier, wie z.B. für "Kopieren".
    Meinungen willkommen!

    Klingt gut.


    Und danke für den schnellen Fix.


    Gruß,
    Brougs78

    Hi!


    Dein Plugin ist ja eine sehr feine Sache. Ich habe nur folgendes Problem.


    Das Standardverhalten von VDR ist ja, wenn man eine Wiedergabe startet und auf EXIT drückt, dass man dann in die Aufzeichnungsliste gelangt. Mit BLAU springt man ins Live-Programm zurück und verlässt das Menü komplett.


    Das ganze wollte ich jetzt auch in extrecmenu haben und habe dafür folgende Option gesetzt:
    "Nach Wiedergabe Plugin aufrufen" --> "nein"


    Nur funktioniert das nur 1x. D.h. wenn ich eine Aufzeichnung starte und mit EXIT rausgehe, dann bin ich im Aufzeichnungsmenü. Starte ich dann direkt danach erneut die Wiedergabe und gehe mit EXIT raus, dann bin ich im Live-Bild und das Menü ist weg. BLAU beendet immer die Wiedergabe und verlässt das Menü komplett, also so wie erwartet.


    Schön wäre, wenn bei dieser Option das VDR-Verhalten vom Aufzeichnungsmenü eingestellt werden könnte.


    IMHO etwas gewöhnungsbedürftig war auch, dass auf GELB nicht mehr direkt das löschen einer Aufzeichnung möglich ist. Zum Aufräumen des VDR muss man so immer 2x GELB drücken.
    Wäre es ev. möglich EDITIEREN in das BEFEHLE-Menü zu verlagern (an erster Stelle)? Denn ich denke die vier Grundbefehle vom VDR-Aufzeichnungsmenü sind für eine schnelle Bedienung ideal.
    Unter Befehle könnte dann ja eben der erste Befehl EDITIEREN sein und danach die Befehle von reccmds.conf folgen (so ähnlich ist das ja auch bei epgsearch). Dann könnte man das Editieren immer noch schnell mit der Taste "1" erreichen.
    Ich weiß nicht wie du das siehst Andreas .... will dir da natürlich nichts einreden. :)


    EDIT: Version is 1.2.1pre in yavdr. Also falls obiges Problem nicht mehr besteht, einfach den Post überlesen. :)


    Gruß,
    Brougs78

    Hi!


    Es gibt ja bei rsync die Möglichkeit, dass du einen Ordner angibst, wo der Unterschied zwischen Quelle und Backup abgelegt wird.
    (weiß sie jetzt allerdings nicht auswendig)


    Damit könntest du dir laufend Ordner erstellen wo die Differenz hingespeichert wird und mit einem Skript die ältesten Ordner löschen.


    Ich habe in der Firma als Backup-Lösung das rsyncbackup.vbs-Skript von c't umgemodelt dass es so etwas macht.


    Falls du nicht weiterkommst muss ich da noch mal reinsehen um die Änderungen rauszusuchen.


    EDIT:
    Habe noch einmal nachgesehen. Die Optionen sind "--backup --backup-dir=BACKUP_FOLDER --delete --delete-excluded".
    Dadurch werden AFAIK die Dateien, die in der Quelle nicht mehr vorhanden sind in den Backup-Ordner ("BACKUP_FOLDER") verschoben. mit "--delete-excluded" werden auch die verschoben, die normalerweise ausgeschlossen sind. Das macht Sinn, wenn sich die Exclude-Parameter ändern.


    Konkret sieht bei mir ein Aufruf so aus (läuft unter WIN, die excludes habe ich weggelassen, da es sehr viele sind):

    Code
    rsync -av --backup --backup-dir="/cygdrive/I/FEA_Backup_Net/_BACKUP/~2011-03-18_07~17" --delete --delete-excluded --exclude ... "/cygdrive/d/FEA" "/cygdrive/I/FEA_Backup_Net"


    Dabei wird von d:\FEA nach i:\FEA_Backup_Net gesichert und die Differenzen werden (in dem Fall) nach i:\FEA_Backup_Net\_BACKUP\~2011-03-18_07~17 verschoben.


    Gruß,
    Brougs78

    Hi!


    iNOB: Danke. Das funktioniert.
    Aber wenn man diesen Kanaleintrag verwendet werden einfach beide Kanäle von tvm2vdr versorgt oder?
    Aber eigentlich egal, Hauptsache ich habe EPG :)


    Gruß,
    Brougs78

    Hi!


    Hatte das selbe Problem und bin dem etwas nachgegangen.


    Lt. Manpage von vdr-addon-lifeguard wird für "cmd" das Kommando "pidof" verwendet. Das berücksichtigt aber keine Skripte und deshalb muss man hier "sh" verwenden, da dadurch "pidof -x" aufgerufen wird, wodurch Skripte Berücksichtigung finden.


    Das ganze idealerweise noch als Template, damit es bei einem Update nicht überschrieben wird. :]


    Gruß,
    Brougs78

    Hi!


    Danke für die Anleitung.


    Das funktioniert ja wirklich sehr gut.


    Ich habe die Änderung für xbmc.conf als custom template abgelegt. Zudem habe ich den Ordner airplayer garnicht verschoben bzw. kopiert. Habe das ganze einfach in /usr/local/src entpackt und die Datei /etc/init.d/airplayer entsprechend angepasst.
    So greift es IMHO weniger in die YAVDR-Distri ein.


    Gruß,
    Brougs78