Posts by Michels

    Hallo zusammen.


    Seit der Umstellung der Frequenz für ZDF HD und der Einführung der neuen HD-Kanäle sieht mein Bild bei allen ZDF HD-Kanälen so aus (die vertikalen Streifen entstehen beim Abfilmen, diese also bitte ignorieren).


    Alle anderen HD-Sender sehen normal aus. Vor der Umstellung funktionierte ZDF HD einwandfrei. Unter Windows 7 sehen alle Kanäle normal aus, am Empfang etc. kann es also kaum liegen.



    Für einen Tip wäre ich wie immer sehr dankbar. Ich habe bisher den aktuellsten NVIDIA-Treiber, eine neue Version von xineliboutput und das Umstellen des Decoders in ~/.xine/config_xineliboutput ausprobiert. Alles ohne Erfolg.

    Ist eine gute Idee, ich mach das auch gerne, ich bräuchte dann aber noch Hilfe wo genau ich den Bugtracker finde.
    So veriert bin ich in Linux nicht, dass ich über google die richtige Website finde. Ich will es nicht auf einer völlig falschen Seite reinschreiben :D.


    Bevor wir/ich das mache(n), werde ich noch ausprobieren, inwieweit sich der Fehler mit einer älteren mkvmergeGUI-Version reproduzieren oder vermeiden lässt.


    -> Auch mit älteren mkvmergeGUI-Versionen tritt dieser Fehler auf, auch wenn man die Kompression der Header ausschaltet.
    Mit Version 4.0.0 und ohne jegliche händische Einstellung funktioniert mein Testvideo auf Anhieb mit VDPAU, inklusive Ton.


    Trotzdem lohnt sich sicher ein Eintrag im Bugtracker.

    So, jetzt habe ich so einiges ausprobiert und bin schon ein bisschen weiter.


    Damit das mkv-Video (x264) abgespielt wird, müssen mehrere Bedingungen erfüllt sein:

    • mit dem aktuellen VDPAU-Dekoder geht nichts, mit dem Tip von johns kann man aber einen älteren verwenden
    • die Header der Videospur dürfen nicht komprimiert sein, z.B. mit mkvmergeGUI kann man das auch nachträglich sicherstellen (man MUSS in der aktuellen Version Komprimierung auf "keine" stellen)


    Bis hierher ist alles klar. So kommt bei mir aber bei den getesteten Videos kein Ton. Und jetzt wird es wieder mysteriös:
    Bei dem einen Video lösen die mkvmergeGUI-Einstellungen "keine" Kompression für die Audiospur (AC3) + "Flag für erzwungene Anzeige" (auch bei Audio) das Problem. Das Video läuft, der Ton kommt.
    Beim anderen Video führen diese Einstellungen dazu, dass es nicht mehr abgespielt wird, der VDR abstürzt (also genau mein Ausgangsproblem) und neu startet. Ich habe es irgendwann geschafft, auch dieses Video
    mit VDPAU und mit Ton abzuspielen, obwohl ich keine weiteren Einstellungen verändert habe, d.h. genau die in diesem Absatz genannten Einstellungen verwendet habe.


    VDPAU scheint mir noch ziemlich in den Kinderschuhen zu stecken. Das ist keine Beschwerde, sondern nur eine Feststellung, ich find den VDR mit VDPAU genial :].

    Vielen Dank für die Anregungen. Leider kann ich sie nicht sofort ausprobieren, bin nicht vor Ort.


    Mit mplayer konnte ich den "nicht funktionierenden" Film abspielen, dafür hat es mir aber den Ton in ein maschinengewehrartiges Knistern zerlegt :D. Aber auch das lässt sich evtl. lösen.
    Ich würde sogar (zumindest eine Weile) damit leben, HD-Filme eben mit dem mplayer abzuspielen, wäre da nicht das Problem, dass dieser immer "hinter" xineliboutput läuft. Ich benutze nodm als Displaymanager
    und bekomme den mplayer nur zu sehen, wenn ich einen Doppelklick mit der Maus mache. Zudem kann es sein, dass xineliboutput den vdr neu startet, weil er eine Weile kein Signal bekommt. Da müsste ich also nicht bisschen dran basteln.


    Das mit dem vorigen Dekoder werd ich auf jeden Fall ausprobieren, danke.


    Dass es am Header liegt, hab ich auch schon vermutet, es gibt ja z.B. seit noch nicht so langer Zeit sogenannte Compressed Headers, die evtl. VDPAU noch
    Bauchschmerzen bereiten könnten. Falls es daran liegt, muss ich eben in den sauren Apfel beißen und alle meine Filme davon befreien.

    Ich bin mir mittlerweile nicht mehr sicher, welche HD-Filme bisher/früher getan haben und welche nicht.


    Das hier funktioniert bei mir nicht:


    Das hier funktioniert:


    Ich bin etwas ratlos. Beides mkv-Dateien. Bei der oberen steht bei muxing "Header Stripping", es funktionieren aber auch Dateien ohne dieses Merkmal teilweise nicht.

    Danke für die Antwort, das erscheint natürlich naheliegend. Ich habe aber bei den betreffenden Videos keine resume-Dateien.
    Mir scheint, dass der Codec des Videos auch nicht richtig erkannt wird. Wenn ich auf Info drücke, zeigt mir der VDR nichts an - allerdings weiß ich nicht mehr, ob das schon einmal anders war.
    Es handelt sich um mkv-Dateien, kodiert mit dem High 4.1-Profil und dem x264-Codec. Die liefen früher problemlos.


    Wenn ich ein apt-get dist-upgrade auf e-tobi-VDR 1.7.22... mache, ändert sich nichts. Auch aktuelle NVIDIA-Treiber habe ich installiert, keine Verbesserung.
    Ein mysteriöses Problem.

    Hallo zusammen. Ich habe meine Konfiguration nicht geändert, außer einem apt-get upgrade ab und zu ist nichts passiert. Nun wollte ich heute ein HD-Video abspielen, Pfeifendeckel.
    Der Player wird manchmal kurz angezeigt, das Bild bleibt aber schwarz und nach einiger Zeit startet VDR sich neu. SD-Videos funktionieren noch.
    Die HD-Videos sind VDPAU-konform kodiert und haben auf diesem VDR bisher funktioniert. Ich bin etwas ratlos, da ich mit dem, was syslog dazu ausspuckt, nicht viel anfangen kann:


    Für Ideen wäre ich sehr dankbar :].

    Meine Antwort hat nichts mit der Entwicklung des Skripts zu tun, aber mit der Fragestellung des Threads. Ich wandle meine VDR-Aufnahmen unter Windows7 so um:


    tsmuxer oder tsremux zum demuxen von Video und Audio


    Videoindex mit DGDecNV oder ohne passende NVIDIA-Grafikkarte eben die anderen DGIndex-Tools (DGMPGDec oder DGAVCDecDI), je nach Format des Videos, erstellen (ich habe mir eine Lizenz gekauft, da mich das Programm total überzeugt hat)


    bei MeGUI unter Tools > AVS Script Creator die im vorigen Schritt erstellte Indexdatei (z.B. irgendwas.dgi) laden, Crop-, Resize- und gegebenenfalls Deinterlace-Einstellungen vornehmen und Save drücken; bei Encoder-Settings den gewünschten Codec auswählen, für HD-Aufnahmen am besten x264:DXVA-High Def.; dann auf Auto Encode unten rechts; hier Container (ich nehme mkv) und Output-Pfad einstellen; unten stelle ich auf No Target Size; Häkchen bei Add additional content, dann Queue drücken; im nächsten Bildschirm Audio- und wenn gewünscht Subtitle-Dateien einfügen und gegebenenfalls Delay einstellen (kann man aber nachträglich sehr schnell korrigieren), dann auf Go drücken; jetzt stehen im Queue mehrere Jobs, mit Start die Abarbeitung starten (wer hätte es gedacht :P) und einen Kaffee kochen/trinken;


    Man braucht:
    tsmuxer oder tsremux
    DGDecNV
    MeGUI -> den Ordner DGIndexNV im MeGUI-Programmordner in den Tools-Ordner kopieren (oder eben DGAVCDecDI, je nachdem, was man benutzt)
    etwas Geduld, die Umwandlung eines HD-Films in 720p-Auflösung braucht auch auf einem Phenom Quad-Core mehrere Stunden (überschaubar, so 2-5 h, je nach Länge des Films)


    Wenn der Beitrag hier unpassend ist oder besser woanders stehen sollte, bitte einfach verschieben. Vielleicht kann diese kleine Anleitung ja jemand gebrauchen, ich wandle inzwischen alle meine Aufnahmen so um, die Resultate sind super.


    P.S. zu meinem Kommentar oben, dass man Video/Audio-Asynchronität noch nachträglich beheben kann: einfach http://www.bunkus.org/videotools/mkvtoolnix/ runterladen, mkvMergeGUI starten und mkv-Datei laden; mit VLC ausprobieren, um wieviel der Ton gegenüber dem Bild verschoben ist und den Wert kopieren; in mkvMergeGUI die Audio-Datei auswählen und unter Formatspezifische Optionen die Verzögerung einstellen; Muxen starten drücken und über ein synchrones Video freuen ;);

    Ich schreibe meine Frage mal hier hinein, da es immer noch um das gleiche Thema geht, wenn auch mein Problem ein allgemeines ist:


    Wie schon beschrieben spielt mein VDR beim Aufruf von mplayer das Video quasi im Hintergrund ab, d.h. hinter dem fluxbox-Fenster, in dem xineliboutput normalerweise das Bild zeigt.
    Das ist nur so, wenn das fluxbox-Fenster maximiert ist, ansonsten kann ich fluxbox so einstellen, dass mplayer automatisch in den Vordergrund kommt.
    Laut fluxbox-Wiki legt sich das maximierte Fenster von fluxbox automatisch und immer über alle anderen Fenster, das ist also wohl nicht zu ändern.


    Ich habe versucht herauszufinden, wie ich das mplayer-Skript (von Dr. Seltsam) so anpassen kann, dass es einfach beim Start das fluxbox-Fenster minimiert und es beim Beenden des mplayers wieder maximiert.
    Leider finde ich die benötigte Information einfach nicht, ich finde stets nur Befehle, die sich vom fluxbox-Fenster und dessen Menü aus ausführen lassen, ich brauche ja aber shell-Befehle.
    Hat da evtl. jemand einen Tip/eine Idee? Vielen Dank 8).

    Super, tausend Dank, mit dem Skript und einer Idee (die mir zugegebenermaßen etwas spät kommt :rolleyes:), funktioniert es:


    Ich habe meinen VDR mit nodm und fluxbox laufen. Da das Fenster hier auf "oben" gestellt war, lief der mplayer buchstäblich im Hintergrund.
    Wie genau ich das einstellen muss, damit der mplayer ohne Mausklick meinerseits in den Vordergrund kommt, muss ich noch herausfinden.
    Aber das ist schon mal ein großer Schritt dank eurer Hilfe. Der Kaffee geht heute auf mich :applaus.


    P.S. Mit mms und externalplayer hab ich mich noch nicht beschäftigt, das wird evtl. eine meiner nächsten Baustellen, danke für den Hinweis :].

    Also die Unterstützung habe ich kontrolliert (wenn ich das richtig gemacht habe):


    Code
    1. root@VDR:~# mplayer -vo help|grep vdpau
    2. vdpau VDPAU with X11


    und

    Code
    1. root@VDR:~# mplayer -vc help|grep vdpau
    2. ffmpeg12vdpau ffmpeg working FFmpeg MPEG-1/2 (VDPAU) [mpegvideo_vdpau]
    3. ffwmv3vdpau ffmpeg problems FFmpeg WMV3/WMV9 (VDPAU) [wmv3_vdpau]
    4. ffvc1vdpau ffmpeg problems FFmpeg WVC1 (VDPAU) [vc1_vdpau]
    5. ffh264vdpau ffmpeg working FFmpeg H.264 (VDPAU) [h264_vdpau]
    6. ffodivxvdpau ffmpeg working FFmpeg MPEG-4,DIVX-4/5 (VDPAU) [mpeg4_vdpau]


    Mit Hintergrund meine ich genau das, was du vermutest. Man hört den Ton und sieht nur den Fortschrittsbalken, nach kurzer Zeit sagt der x-server "No Signal", der Ton läuft so lange weiter, bis man das Video stoppt.


    Danke für den Hinweis mit der FB, da werde ich mich dann mal einlesen, wenn/falls ich mit Hilfe deines Skripts ein Bild zustande bekomme :tup.


    P.S. Sorry, dass ich den Thread nicht vorher gefunden habe, in dem du dein Skript gepostet hast, ich hab echt intensiv gesucht und gelesen.

    Danke für den Tip, das erklärt schon einmal, weshalb ich bei meiner Suche nichts gefunden habe.
    Ich habe mir die Datei angeschaut, da ich vom Programmieren fast null Ahnung habe, erschließt sich mir aber nicht, wie genau sie auszusehen hat.


    Außerdem ist mir (jetzt endlich) aufgefallen, dass die Datei /etc/mplayer/mplayer.conf ebenfalls die einige der entsprechenden Einstellungen enthält.
    Was nicht heißt, dass ich jetzt wüsste, wie genau ich zum Ziel komme :rolleyes:.


    Am einfachsten wäre, wenn ich die entsprechenden Parameter einfach in der mplayer.conf an das Plugin übergeben könnte, viele (wie vc=vdpau) stehen ja auch schon drin.
    Mein mplayer spielt die Dateien auch ab, nur eben "im Hintergrund" (Die Option "ontop=yes" bringt da nichts), also muss ich die Ausgabe noch irgendwie an den x-server weitergeben oder? Der Fortschrittsbalken ist auch da, die Basisfunktionen der LIRC-FB tun auch, nur z.B die Zahlen nicht.
    Irgendwelche Ideen?


    P.S. Ich hab mir die man page von mplayer angeschaut, ich bewege mich aber leider auf der Ebene "Halbwissen", deshalb ist mir nicht klar, was noch in die .config-Datei muss.

    Files

    • mplayer.conf

      (3.67 kB, downloaded 111 times, last: )

    Danke für die Antwort.
    Meine Distribution/Version ist die 1.7.17-1~ctvdr1 mit den Plugins etc. von e-tobi, d.h. meine runvdr ist vermutlich die Datei /etc/init.d/vdr.
    Nur, wie genau/wo genau pack ich da die Parameter rein?
    Hier die genannte Datei, das .txt hab ich nur angefügt, damit sich die Board-Software nicht unnötig aufregt :P.

    Files

    • vdr.txt

      (3.82 kB, downloaded 128 times, last: )

    Da ich im Moment "soweit" bin, dass ich genau das gleiche Problem habe wie rudirabbit, bräuchte ich mal wieder Hilfe.


    Wie angesprochen, gibt es ja von wbreu eine schöne Anleitung, mir ist nur ein Punkt nicht klar.
    Für Fortgeschrittene sicher ein Witz, ich kann es aber einfach nirgends finden:

    Code
    1. Startaufruf im VDR:
    2. \"-Pmplayer -m /usr/bin/mount.sh -M /usr/bin/mplay.sh\"


    Wie übergebe ich dem VDR-Player diese Parameter beim Start, in welches Skript/in welche .config muss ich das einfügen?


    Vielen Dank im Voraus :].

    Pardon, das war nur ein Zahlendreher hier in meinem Text.
    Offensichtlich funktioniert bei mir der im Wiki angegebene Befehl zum Starten des OSD nicht:

    Code
    1. VCH: echo "curl http://localhost:8080/osdserver >/tmp/vchosd.log 2>&1" | at now

    .
    Wenn ich stattdessen

    Code
    1. curl http://localhost:8080/osdserver

    oder ähnliches verwende, funktioniert es.
    Danke für die Antworten.

    Hallo zusammen.


    Ich habe leider eine Verständnisfrage, die ich trotz intensiven Lesens bisher nicht klären konnte.
    Ich möchte gerne den Vodcatcher-Helper benutzen, er läuft auch (bisher manuell) einwandfrei und auch der Webserver läuft, sodass ich über http://vdr:8080/news
    Änderungen an der Konfiguration vornehmen kann. Vorgegangen bin ich nach der Anleitung im VDR-Wiki (Vodcatcher-Helper).


    Nun benutze ich aber xineliboutput und daher meine Frage:
    Wie bekomme ich das Vodcatcher-Helper-Menü auf mein OSD bzw. welchen Port muss ich im Web-Frontend von VCH einstellen?
    Im Normalfall ist der OSD-Port 2001 und man startet einen OSD-Server mit einem Befehl wie z.B.

    Code
    1. VCH: echo "curl http://localhost:8080/osdserver >/tmp/vchosd.log 2>&1" | at now

    in einer commands.conf.


    Für Hilfe wäre ich sehr dankbar :bpl .

    Danke für die Antwort. Nachdem ich die externremux.sh aus den Sourcen von streamdev genommen habe, bekomme ich das hier:

    Code
    1. ffmpeg: relocation error: /usr/lib/libavcore.so.0: symbol av_default_item_name, version LIBAVUTIL_50 not defined in file libavutil.so.50 with link time reference


    Vielleicht ein ffmpeg-Problem...?
    ffmpeg stammt aus derselben Quelle wie der mplayer/mencoder.


    Edit: Es funktioniert.
    externremux.sh-Beispieldatei aus den streamdev-Sourcen nehmen, den eigenen Bedürfnissen anpassen und dann die Rechte des Skripts nochmal überprüfen :cursing: .


    Vielen Dank nochmal für die Hilfe, der entscheidende Hinweis kam trotzdem von dir, schmirl :tup .


    Thema kann damit als [gelöst] markiert werden, danke.

    So, ich hab mir jetzt 2 Tage einen abgebrochen, aber ich bekomm es einfach nicht gebacken.
    Vielleicht hat ja jemand einen guten Tip.


    Ich möchte "einfach nur" DVB-s über das streamdev-server-Plugin und den mencoder umwandeln und streamen, auf meiner früheren VDR-Version war das überhaupt kein Problem.
    Meine VDR-Konfiguration steht ja in meiner Signatur, es gelingt mir nicht, eine funktionierende mplayer/mencoder-Version zu installieren.
    In meiner sources.list steht:

    Code
    1. deb http://www.debian-multimedia.org squeeze main non-free

    .


    Versuche ich zu streamen, steht in einer Fehlerdatei in /tmp:

    Code
    1. get_path("config") problem
    2. ============ Sorry, this file format is not recognized/supported =============
    3. === If this file is an AVI, ASF or MPEG stream, please contact the author! ===
    4. Cannot open demuxer.


    Meine externremux.sh sieht so aus:


    Der mplayer, mencoder und ffmpeg wurden alle aus oben angegebener Quelle installiert.
    Für Hinweise wäre ich wirklich dankbar.


    P.S. Ich hab natürlich alle möglichen Quellen durchsucht, der Fehler tritt auch bei anderen auf, aber meist, weil irgendwas mit der Installation nicht passt.
    Und ich hoffe ich hab in die richtige Sektion gepostet, an sich gehört der mencoder doch zum mplayer oder nicht?
    Ansonsten bitte verschieben, danke :D .