Posts by marcuszurhorst

    Hallo zusammen,


    ich bin gerade absolut ratlos, da ich zum ersten Mal mit Python zu tun habe.
    Ich möchte für Kodi bzw. OpenELEC mein Atmolight auf einen Knopf meiner Fernbedienung legen um es an- und abzuschalten.
    Nun habe ich erfahren, dass ich dies in der keymap.xml Datei machen kann mittels des Befehls "RunScript()", welcher ein .py Python-Script ausführen kann.


    Das Script soll als eine Art Schalter immer hin- und her schalten:
    1) Die boblight-x11 Datei ist geladen, dann soll sie gekillt werden
    2) Die boblight-x11 Datei ist nicht geladen, dann soll sie gestartet werden.


    Folgendes würde mir helfen:
    a) eine Bestätigung, dass der Plan so umsetzbar ist.
    b) ein paar Schlüsselworte, nach denen ich googlen kann für einen schnellen Einstieg



    Dankeschön und viele Grüße,
    Marcus

    Hallo zusammen!


    Ich denke, Louis bringt es auf den Punkt. Gut möglich, dass es an mir selbst liegt.
    Ich kann mich aber noch an frühere Software-Versionen erinnern, wo man mehr selbst einstellen konnte.



    Ich bilde mir gerade ein, dass ich über http://members.harmonyremote.com bessere Einstellmöglichkeiten habe als mit dieser Software.
    Aber so ganz passt es auch da noch nicht:


    1) Aktion "Audio / Video" für alles was auf dem HTPC läuft.
    --> Ich habe den Fernseher als Ausgabe-Format für das Bild
    --> und einen AV-Receiver für die Ausgabe des Tons


    Aber folgende Einstellungen sind mir nicht offensichtlich:
    -- Alles was Lautstärke betrifft (Vol+, Vol-, Mute) soll an den AV-Receiver gesendet werden
    -- Und alle anderen Tasten gehen an VDR/XBMC.



    Wo lege ich solche Details fest?



    Danke & Gruß,
    Marcus

    Hallo zusammen,


    ich muss mal wieder feststellen, dass ich mit meiner Harmony 900 auf Kriegsfuß stehe.
    Einerseits bin ich hellauf begeistert, da ich durch diese Funk-IR-Brücke auch die Geräte im geschlossenen Schrank bedienen kann. Das funktioniert 1A und ohne Verzögerungen.
    Wirklich gut, und das war auch der Grund für die teure Anschaffung!



    Aber andererseits nerven mich diese sogenannten "Activities" total an, und diese Harmony-Sofware (v 7.7.0) macht es auch nicht gerade besser.
    Ich kriege die Fernbedienung nicht gescheit programmiert.



    Hat jemand eine Empfehlung zu einer Fernbedienung, welche auf diese Activities verzichtet, aber gleichzeitig auch Geräte in einem geschlossenen Schrank fernbedienen kann?
    -- Das ist die einzige Funktion auf die es mir ankommt.
    Darüber hinaus brauche ich auch nicht die Möglichkeit 29+ Geräte zu steuern oder sowas. Nichts extrem hochgezüchtetes.
    Mir reicht eine FB für 3-4 Geräte, und am besten hat sie eine Taste um die Steuerung für dieses Gerät zu aktivieren. Ich habe kein Problem damit, 1-2 Tasten mehr zu drücken, solange ich nur dieses Makro-Gefrickel los werde.




    Danke schon mal, und viele Grüße!
    Marcus

    So, von Silverstone Deutschland bin ich tatsächlich beindruckt.
    Die haben mir nämlich binnen 2 Tagen ein Ersatzteil hier gehabt, klasse.


    Kleiner Wermutstropfen:
    Ich habe leider silberne Knöpfe gekriegt.
    Passend zum schwarzen Gehäuse. NICHT. :(


    Anyways, ich hoffe dass ich mein gutes Verhältnis nach Hamburg nicht überstrapaziere.
    Habe mir gerade das gleiche nochmal in Schwarz erbeten.


    Joa, Caseking ist hier einen einfachen Weg gegangen.
    Aber ich wollte natürlich auch nicht gerne mehrere Wochen Bearbeitungszeit abwarten.

    So, mal kurz ein neuer Wasserstand, der mich zufrieden stimmt:
    -- Ich habe mich direkt in Hamburg an Silverstone gewendet und ein Foto der kleinen Platine mitgeschickt, auf welcher die 7 Hotkeys drauf sind.
    Die haben mir nun zugesagt, dass mir ein solches Ersatzteil zugesendet werde.


    @LiNux:
    klar könnte ich die Tasten aus abklemmen. Aber es ist ja nicht Sinn der Sache etwas zu kaufen und vom ersten Tag an einen Defekt zu akzeptieren.

    Danke nochmal für die Hilfe.


    Badenser : was genau meinst du Shield-Kontakten?



    So, ich habe mit der Caseking Hotline gesprochen.
    Im Falle eines Widerrufs verliere ich Geld, das da Gehäuse ja nun gebraucht sei.
    Ich könne es natürlich gerne einschicken zur Reparatur, das würde aber wiederum einige Zeit dauern.
    Daher gab mir der Mitarbeiter nun den Tipp, ich solle doch mal in Hamburg über den Silverstone-Vertrieb schauen, ob ich ein Ersatzteil bekommen könne.


    Witzigerweise fand ich im Handbuch gerade noch einen Vermerk im Abschnitt der Hotkey-Tasten: "* For Windows ME / 2000 / XP only *"
    -- Können die mir dann Garantie verweigern, da die Tasten ja eh nicht unter Linux funktionieren sollten? (Und ich habe natürlich mit Win7 probiert, was älteres habe ich nicht hier...)



    Danke & Gruß,
    Marcus

    Das IMON selbst funktioniert tadellos, habe gerade mit LCDproc rum gespielt.
    Einzig diese 8 Knöpfe für Play, Pause, Stop, ... unterhalb des Lautstärkereglers funktionieren nicht.


    Das IMON hat die ID 15c2:0036, das wird auch tadellos erkannt.
    Das sehe ich wenn ich das syslog beobachte während ich den Stecker einstecke.


    Nur wenn ich zusätzlich den zweiten Stecker für die 8 Knöpfe (laut Handbuch nennen die sich "Hotkeys") einstecke, dann geht gar nichts mehr mit z.B. lsusb.
    Dieser Befehl hängt und lässt sich z.B. auch nicht mittels Strg-C abbrechen. Ziehe ich dann den Stecker wieder ab, dann greift plötzlich das Strg-C, und ich bin zurück in der Bash.



    Ich stecke es ganz eindeutig auf einen USB2.0 Port drauf. (die mit den 9 statt 19 Stiften).
    Das ist im Handbuch klar beschrieben, und das ist ja auch nicht das erste Mainboard, was ich zusammen stecke.


    Den Punkt mit dem xhci_hcd habe ich aber auch schon gesehen vorhin.
    Was ich gleich noch ausprobieren werde ist, dieses Modul mal auf die Blacklist zu setzen.


    Für morgen Vormittag freue ich mich schon auf ein Telefon mit Caseking. Mal gespannt was die mir vorschlagen.
    Nur alles wieder auseinander zupfen wäre echt ärgerlich natürlich :-(




    Danke und Gruß,
    Marcus

    So, nun habe ich wieder Linux installiert.
    Das bringt mich aber nicht richtig weiter.


    1) Linux: Ubuntu 14.10
    2) Kernel: 3.16.0-29-generic
    3) Installation funkioniert nur, wenn das Device abgestöpselt ist
    4) lsusb funktioniert ebenfalls nur, wenn das Device abgestöpselt ist. Sobald ich es einstecke, bleibt der Befehl hängen
    5) wenn ich es im laufenden Betrieb anstecke, dann erscheinen folgende Meldungen in dmesg:

    Code
    1. [ 1764.344101] usb 3-8: new low-speed USB device number 7 using xhci_hcd
    2. [ 1779.634675] usb 3-8: new low-speed USB device number 8 using xhci_hcd
    3. [ 1794.925099] usb 3-8: new low-speed USB device number 9 using xhci_hcd



    wirbel :
    wie kann ich rausfinden, welche Controller ich verwende? -- Das Asus-Board H97M-Plus hat USB2.0 und USB3.0 Anschlüsse intern verbaut.
    Die Kabel sind an den USB2.0 Buchsen angesteckt.



    Gerade habe ich übrigens noch eingekreist, dass an diesem faulen Gerät nur diese "Hotkeys" unter dem Lautstärke-Regler hängen.
    Der Lautstärkeregler selbst funktioniert und hängt an dem USB-Stecker vom iMON VFD.



    Ok, ich bin mit meinem Latein am Ende. Sobald ich das Gerät einschalte, funktionieren die Tools nicht mehr zum Debuggen, und das Syslog enthält auch nichts.
    Hat jemand noch eine schlaue Idee?


    Danke & Gruß,
    Marcus

    wirbel :
    Ich war zielstrebig dahingehend, erst überhaupt mal rauszufinden, ob irgendein OS sich überhaupt installieren lässt mit funktionierenden Geräten.
    Mir läuft die Zeit davon, da ich durch den Mainboard-Tausch einen Teil der 14 Tage Widerruf verloren habe. Der Mitarbeiter von Caseking z.B. war gar nicht angetan von meinen Versuchen mit Linux und ist der Meinung dass ich ja nicht die passenden Treiber installiert hätte von der beiliegenden CD. Ergo installierte ich Windows, das fliegt aber gleich wieder runter da ich nun ja weiß wie ich Linux drauf bekomme.


    M-Reimer :
    Hub habe ich nur zur Verfügung. Ich muss aber sowieso morgen bei Conrad vorbei. Ich werde mir einen USB-Stecker basteln, der am anderen Ende die Stiftleiste für die internen USB-Ports hat.
    Dann kann ich die Hardware auch mal mit meinem Laptop untersuchen.



    Danke bis hierher und bis später.
    Marcus



    PS: Gibt es ein Tool, mit dem man die Topologie der Controller und Geräte ausgeben kann?

    Hallo zusammen,


    ich habe meinen Plan in die Tat umgesetzt und neue Hardware zugelegt.
    Inzwischen ist alles da seit einer Woche, und ich habe bisher ziemlich viel Frust.
    Die Ursache konnte ich inzwischen vermutich einkreisen, aber nun weiß ich nicht so recht weiter.


    Mal der Reihe nach:
    -- Silverstone LaScala 16 Gehäuse mit Imon-VFD-Display und solchen Bedienelementen (Drehrad, ein paar Knöpfe) auf der Front
    -- Mainboard 1: Asrock H97M-Pro4
    -- Haswell core i3 CPU
    -- ...


    Nachdem alles verbaut war, wollte ich Linux installieren. Als erstes eine "normale" Distribution (Mageia 4), um die EDID vom Fernseher zu laden etc.
    So weit kam ich gar nicht, meine USB-Maus/Tastatur (wireless) funktionierten gar nicht.
    Also am nächsten Tag erst Tastatur und Maus mit Schnur gekauft, und wenigstens in BIOS bzw. UEFI kam ich rein. Erschreckend viele Einstellungen!!
    In den nächsten 2-3 Tagen probierte ich Mageia 4, Mageia 5beta2 und auch Ubuntu 14.04 aus, und immer wieder kam es zu Problemen.
    a) Maus/Tastatur funktionieren ggf. im Text-Modus des Installers, wenn aber in die Grafik umgeschaltet wird waren die Geräte nicht nutzbar
    b) Mageia 4: die Installation klappte komplett, aber beim ersten Hochfahren steckte der Boot fest bei "Erkenne weitere Hardware..."
    c) Unbuntu: Installation ging, Boot ging, aber dann hatte ich den Login-Manager, und hatte dort wieder keine Eingabegeräte


    Frust pur, und mein Verdacht fiel auf das Mainboard.
    Daher bin in zwischen stolzer Besitzer von Mainboard 2: Asus H97M-Plus


    Letztes Wochenende alles umgebaut, und siehe da, ich hatte genau die gleichen Probleme noch einmal.
    Damit lag es schon mal nicht am Mainboard. Großer Mist.



    Nun probierte ich noch LinuxMint 17.1 aus (sehr schick gemacht übrigens), und damit bekam ich während des Bootens zumindest mal ein Log zu sehen.
    Da lautete eine Meldung "usb 3-6: device not accepting address XYZ. error -71", wobei XYZ hochzählte bis 127 und dann wieder von vorne begann.
    Hier kam nun der Durchbruch: Ich habe mal alle internen USB-Geräte abgestöpstelt, und plötzlich klappt das Booten.


    Die internen USB-Geräte gehören zum VFD-Display, zu den Bedienknöpfen und zu Audio-Klinkensteckern in der Gehäusefront.
    Und das besagte Gerät scheint das zu sein von diesen Bedienknöpfen.



    Mein jetziger Stand:
    a) Diverse Linuxe zicken rum
    b) Windows 7 läuft problemlos (auch mit diesem "kaputten" Gerät)
    c) Dieser Fehler 71 legt laut Recherche nahe, dass es ein Hardware-nahes Problem sein könne, wie z.B. Verkabelung nicht in Ordnung etc.



    Mich wundert, dass Windows diesbezüglich toleranter mit den Fehlern umgeht.
    Außerdem wundert mich, dass mit eingestecktem Gerät bei Linux zumindest während des Bootens gar nichts klappt. (wenn ich es einstecke nach Start des Rechners geschieht nichts)


    Könnte es also auch nur Log-Spam sein? -- Wie kann ich rausfinden, ob das Gerät wirklich eine Macke hat, oder funktioniert?



    Dankeschön und viele Grüße,
    Marcus

    Mensch, genau sowas habe ich gesucht.
    Das muss ich mir mal merken, dass man bei Geishals gut filtern/vergleichen kann.


    Klasse Link, danke!


    Gruß,
    Marcus



    PS: auch gerade noch gesehen, dass bei den Boards ohne so einen Ausgang ggf. dennoch intern ein Pin-Out vorliegt, um dort mittels Slotblech eine optische Buchse nachzurüsten.
    Also ist die Lage dann doch nicht so eingeschränkt.

    Hallo zusammen!


    Für meinen neuen VDR bin ich auf der Suche nach einem Mainboard für meine i3-4150 CPU.
    Ich habe an µATX Formfaktor gedacht, und ich scheitere kläglich daran, ein gescheites Mainbaord zu finden, welches auch noch über einen optischen Soundausgang verfügt.
    (habe das Gefühl, früher hatten mehr Mobos so etwas; es scheint nun seltener zu sein)


    Den optischen Ausgang des Mainboards verwendete ich bis dato, um im "nur Audio" Modus die Musik an meinen AV-Receiver weiter zu geben.
    Beim "Ton+Bild" Modus soll es dann über den HDMI meiner GT630 Grafikkarte raus zum TV.


    Wenn alles nix nützt, dann nehme ich einfach ein Mainboard ohne den optischen Ausgang und muss dann noch eine Soundkarte rein packen.
    Aber das würde ich echt gerne vermeiden, schon alleine der Abwärme und zusäzlicher Obstacles für die Kühlung wegen.



    Vielen Dank vorweg, Gruß,
    Marcus

    Hallo Moorviper,


    das ist für meine bescheidenen Bedürfnisse Overkill.
    Und es übersteigt mein Ziel-Budget um 100% ?(


    Letztlich sind dort zumindest selbst augestellte SSL-Zertifikate möglich, allerdings braucht es dafür 30,00 EUR Einrichtungsgebühr.
    Das ist echt toll bei WebhostOne, dort kann ich die Zertifikate einfach in der grafischen Verwaltung selbst eintragen.



    Danke dennoch!


    Gruß,
    Marcus

    Hallo zusammen!


    Da hier unter anderem die Empfehlung für Netcup gekommen ist, dazu noch zwei Fragen:
    1) habe ich dort einen SSH-Zugang, oder nur FTP?
    2) und kann ich dort selbst ausgestellte SSL-Zertifikate einspielen?



    Momentan bin ich bei WebhostOne, allerdings reicht mir dort der Speicherplatz nicht aus.
    Netcup ist diesbezüglich bei beinahe gleichen monatlichen Kosten sehr viel attraktiver.




    Kennt jemand Alfahosting? -- Die habe ich ständig in der Werbung meines Browsers, und dort gibt es für kleines Geld auch viel Speicher.





    Ich suche etwas mit 10-20GB Speicher und SSL-Zertifikaten (für Owncloud-Instanz) und würde das gerne bei max 5 EUR / Monat deckeln.


    Viele Grüße,
    Marcus

    Danke für das Plugin.


    Wenn ich es richtig verstehe, dann könnte mit Start des Computers der Serverdienst von Boblightd direkt gestartet werden könnte.
    Damit gäbe es zwei parallele Clients für VDR und für XBMC.


    Ein Vorteil davon könnte ggf. eine geringere Komplexität beim Umschalten von VDR zu XBMC und zurück sein.
    Bisher muss man ja ggf. das Gerät freigeben, Dienst starten/stoppen etc.



    Gruß,
    Marcus

    Hallo zusammen!


    Ich poste mal hier meine Frage, da ich noch nicht mal weiß, in welchem Board man sowas am Besten diskutieren könnte.
    Also, es geht um Webdesign für eine einfache, private Homepage.
    Ich suche jemanden, der mir ein paar Anpassungen in Wordpress und TNG macht, da ich selbst es nicht hinkriege.


    Meine Homepage: www.die-zurhorsts.de (schaut momentan gruselig aus, eine lokale Variante ist bereits deutlich weiter)


    Ich habe folgende Ziele für die Seite:
    1) Ich möchte auf der Seite "Genealogie" die Ahnenforschungssoftware"TheNextGeneration" anzeigen lassen.
    Das klappt auch mittels einen Plugins für WordPress ganz leidlich.
    Nur passt das Layout eben nicht, und ich bin gescheitert mit meinem CSS-Unkenntnissen.


    2) In TNG selbst sind zuviele Menüeinträge vorhanden.
    Ich kann die nicht benötigten Einträge einfach aus der index.php raus löschen, klappt super.
    Mir wäre aber lieber, wenn sie "versteckt" wären hinter einem Link "mehr", und dann eben nur angezeigt werden wenn jemand das Menü expandiert.


    3) Der Wordpress-Header soll Bilder anzeigen. Und zwar zwei Stück
    a) immer gleich: linksbündig ein Logo.
    b) abhängig von der jeweiligen Seite dann ein angepasstes Bild rechtsbündig.


    4) evtl. noch Responsive Design, aber das hat kaum Priorität.
    (wäre ggf. aber machbar, da mein gewähltes Theme bereits responsive ist)


    Es gibt einige sehr schöne Seiten, die TNG und WordPress nahezu nahtlos integrieren.
    So soll es halt am Ende werden. Beispiel: www.toniasroots.net



    Mir fehlt momentan ein Gefühl für die Kosten, mit denen ich rechnen müsste.
    Reden wir hier von 10 Stunden Arbeit? -- Oder noch viel mehr?


    Naiv würde ich ja denken, dass jemand, der das beruflich macht, das quasi so runter schreibt.
    Aber vielleicht täusche ich mich auch.


    Was meint ihr dazu?


    Viele Grüße,
    Marcus

    Ist das eine gute oder eine schlechte Nachricht?
    -- Ohne mir das Nächte mit um die Ohren zu hauen ist es echt unübersichtlich geworden.


    Gibt es denn deiner Meinung nach irgendeine Kennziffer, anhand der man die thermische Emission grob vorhersagen kann?

    Mist, ich war wohl zwei Mal unpräzise. *grrr*


    @Rollencontainer: Ich meinte, dass es dort keinen Hinweis auf "Haswell-Celerons" gibt. Pentiums hatte ich wohl gelesen.
    Mir ist aber ingesamt der Unterschied zwischen Celeron, Pentium und Core i-Irgendwas nicht so klar. (glaube, die ersten beiden haben keine integrierte Grafik).
    Da Johns im Hardware-Thread Celerons empfahl, meinte ich nur diese.


    yve :
    Auch hier war ich ungenau. Ich bezog mich auf meine eigene Auflistung (Seite 1) der möglichen CPUs, und ich meinte die sparsamere T-Variante des 4570.
    Die hat nämlich nur 35 Watt. Als du nun 84 Watt schriebst, wollte ich fast einen Termin beim Augenarzt machen, aber nun ist das auch geklärt.



    Gruß,
    Marcus


    Die Celerons sind für September angedacht...
    Dauert also noch bis zum vernünftig "motorisiertem" VDR mit Haswell. Der 4570 ist viel zu dicke, zeigt aber, wo es hingeht.


    Diesen Artikel fand ich auch, allerdings sind in der Tabelle unten nur Mobilprozessoren aufgelistet. Ankündigungen für Haswell-Desktop-CPUs fand ich nicht.
    Keine Ahnung, ob man aus dieser Ankündigung dann schließen kann, dass mit ein bisschen warten eben logischerweise auch Desktop-CPUs abgeleitet werden.



    Ob der 4570 "viel zu dick" ist, weiß ich eben nicht, da er ja auch wieder nur 35 Watt verbrauchen soll.
    Wenn ich für die gleiche Leistungsaufnahme mehr Rechenleistung bekomme, dann wäre es evtl. eine Überlegung wert, das Transkodieren von DVDs direkt auf dem VDR machen zu können.
    Bis dato macht das nämlich mein alter Core2Duo Laptop, und der schnauft die ganze Nacht durch. Und das sind die einzigen beiden Computer hier im Haus.


    Ich werde mal bis zum Herbst warten was noch alles angekündigt wird.



    Gruß,
    Marcus

    Hi!


    Ich überlege auch derzeit, mir ein neues System zusammen zu stellen.
    Allerdings hatte ich dieses Haswell-Mainboard im Auge, da ich ATX gerne mag und den Platz auch habe im Gehäuse:
    http://geizhals.de/950962 (Gigabyte GA-Z8X-UD3H)



    Allerdings habe ich die CPU-Kompatibiltätsliste angeschaut, und diese verglichen mit Johns Hardware-Thread.
    Dabei fiel mir auf, dass Johns Celerons und Pentiums empfielt, aber keine Core i{3,5,7} Prozessoren.
    Nun ist mir nicht ganz klar, ob der Unterschied zwischen Celeron/Pentium und Core-i{3,5,7} einfach nur darin liegt, dass letztere eine Grafikeinheit haben, die ich nicht brauchen würde.


    Bei Haswell gibt es zumindest heute nämlich noch gar keine Celerons. Die sparsamsten Prozessoren waren anscheinend diese beiden hier:

    • Core i7-4765T (35 Watt)
    • Core i5-4570T (35 Watt)
    • Xeon E3-1230Lv3 (25 Watt)


    Jetzt frage ich mich, ob ein man die 35 Watt Zahl immer miteinander vergleichen kann, oder ob es da doch Unterschiede gibt.
    Einerseits ist die Haswell-CPU mit 35 Watt angeben, und ich würde einen Teil davon gar nicht nutzen. Könnte der Verbrauch noch niedriger ausfallen, weil es im Grafik-Teil keine Last gibt?


    Andererseits wäre es vermutlich am besten, wenn dieser Teil dann gar nicht erst im Chip drin wäre, wenn er eh nicht genutzt wird.
    Evtl. warte ich auch noch ein bisschen und es kommen neuere Celerons auf Haswell-Basis.



    Gruß,
    Marcus