Posts by gehlhajo

    olaf


    Hi


    Zu Deinem Prpblem:


    >Und wie kann man generell der Mühle beibringen, das das CD-ROM, vorher
    >beispielsweise /dev/hdd jetzt auf einmal /dev/hdc ist ? Ich meine, macht ja
    >nicht viel Sinn, jedes Mal nen neues System zu installieren zu müssen, nur weil
    >man mal die Laufwerke vertauscht hat.


    Sowas ähnliches hatte ich letztens auch. Ich habe mir einen DVD-Brenner zu-
    gelegt und wollte dann das DVD-Plugin zum Laufen bekommen (schön mit
    automount und so). Nur war das DVD Laufwerk unter /dev/hdc (wo es eigentlich
    sein sollte) nicht anzusprechen.Nicht nur das, /dev/hdc gabe es bei mir gar nicht.
    Unter Yast-->Hardware war es aber auf- geführt. Das CD-ROM Laufwerk konnte
    wiederum richtig mit /dev/hdd an-gesprochen werden.
    Also kurz nachgedacht und festgestellt, das das CDROM
    Laufwerk vor der Installation von Suse und das DVD nachträglich eingebaut
    wurde.Also musste ich DVD-Laufwerk das von Hand einfügen.
    Die Gerätedateien von optischen Laufwerken heisssen in Wirklichkeit
    /dev/sr0 dev/sr1 dev/sr... usw. ( zumindestens bei mir (Suse 8.2))
    Kommt wohl daher, dass sie als SCSI-Devices angesprochen werden.
    Sollte Dein CDROM beispielweise vorher unter /dev/hdc anspechbar gewesen
    sein so ist /dev/hdc nur ein Link aud die oben genannten realen Gerätedateien.
    Also mal müsstest Du Dir die Links anpassen bzw. erst
    einmal anlegen. Versuch das mal :=)


    Bye Wildro

    >>Athlon 2200XP, weil ich hier noch einen liegen hab


    Achsooo....



    >>In das Gehäuse passen alle lange Karten rein.


    .. ich bezug mich auch auf die kleinen schicken Gehäuse ...=)))


    >>Die Fujitsu-Siemens ist jedoch keine TT-Clone


    jein, elektrisch sind sie ziemlich gleich (merkt man daran, dass die Technotrend-Treiber auch auf der Siemens laufen , zumindestens die alten)
    Siemens hat sich halt für ein anderes Konzept beim Thema CAM entschieden.
    Außerdem muss das Analogmodul ja auch noch draufpassen :=)


    >>Wo hast du denn deine Fujitsu-Siemens her?


    Bei www.pc-werksverkauf.de
    Aber ich glaube , die habense nicht mehr


    Bye

    Hi


    Ich frag nur so aus Interesse.
    Unten schreibst Du:


    >>Ich denke, bei DVD-Laufwerk und Festplatte gibt es nicht viel zu beachten
    >>(außer Lautstärke ;-) )


    hmm, warum dann so ein Prozessor ? Oder willst Du noch andere Dinge mit dem
    VDR machen ? ("dedizierten VDR-Rechner" )


    So einen Prozessor konventionell leise zu kühlen (d.h. ohne Wasserkühlung)
    ist schon eine ziemliche Aufgabe.


    Wenn Du DIVX schauen möchtest, reicht schon ein 1GHz Celeron , und der
    hat wesentlich weniger Verlustleistung. Einige DIVX-FIlme kann ich sogar mit
    nem VIA C3 866 sehen.Willst Du auf DIVX verzichten, reicht o.g VIA C3
    vollkommen aus (läuft hier mit 972 Mhz passiv gekühlt)
    Nur so als Anregung , nicht das Du Dich nacher über ne Flugzeugturbine
    im Wohnzimmer ärgerst :D


    Als leise Festplatte kann man immer auf Maxtor oder Samsung zurückgreifen.
    Die laufen, laufen, laufen.... :=) (gibt aber sicherloch noch andere leise...)
    Hier mein Tipp: für den VDR immer 5400er Platten nehmen da:


    1. von der Performance vollkommen ausreichend
    2. in der Regel leiser
    3. in der Regel kühler (kann bei kleinen Gehäusen wichtig werden)
    4. in der Regel billiger


    Zu den DVB-C Karten kann ich nicht viel sagen.
    Ich habe ne Fuitsiu Siemens (oder so) :=))


    Vorteile:


    - Analogmodul erhältlich(für Kabelseher eigentlich ein Muss)
    Die Treiber-Entwickler arbeiten auch schon dran
    - klasse Kabelpeitsche liegt bei (Scartstecker rein und schauen :=)
    - Full-Fearture-Card
    - 100% VDR kompatibel


    Nachteil:


    - sie ist so elendich lang, d.h in die meisten (schicken) Barebone Gehäuse
    passt sie nicht rein.


    Aber auf jeden Fall solltest Du eine Full-Feature-Karte nehmen. Das Geld,
    das Du hier mehr ausgibst, spart Du nachher an anderer Stelle.. :=)


    Zu Deiner eigentliche Frage wegen dem Mainboard kann ich Dir leider nichts
    sagen. Aber es gibt genug Profis hier.. :=)


    Bye...

    Hi poetter


    Da gibt es zich Möglichkeiten. Ich weis nicht wie fit du in Sachen Linux
    bist oder welche Distri Du hast.
    Eine einfache (wenn auch unbefriedigende) Lösung wäre, erstmal
    die Befehlszeile, die Du zum Einschalten des DMA-Modus benutzt hast , mit
    in die runvdr aufzunehmen. Hat natürlich den Nachteil, das du den VDR immer
    erst einmal startern musst, um den Genuss des höheren DMA zu kommen.
    Aber zum DVD schauen mit dem VDR reichts dann.....


    Die Erfahrung zeigt aber, dass man später noch mehrere Dinge beim
    Hoch bzw. Runterfahren des Rechners automatisiert haben möchte.
    Viele Leute passen dann je nach Distrbution einzelne Startscripts an.
    Hat für mich jedoch den Nachteil, dass man beim Neuaufsetzen eines Systems
    den ganzen Kram immer wiederholen muss.
    Meine Philosophie ist es, ein frisch installiertes System möglichst in Ruhe
    zu lassen und all meine Änderungen zentralisiert in einem Startscript vorzunehmen.


    Falls Du Suse am laufen hast:


    Du hast doch sicherlirch den LIRCD installiert.
    Schau Dir mal an wie Hubertus Sandmann die Installation beschreibt. Analog
    dazu kannst Du Dir dann dein eigenes Startscript zusammenbasteln.
    Im LIIRC Packet sind Beispielscripts für den Start des LIRCD enthalten.
    Die kannst Du als Basis nehmen und nach Deinen Bedürfnissen anpassen.
    Um dann Dein selbst erstelltes Script auch automatisch beim Starten
    auszuführen , verfährst DU dann ebenfalls nach Hubertus Sandman
    (Das ist der Punkt mit der ganzen "Verlinkerei" des Scripts nach /etc/init.d/rc3.d)
    Falls Interesse besteht kann ich Dir ja mal Mein Startscripts posten)


    Bis denne.....


    gehlhajo

    dekickel


    Hi


    bis dieses Feature mal eingebaut wird behelfe ich mir
    derweil mit diesem Script (benennt alle Files in einem
    Verzeichnis passend zum Erstellungsdatum um
    und nimmt dieses natürlich auch wieder
    zurück)


    Vielleicht hilfts Dir ja auch


    Gruß


    Gehlhajo

    Files

    • rendate.zip

      (488 Byte, downloaded 87 times, last: )

    Hi Folks


    Mitleid an Olaf.
    Ich kanns nachvollziehen, ist mir auch schon öfters passiert.
    (aber eben aus Dämmlichkeit, nicht wegen "technischem Versagens")
    Also,ich mache das mit meinem System so:



    Meine Platte:


    hda1 = DOS BOOT FAT32
    hda5 = WINSWAP FAT32
    hda6 = Win2000 FAT32
    hda7 = DATA FAT32 (hier befinden sich die SUSE Installations-CDS)
    sowie sämtliche von mir erstellten Scripts und VDR
    Packages


    hda8= / ext2
    hda9 =/video VFAT32
    hda10 =swap



    Wie Ihr seht,fahr ich (noch) ein DUAL-BOOT-System,da ich leider
    auf ne VIDAC angewiesen bin und die hat leider nur Windows-Treiber.
    (gehöre zu den DVB-C Gekniffenen und keine Schüssel in Sicht. :§$% )
    Wenn ich meine Suse Grundsystem auf ext2 installiert habe ,
    (will heissen : ohne X,mit Fritzcarddsl SAMBA und Compilerzeuchs) wird
    diese mittels Norton Ghost auf hda7 gesichert (und CD natürlich.)
    Deswegen auch ext2 da Ghost kein ext3 kann. Für Nachahmer: Unbedingt
    schalter 'ial' benutzen, da Linux wohl ein paar Daten an ganzg ewissen Stellen
    erwartet und sonst das booten nicht mehr klappt.
    Da der Schalter 'ial' sektorweises kopieren bedeutet, lohnt sich vor
    dem Image immer ein:


    dd if=/dev/zero of=a.dat
    sync
    rm a.dat


    Durch das Überschreiben der leeren Sektoren mit Null, erhöht sich
    bei Ghost die Kompressionsrate doch ziemlich und das Image wird
    kleiner.
    Natürlich macht dieses Verfahren nur Sinn, wenn Ihr Eure Massendaten
    (Filme, Mp3 ..) eben NICHT auf der System-Platte habt.
    Die müsst Ihr dann eben anders sichern. Da /video aber FAT32 ist,
    komme ich immer noch zur Not mit Windows drauf.
    So habe ich ein fertiges immer wiederherstellbares
    DSL-ROUTER-FILESERVER-TIMESERVER-USW. - System :]
    Alles was jetzt noch auf mein System darf, wird durch den
    Kompiler gejagt. Und zwar per selbstgebastellten Installationsscript.
    (Die sich ja auf hda7 befinden) )So ist immer dersselbe Zustand wieder herzustellen.
    Alle zusätzlich benötigten Conf-Dateinen befinden sich ebenfalls auf hda7
    und werden auch per Script in die geeigneten Verzeichnisse
    kopiert...
    Ein weiterer Vorteil des Scripts ist, dass man dadurch praktisch seine eigene
    Doku schreibt :=)
    (..und man lernt ein bisschen Linux)
    Mit dieser methode, binn ich bis jetzt immer gut gefahren.


    @schluzkrapfnf
    BTW: Wer hat Erfahrungen mit dem SuSe Sicherungskopiemanager ??

    schlechte, gaaaaan ganz schlechte
    1. lässt sich der Vorgang nicht automatiseren (bzw ich weis nicht wie)
    2. leider schon des öfteren erlebt , dass nach Rücksicherung kein boot mehr
    möglich war,


    dagobert_1
    s amsung 1204H hat 120,0 GB 8,9/2048/5400 U-100 IDE 89.00 EUR

    genau die hatte ich auch im Auge , werde ich mir auch besorgen...
    ( und zwar zwei Stück... :D )

    Also Olaf, Kopf hoch und fang an zu Scipten :D


    Gru0


    gehlhajo

    .. Vielen Dank hat geklappt :D
    Nur eins verstehe ich nicht , warum hat das bei mir
    auf normalen Weg nicht funktioniert, bei den anderen
    scheinbar schon ?
    Obwohl es ja jetzt geht, möchte ich mal irgendwann
    dahinkommen, das der Patch auch ohne Patch läuft. ;D
    Bye


    Gelhajo

    Hi Folks


    Ich habe hier im Board verzweifelt gesucht,
    aber leider nichts zu meinem Problem gefunden.
    Also müsst Ihr wieder dran glauben 8)


    Also,ich habe :


    VDR 1.2.1
    vdr-mp3-0.7.15


    und den neusten MPlayer.


    Installation klappt hervorragend , alles lüppt , wie wir Friesen sagen :D
    (Ich habe gerade bemerkt,wie man die Smilies benutzt. Cool)
    Nun ja, dann habe ich mich an dem ELCHIAOI versucht.


    Zuerst patchen. Da kam das erste kleine Problem.
    Ich habs genau nach Anleitung gemacht, wie es in der Download-Area
    beschrieben ist. Da meckerte PATCH,das dies kein gzip-Format ist.
    (Ist es wohl auch nicht, oder packt der IE das File beim Download automatisch
    aus ???).
    Verstehen tue ich das nicht , aber mit "cat" anstatt "zcat" gings ja auch.
    So , patch lief halbwegs durch es gab nur einen reject.
    Und zwar in osd.h:


    -------------------schnipp--------------------------------------


    ***************
    *** 99,105 ****
    //XXX
    osd = OpenRaw(x, y);
    //XXX TODO this should be transferred to the places where the individual windows are requested (there's too much detailed knowledge here!)
    - if (h / lineHeight == 5) { //XXX channel display
    osd->Create(0, 0, w, h, 4);
    }
    else if (h / lineHeight == 1) { //XXX info display
    --- 99,105 ----
    //XXX
    osd = OpenRaw(x, y);
    //XXX TODO this should be transferred to the places where the individual windows are requested (there's too much detailed knowledge here!)
    + if (h / lineHeight == (Setup.Symbol ? 6 : 5)) { //XXX channel display
    osd->Create(0, 0, w, h, 4);
    }
    else if (h / lineHeight == 1) { //XXX info display





    -----------------------------schnipp---------------------------------------------------------


    Anschließend habe ich den VDR (ohne Plugins) neu kompelliert.
    Bis hierhin alles okay.
    Anschließend habe ich das mp3-plugin neu kompelliert. (make plugins)
    Jetzt wird , im Gegensatz zu oben, das mp3-Plugin mit dem Schalter
    -DHAVE_BEAUTYPATCH kompelliert. Ich denke , das ist auch so gewollt.
    Nur bekomme ich dann folgende Fehlermeldung:


    -----------------------------schnipp---------------------------------------------------------


    menu-mplayer.c: In constructor `cMPlayerControl::cMPlayerControl()':
    menu-mplayer.c:90: `fontSym' undeclared (first use this function)
    menu-mplayer.c:90: (Each undeclared identifier is reported only once for each
    function it appears in.)
    make[1]: *** [menu-mplayer.o] Error 1



    -----------------------------schnipp---------------------------------------------------------



    Wie gesagt , dass passiert nur mit dem Schalter -DHAVE_BEAUTYPATCH ;(
    Fehlt mir da ein Font , oder wie ?
    Wie gesagt, ich weis nicht mehr weiter.
    Bitte lasst mich nicht weinend zurück :]



    Gruß


    gehlhajo

    .. nein, so lässt sich leidert nicht erkennen, was dort faul ist.
    Meine ganzen Scripts sind leider auch weg :=((
    ( Never tauch a runnung system )


    and especially


    Never touch a running System while drinking Becks


    Aber ich arbeite bereits wieder an einem Neuanfang.
    Mein Ziel ist jedoch nicht, eine Konkurenz zu dem bestehenden Install-Scripts
    zu etablieren. Ich benutze dieses Script nicht , weil es schlecht wäre ( im Gegenteil, es bietet einem sehr viel Komfort), sondern weil ich die ganze VDR-
    Geschichte auch dazu nutzen möchte , mich mehr mit Linux zu beschäftigen.
    Aber da ich nun mal ein fauler Typ bin, nutze ich Scripte, um halt die immer wiederkehrenden Vorgänge zu automatisieren.
    Diese Vorgehensweise kann ich jedem Linux-Newbie, der sich intensiver mit
    dem Betriebssystem beschäftigen möchte, nur empfehlen. Man lernt wirklich
    viel, und ein funktionierendes Script löst (beinah) dieselbe Befriedung aus ,
    wie der este Blick auf den Fernseher eines laufenden VDR's :=)


    Bye


    gehlhajo

    HI


    Ja, genauso habe ich mir das auch vorgestellt. Mir
    geht es in erster Linie auch nicht darum, jemandem
    Konkurenz zu machen :=). Mein Anliegen ist es,jeden
    Stand wiederherstellen zu können. Ich weis, wenn
    man jetzt cool wäre, würde man meinen einen eigenen
    CVS-Server aufsetzen. Ich habe zwar KM-Erfahrung,
    (ClearCase), aber das wäre mir dann doch zu aufwendig. So brauche ich nur mein Install-Script zu
    versionieren.
    Bis jetzt laüft dass auch schon sehr gut.( Allerdings
    ohne PLugins) Dies ist mein nächster Schritt.



    Bye
    gehlhajo

    Erstmal Danke an Euch beide :=)


    Also ich installiere prinzipiell nach Herrn Sandmann :=)
    Nur habe ich die Sourcen von den beiden Libs
    verlinkt:


    ln -s /inst/packages/mad-1.0.4 /user/local/src/libmad


    Dann so installiert , wie in der README beschrieben.


    Kann es am Link liegen ?


    gehlhajo

    Hi Folks


    Beim Installieren findet das Plugin Header-Files von
    libmad und ibsndfile (z.b sndfile.h oder mad.h) nicht.
    Natürlich sind beide Libs installiert.
    Wenn ich nun diese beiden Header-Dateien zB nach
    /user/include kopiere klappt es mit der Installation.
    Deshalb meine Frage: Wo erwartet das Plugin diese
    Header-Dateien ? Kann es sein das bei der Installation
    der beiden Libs einen Fehler gemacht habe ?
    Denn diese Header-Files befinden sich nach der
    Installation nur in Ihren jweiligen Verzeichnissen.
    Müssten diese nicht dem System bekannt gemacht werden ?


    Gruß


    Gehlhajo

    Hi


    Falls da drausen noch jemand ist, der sich wegen
    meines Problems den Kopf zerbricht, ich habe den
    Fehler gefunden.


    Man muss neben dem Link nach /usr/local/src/vdr


    (ln -s /inst/pakages/vdr-1.1.27 /usr/local/src/vdr)
    (
    noch einen Zweiten im Packages-Verzeichnis anlegen.


    (ln -s /inst/pakages/vdr-1.1.27 /inst/packages/vdr)


    Gleiches gilt für das "Verlinken" des DVB-Treibers.
    Das liegt wohl daran , dass ich indirekte Pfadangaben
    (../../../vdr) sich nicht auf die Linkstruktur, sondern
    auf das tatsächlich eistierenden Verzeichnis ( in diesem
    Fall /inst/pakages/vdr-1.1.27 ) beziehen.


    Gruß


    gehlhajo

    Hi Folks


    Ich habe da ein kleines Problem mit der Installation. ( Ist wohl eher ein Linux antatt eines VDR-Problems) Also:


    Wenn ich VDR nach Herrn Sandmann installiere, d.h. I kopiere die Sourcen nach /usr/local/src/DVB bzw. nach /usr/local/src/vdr , funktioniert das kompelieren einwandfrei. Wenn ich jedoch die "Link-Technik" verwende ( heist, die Sourcen irgendwo ablegen und zu o.g. Verzeichnissen verlinken ) findet der Kompiler den Include-Pfad für die DVB-Header-Files nicht mehr


    Im VDR-Makefile ist derEintrag


    DVBDIR = ../DVB


    anscheinend nicht mehr gültig


    Wenn ich en Pfad direkt eintrage mit


    DVBDIR = /usr/local/src/DVB


    funktioniert alles wieder problemlos.
    dDe Verzeichnisse DVB und vdr liegen garantiert auf einer Ebene.
    Ist zwar nicht so tragisch , da ich aber ein Install-Script schreibem will, ist das schon zienlich lästig, bei jeder neuen Version des VDR das Makefile anfassen zu müssen.
    Vielleicht weis ja jemand Rrat


    Achso, anbei noch das Script an dem ich gerade arbeite. Vielleicht liegt der Fehler dort


    Gruß


    gehlhajo




    Code:


    #! /bin/sh
    #
    #Installing VDR
    #



    # Was soll installiert werden



    INSTALL_DVB="yes" # Treiber
    INSTALL_VDR="yes" # VDR



    # Wohin sollen die Sourcen


    VDRROOT="/usr/local/src"
    VDRDIR="$VDRROOT/vdr"
    DVBDIR="$VDRROOT/DVB"


    # Welche Packete sollen genommen werden (bereits entpackt)


    VDRPACK="/video/packages/vdr-1.1.28"
    DVBPACK="/video/packages/linux-dvb.2003-04-21"




    if [ "$INSTALL_DVB" = yes ];then


    test -d $DVBPACK || exit # kein Packet gefunden -> Ende
    test -L $DVBDIR && rm $DVBDIR # Falls der Link für die Sourcen existieren wird er gelöscht
    ln -s $DVBPACK $DVBDIR # Link für die Sourcen anlegen

    cd $DVBDIR
    make clean
    make
    $DVBDIR/driver/makedev.napi

    fi


    if [ "$INSTALL_VDR" = yes ];then


    test -d $VDRPACK || exit # kein Packet gefunden -> Ende
    test -L $VDRDIR && rm $VDRDIR # Falls der Link für die Sourcen existieren wird er gelöscht
    ln -s $VDRPACK $VDRDIR # Link für die Sourcen anlegen


    cd $VDRDIR
    make clean
    make REMOTE=LIRC VFAT=1
    make install


    fi



































    [FONT=courier new]