Posts by tecfreak

    Wenn ich mich nicht täusche sollte mit einem aktuellen OS (also kein legacy wie Ubuntu 18.04 laut deiner Sig) das gehen. Irgendjemand hatte das ich meines Wissens schon mit LibreELEC getestet und für gut befunden.

    Hmm, das darf aber erst mit FFMpeg 4.3 funktionieren und da ist der PR noch offen und wenn ich das richtig sehe, sind minimale Anpassungen in der VDPAU.cpp nötig.


    Benötigt wird neben ffmpeg 4.3 libvdpau >= 1.3 und nvidia blob >= 440.26. Bis auf ffmpeg welches kodi ja eh selber mitbringt das statisch gelinkt ist? erfülle ich mit meinem 18.04 eigentlich alle Voraussetzungen.

    Hallo,


    weiß zufällig jemand ob es irgendwo einen fork/patch gibt der VDPAU/VP9 in Kodi nachrüstet?

    Ich nutze Kodi zum abspielen von YT Videos und komme mit meiner Hardware und soft-decode bei einigen channels mittlerweile an die Grenzen (4K/50p).


    Die Einstellung der wenigen verbliebenen Kodi devs zu Nvidia dürfte ja allgemein bekannt sein, so dass da kein offizieller support jemals zu erwarten ist.

    Einzige Alternative wäre Intel, aber da bin ich nicht bereit jedes mal die komplette Plattform für eine neue iGPU zu tauschen und würde eher dann erstmal auf die DG1 dGPU warten und bis diese auch ordentlich supported ist.

    Mal eine kurze Frage zu dem vdr-addon-lifeguard-ng. Ist dafür das vdr-plugin-dbus2vdr nötig?




    Dann noch eine Sache zum vdr-addon-acpiwakeup. Irgendwie will das bei mir nicht so richtig und ich bekomme im log jedes mal die folgende Meldung:

    Code
    1. /usr/share/vdr/shutdown-hooks/S90.acpiwakeup: 84: /usr/share/vdr/shutdown-hooks/S90.acpiwakeup: Syntax error: "(" unexpected (expecting "fi")

    Erklären kann ich mir das nicht, da mit dieser Zeile eigentlich alles stimmt.


    Wenn ich die Elemente dem Array aber einzeln zuweise, dann läuft alles wie es soll.

    Diff
    1. --- S90.acpiwakeup So Apr 7 11:19:44 2019
    2. +++ S90.acpiwakeup Do Jul 18 16:20:23 2019
    3. @@ -84 +84,4 @@ SetWakeupTime()
    4. - dates=("now +1 year -1 min" "now +1 month -1 min" "now +1 week -1 min" "now +1 day -1 min")
    5. + dates[0]="now +1 year -1 min"
    6. + dates[1]="now +1 month -1 min"
    7. + dates[2]="now +1 week -1 min"
    8. + dates[3]="now +1 day -1 min"

    g3joker

    Bin auf Bionic, habe aber Kubuntu-Desktop als Unterbau. Nutze daher nur die Pakete aus dem im OP erwähnten PPAs, also alles händisch eingerichtet.

    Ich schätze aber du musst einfach nur den normalen Installationsweg nehmen und anschließend das frontend gegen vdr-plugin-softhddevice-ffmpeg-2.8 tauschen und das nvidia 340 Treiberpaket nachinstallieren.

    Wie der richtige Weg unter yavdr/ansible aussieht kann ich dir leider nicht sagen da ich mir wie gesagt nur die Pakete ausleihe und auf das ganze drum herum verzichte bzw. verzichten muss da ich auf den Clients einen Desktop brauche und neben vdr und kodi noch andere Anwendungen genutzt werden.

    in dem Fall würde ich mal vdr-plugin-softhddevice-openglosd-ffmpeg-2.8

    Lief bei mir noch nie stabil. Wurde in den letzten Monaten noch daran gearbeitet?

    das auf neuere ffmpeg-Versionen angepasste vdr-plugin-softhddevice probieren. Das sollte dann auch mit dem aktuellen automatisch vom Playbook installiertem nvidia-Treiber funktionieren.

    Das hatte ich von anfang an genutzt. Mit der GT 730 funktioniert es nur mit dem 340er nvidia Treiber bzw. bis max. 384 wie man so im Forum lesen kann. Der 390er (aktuell default bei ubuntu) und 430er wollten beide nicht.


    Bleibt nur noch das Problem mit dem Ton. Passthrough kann ich einschalten beim Client#1 mit der GT 730, aber das Endgerät kann kein E-AC3 daher nur für PCM und AC3 aktiv. Sender mit E-AC3 werden den vdr weiterhin crashen wenn der stream von 2.0 auf 5.1 geht.

    Also mit dem 340er nvidia klappt das nun tatsächlich. Danke dir für den Tipp wolfi.m  


    Was ich aber noch beobachtet habe ist (auf beiden Clients) wenn der Ton nicht per passthrough wiedergegeben wird, dann crasht der vdr wenn Werbung zu Ende geht und wieder von 2.0 ac3 auf 5.1 ac3 gewechselt wird. Laut log liegts an libswresample.

    Code
    1. kernel: [24457.214050] device 2 receiv[3628]: segfault at 0 ip 00007f9019b321e0 sp 00007f8fe3360830 error 4 in libswresample.so.2.9.100[7f9019b2a000+1c000]
    2. kernel: [24457.214065] Code: ca 4c 63 d1 4f 8d 2c 49 4e 8d 24 8d 00 00 00 00 4a 8d 2c 95 00 00 00 00 f3 0f 10 0d 4a f2 00 00 66 2e 0f 1f 84 00 00 00 00 00 <f3> 0f 10 06 f3 0f 59 c1 f3 48 0f 2d c0 f3 42 0f 10 04 0e f3 0f 59


    Ist das ein bekanntes Problem mit ffmpeg 3.4.6 bzw. mit dem build aus yavdr/experimental-main ?

    Hallo,


    ich habe ein seltsames Problem mit einem meiner Clients.

    Bei diesem Client (Client#1) wird das OSD total falsch dargestellt wie auf dem screenshot zu sehen:

    Das Theme ist hier übrigens "Orange" wie auf dem anderen Client auch.


    Auf einem anderen Client (Client#2) mit dem identischen Softwarestand (Kubuntu 18.04.2; linux 4.18 hwe) und config sieht das dagegen ganz normal aus:


    Beide nutzen das yavdr/experimental-main und das seahawk1986-hotmail/vdr-2.4.1 PPA und Nvidia 430.26 aus dem graphics PPA (390.116 auch schon erfolglos probiert). Ich habe auch schon vdr Pakete aus frodo's PPA und dem yavdr/experimental-vdr PPA probiert, aber Client#1 zeigt immer das gleiche Fehlerbild. Als Ausgabeplugin wird softhddevice 0.7.0 genutzt und entsprechend ffmpeg 3.4.6 aus experimental-main nehme ich an. Ausgabe läuft mit 50Hz und compositing ist deaktiviert wenn softhddevice attached wird.


    Client#1 hat eine GT 730

    Client#2 hat eine GTX 1050ti


    Vorher lief auf Client#1 noch Kubuntu 14.04 precise mit yavdr Paketen ohne Probleme. vdr/softhddevice/skindesigner ist das einzige was aktuell Probleme macht, Kodi und andere Anwendungen laufen dagegen problemlos. Das OSD bei Client#1 ist egal mit welchem Skin immer fehlerhaft. Im Log ist absolut nichts zu erkennen.


    Jemand eine Idee?