Posts by Negge

    Dass man den Client mehrfach starten kann/muss, wenn man es braucht, hab ich, glaube ich, im README gelesen, aber mehrere streamdev-Server klingen unlogisch. Das ist sicherlich ein Missverständnis.
    Ich kann z.B. mehrere vlc auf einen streamdev-Server zugreifen lassen und alle zeigen unterschiedliche Transponder, solange genug Karten im Server stecken.


    Ja, stimmt. Auf den Streamdev-Server kann man von mehreren Clients parallel zugreifen.


    Allerdings funktionieren mehrere Streamdev-Client-Instanzen auf dem Client nicht zu der Nutzungsmöglichkeit mehrere devices. Der VDR meldet die anderen devices immer als belegt. Interesanterweise sagt das devstatus-plugin 16 devices. Hängt das mit dem dynamit-plugin zusammen?!?


    Naja, zurück zum Ursprungsthema: Zu der Problematik mit den radio-sendern mit streamdev ist nichts bekannt?

    Will man mehrer StreamDev-Devices an einen Client weitergeben muss man wohl mehrere Streamdev-Instanzen haben, indem man auf dem Client die "libvdr-streamdev-client.so.1.X.X" kopiert nach "libvdr-streamdev-client2.so.1.X.X", "libvdr-streamdev-client3.so.1.X.X" usw. (je nach Menge der benötigten Devices). Wahrscheinlich muss man dies auch noch auf dem Server machen, damit diesere mehrere Devices bereit stellt (entsprechend der Menge an Devices auf dem Server?!?). Das man die Menge an übergebenen StreamDev nicht im Plugin irgendwo festlegen kann ist IMHO noch etwas was StreamDev fehlt!

    Zur Info am Rande:


    Bei yavdr 0.5 muss man lediglich unter /usr/lib/vdr die "libvdr-streamdev-client.so.1.X.X" kopieren, weitere Instanzen weden dann automatisch geladen. Bringt einem aber nicht viel weil er nun meckert, dass keine DVB-Karte frei sei, wenn man am Client was aufnehmen möchte. Auch weitere Instanzen des Streamdev-Servers (auf port 3001/2005 und 3002/2006) brachten keine abhilfe?!?



    Insgesamt erscheint mir inzwischen Streamdev als Lösung für den Client im Wohnzimmer mehr und mehr als suboptimal. Möglicherweise ist es eine Lösung, auf dem Client im Wohnzimmer das Frontend VDR-SXFE laufen zu lassen, und den mit dem libxineoutput auf dem Server zu verbinden. Ich muss nur noch schauen wie ich das dem YAVDR beipuhle. Oder hat da schon jemand eine feritige Anleitung?

    Nach Streamdev-Manual ist NumPorividedSystems nicht die Anzahl der DVB-Karten im Server, sondern die Summe der verfgbaren unterschielichen Möglichkeiten, die die StreamDev-DVB-Karte bereitsstellt (siehe Spoiler).



    Des Weiteren musste ich feststellen, dass der Streamdev-client für den VDR nur genau 1 Device darstellt, .d.h. wenn eine Aufzeichnung auf dem
    Stremdev-Device (z.B. pausiert) läuft ist das Device auf den Transponder festgenagelt weil üblicherweise ja kein zweites Streamdev-Device vorhanden ist. Wie gesagt hat das also nichts mit der Numer der Devices im StreamDev-Server zu tun.


    Will man mehrer StreamDev-Devices an einen Client weitergeben muss man wohl mehrere Streamdev-Instanzen haben, indem man auf dem Client die "libvdr-streamdev-client.so.1.X.X" kopiert nach "libvdr-streamdev-client2.so.1.X.X", "libvdr-streamdev-client3.so.1.X.X" usw. (je nach Menge der benötigten Devices). Wahrscheinlich muss man dies auch noch auf dem Server machen, damit diesere mehrere Devices bereit stellt (entsprechend der Menge an Devices auf dem Server?!?). Das man die Menge an übergebenen StreamDev nicht im Plugin irgendwo festlegen kann ist IMHO noch etwas was StreamDev fehlt!



    Ohne FilterDaten habe ich noch nicht probiert, da der Client auch das EPG über StreamDev bezieht. Zudem sollte das eigentlich nicht das Problem sein. Ich hab inzwischen irgenwo gelesen, dass man Radio-Daten wohl als "ES" streamen, und nicht als "TS" wie die Video-Daten. Wobei mich dies wundert, da er ja ein gesamtes Device auf dem cleint emuliert und eigentlich den rohen Datenstrom weiterleiten sollte. Damit müsste doch Radio eigentlich auch gehen (was es jedoch nicht tut)?!?

    Hi,


    ich weis nicht ob das ein bekanntes Problem ist. Ich hab auf dem Client in der channels.conf auch DVB-S-Radiosender. Schalte ich am Client auf einen Radiosender, dann hängt sich der Client auf (Packet Error), weil er vom Streamdev-Server einen nicht geeigneten Stream erhält?!? Ist das Problem bekannt und gibt es eine Lösung?


    Anbei dei StreamDev-Conf


    Server-Conf:


    Client:

    Code
    1. streamdev-client.HideMenuEntry = 1
    2. streamdev-client.LivePriority = 10
    3. streamdev-client.MaxPriority = 99
    4. streamdev-client.MinPriority = -99
    5. streamdev-client.NumProvidedSystems = 5
    6. streamdev-client.RemoteIp = 192.168.5.76
    7. streamdev-client.RemotePort = 2004
    8. streamdev-client.StartClient = 1
    9. streamdev-client.StreamFilters = 1
    10. streamdev-client.Timeout = 10

    Nur zur Info: Ich habe es mit der FullFeatured und YaVdr0.5 nicht wirklich hin bekommen. Mein workaround ist nun Xen. In der Dom0 läuft der YaVDR mit den DVB-S2-Devices, und in eine DomU werden ich einen (wahrscheinlich) älteren YaVDR (vielleicht die 0.3) packen, der dann das SD-Bild auf der FullFeatured ausgeben wird. Die entsprechende PCI-Karte ist auch schon per PCI-back für die Dom0 ausgeblendet (fnu hat das in einem anderen Thread beschrieben). Wenn ich damit weitergkommen bin, werden ich das nochmal in einem Thread berichten....

    Quote

    FYI: Das ist jetzt nen Plugin und kein Patch.

    klar, stimmt. War so dahin geschrieben...


    Quote

    AFAIK kann man das mit epgfixer nicht machen. epgfixer modifiziert nur einzelne EPG Einträge, vergleicht aber nicht mehere miteinander.

    OK, dann hilft das wohl nicht weiter...

    Quote


    Die übliche Lösung ist das xmltv2vdr Plugin im Modus mischen zu nutzen.

    Genau die Einstelloption finde ich aber bei yavdr 0.5 nicht (wieder). Die war doch (früher) unter "System"->"Einstellungen"->"EPG", oder?
    Ich finde zumindest dort als auch in keinem Plugin-Menü oder sonstigen Einstellungs-Menu den entsprechen Punkt (oder ich bin Blind, was ich nicht ausschließen möchte).


    CU

    Hi,


    wie kann man denn beim aktuellen "stable" yavdr 0.5 dopplete EPG-Einträge des externen und internen EPG fixen/mischen. Früher ging das ja mal mit "adjust" im "EPG"-Menu, aber den Eintrag / den Patch gibt es beim aktuellen VDR wohl nicht mehr. Ich wollte jetzt nicht den internen EPG per NoEPG-Patch deaktivieren. Das Plugin vdr-plugin-epgfixer ist ja vorhanden, nur da bräuchte man eine passende Regel. Gibt es da schon was / geht das überhaupt? Oder gibt es eine andere Lösung?

    Hi,

    Problem mit der Fernbedienung ist gelöst -> Lösung: einfach /etc/modprobe.d/av7110_ir.conf ergänzen um && chmod 666 /proc/av7110_ir zu:

    Code
    1. ]install dvb_ttpci /sbin/modprobe --ignore-install dvb_ttpci && chown vdr:vdr /proc/av7110_ir[b] && chmod 666 /proc/av7110_ir[/b]

    .


    Ursache: Anscheined kann das remote-Plugin die Berechtigung für /proc/av7110_ir im Modus "-i autodetect" selbst setzen, allerdings nicht wenn man per udevrules das input-device auch /dev/input/ir umbiegt und mit "-i /dev/input/ir" in der Plugin-Optionen startet. Letzteres ist aber sehr sinnvoll, das sonst sich das input-device sonst gerne mal beim booten ändert und dann die Fernbedienung nicht mehr geht, weil das remit-plugin das device mit in der remote.conf speichert....



    So, jetzt müssen nur noch die oben angesprochenen Bild und Ton-Probleme gelöst werden

    Hi, es lag an dem UEFI-Mist. Nachdem ist das im Bios deaktiviert habe und alles mehrfach neu installiert habe funbktioniert es jetz prinzipiell, bis auf viele viele Kleinigkeiten.


    Wie gesagt, das Teil soll asl Stremdev-Server für Yavdr-Clients dienen, aber auch noch gleichzeitig einen älteren LCD (nur Scart) über die FullFeatured ansteuern (Hardware siehe Signatur)


    Was geht:
    - Bild! Meistens.
    - Netzwerk
    - Web-Konfig


    Probleme:
    - ich habe keinen Ton auf der FullFeatuared? (auf der anderen Platte auf dem selben Rechner ist noch der ct-vdr, selbe Hardware, der hat Ton!) --> Syslog sagt nichts


    - /proc/av7110_ir hat nach dem booten nicht die richtigen berechtigungen. - modprobe.d-script funktionieren nicht weder das mitgelieferte

    Code
    1. install dvb_ttpci /sbin/modprobe --ignore-install dvb_ttpci && chown vdr:vdr /proc/av7110_ir

    noch mein unter ctvdr funktionierendes

    Code
    1. post-install dvb_ttpci chmod +r /proc/av7110_ir


    - Bild stopt alle paar sekunden -> Syslog sagt

    ja, war sdc. Aber der Installer wollte immer die Platte am Port1 mit grub bearbeiten. Irgenwie lag das wohl am UEFI-Krams. Ich hab dann schlussendlich alle Platen raus und nur die Ziel-Installationsplatte an Port 1 rein. Jetz bootet die Kist mit UEFI?!? Der post-install ist aber wohl nicht durchgelaufen, oder wo kann ich nun einstellen, dass die Kiste den VDR auf der FullFeatured laufen lassen soll und für den HD-Krams nur als Server für den HD-Client dienen soll. Wie gesagt komme eigentlich vom e-tobis vdr ...

    Hallo,


    ich habe in Problem mit der Installation vom Yavdr. Dieser sollte zunäscht einmal auf der einer blanken Platte erfolgen (an Sataport3). Im System ist aber auch noch das alte Debian auf der Platte an Sataport1. im Bios ist als bootplatte sataport3 eingestellt, der installer lässt sich aber partotut nicht dazu übereden grub auf die platte am sataport3 zu installieren, sonder schreibt den immer auf die erste Platte. :wand Damit ist das ganze dann natürlich nicht bootfähig.


    Was tun?!?

    Hi,


    ich nutze den VDR mit der videopartion auf einem mhddfs (0.1.39). Funktionierte soweit auch OK, nur habe ich nun nach Mainboard/CPU-Wechsel häufer Segfaults, was den VDR natürlich dann abschiesst. Vorher hatte ich die Segfaults auch, aber wesentlich seltener.


    Hi, erstmal danke für die Antworten, Signatur stimmt soweit weitgehend. Das ICE-LCD ist weg, da der "vdr" nun in einem "standard"-Gehäuse steckt. Der kommt so in den Abstellraum und wird per UHF-Modulator die nicht-HD-TVs versorgen. Im Wohnzimmer hab ich parallel schonmal nen Lenovo Q150 als HD-VDR-Client unter YaVDR, der als reiner Streaming-client auf den XP-M zugreifen kann. Prinzipiell wäre natürlich auch nen Aufrüstung denkbar, aber ist eigentlich ein wenig overkill. EasyVDR hatte ich übrigens auch schon gestestet. Aber hat mir jetzt nicht so zugesagt. YaVDR gefällt mir etwas besser. Aktuell hab ich auch den ct-vdr mal auf die aktuelle 2.0.1. von etobi geupdatet, allerdings fehlt da inzwischen bei etobi doch einige was ich so gerne hätte. Außerdem ist die ct-vdr-installation etwas "organisch" geworden, da diese seit sarge immer wieder geupdatetd wurde, wodurch doch noch die ein oder anderen altlasten vorhanden sind. . Tisno.de hört sich super an, das werde ich mal als start ansetzten. Oder hat noch jemand nen günstiges stromsparendes 64bit-system mit mindestens 3 PCI-Slots über?

    Hi,


    ich würde gernen meinen e-tobi-ctvdr in rente schicken und durch yavdr ersetzten. Auf dem HD-Testclient (Stremdev) läuft auch schon yavdr 0.5 und ich bin damit recht zufrienden. Das Problem ist nur, dass es sich bei dem derzeitigen Server (nicht headless) um ein 32bit-System handelt. Wie gesagt läuft da momentan noch ein e-tobi-vdr. Gibt es irgenwo eine Anleitung wie ich den 32bit-yavdr am einfachsten auf die Kiste drauf bekommen könnte? Die 32bit-Pakete sind im ppa ja offenbar (nahezu) alle vorhanden. Sollte ich nun also am besten ne Installation vom Yavdr-05 iso machen und da dann die 64bit Pakete durch 32bit ersetzen oder erst precice pangoling installieren und dann yavdr aus dem ppa nehmen.


    Danke schonmal für Hinweise. Oder hat da noch keiner Erfahrungen dazu?

    Hi Sven,


    ich hab das selbe probiert. Theoretisch sollte ja auch das neue easyvdr 1.0 gehen, irgendwie läuft das aber schon bei der Installation nicht so richtig. Mein Ziel war neben der ehd das ganze von einem USB-Stick (32GB) laufen zu lassen. Wenn du eine Lösung hast lass es mich wissen, ich bin da nicht wirklich weiter gekommen.


    Beste Grüße

    Das mit den zwei antworten ist zwar gut gedacht, finde ich aber sehr knapp, da da schon 2x ein "Must Have" dabei ist und dann die Frage ist wie aussagekräftig die weiteren Antworten noch sind. Daher hier noch ein wenig ausfühlicher. Ist aber insgesamt sehr gut zusammengefasst was der LiveBufferPatch können sollte.


    a) Zielstelluungen die LiveBuffer bevorzugt bieten sollen
    - Verwendung des Livebuffers für eine rückwirkende Sofortaufnahme (will wohl jeder haben, must have)
    - Beibehaltung des Buffers bei Kanalwechsel (nice to have Feature vor allem im Vergleich zu Kaufreceivern)
    - Jederzeit vor- und zurückspulen können, ohne den Buffer explizit zu starten (sollte auch klar sein das dass immer dabei ist, must have, sonst mancht der Livebuffer ja keinen Sinn)
    - Möglichst geringe Festplattenaktivität bei Verwendung des Buffers (sollte jeder selbst einstellen können, je nach RAM oder Festplattenkapazität)
    - Nichts, die bestehenden Funktionen sind gut so wie sie sind (kein Kommentar)


    b) wie die Umsetzung erfolgen soll (schließen sich gegenseitig ja aus) --> kann man gegebenenfalls ja ebenfalls wählbar machen in den Plugin-Einstellungen...
    - Keinen Wechsel in den Replaymodus (Tasten wie im "Live-Modus") (finde ich nicht so gut, ist aber nicht entscheidend)
    - Expliziter echsel den "Replaymodus" (wie bisher) (finde ich besser) --> starten durch Pause oder "rewind"