Posts by doggsta

    Manchmal kann das Leben so einfach sein!


    --disable-ivtv hatte ich schon probiert nur das "debian/rules clean" vergessen.


    Super danke Ioannis jetzt läufts!


    Gruß


    doggsta

    Hallo,


    ich habe ein Probem beim kompilieren des aktuellen mplayer.
    Es kommt folgende Fehlermeldung:



    Ich verstehe es nicht. Ich nutze doch kein ivtv??
    Kennt jemand das Problem?
    Vorgegangen bin ich mit der Anleitung von hier


    Vielen Dank im Vorraus fürs evtl. Tips



    Gruß


    doggsta



    Hier noch die config:


    So jetzt gehts wieder... bin ich froh!


    Die Datei vdr-shutdown hatte den falschen Benutzer. Diese benötigt root und nicht vdr. Anscheinden habe ich beim Kopieren mit cp mal das -p vergessen.


    Code
    1. apt-get install vdr --reinstall -o Dpkg:Options::=--force-confmiss


    .. hat mir dann geholfen die richtigen Einstellungen zurückzusetzten.


    Danke an Euch alle!


    Gruß


    doggsta

    Hallo wilderigel


    Zwischen der Umstellung und meinem jetzigen Problem wurde kein upgrade durchgeführt. Zumindest nicht bewusst.


    Ich bin die Skripte durchgegangen. Der VDR führt das Komandu:
    "/sbin/shutdown -h now" aus nur passiert da nichts da vdr keine Rechte zum beenden hat. Wie bekommt der user vdr das Recht den PC zu beenden?


    Gruß


    doggsta

    Ja der Vdr wird als vdr user ausgeführt. Mir kommt es vor als ob der vdr kein recht hat den PC abzuschalten. Nur weiß ich noch nicht warum das so ist, und wie es dazu gekommen ist. Denn vorher ging ja alles.


    Hier mal das syslog:


    und das vdr-shutdown:



    und noch die config-loader.sh:


    Alle drei Dateien vdr owner und vdr group.


    Hast du einen Vorschlag?


    Danke


    Gruß


    doggsta

    Hallo!


    Ich habe einige Teile meines VDRs in die Ramdisk verfrachtet um die Platte schlafen zu legen.
    Und zwar folgende Pfade liegen jetzt in der Ramdisk:
    /usr/lib/vdr
    /usr/share/vdr-skins/
    /var/cache/vdr/epg.data
    /var/cache/vdr/vtx/
    /var/lib/vdr


    Jetzt legt sich zwar meine Platte braf schlafen und wacht nur noch bei Festplattenzugriff auf. Doch der VDR fährt nicht mehr runter.
    Im syslog ist nichts zu sehen.
    Der Fernseher wird kurz schwarz., dann kommt jedoch wieder das Bild und er benimmt sich als währe nichts gewesen.
    Kann es sein das ich irgendwelche Rechte aus versehen verstellt habe?
    Als vdr user kann ich nicht den vdr abschalten:

    Code
    1. VDRServer:~# su vdr
    2. vdr@VDRServer:/root$ /sbin/shutdown -h now
    3. shutdown: you must be root to do that!
    4. vdr@VDRServer:/root$



    Mir fällt nicht mehr ein!


    Habt Ihr noch eine Idee?


    Gruß


    doggsta

    Hallo!


    Ich habe mir die laptop-tools installiert um die Festplatte bei normalem Fernsehen schlafen zu legen. Das /vtx Verzeichnis und die epg.data Datei liegen schon in der Ramdisk. Die Festplatte bleibt auch braf aus beim zappen doch wenn ich ins Menü gehe startet die Festplatte.
    Worauf greift der VDR dabei zu? Und kann ich das unterbinden?
    Wer hat es geschafft die Festplatte, wenn keine Aufname läuft oder abgespielt wird, abzuschalten?


    Vielen Dank im Vorraus!!


    Gruß


    doggsta

    Hallo,


    diese Woche wollte ich den Livebuffer Patch für Permantentes Timeshift testen. Der Patch funktioniert super und ist echt super Praktisch.
    Leider lässt sich jetzt der VDR nach einer gewissen Zeit nicht mehr über die Fernbedienung beenden und abschalten. Das Bild wird kurz schwarz und dann kommt der VDR wieder hoch als währe nichts gewesen. Bei abgeschaltetem Timeshift funktioniert alles wie vorher.



    Hier ein Auszug aus meinem syslog:




    Was mich verwundert ist die Fehlermeldung: ERROR (thread.c,501): Cannot allocate memory


    Wisst Ihr vielleicht woher diese Fehlermldung kommt?



    Vielen vielen Dank für eure Hilfe im Voraus!


    Liebe Grüße
    doggsta

    Ja ich denke schon.


    apt-cache policy sagt:




    So wie ich das verstehe müsste doch alles von der gleichen Quelle sein oder?


    Vielen Dank


    doggsta

    Hallo,


    ich habe ein Problem mit dem vcd Plugin. Nach der Installation wird das Plugin ausgelassen wegen "binary incompatibility".
    Was mache ich falsch?
    Hat jemand einen Tip?



    sources.list:


    und preferences:


    Vielen Dank im voraus


    doggsta

    Hi,


    cirrussc hat schon recht 128 sind ein theoretischer Wert der mit den 400kHz wahrscheinlich nicht zu schaffen sein wird. Aber 20 hatte ich schon ohne Probleme mit voller Speed laufen. Wenn es nicht klappt kannst du ja die Frequenz runter setzten. Am besten siehst du das mit einem Oszi wenn die Flanken zu flache werden. Es ist eben immer eine Frage des timings. Wie viele Slaves willst du ansteuern und in welcher Zeit.


    Die Lösung mit dem Microcontroller gefällt mir auch sehr gut, daran hab ich auch gedacht denn da kannst du den eingebauten I2C und RS232 Controller nutzen. Was einiges an Arbeit ab nimmt wenn du dich schon mit MCU Programmierung aus kennst.


    Das Scannen in einem I2C Bus nach Slaves ist ziemlich einfach. Du Sendest ja immer zuerst die Adressa 7bit dann ein Bit für lesen oder schreiben macht 8 Bit. Das 9. Bit ist ein Acknowledge vom Slave mit der richtigen Adresse. Dabei sendet der Master ein High und der Slave zieht die Leitung auf Ground also Low-Signal. Kommt das Acknowledge, Slave vorhanden. Kein Acknowledge, kein Slave oder bei Eproms Slave beschäftigt.


    Gruß


    doggsta