Posts by joachim-h

    Ich habe auf einem Rechner zwei "Versionen" von VDR im Dual-Boot und bei einem von beiden funktioniert Lirc nicht richtig, vielleicht kann mir ja jemand einen Hinweis geben, was ich machen kann?


    VDR-"Versionen":

    1. MLD 5.4 unstable (VDR 2.3.8 auf einem System basierend auf Debian Jessie)

    2. Ubuntu 16.04 mit VDR 2.3.8 aus dem PPA von Seahawk


    Als Fernbedienung benutze ich eine Logitech Harmony mit dem Profil von KLS.


    Bei beiden wird die gleiche lircd.conf benutzt, bei der MLD mit dem Modul lirc_serial, bei Ubuntu mir dem Modul serial_ir.


    Mein Problem: Bei der MLD funktioniert die Fernbedienung wie gewohnt, unter Ubuntu praktisch überhaupt nicht.

    Unter Ubuntu wird von zehn Tastendrücken nur einer erkannt und das Log ist voll mit Meldungen über ignorierte Spikes:

    Code
    Jan 31 14:28:00 vdr kernel: serial_ir serial_ir.0: ignoring spike: 1 1 257116778301ns 233425999249ns

    Dazu finde ich im Netz nur Sachen von 2010 oder früher.


    Das mein Fernseher mit seinem Backlight den Empfang des Sensors beeinflusst (das könnten die Spikes sein) ist mir bekannt, unter MLD kommt Lirc damit aber auch klar.


    Ein Versuch, bei dem ich zehn Tasten langsam nacheinander gedrückt habe (2x hoch, 2x runter, 2x links, 2x rechts, 2x OK) sieht im Log so aus:

    Code
    Jan 31 14:40:17 vdr lircd-0.9.0[1720]: accepted new client on /run/lirc/lircd
    Jan 31 14:40:21 vdr kernel: serial_ir serial_ir.0: ignoring spike: 1 1 998708528539ns 961559478495ns
    Jan 31 14:40:28 vdr kernel: serial_ir serial_ir.0: ignoring spike: 1 1 1005387564180ns 961559478495ns
    Jan 31 14:40:30 vdr vdr[1597]: [2138] VNSI: Requesting clients to reload channel list
    Jan 31 14:40:35 vdr vdr[1597]: [2138] VNSI: Requesting clients to reload channel list
    Jan 31 14:40:42 vdr kernel: serial_ir serial_ir.0: ignoring spike: 1 1 1019945674969ns 1013847164196ns
    Jan 31 14:41:03 vdr lircd-0.9.0[1720]: removed client

    irw hat dabei nur einem Tastendruck (1x runter) erkannt.



    Habt Ihr irgend eine Idee?



    Gruß



    Joachim

    Die Frage ist, ob das EPGD kümmert, wenn man über VDR-live einen Timer setzt (zb per Suchtimer), nimmt er auch die Einstellungen für Vor- und Nachlauf aus Live und ignoriert die Einstellungen aus dem OSD.

    Ich hatte vergessen zu schreiben, dass ich das inzwischen erledigt habe. war wirklich extrem einfach. Ich habe einfach in der channelmap-Tabelle die Id des einen Senders mit "299" ersetzt, dann die ID des zweiten Senders auf die des ersten geändert und dann die des ersten Senders von "299" auf die des zweiten Senders. ISt erledigt.

    Ich gehe davon aus du rätst mir dazu das Paket von Jasmin zu installieren?! Wenn ich richtig verstanden habe laufen danach die Cine S6 + S7 und der CI Schacht treiberseitig. Bekomme ich das Paket von Jasmin über das Webinterface oder muss ich via SSH hinzufügen und installieren?


    Um dann das Alphacam zu Lesen benötige ich im MLD das ddci2 Plugin. Wie kommt das in den MLD (SSH?! oder Webinterface?!)

    Damit das CAM gefunden und genutzt wird, benötigst Du die richtigen Treiber, die schon im, bei MLD 5.4 verwendeten Kernel 4.14 drin sind. DDCI2 ermöglicht Dir MTD (Multi Transponder Decoding, Dekodieren mehrerer Transponder gleichzeitig) und ist ein VDR-Plugin, dass Du ganz normal, wie andere Plugins über das Webinterface installierst. Es hat keine Konfigurationsmöglichkeiten und muss nur installiert sein.

    Leider ist das Thema CI/CAM nicht ganz so einfach. Besonders, wenn man MTD (Multi-Transponder-Decoding) haben möchte um frei mehrere Sender aufzeichnen zu können.


    Bei MLD empfehle ich Dir die MLD 5.4 testing einzusetzen, denn dort bekommst Du direkt VDR 2.3.8 und das passende DDCI2-Plugin um MTD nutzen zu können.


    Treiber hängen von der verwendeten DVB/CI-Hardware ab. Bei mir ist beides von Digital Devices und wird von der MLD 5.4 automatisch richtig erkannt. Bei anderen VDR.Distributionen musst Du teilweise selbst Hand anlegen.

    Im Preeseed wir das multimedia-Paket mit den DVB-Treibern gebaut. Auf meinem System braucht er dafür knapp 3 Stunden. Und nur, damit ich es dann runterschmeiße und dddvb-dkms installiere. :)

    Danke, dann wird es wohl eine GT710 werden, dann aber erst wenn mir der Lüfter der 520 genug auf die Nerven geht. Ich dachte halt, da sei vielleicht noch was an besseren Upscalern und Deinterlacern drin.

    In meinem VDR werkelt eine relativ betagte NVidia-Karte (520 GT, aktiv, glaube ich).

    Mein neues Mainboard ist ein ASROCK Q1900M und deshalb könnte ich eigentlich auf Intel umsteigen, mich schrecken aber mehrere Bemerkungen von Besitzern dieses Boards über die besch***ene Bildqualität bei SD-Material ab.


    Welche NVidia-Grafikkarten sind denn derzeit empfehlenswert?

    • Soll nur für VDR und KODI eingesetzt werden.
    • Muss Low-Profile sein.
    • Sollte passiv gekühlt sein (Muss aber nicht unbedingt).


    Was ist da derzeit das beste nach den Kriterien Leistung und Preis und würde ich bessere Leistung (als die 520er) überhaupt zu sehen bekommen? Kann man mit neueren Karten bessere Upscaler und Deinterlacer benutzen als mit der 520er?

    OK. Läuft. Ohne das ich eine Dokumentation finden konnte, hatte ich angenommen, epgd und epghttpd seien zwei Versionen der gleichen Applikation (weil beide die selbe Konfigurationsdatei genutzt haben). Ich bin nicht drauf gekommen, dass man epgd und epghttpd starten muss!


    Blöd, ich weiß. :wand

    Ok. Dann liegt der Fehler woanders. Ich hatte es so versucht, weil ich keine Dokumentation zu epgd-http finden konnte und nach dem Start kein Webserver auf Port 9999 (wie in epgd.conf konfiguriert) lauscht.


    epgd.conf

    Hallo Seahawk,


    da habe ich mich, glaube ich, nicht genau genug ausgedrückt.


    Ich habe epgd und epgd-http auf dem selben Server. Auf einem anderen Rechner läuft ein VDR mit epgd2vdr und scraper2vdr.


    Auf dem Server läuft ein nginx, auf dem ich einen Server auf Port 9999 mit der root /var/epgd/www konfiguriert habe. Ich kann nun unter {ip-des-servers}:9999 das Webfrontend des epgd-http erreichen, allerdings bekomme ich da nur die Rahmen, Bedienelemente und eine Fehlermeldung "Es ist ein allgemeiner Fehler aufgetreten" angezeigt. Der Menüpunkt "Einstellungen" funktioniert, auf den anderen bekomme ich einen "404"er angezeigt.

    Hallo,


    mal eine Frage an die, die sich auskennen:


    Kann ich epgd-http auch auf einem Server ohne laufenden VDR laufen lassen, oder genauer, kann das Webfrontend ohne einen laufenden VDR benutzt werden? Ich weiß, dass ich dann vielleicht keine Timer oder Aufnahmen sehen kann, aber kann ich das Webfrontend einfach als Programmzeitschrift benutzen?

    Mein Setup

    - Server mit epgd-http

    - VDR mit epgd2vdr und scraper2vdr


    Nutzung des epgd auf dem VDR funktioniert, ich bekomme nur das Webfrontend auf dem Server nicht richtig zum laufen.