satip-plugin or satip-Server? What's the reason for the problems?

  • Hi,


    I'm new to this forum, but not new to Linux or VDR (using Linux since 1993 and VDR since about 13 years). I read all threads with "satip", followed all hints and tips, but didn't get a solution for my problem, so I try to explain, what happend and happens:


    Last autum I decided to buy a Telestar Digibit R1, which did an automatic firmware update to V1.13.x.y. After some problems in the beginning, the device and the satip-plugin worked seemlessly, using 1 FF-DVB-Card-tuner and two SAT-IP-tuners (--devices=2), because only two SATIP-tuners have cables to the LNB. Due to slight problems with the (very old) FF-tuner I decided to give SAT-IP highest priority. Everything worked well. 3 (and more from same bouquet) recordings at the same time didn't show any problem.


    Then I decided to do a firmware update on the Digibit R1 to V1.16.x.y. The device rebootet and showed V1.16.x.y as expected. Good.


    After several weeks, now about 3 weeks ago I had a power loss, so the Digibit reboot hard. After that, the problems began:


    Live viewing on the VDR seems to work without problems (but, I'm not sure if VDR then uses the FF-tuner or the satip-tuner). But all recordings from the satip-tuner have several repeated "loops", i.e. during playback there's a short "disruption" and the last 1-2 seconds of the video are repeated. When it reaches the same position where the disruption began, there's no 2nd disruption. This happens about 1-3 times in 2 minutes :-( If I try, I can cut these repeated frames with VDR, so that it get invisible, but that's not a solution. Recordings from the FF-tuner don't have this problem.


    Until now I'm using VDR 2.0.3 on Debian wheezy, sat-ip-plugin Version 0.3.3 and/or 1.0.2. Then I compiled newest vdr 2.2 and sat-ip-plugin 2.2.1, but this problems still exists. Due to Debian wheezy I still use curl 7.26, but I hope this can not be the reason for these problems.


    Again: the problems started after the unplanned reboot of the Digibit... :-| X( I supposed, that a soft reboot doesn't do the same like a hard reboot???


    2 days ago I tried the Elgato Android SATIP-App and didn't see any problem. But when i tried to access the Digibit via Raspi/OSMC and UPnP, I saw similar glitches.


    So I used, as recommended, the latest firmware version 1.17.x.y (linked in some other thread here, including cut of the first 16 byte and so on, because automatic firmware update had not been offered). But that also didn't help. For further debugging I'd like to "downgrade" the Digibit R1 to Version 1.13.0.105, but I couldn't find this version anywhere. So I have these questions:


    1.) Can someone give me access to the firmware version 1.13.x.y of the Telestar Digibit R1 or identical devices from other vendors?
    2.) Is there anybody else with similar problems?
    3.) What else can I do, which infos can I post, what debug switch can show me where and why the problem happens?
    4.) What causes the problem, satip-plugin oder satip-server?


    In syslog there are several satip errors/warnings, but most of them (I think) where also there before the problems started. I also can make a small recording with one of the "disruption scene", if you like, to look for sequence numbers or buffer problems or something like that.


    Thanks in advance!

  • Hi,


    I'm back after some weeks of testing, trying, examining recordings, etc. My result: It's not everything OK. :-(


    Before thehlers sent me the older version 1.13 for testing I rebooted the SATIP server (still with V1.17) and had no problems for several days. But then, they appeared again: several disruptions per minute, each time with 1-2 seconds of repeated recording loops. So I flashed firmware 1.13 and thougt that indeed all problems have gone. But yesterday, about 4 days later, the same problem appeared again. I rebooted the satip server, I restarted VDR, I downgraded the satip plugin to 0.3.3 instead of 1.0.2, but the problem didn't go away.


    I have:
    - Debian 7.8
    - vdr 2.2.0
    - satip-plugin 0.3.3 and 1.0.2
    - Telestar Digibit R1 with firmwares 1.13. or 1.16. or 1.17.


    I tried vdr 2.4 and actual satip-plugin (both manually compiled), but the problem still existed :-(
    As I mentioned before, the problem exists also when getting the stream by UPnP from the satip server (didn't test that with every firmware/software combination).


    Can someone tell me, what information is needed to find the cause for this problem?
    What can I do for further investigations?


    I can make a short record and upload the defect stream for someone to look into it, if you want.



    Thanks in advance for hints and tips!!!