Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

matthew

Anfänger

  • »matthew« ist der Autor dieses Themas

Beiträge: 7

Wohnort: Kaiserslautern

Beruf: Informatikstudent u. Systemadministrator

  • Nachricht senden

1

Freitag, 1. Dezember 2006, 11:35

vdr 1.4.4 / xineliboutput 1.0.0_pre6 friert kompletten Rechner ein

Hallo Leute.

Ich versuche gerade von MythTV auf vdr umzusteigen und bin von der Bedienung und dem Funktionsumfang von vdr begeistert, allerdings treibt mich ein Problem in den Wahnsinn, was sich auch nicht groß debuggen lässt.

Wenn ich vdr-sfxe oder xine-ui mit vdr benutze, kommt es beim Umschalten auf andere Kanäle (mehr oder minder) zu zufälligen Abstürzen des Systems... und das richtig. Selbst mit den Magic SysRq Keys lässt sich nur noch ein Neustart auslösen und fertig. (also keine dumps, auch kein per ssh remote drauf und mal schauen was los ist)

Ich konnte das Problem zumindest 100% reproduzierbar nachstellen:

1) vdr als Demon starten (mit xineliboutput) [läuft als vdr:vdr bzw.]
2) vdr-sxfe oder xine xvdr:// als irgendein user starten

Jetzt einfach mal ein kill -9 auf den jeweiligen Frotendprozess schicken und schon steht die Kiste still. Ich vermute, dass es sich hier um den selben Absturz handelt, wie den, den ich zufällig erlebe... anscheinend schmiert der Frontend wegen irgendwas ab und das Ergebnis dürfte das selbe sein.

Hat hierzu jemand irgendwelche Ideen?

Das System sieht übrigens wie folgt aus:

- OS: Gentoo ~amd64 (64 bit -hicks-)
- KNC ONE DVB-C Plus mit Cineview und Alphacrypt Light
- dvb frisch vom mercurial repository (linuxtv.org)
- 2.6.19rc6git10 (also nahezu mit 2.6.19-final identisch)
- xinelib 1.1.3_pre20061129
- vdr 1.4.4 mit folgenden USE flags: "bigpatch cmdsubmenu dolby-record-switch
dvbplayer jumpplay setup-plugin submenu subtitles -aio -child-protection -debug
-dxr3-audio-denoise -lnbsharing -noepg -rotor -sourcecaps -vanilla -yaepg"

Ich hab natürlich auch schon ältere Kernels und DVB Versionen probiert- ohne Veränderung. Ein HW Problem schliesse ich mittlerweile auch aus, da ich den Fehler mit keinem anderen Programm reproduzieren konnte und es zu sehr nach einem vdr/xineliboutput Problem aussieht.

[NACHTRAG]

Das Problem lässt sich übrigens auch nicht mit vdr alleine reproduzieren, d.h. wenn man vdr direkt mit xineliboutput startet und nicht als demon. Keine Abstürze beim Kanalwechsel o.ä.. Auch den vdr per kill -9 kicken führt zu keinen unerwünschten Nebeneffekten.

[/NACHTRAG]

Ich bin für -jegliche- Hilfe mehr als dankbar.

Viele Grüße,
matthias.

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »matthew« (1. Dezember 2006, 11:47)


2

Samstag, 2. Dezember 2006, 17:01

RE: vdr 1.4.4 / xineliboutput 1.0.0_pre6 friert kompletten Rechner ein

Habe aehnliche Effekte mit vdr 1.4.3. Ist mir aufgefallen, seit ich von xineliboutput 0.0.9rc5 auf 1.0.0pre6 und zugleich von xinelib1 1.1.3 Packman zurueck auf selbstcompilierte xine-lib-cvs-20060319194500 (ist eine 1.1.2) mit xinie-network-patch umgestiegen bin.

Ich kann daher nicht sagen, ob es an xinelib oder am xineliboutput liegt. Gemeinsam koennen wir den vdr als Schuldigen wohl ausschliessen.

mfg
CR
Wohnzimmer: VIA EPIA NL1000, LIRC, xineliboutput (vdr-sxfe), keine Tastatur oder Maus, nur TV-Geraet,
Keller: Quard-Core, 64bit, 2,6GHz, viele Platten, 2*Budget dvb-c (Terratec), VDR 1.6, HDTV-patch, div. Plugins
Verteilt: Div. andere Rechner, dazwischen 100Mbit Ethernet, Distri fuer alles: SuSE 11.0/11.1

3

Samstag, 2. Dezember 2006, 17:27

selbes problem hier mit vdr 1.4.4 xineliboutput unter ubuntu 6.10 Ich bin deswegen auf das xine plugin umgestiegen
Server:
Pentium D * 3 TB HDD * Ubuntu 6.06* VDR 1.4.7,2xSkystar2 in XEN DomU
Clients:
Compaq Deskpro EN umgebautes easyvdr via pxe boot
2 SMT 7020s umgebautes Zenslack

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »tuxinger« (2. Dezember 2006, 17:28)


matthew

Anfänger

  • »matthew« ist der Autor dieses Themas

Beiträge: 7

Wohnort: Kaiserslautern

Beruf: Informatikstudent u. Systemadministrator

  • Nachricht senden

4

Dienstag, 5. Dezember 2006, 21:06

Hallo.

Also, ich hab das Problem mal auf der VDR Mailingliste angesprochen und folgender Post dürfte wohl für jeden interessant sein, der von dem Problem betroffen ist. :-)

http://linuxtv.org/pipermail/vdr/2006-December/011361.html

Ich hab an die Mail einen Patch angehängt, der das Problem (zumindest bei mir) behebt. Leider nicht auf meinem Mist gewachsen, aber zumindest gefunden. :-)

Ich hoffe das hilft auch euch weiter...!

Viele Grüße,
matthias.

5

Mittwoch, 6. Dezember 2006, 00:13

Matthew,

danke fuer Deinen Hinweis. Er hat wirklich Fortschritte gebracht. Ich habe beide Patches ausprobiert, und der Server lauft problemlos.

Allein bei etwa jedem dritten Kanalwechsel schmiert der Client kommentarlos ab. Hast Du dazu einen aehnlich guten Tipp?

Ich glaube, ich warte einmal, bis eine Verson heraus kommt, wo kein pre mehr hinten steht, und geh dann auch gleich auf die aktuellste Version vom VDR, ausser es hat jemand eine gute Idee dazu.

mfg
CR
Wohnzimmer: VIA EPIA NL1000, LIRC, xineliboutput (vdr-sxfe), keine Tastatur oder Maus, nur TV-Geraet,
Keller: Quard-Core, 64bit, 2,6GHz, viele Platten, 2*Budget dvb-c (Terratec), VDR 1.6, HDTV-patch, div. Plugins
Verteilt: Div. andere Rechner, dazwischen 100Mbit Ethernet, Distri fuer alles: SuSE 11.0/11.1

Immortal Romance Spielautomat