Posts by Herb01

    Hallo Florian,


    ich hoffe, ich bekomme das noch alles zusammen:

    • das paket nvram-wakeup muß installiert werden
    • im Einstellungsmenü des VDRs nvram-wakup als Wakeup-Methode einstellen
    • die Datei /etc/vdr/vdr-nvram-wakeup.conf entsprechend anpassen. Ich habe meine angehängt. Insbesondere die Zeile SPECIALSHUTDOWN="grub-reboot halt ; reboot" ist entscheidend.
    • Der EasyVDR-Kernel wurde mit CONFIG_STRICT_DEVMEM=y kompiliert, so daß nvram-wakeup die Aufwachzeit nicht schreiben konnte. Ich habe daher einen neuen Kernel kompiliert, bei dem diese Option nicht gesetzt ist. Keine Ahnung, ob das auch anders geht, ich weiß es nicht besser. Ich habe damals die Version 4.4.70 genommen, das war damals der neueste 4.4er. Dieser Kernel muß installiert werden.
    • Bei meinem Board muß nach dem Schreiben der Aufwachzeit noch einmal gebootet und danach der Rechner ausgeschaltet werden. Das geht über entsprechende GRUB-Einstellungen. In der Datei /etc/default/grub muß die Option GRUB_DEFAULT=saved gesetzt sein. Die Datei /etc/grub.d/40_custom muß angepaßt werden Ich habe sie ebenfalls angehängt. Der Befehl update-grub erstellt die neue grub.cfg-Datei mit den Änderungen.

    Ich denke, das war alles und hoffe, daß es hilft.


    Viele Grüße

    Herbert

    Quote

    Nvram benutzt niemand sonst mehr...

    Doch ich :-) Und zwar mit EasVDR 3.0 32 Bit.Ich habe ein uraltes Board, bei dem mit ACPI-Wakeup nur die Urzeit berücksichtigt wird und der Rechner daher immer zur angegebenen Uhrzeit am nächsten Tag aufwacht (was ziemlich nervt). nvram-wakeup hingegen funktioniert, war aber ziemlich stressig, bis es lief. Aus dem Gedächtnis:

    • nvram-wakeup installieren und als Aufwach-Methode einstellen
    • script erstellen, das die Uhrzeit setzt
    • den notwendigen Reboot nach dem Setzen der Uhrzeit mit grub statt mit lilo hinbekommen
    • der Kernel hat jetzt ein Security-Feature aktiviert, das verhindern, daß nvram-wakeup die Uhrzeit setzen kann. Ich habe dann einen neuen Kernel kompiliert, der dieses Feature disabled.

    Details suche ich gerne raus, falls es noch jemand interessiert.


    Viele Grüße

    Herbert

    Kenne nur ext3, aber da bist Du völlig chancenlos. Das Verhältnis Bytes zu Inodes kann man beim Formatieren (und nur da) angeben. Daher kommst Du um die Prozedur Backup - Formatieren - Restore nicht herum. Wenn Du sehr viele kleine Dateien auf der Partition liegen hast, die Du nicht permanent im Zugriff haben mußt, könntest Du die noch mit tar oder zip oder ... in eine einzige große Datei packen und löschen.


    Viele Grüße
    Herbert

    keine Ahnung, ob das für Dich praktikabel ist. Aber Du könntest zum Beispiel ganze Verzeichnisse mit sehr vielen kleinen Dateien mit tar (o.ä.) in einer einzigen Datei ablegen und so wieder freie Inodes bekommen (wenn Du die Originale löschst).


    Viele Grüße
    Herbert

    Der VDR räumt in "seinem" Video-Verzeichnis auf und löscht dann die gelöschten Aufnahmen (die zuerst nur in .del umbenannt wurden) und die leeren Verzeichnisse. Ich lege in den Verzeichnissen, die nicht gelöscht werden sollen, immer eine leer Datei an, die das Löschen verhindert. Bei Dir wäre das daher so was wie touch /var/lib/video.00/film/.nicht_loeschen oder so.


    Gruß Herbert

    Quote

    Lt. Wiki macht die Karte das erst ab einer bestimmten Seriennummer.


    Genau. Es gibt alte und neue Modelle. Und erst die neuen liefern 5 Volt Versorungsspannung. Glaube, die hatten einen Aufkleber mit einem Hinweis auf der Platine. Und einen Jumper zum Abschalten gab es nicht.


    Gruß Herbert

    Hallo zusammen,


    habe auch gerade das vdradmin-am-Paket aus Tobis Repository upgedatet und das selbe Fehlverhalten wie FataMorgana gehabt. Die Fehlermeldung lautete:

    Code
    1. QUOTE] Can't locate Date.pm in @INC (@INC contains: /usr/bin/lib/ /usr/share/perl5/vdradmin-am /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl[/QUOTE]


    Ich habe manuell libwww-perl (apt-get install libwww-perl) nachinstalliert, dann funktionierte vdradmin-am wieder. Ist aber eher ein Problem von Tobis Paket bzw. dessen Abhängigkeiten?


    Gruß Herbert

    wir gesagt: mplay.sh spielt die von mir konvertierten Filme mit dem richtigen Aspekt-Verhältnis ab. Das ist der einzige Unterschied zum mplayer.sh-Script, den ich für mich wahrgenommen habe. Und noch ein Hinweis: damit für die mit den letzten mencoder-Versionen konvertierten Filme das Aspect-Verhältnis (wieder) richtig ausgelesen wird, muß im mplay.sh-Script der Parameter für die Option endpos von 0.1 auf 0.2 erhöht werden.


    Gruß Herbert

    mplay.sh hat 755. die conf-Dateien 644. VDR lasse ich mit root-rechten laufen. Was mir noch einfällt (halt schon ne Weile her, sorry): Ich habe in der mplayrc-Datei die Variable MPLAY_PLAY so gesetzt: MPLAY_PLAY="/tmp/mplay.play". Der Default hat nicht funktioniert.


    Gruß Herbert

    Quote

    wie schreibt man den aufruf rein?


    Stimmt, das war nicht einfach :-) Der gehört (bei mir) in die Datei plugin.mplayer.conf rein, die bei mir unter /etc/vdr/plugins steht. Sie sieht dann so aus:

    Code
    1. #
    2. # Command line parameters for vdr-plugin-mplayer
    3. #
    4. # For details see /usr/share/doc/vdr-plugin-mplayer/README and README.Debian
    5. #
    6. --mount /usr/share/vdr-plugin-mplayer/mount
    7. --mplayer=/usr/local/bin/mplay.sh


    Das spannende ist die letzte Zeile, die muß hinzugefügt werden. Wenn sie fehlt, wird das mplayer.sh-Script aufgerufen. Du mußt ggf. den Speicherort des mplay.sh-Scripts anpassen.


    Viele Grüße
    Herbert

    Quote

    muß die mplay.sh mit den konfigurationsdateien ins /tmp verzeichnis?


    Nein. Eher nach /usr/bin oder /usr/local/bin. Ist in der INSTALL-Datei beschrieben


    Quote

    muß ich die mplayersources.conf anpassen oder kann sie so bleiben wie sie ist


    Nein, bleibt so.


    Quote

    habe den ganzen thread nochmal durchgelesen und wird auch über asyncronitäten gesprochen.ist dies immer noch der fall?


    Hab ich nie gehabt und denke, dann würden die vom mplayer und nicht vom startenden Script verursacht.


    Quote

    wird das script nicht mehr weiterverbessert?


    Hier ist in der Tat lange nix passiert. Vielleicht liest Neverwise ja mit und sagt was dazu.


    Probiers doch einfach mal aus. Ist ratz fatz installiert und läuft parallel zum mplayer.sh-Script, wenn man nur die Zeile zum Aufrufen anpaßt.


    Gruß Herbert