Posts by berndb

    Na ja, "unter aller Sau" finde ich aber sehr hart.


    Bei mir kommt an:
    Software hier und da nicht rund. Da ein Debian unter der Haube ist, kann man da mit ein wenig Administratorwillen mit sehr übersichtlichen Aufwand bei der Konfiguration korrigierend eingreifen.
    Der Treiber, der die hevc/h264 Hardwareunterstützung aktivieren könnte, fehlt aber noch - und ist offenbar auch nicht in Sicht. Damit fehlt ein wesentliches Feature, dass das Board von anderen positiv abheben würde.


    Insofern finde ich die Empfehlung: Finger weg! zugespitzt, aber begründet.

    Unter Windows scheint die Software verantwortlich, ob bei dieser Karte Hardware PID Filter genommen werden oder nicht.
    Im Mediaportal-Forum wurde mir bestätigt, dass diese Software die Filter der Karte noch nicht nutzt - das wird erst in einer kommenden Version gehen.


    DVBViewer hat die Option "Ganzen Transponder öffnen". Setzt man sie nicht (!), werden bei der Skystar S2 die Hardware PID-Filter genutzt. So steht es jedenfalls hier . Und tatsächlich habe ich bei Setzen des Hakens in der Demo-Version von DVBViewer Pro genau die gleichen Empfangsprobleme wie unter Linux.


    Ist das nun ein fehlendes Feature im vdr oder ein Treiber-Fehler? Hat jemand eine Idee, wie ich das noch genauer einkesseln kann?

    Dank Grippe und Feiertage habe ich das Testen jetzt mal wiederholt:


    Windows:
    Deutlich besserer Emfpang, ich kann alle genannten kritischen ITVHD-Kanäle tunen.
    Linux:
    ITV HD tuned praktisch nie, bestenfalls STVHD oder UTVHD.


    Die schlecht-Wetter-Reserve scheint bei Windows größer. Bei Aufnahmen habe ich so alle 2-3 Aufnahmestunden einen Bildfehler/ fehlende Frames. Vielleicht häufiger bei ZDF-HD-Sendern, vielleicht weniger bei ARD-HD - schwer zu reproduzieren. Aber hier bin ich von meiner Technotrend oder Mystique SaTiX-S2 einen problemloseren Betrieb gewohnt. Wenn hier Aufnahmen sichtbare Fehler bei der Wiedergabe zeigen, dann hat es gestürmt oder eimerweise Wasser geregnet.


    Im DVBViewer Forum schrieb ein Moderator hierzu:

    Quote

    Denkbar ist auch, dass der DVBViewer unter Windows die Hardware PID Filter der SkyStar S2 verwendet (tut er standardmäßig), und Linux nicht. Der Transponder 11097 V auf Astra 28° Ost mit ITV HD liefert eine Bitrate von ca. 50 MBit/s. Das ist mehr, als die SkyStar S2 mit ihrer beschränkten Bandbreite via PCI durchreichen kann, und wenn dann nicht bereits hardwaremäßig die gewünschten Video/Audio-Streams herausgefiltert werden, gibt es Aussetzer durch Datenverluste.


    Kann ich das als Normsterblicher vdr-user feststellen/ oder gar einstellen? Oder ist das nicht Sache des Treibers:


    Code
    1. [bernd_b@amd64-archlinux ~]$ dmesg | grep flexcop
    2. [ 10.642282] b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital TV receiver chip loaded successfully
    3. [ 10.766776] flexcop-pci: will use the HW PID filter.

    Was ich gemacht habe:


    gleicher Rechner, also auch gleiches SAT-Kabel.


    Rechner gebootet, ITV Sender versucht zu tunen, Rechner aus, Platte getauscht, ITV Sender getuned.


    Könnte natürlich auch der zeitliche Versatz gewesen sein, eine Wolke mehr oder weniger kann ja auch entscheidend bei einem Signal auf der Kippe sein. Jedenfalls sehe ich im Falle des Scheiterns Bildmüll, z.B. das Bild des zuletzt eingestellten Senders mit grünen Overlay oder ähnlichen Driss. Abgestürzt ist der vdr dabei nicht.

    Ist Mauros neuer Treiber der im Kernel? So verstehe ich den Link.


    Also rausknallen tut der bei mir nicht bei schwachem Signal, aber die Grenze zum nicht-Empfang ist früher, als wenn ich die gleiche Karte unter Windows laufen lasse (vgl. oben).

    Hoffentlich machen sie es nicht wie bei DVB-T:
    Auf der einen Seite mit "digitalem" Bild werben, und dann die Transponder so mit Sendern vollknallen, dass die Bildqualität vor lauter Kötzchen schon auf jedem Röhrenfernseher jenseits der 40cm Diagonale weh tut. Dann ist die höhere Auflösung sogar kontraproduktiv.


    Und was bedeutet:

    Quote

    Sender und Elektronikhersteller haben sich für ein kartenloses Verschlüsselungssystem mit Chips entschieden

    So, konnte jetzt immerhin jeweils eine 32bit und eine 64bit Version von Kernel 3.18.29 erstellen.


    Auf der 32bit Maschine empfange ich nun wie unter Windows alle aufgeführten ITV-HD-Kanäle, auf der 64 bit Maschine immerhin alle außer den beiden auf 11.052 (oder 11.053?).


    Also scheint der Treiber nicht ganz unschuldig zu sein, wenn ich das Ergebnis auch nicht ganz schlüssig finde: Auf dem gleichen PC, auf dem mit Windows alle Kanäle gehen, klappt es mit dem aktuellem Kernel aus dem ARCH-REPO nur mit einem ITV-HD-Kanal - allerdings mit kleinen Bildstörungen-, mit dem gepatchten Kernel 3.18.29 dann mit fünf ITV-Kanälen, mit dem gleichen Kernel auf dem 32-bit-PC dann alle ...

    Von meinen beiden PIII hat leider zum Frühlingserwachen wohl endgültig den Geist aufgeben, zumindest kann ich das Ding nicht mehr auch nur zu einem Piep bewegen - Netzteil, CPU?
    Der andere tut es hoffentlich mit seinen 96MB als Aufnahmegerät noch eine Weile. Mit einem PII ging es auch, aber zeitgesteuertes Hochfahren ging nicht, daher musste er einem modernerem PIII weichen.


    Gerade kämpfe ich als Ersatz mit einem AMD-K7-Board, hoffentlich bald stabil. Ich fürchte, meine bisher verwendeten DDR-Speicher sind futsch oder das Bord gehörte doch schon länger auf den Recyclingfriedhof.


    Aufgenommen wird immer auf "hochmodernen" externen USB2-Festplatten, die an einer USB2-PCI-Card hängen.

    Heißt "angepasster Patch", dass Du den nochmal für neuere Kernel verändert hast? Hättest Du einen Link zu diesem Patch - ich denke, da ich diesen Test wohl auf einen 32bit-Rechner machen werde, dass ich einen Kernel zum Vergleich bauen werde(n muss).
    Wenn nicht nehme ich einfach den Patch aus dem Link oben und baue halt einen passenden 3.x-Kernel.

    Das bedeutet, die Karte kann alle Kanäle, wo im Kanalstring ein C34M5 drinsteht, nicht tunen


    Mit dem Frequenzdrifttrick kann wolfi.m aber offenbar FOXHD tunen, und da steht auch "C34M5" im Kanalstring.


    Ich habe jetzt noch mehr Zeit an die Karte verschwendet :rolleyes: ?( :rolleyes: und auf einer alten Platte Windows draufgeknallt und in meinen Rechner gehängt. Also gleiche Karte, gleicher Rechner, gleiches Kabel zur Sat-Schüssel.


    Mit ProgDVB einen Suchlauf gemacht und siehe da, er findet nicht nur diverse ITVHD Sender, der Empfang läuft offenbar problemos?!


    Hier die Daten, die ich aus ProgDVB abgeschrieben habe:

    Code
    1. Frequenz Pol Symbrate Modulation SID TID NID PMT PCR Video Teletext ECM
    2. Name 11.097.000 V 23.000 NBC_8PSI 21030 2066 2 261 2320 2320 2323 0
    3. ITV HD 11.097.000 V 23.000 NBC_8PSI 21000 2066 2 258 2305 2305 2308 0
    4. ITV HD 11.097.000 V 23.000 NBC_8PSI 21020 2066 2 260 2315 2315 2318 0
    5. ITV HD 11.053.000 H 23.000 NBC_8PSI 20740 2063 2 260 2330 2330 2333 0
    6. ITV HD Wales 11.053.000 H 23.000 NBC_8PSI 20730 2063 2 256 2320 2320 2323 0
    7. STV HD 11.068.000 V 23.000 NBC_8PSI 20800 2064 2 261 2305 2305 2308 0


    Ist was mit dem Treiber im Kernel nicht in Ornung? Würde es Eurer Meinung eine Chance geben, mit "Vorversionen" wie dieser hier andere Ergebnisse zu erzielen?

    So, nun auch mal alle Channels von Hepi durchprobiert:


    Mit meiner Technotrend TT 1600 habe ich bei allen Kanälen Empfang, mit der Skystar S2 gibt es immerhin beim letzten ("STV HD") ein Bild. So ganz ohne Klötzchen scheint mir es auch hier nicht zu gehen, der Ton ist aber soweit sauber.


    Sieht für mich immer noch so aus, als sei die Skystar doch etwas wählerischer, was das SAT-Signal betrifft. Ich mach nochmal eine Probeaufnahme, um auszuschließen, das xineliboutput die Klötzchenquelle ist.

    Wie läuft die Karte denn auf Astra 19.2E?


    Also auf Astra hatte ich bisher keine Probleme.

    ...funktionieren bei mir, RTL als z.B. nicht


    Gerade mal auf RTL geschaltet - Bild sofort da.


    Auf Amazon hat jemand in einem Kommentar geschrieben, dass die Karte manchmal nach dem Booten nicht sofort erkannt wird. Dann hilft nur ein Reboot und hoffen, dass es diesmal klappt.


    Ich hatte das heute auch schon zum dritten Mal. Dmesg zeigt:


    Statt zu rebooten habe ich mal vesucht, alle Treibe zu entladen. Das beste, was mir bisher einfiel war:

    Code
    1. modprobe -r -a cx24120 b2c2_flexcop_pci b2c2_flexcop cx24123 stv0299 lgdt330x b2c2_flexcop dvb_core
    2. [modprobe -a cx24120 b2c2_flexcop_pci b2c2_flexcop cx24123 stv0299 lgdt330x b2c2_flexcop dvb_core


    Das soll der Versuch sein, alle Treiber, die irgendwie was mit der Karte zu tun hat zu entfernen und wieder zu laden.


    Tatsächlich meldet dmesg:


    "CX24123: wrong demod revision: e9" und

    Code
    1. nxt200x: nxt200x_readbytes: i2c read error (addr 0x0a, err == -121)
    2. [ 243.427775] nxt200x: Unknown/Unsupported NXT chip: 00 00 00 00 00


    klingen nun in meine unwissenden Ohren nicht so dolle. Aber immerhin ist so ohne Reboot Bild und Ton da. Wenn das so zuverlässig klappt, wäre das ja ein work around für zeitgesteuert hochfahrende Systeme ...

    Gut,


    die gleiche Ausgabe wie bei wolfi.m erhalte ich mit:

    Code
    1. dmesg | grep flex
    2. [ 8.933808] b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital TV receiver chip loaded successfully
    3. [ 9.035092] flexcop-pci: will use the HW PID filter.
    4. [ 9.035100] flexcop-pci: card revision 2
    5. [ 9.048657] b2c2-flexcop: MAC address = 00:08:c9:e0:bc:d1
    6. [ 9.710606] b2c2-flexcop: ISL6421 successfully attached.
    7. [ 9.710613] b2c2-flexcop: found 'Conexant CX24120/CX24118' .
    8. [ 9.710621] b2c2_flexcop_pci 0000:03:06.0: DVB: registering adapter 0 frontend 0 (Conexant CX24120/CX24118)...
    9. [ 9.711729] b2c2-flexcop: initialization of 'Sky2PC/SkyStar S2 DVB-S/S2 rev 3.3' at the 'PCI' bus controlled by a 'FlexCopIIb' complete


    Also bei lspci heißt sie Skystar2, was blöd ist, weil es die gleiche Bezeichnung ist, die auch die DVB-S Variante trägt. Beim booten meldet der Kernel offenbar den Namen Skystar S2. Ich ändere das mal in der Thread-Überschrift.


    Hier mal das komplette lspci von dem PC, in dem ich das Ding im Moment drin habe. Die alte DVB-S Technisat liegt neben mir auf dem Tisch.

    Die SD-Variante habe ich in meinem Initialpost erwähnt. Das die PRO7-Sat.1 Gruppe ihre SD-Programme nicht mehr in DVB-S, sondern DVB-S2 sendet, ist mir neu .... Gerade mal reingetuned - mein VDR sagt, die sind DVB-S. Das ist also wohl nicht der Grund für meine Empfangsprobleme mit meiner alten(!) DVB-S-Technisat-Karte bei diesen Sendern.


    Die beiden Links in meinem Post verweisen auf eine DVB-S2-Karte. Das erklärt, warum ich mit Ihr ARD, arte und ZDF usf. in HD empfange.


    Ja, die Engländer senden auch mit DVB-S2, deshalb empfange ich mit der Karte ja auch BBC und Channel 4 in HD. Nur (!) bei ITV HD klemmt es bei mir.

    Wenn man für sein älteres Bord eine PCI-Karte für DVB-S2 sucht, ist man im Moment schnell rund 50 Euro los - auch wenn man "nur" Free to air haben will-


    Die Technisat SkyStar2 bekommt man zur Zeit so billig, dass ich mich mal zugeschlagen habe und Warentester spiele. Skepsis herrscht vor, ich habe eine alte Technisat DVB-S Karte, die jetzt kein SAT.1, Pro7 & Co mehr schafft ... (nennt sich leider auch Skystar 2 // Rev 2.6D)


    Bei mir meldet sich die Karte mit

    Code
    1. 03:06.0 Network controller: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card (rev 02)


    und wie hier (easy-vdr-wiki) und hier (linuxtv.org) beschrieben, läuft die Karte mit aktuellem Kernel tatsächlich out of the box - wenn man davon absieht, dass man noch eine Firmware runterladen muss (vgl. genannte Links).


    Meine ersten Erfahrungen:
    Dort, wo das Signal stimmt, klappt alles bisher wie gewünscht. Wenn der Empfang dünn wird (meine Schüssel versucht sich an den UK-Sendern auf 28.2E), kommt die erste Ernüchterung bei mir:
    Sowohl mein Fernseher als auch eine schon Jahre im Betrieb befindliche TT-1600 schaffen ITVHD, die Skystar liefert am gleichen Kabel und gleichem PC bestenfalls grüne Kästchen und Gepiepse. Komisch finde ich, dass die anderen FTA-HD Sender (BBC, Channel 4) empfangen werden, auch wenn das Tuning etwas länger braucht.


    Soweit meine ersten Eindrücke. Wie gesagt, vielleicht gibt es ja hier noch andere mit dieser Karte und oder Tipps und Tricks?

    [

    Man könnte auch noch eval, grep und cut loswerden und das ganze abkürzen:

    Code
    1. Time_to_next_record=$("${prefix}/svdrpsend" NEXT rel | sed -ne 's/^250.*\ \([[:digit:]]\+\).*$/\1/p')


    O.K., ich gestehe: Ich mag ich es lieber lesbarer. Bei all den eleganten |&%##' Konstruktionen weiß ich sonst als "alle Jahre wieder"-Skripter fünf Minuten später überhaupt nicht mehr, was da passieren könnte.


    Ich hatte selbst schon versucht, mit

    Code
    1. tr -d 'r'

    den Output zu "säubern", aber das bleibt wirkungslos bei mir. Also merci bien für den sed-Befehl.