Beiträge von clausmuus

    Ne, das war nen Kopierfehler. Hab's ober korrigiert.


    Ich hab aber inzwischen herausgefunden wo der Haken war. Es muss als Quelle der Sourcen nicht der Ordner des VDR sonder der des Plugins angegeben werden. Und obendrein ist ein anzeigen der Sourcen erst möglich, nachdem der VDR das Plugin geladen hat.

    Code
    1. gdb --directory=/usr/src/vdr/PLUGINS/src/softhddevice

    Hi,

    Danke schon mal für die Antwort. Da ich den gdb zur Laufzeit des VDR attache, listet mit info sharedlibrary auch das Plugin mit auf.

    Aber z.B. ein "list" findet die Sourcen nicht:

    Code
    1. (gdb) list /usr/src/vdr/PLUGINS/src/softhddevice/softhddevice.cpp:0
    2. No source file named /usr/src/vdr/PLUGINS/src/softhddevice/softhddevice.cpp.

    Bei einer VDR Source hingegen geht das:

    Vorhanden sind die Plugin Sourcen am genannten Ort:

    Code
    1. $> ls /usr/src/vdr/PLUGINS/src/softhddevice/V.cpp
    2. /usr/src/vdr/PLUGINS/src/softhddevice/softhddevice.cpp

    Wie erkläre ich jetzt also dem gdb, dass die Plugin Sourcen mit dazu gehören und er die verwenden soll?

    Hi,

    Kann mir jemand erklären, wie ich mit dem gdb VDR Plugins debuggen kann?

    Den VDR Selber mit dem gdb zu untersuchen ist kein Problem. Bei den Plugins weiß ich allerdings nicht wie das geht. Wenn ich z.B. den VDR starte und anschließend den gdb unter Angabe des Verzeichnisses der VDR Sourcen da drauf schalte, kann ich im VDR selbst Brakepoints setzen und mir im gdb die VDr Sourcen anzeigen lasen. Für die Plugins geht das jedoch nicht. Der gdb scheint von den Plugins nichts zu wissen. Wie kann ich ihm diese bekannt machen?


    Claus

    kls ,

    ja, Deine Annahmen sind richtig. Es hat sich lediglich die HDD Hardware für die Daten geändert. Alles andere ist identisch wie vorher. Und ich gehe auch einfach mal davon aus, dass die neue doppelt so große Platte nicht langsamer als die alte ist, sondern höchstens schneller. Ich habe also bisher keine Idee, wieso das öffnen des Aufnahme Menüs jetzt spürbar länger dauert.

    Hi,

    ich habe auch ein "ähnliches" Problem. Seitdem ich (beim VDR 2.2) mein 6TB Video Laufwerk gegen ein 12TB Laufwerk ersetzt habe, dauert das öffnen des Aufnahme Verzeichnisses einige Sekunden (beim ersten öffnen des Aufnahme Menüs am Tag). Vorher ging das sofort auf. Die Aufnahmen habe ich nur auf die neue Platte kopiert. Die Platte ist auch nicht im Schlaf Modus, da das Problem auch auftritt wenn gerade eine Aufnahme läuft. Allerdings verwende ich das extrecmenu Plugin.

    Ich weiß nicht ob das eine ähnlich Ursache hat und wollte das nur zum Erweitern der "Datenbasis" kundtun.


    Grundsätzlich würde ich mir wünschen, dass im Fall einer langsamen HDD (falls das die Ursache ist) , das Menü sofort aufgeht und eine "Bitte warten" anzeige erscheint bis die Daten bereitstehen. Aber wie gesagt, bis zu meinem HDD Tausch kannte ich so eine verzögerte Reaktion überhaupt nicht und hab auch noch keine Ursachenforschung betrieben, da bisher immer nur meine Frau betroffen war :)

    Hi,


    kannst Du mir mal die Ausgabe von ldd für das softhddevice geben?

    Ich versuche derzeit das Plugin unter Debian buster zu kompilieren. Compilieren lässt es sich auch, nur nen Bild bekomme ich nicht, nur Ton. Fehlermeldungen gibt's keine...

    Beim vaapidevice ist's umgekehrt. da habe ich Bild aber keinen Ton ;(

    Mit dem mpv Player gibt's Bild und Ton.

    Und das softhddevice von jojo61 funktioniert auch so wie von Dir beschrieben: HD geht, SD hüpft...

    Für mich klingt das danach, dass im wesentlichen zwei aktive User administrativen Zugriff auf den Forum Server bekommen müssen, um in solchen Fällen wie den aktuellen, aktiv werden zu können. Zwei ist wichtig, damit eine Vertretung vorhanden ist.

    Und wenn man noch weiter geht, wäre es sehr sinnvoll, dass auch mindestens eine zweite Person als Kontakt für den Hoster eingetragen ist und auch Zugriff auf die Backups hat. Nicht dass es dem VDR Portal irgendwann so wie der MLD Webseite geht, und Webserver und Hoster-Kontakt (gesundheitsbedingt) gleichzeitig ausfallen und wochenlang niemand aktiv werden kann. Glücklicherweise konnte ich wenigstens die DNS Einträge ändern.

    Bei der MLD wird kaum auf das root filesystem geschrieben. Logfiles landen per Voreinstellung in der RAM-Disk, und der Cache und die Daten auf dem Datenlaufwerk. Wenn Du die NAS für alle Daten verwendest, dann also auch die epg Daten usw. Lediglich bei der Verwendung von kodi wird noch in's root Filesystem geschrieben, wenn man da nicht und anlegt und das umlenkt.


    Claus

    Nach dem Mount des NFS Shares must Du das auch noch dem Datenspeicher hinzufügen. Das geht auch über das Webif im Selben Bereich in dem Du auch den NFS Mount durchgeführt hast.

    Sofern Du das schon gemacht hast, musst Du beachten, dass die MLD die TV Aufnahmen im Unterordner tv (/data/tv) erwartet.

    Erstelle mal ein Debuglog.

    Seitdem ich meine 6TB Daten Festplatte durch ein 12TB Laufwerk ersetzt habe, ist das erste Aufrufen des Aufnahmen Menüs (nach einem VDR neustart), um einige Sekunden verzögert. Das ist auch der Fall wenn der VDR bereits einige Stunden läuft.

    Hat jemand eine Idee was der Auslöser sein könnte?

    Soweit ich das bisher verstanden habe, wird das Verzeichnis nur beim VDR Start einmalig eingelesen. Ein langsames Laufwerk dürfte also nicht schuld da dran sein. Mal abgesehen davon, dass ich davon ausgehe, das die neue HDD schneller ist als die alte. Und es liegt auch nicht da dran, dass sich diese im Ruhemodus befindet, denn der Fehler tritt auch auf, wenn gerade eine Aufnahme läuft. Und auch die Anzahl der Aufnahmen hat sich bisher nicht relevant geändert. Auch sonst habe ich nichts am System geändert, nur das Datenlaufwerk habe ich getauscht.


    Claus

    Ne, leider nicht. Dafür müsste die Fritzbox so plaziert werden, dass ich nicht mehr im ganzen Haus WLAN hätte.

    Ich hab nur eine nicht mehr benötigte zweite Fritzbox entfernt und den Satip Server vom Wohnzimmer ins Arbeitszimmer verbannt.

    Hi,


    in der README zum vaapidevice Plugin steht als Voraussetzung die ffmpeg Version 3.2. Damit lässt sich das Plugin aber nicht kompilieren, da die libav Eigenschaft hw_device_ctx verwendet wird, und diese erst ab der Version 3.3 existiert. Die README müsste also mal angepasst werden.


    Da ich Debian verwende, und hier in der stable Version lediglich die Version 3.2 zur Verfügung steht, würde ich gerne wissen, ob mir jemand sagen kann, ob auf das hw_device_ctx verzichtet werden kann, und ob jemand einen Patch dafür hat, bzw. mal schauen kann, ob sich die Abhängigkeit leicht entfernen lässt?


    Claus