Posts by schitthoch2

    Wird sie denn von Alsa unterstützt?
    Ja, eigentlich immer seit kernel 2.6
    Was sagt lspci usw?

    lspci -vv

    Hallo zusammen


    Ich habe eine GT520 über HDMI an meinem TV angeschlossen. Zusätzlich dazu habe ich aber noch eine Creative Labs SB Live! (PCI) eingebaut.
    Den Ton möchte ich über letztere über Analog-Stereo an meinen alten Verstärker ausgeben (Chinch). Doch dort ist es still.


    pulseaudio zeigt mir leider nur die GT520 HDMI an, die analoge Karte wird nicht angezeigt. Kann mir jemand helfen mit dieser Konfig?


    Noch lieber wäre mir eigentlich wenn ich den Ton über beide Ausgabedevices ausgeben könnte ...


    aplay -l


    aplay -L

    schitthoch2 thanks
    [..]
    With a rough wall meter (Belkin) I observed about 4W increase in idle and video playback power. During normal TV playback the CPUs really spent most of the time deeper sleep states and only 1-2% in C0.

    pantzu : Credits should go to Seahawk1986, as he pointed towards the kernel energy saving options. Thank you Seahawk1986 :prost2
    Thank you pantzu for measuring power consumption with these parameters. I feared a lot more consumption and heat dissipation, but had no measuring device at hand.

    pantzu
    Can you add the following GRUB parameters to your grub.cfg and report back here?


    intel_idle.max_cstate=0 processor.max_cstate=0 idle=halt


    Should look about like this (all on one line):
    linux /boot/vmlinuz-3.13.0-77-generic root=UUID=xxxx ro vmalloc=256m quiet splash noresume nohz=off acpi_enforce_resources=lax $vt_handoff intel_idle.max_cstate=0 processor.max_cstate=0 idle=halt


    you can use the tool i7z in console to see that the processor is only going into C1E state, instead of C3 or C6. So power consumption should be higher but my playback picture is finally ok.SOURCE

    Hilft es vielleicht die Kerne daran zu hindern die tieferen Energiesparmodi zu nutzen?


    ja, jedoch scheitere ich an einer praktikablen Implementierung:
    Tests mit:

    • Grub Zusatz "processor.max_cstates=1 idle=poll" führt zu gutem Bild
    • Grub Zusatz "processor.max_cstates=0" bringt keine Besserung


    Ersteres ist AFAIK zu energiehungrig für den täglichen Einsatz und bei Zweiterem fehlt gemäss deinem Link irgendein script o.ä, welches eine Datei offen hält. Dort verstehe ich nicht, was zu tun ist.

    Dear pantzu:
    I have the same DVB-card(s).
    One is the Terratec 1200 and the other is the brandlabeled Mystique Cabix (same HW). With both cards I had the same problems with different recent systems on the same hardware (yaVDR 0.6, Archlinux with MythTV).


    Reducing the Active Processor Cores to 1 solved it (reduced the blocking artefacts) to an extend that I can happily watch TV with it again.


    Of course i'd rather would like to use all 4 cores available, so I would be interested if you have found a better solution yet.


    I did not have the problem using yaVDR 0.5


    See here, my thread for cross-reference

    Aaaalso, nach stundenlanger Internetrecherche und pröbeln, pröbeln, pröbeln habe ich einen Workaround gefunden.


    Ich habe für meine CPU i7 870 im BIOS (Motherboard siehe Signatur) die
    Active Processor Cores auf 1 (anstelle 2 bzw. "all") gesetzt.


    Resultat: Keine Artefakte mehr, auf diversen Setups (MythTV auf ArchLinux, yaVDR 6, ...) wo es vorher Artefakte gab.
    yaVDR 5 war von diesem Problem aber nicht betroffen, weshalb ich aktuelle Kernelversionen als Ursache vermute.


    Da ich gerne 4 cores benutzen würde, suche ich aber immer noch einer Lösung anstelle dieses Workarounds.


    Bin um alle Tipps dankbar.

    Hi. Also anbei die Infos:
    EDIT: EDID sieht interessant aus ...


    /var/lib/yavdrdb.hdf


    WebFE Screenshot
    [Blocked Image: http://i66.tinypic.com/ek2f84.png]

    Hallo Hoheit :D
    Ich sollte dazu noch sagen, dass ich nach der Installation nur die Konsole mit Login sah (mit der GT520). Ich vermute den nvidia Treiber bzw. VDPAU mit diesem als Ursache.
    Annei die geforderte Datei /etc/X11/xorg.conf.yavdr

    Hallo zusammen


    Nachdem nun unter 0.5a alles gut läuft habe ich auf einer weiteren Partition parallel dazu yaVDR 0.6 installiert.
    Resultat: Die Wiedergabe ist bei sehr gutem Signal ganz schlecht. Ich sehe nur Klötzchen.


    Nach einem Reboot zu yaVDR 0.5a schalte ich auf denselben Kanal: Perfekte Bildwiedergabe.


    Im syslog auf 0.6 erhalte ich ganz viele Fehlermeldungen:


    Im WebFE habe ich 50Hz für den Sony TV ausgewählt, jedoch zeigt xrandr -q immer 60Hz


    Hat irgendwer eine Ahnung an was dies liegen könnte? Ich habe beide Installationen 0.5a und 0.6 hier und kann zwischen beiden hin- und herbooten, falls euch das was hilft.


    Gebt einfach Bescheid, welche Logs/Settings ihr wissen möchtet.

    Hab eich installiert. Ausserdem auf nvidia-331 upgraded. Sehr viele Artefakte, jedoch habe ich nun folgende Fehlermeldungen im syslog

    Code
    1. Jun 28 11:34:19 TVBOX vdr: video/vdpau: can't block queue: The display was pre-empted, or a fatal error occurred.
    2. Jun 28 11:34:19 TVBOX vdr: video/vdpau: can't render mixer: An invalid handle value was provided.
    3. Jun 28 11:34:19 TVBOX vdr: video/vdpau: can't queue display: An invalid handle value was provided.

    Also erst mal noch ein paar Feststellungen:
    Boote ich den Kernel linux--3.2.0-41-generic ist die Wiedergabe auch mit einem upgedatetem System perfekt
    Boote ich den Kernel linux--3.2.0-86-generic habe ich endlos Artefakte.


    Videotreiber: nvidia-304
    Paket »ffmpeg« ist nicht installiert und es ist keine Info verfügbar.
    xserver-xorg-core Version: 2:1.11.4-0ubuntu10.17


    Auszug aus dem Syslog von 86er Kernel