Posts by Hollywood

    Ich habe den VDR ca. 15 Jahre ausschließlich benutzt. Gerade die Geschichte mit den Ausgabeplugins, in unsinniger Vielfalt und größtenteils ungepflegt, und meiner damit nicht kompatibler (performanter) Hardware, obwohl vor einem Jahr für UHD erst angeschafft, hat mich vor 2-3 Wochen dazu bewogen eine VU+ anzuschaffen. Vor 15 Jahren waren Festplattenreceiver arschteuer und mit den Funktionen des VDR nicht ansatzweise zu vergleichen. Die Linux-Receiver haben da aber deutlich auf, wenn nicht sogar überholt, und bieten auch für bastelfreudige wie mich noch genug Möglichkeiten. Im Moment vermisse ich da für meine Bedürfnisse nix und es läuft einfach, wie ich finde, flüssiger und moderner.


    Der VDR lief seitdem nurnoch ein- zweimal um die vorhandenen Aufzeichnungen auf die VU+ zu übertragen. ;(

    Hi Ulrich,


    spar dir die Arbeit, ich habe das gleiche Board und hatte große Hoffnung dass es hierfür nun bald was aktuellen gibt. Die Grafikeinheit UHD600 ist für dieses Plugin nicht geeignet, wie du einige Beiträge zuvor lesen kannst.


    Nimm die hier angesprochene Version vom vaapidevice oder das erwähnte softhddevice.

    Tja, dann war's das wohl mit der Hoffnung auf ein gepflegtes Ausgabeplugin mit OpenGL-Unterstützung für vaapi und die kleinen IGP´s. ;(


    Das es generell funktioniert zeigt ja Kodi und das von mir genannte vaapidevice. Auch das von 9000H erwähnte softhddevice hatte ich bei mir schonmal getestet, das läuft bei mir auch in der aktuellen Git-Version, allerdings mit Einschränkungen im UHD-Bereich. Nur tut sich ja bei den ganzen vaapi´s und softhddevices hinsichtlich Weiterentwicklung nicht mehr wirklich viel.


    Ich habe die letzten Wochen schon immer mal wieder Richtung VU+ und Enigma2 geschielt. Die Kisten sind ja mit meinen im Schrank verstaubten DBox2´en schon ewig nicht mehr zu vergleichen und können schon länger auch das, wofür ich mir meinen ersten VDR vor ca. 15 Jahen angeschafft habe. Mal sehen wo meine nächste Reise dann hingeht.


    Schade ...... , aber trotzdem vielen Dank für deine Bemühungen, einen Versuch war es ja Wert ! :thumbup:

    Ja, die Scalereinstellungen hatte ich mal nach deiner Empfehlung vorgenommen.


    Komisch ist, ich komme nicht mehr ins OSD um dort Einstellungen vorzunehmen. Jetzt beim tippseln öffnet es sich gerade, obwohl ich vor gefühlt 1 Minute die Taste auf der Fernbedienung gedrückt habe.


    Ich habe dann aber die Parameter direkt in der Setup.conf von 17 auf 2 geändert (natürlich bei gestopptem VDR ;)), das bringt aber auch keinen Unterschied außer, dass die Logmeldungen jetzt schneller über meine Konsole laufen. Auch die Auslastung der GPU ist weiterhin bei 100%.


    Hier das Log dazu.

    Das sind meine Einstellungen

    Neue Log


    Und intel_gpu_top mit deinem Plugin, die vorherige Ausgabe war, wie gesagt, vom vaapidevice. Wieder ARD-HD, allerdings ändert sich bei SD und UHD diesmal nix, immer 100% Auslastung.

    Ich habe mir mal intel_gpu_top installiert, keine Ahnung ob du mit der Ausgabe etwas anfangen kannst oder ob diese hilfreich ist. Das ist bei der Wiedergabe von ARD-HD, bei SD ist sie ähnlich und bei UHD ist die Auslastung geringer. Getestet allerdings mit vaapidevice !!!

    Oh grosses Sorry, da habe ich nach dem compileren doch ein make install vergessen und dir ein Log von der gestrigen Version auch noch ohne Erhöhung des Swapbuffers gegeben. Allerdings lediglich mit epg2vdr ohne die restlichen Plugins somit wissen wir, dass diese keinen Einfluß auf das Problem haben. :O


    Hier nun das richtige Log mit der Datei von vorhin.

    Ich bin gerade nochmal bei den Kernelparametern die seahawk1986 angesprochen hatte.


    i915.enable_guc_loading=1 i915.enable_guc_submission=1 i915.enable_huc=1


    mal abgesehen davon das die Parameter jetzt anders heissen funktioniert GUC bei mir aber nicht. Wenn ich das über die Kernelparameter aktivieren will bekomme ich Logmeldungen das die Firmware nicht geladen werden konnte.


    Code
    1. [ 2.038007] [drm] Finished loading DMC firmware i915/glk_dmc_ver1_04.bin (v1.4)
    2. [ 3.190444] i915 0000:00:02.0: GuC: No firmware was defined for GEMINILAKE!
    3. [ 3.190472] i915 0000:00:02.0: HuC: No firmware was defined for GEMINILAKE!


    Die habe ich aber runtergeladen ins Verzeichnis /lib/firmware/i915 entpackt, initrd neu erstellen und grub-update laufen lassen.


    Ich habe nun bei der Recherche gelesen, dass das mit GeminiLake noch nicht funktioniert. Wird denn überhaupt etwas was GUC bereitstellt für dein Plugin benutzt, hat das was mit meinem Problem zu tun oder kann ich das erstmal vernachlässigen ?



    Zwischen 20.02.18 und Anfang März gab es im vaapidevice so viele Umbaumaßnahmen, dass es schwer werden wird herauszufinden, ob und welcher einzelne commit die Ursache ist.

    Ja die Änderungen scheinen mir auch recht umfangreich, mich wunderte das jojo61 in dem anderen Thread sagte, dass dort nur etwas am Buffermanagement gebastelt wurde und die Änderungen keinen Einfluß auf die Dekodierung haben. Ich hatte Hoffnung das er vielleicht anhand der Commits sehen könnte in welchem Bereich es hakt, aber vielleicht haben wir da irgendwie aneinander vorbei geredet.

    Bei mir gibt es direkt nach dem Start gleich ein korrekt positioniertes OSD. Hast du Xorg auf UHD oder HD eingestellt ?


    Die Skalierung muss ich auf Fast oder Normal stellen, sonst wird es asynchron und die komplette Bedienung des VDR um einiges zäher. Deinterlacer habe ich auf Motion Adaptive eingestellt.

    Code
    1. ii mesa-va-drivers:amd64 19.0.8-0ubuntu0~19.04.1 amd64 Mesa VA-API video acceleration drivers
    2. ii mesa-vdpau-drivers:amd64 19.0.8-0ubuntu0~19.04.1 amd64 Mesa VDPAU video acceleration drivers
    3. ii mesa-vulkan-drivers:amd64 19.0.8-0ubuntu0~19.04.1 amd64 Mesa Vulkan graphics drivers


    Was auf meiner Seite aber gegen deine Vermutung spricht ist die Tatsache, dass das Problem seit ca. 1 Jahr bei mir besteht. Unter Debian 8 und Ubuntu 18.04 und jetzt unter Ubuntu 19.04 ist das von mir beschriebene Verhalten identisch.