Posts by dad401

    Nochmal zu meiner Frage - es muss doch hier jemand geben, der mir kurz etwas genauer sagen kann, was burn-buffers macht.


    Man müsste doch (fast) nur diese Zeile in vdrburn-dvd.sh durch ProjectX ersetzen...


    Code
    1. vdrsync.pl -o $MPEG_PATH \
    2. -v-filter "$REQUANTCMD burn-buffers" \
    3. -a-filter "burn-buffers" \
    4. -ac3-filter "burn-buffers" \
    5. $IGNORE "$RECORDING_PATH"


    Die Ausgabe der Video/Audio-Daten wird nach burn-buffers umgelenkt. Ist es etwa dazu da, um die Progessbar des Burn-Plugins upzudaten?!


    Übrigens funktioniert vdrsync manchmal auch mit AC3, aber leider eben nicht bei allen Filmen :(

    Bin auch gerade am Testen des (neuen) burn-Plugins...


    Bis auf AC3/vdrsync Probleme funktioniert es hier schonmal ganz gut :)


    Ich hab aber mal eine Frage: Wofür ist eigentlich burn-buffers gut?


    Könnte man nicht den den Demux von ProjectX machen lassen (wegen AC3 etc.)? - ich würde das gern testen, jedoch weiss ich noch nicht so recht, wofür der Pipe zu burn-buffers genau ist...


    Gruss
    Marcus

    Hallo,


    kürzlich bin ich auf das Plugin DigiCam aufmerksam geworden, mit welchen man auch auf Digitalkameras zugreifen kann, welche nicht als USB-Massenspeicher angesprochen werden können (das ganze funktioniert per gphoto2).


    Mit dem Plugin konnte man jedoch "nur" Dateien von der Kamera kopieren und dann erst ansehen, so dass ich mich im Netz noch ein wenig auf die Suche gemacht habe.
    Gefunden habe ich einen virtuellen Dateisystemtreiber, über welchen man die Kamera nun ganz normal mounten kann und danach z.B. mit dem Image-Plugin die Bilder direkt von der Kamera aus ansehen kann :).


    Hier mal eine kleine Anleitung - falls Interesse besteht, kann es auch in´s
    Wiki...


    Für die Digitalkamerabibliothek libgphoto2 gibt es einen virtuellen Dateisystemtreiber, welcher FUSE benutzt um über libgphoto2 auf die Kamera zuzugreifen. Mit der aktuellsten libgphoto2 konnte ich den Treiber leider nicht zum Laufen bringen und auch sonst ist das ganze noch nicht ganz stabil, aber mit folgender Konfiguration läuft es bei mir - zumindest das Bilder anschauen geht recht stabil (AVI´s von der Kamera über den MPlayer klappte noch nicht so richtig).


    System: Debian Sarge 3.1r0a
    Kernel: 2.6.14.2 (USB-Unterstützung muss vorhanden sein!)


    Da wie gesagt das neueste (lib)gphoto2 nicht mit dem Treiber lief, habe ich per APT ältere Versionen (2.1.5-6) installiert:


    apt-get install gphoto2 libgphoto2-2 libgphoto2-2-dev libgphoto2-port


    Hier kann man mit gphoto2 überhaupt erst einmal testen, ob man auf die Kamera zugreifen kann.


    Weiterhin wird FUSE benötigt - dieses habe ich als Source selbst installiert (Version 2.5.3) - hierbei sind die Kernelquellen notwendig, da ein Kernelmodul neu gebaut werden muss.


    Nun der eigentliche Treiber: gphotofs (Version 0.2 - man sollte also nicht zuviel erwarten ^^). Dieser kompiliert mit der "alten" libgphoto2 (2.1.5-6) aber nicht richtig, so dass man ein paar (in der alten lib noch nicht vorhandene) defines auskommentieren muss:


    Nun kann man die Kamera "mounten":


    gphotofs <mountpoint>


    Das ganze geht auch per fstab (siehe FAQ im FUSE-Verzeichnis).


    Hier nochmal alle verwendeten Tools und Links
    (interessant wäre zu sehen, ob es jemand mit den neueren gphoto2-Bibliotheken
    zum Laufen bekommt):



    Statt gphotofs gibt es auch ein Perl-Skript (siehe Links), welches bei mir aber nicht ganz so gut wie gphotofs lief...


    Links:
    erste Ansätze
    fusegphoto2
    gphotofs


    Gruss
    Marcus

    Evtl. liegt´s ja auch an einem Kabel/Gerät von der Quelle (Kabel defekt, LNB Problem, etc.) und nicht an der Karte selbst (auch wenn 18V vorhanden sind)...


    Ich würde erstmal einen anderen Receiver an das gleiche Kabel hängen - an der Karte kann man dann immer noch basteln ;)

    Hallo,


    mir ist kürzlich bei der Programmierung einer Aufnahme folgendes aufgefallen:


    Aufruf der Programmliste, z.B.:


    10:00 Sendung 1
    11:00 Sendung 2


    Ich wähle Sendung 1 aus und drücke ok, so dass ich den EPG von Sendung 1 sehe.
    Nun kann man ja mit rechts/links die Infos zur nächsten/vorhergehenden Sendung
    sich anzeigen lassen. Wenn ich nun nach rechts drücke, die Infos der Sendung 2
    sehe und dann auf rot (um diese aufzunehmen), wird jedoch statt Sendung 2 die
    Sendung 1 in die Timerliste eingefügt.


    Kann das jemand nachvollziehen, oder ist das evtl. schon in einer höheren
    VDR-Version (siehe Nummer 1 in der Signatur) behoben?

    Es wird Euch nicht wirklich helfen, aber ich hab mir das Plugin (und den VDR) inzwischen selbst kompiliert und habe das Problem somit nicht mehr.


    k.A. woran das damals lag - aber gernervt hat es mich auch.


    Viel Erfolg noch bei der Ursachenforschung/behebung...


    P.S.: Habt Ihr die gleiche Konfiguration (LinVDR 0.7 mit dem MarkTwain-Patch (linvdr-0.7-mt-1.3.22-20050302.tgz)) wie ich damals?

    womble


    Also ich hatte das Problem über den TV-Ausgang der DVB-Karte (fbtv hab ich zusätzlich auch, aber dort hab ich leider nicht nachgesehen). Seit diesem einen Film (Pleasentville) ist es jedoch nicht mehr aufgetreten.


    Es könnte wohl daran liegen, dass dieser Film "unter Last" aufgezeichnet wurde. Das sollte ich evtl. nochmal probieren.

    Hallo,


    ich versuche (als kleinen Ersatz für das AnalogTV-Plugin) die TV-Ausgabe (analog) des Movieplayers auf meiner TT DVB-S 1.6
    wiederzugeben, was (bis auf den Ton) ohne Probleme funktioniert.


    Ein Problem mit den Soundtreibern schliesse ich eigentlich aus, da dass Abspielen eines Filmes über DVB (mplayer) und
    das Aufnehmen des analogen TV´s (mencoder) mit Ton funktioniert!


    Kann es sein, dass der MPlayer keine Tonausgabe für´s analoge TV bietet? Dann dürfte ja aber der mencoder (der zum mplayer
    gehört, auch nur eine Aufnahme ohne Ton liefern :-/ )


    Ich habe mal alle 3 Befehlszeilen und die Ausgaben (verbose) angehangen. Ich hoffe mir kann jemand weiterhelfen:


    1. Ausgabe des analogen TV-Signals über die DVB-Karte (kein Audioton)


    2. Aufnahme des analogen TV-Signale mit dem mencoder (klappt alles, inkl. Ton):


    3. Ausgabe einer Videodatei über DVB (alles klappt, inkl. Audioton):

    Hallo,


    da auf meinem System, trotz aller Versuche, das analogtv-Plugin nicht stabil
    laufen will, habe ich mir überlegt: Warum nicht das MPlayer-Plugin dafür nutzen.


    Der Nachteil ist natürlich, dass man hierbei nichts aufnehmen kann und die
    Bedienung nicht sehr komfortabel ist. Mir geht es aber eigentlich nur ums
    anschauen von Fernsehsendern, die z.B. nur im lokalen Kabel kommen und ich
    nicht extra das Kabel an den Fernseher stecken will (hab da sonst eine Brummschleife).


    Hierfür habe ich die mplayer.sh-Datei ein wenig angepasst (siehe Anhang).


    Damit das ganze funktioniert, muss also nur diese Datei gepatched bzw.
    ausgetauscht werden und für jeden TV-Sender eine Datei mit der Endung
    ".tv" und mit folgendem Inhalt angelegt werden:


    Code
    1. TVDEVICE="/dev/video1"
    2. TVDRIVER="v4l2"
    3. TVFREQ="217.250"
    4. TVINPUT="0"
    5. TVNORM="PAL"


    Nun wird diese Datei mit Hilfe des MPlayer-Plugin gestartet (als wäre es
    eine Videodatei).


    Momentan ist das ganze noch in der Testphase, so dass z.B. der Ton noch
    nicht funktioniert. Sollte aber bald klappen...


    Verbesserungen, Ideen können gerne gepostet werden.


    Was mir an der mplayer.sh noch aufgefallen ist:


    Code
    1. # get the file extension of the video
    2. SUFFIX=$(echo -e "${FILE:$[${#FILE}-4]:4}" | tr [A-Z] [a-z])
    3. debugvar SUFFIX $SUFFIX


    Stimmt hierbei eigentlich das Suffix? Bei einer Datei mit dem Namen xyz.tv
    erhält man "z.tv" - also die letzten 4 Zeichen - aber das stimmt doch so
    nicht, oder?


    Gruss
    Marcus

    Hallo,


    ich verwende hier eine Technotrend DVB-S 1.6 (also FF-Karte), mit der ich fast ohne Probleme z.B. ASTRA-HDTV (MPEG2) aufnehmen kann (Stichwort: LiveTV pausieren).
    Die Probleme machen sich nur in digitalen Fehlerartefakten der Aufnahme bemerkbar (falls hierbei jemand mehr weiss, gebe Bescheid - dies soll jetzt aber nicht das Hauptthema dieses Threads sein).


    Ist es eigentlich auch möglich damit MPEG4 aufzunehmen, oder macht da der VDR / die Karte nicht mit?
    Wenn ja, wie sieht dann der channels.conf Eintrag z.B. für ASTRA-HDTV (MPEG4) aus. Bisher wurde eine FEC von 9/10 noch nicht? verwendet...


    Danke!


    zur Info (ja ich weiss wie die channels.conf aufgebaut ist, jedoch habe ich irgendwie ein Problem mit dem Eintragen der FEC 9/10):
    Astra HD mit MPEG-4 ist über Astra 19,2 Grad Ost,12.440 MHz vertikal, SR 27.500, FEC 9/10 zu empfangen, Astra HD mit MPEG-2 sieht man über Astra 19,2 Grad Ost, 12.168 MHz vertikal, SR 27.500, FEC 5/6.

    Quote

    Original von obi
    Heute gab es schon einen Thread zum Thema RTL und Verschlüsselungen im Kabelnetz....


    Ich weiss, aber hier geht es diesmal um SAT. Es wurde ja schonmal vor kurzem von Pro7/Sat1 angedeutet, aber dann wieder verworfen. Und jetzt meint wohl RTL sowas machen zu müssen.


    "Kostenlos" ok - aber dafür noch zahlen - nicht mir mir.

    Komisch, dass das nicht mit einem gemounteten Netzlaufwerk geht, dass sich im Videoverzeichnis befindet :-/. Müsste man mal den Patch untersuchen, wie er das ganze verschiebt...


    Die Rechte stimmen alle, d.h. vdr darf zugreifen/schreiben auf den Mountpoint?

    Das verschieben von Aufnahmen innerhalb des Videoverzeichnisses funktioniert auch mit einem Patch - ich weiss jetzt leider nicht welcher (habe den BigPatch drin).
    Geh mal auf eine Aufnahme und drücke 0 - vielleicht hast Du den Patch ja schon drin.