Posts by goofy

    Sehr komisch....
    Ich habe eine billige Realtek 1GBit 8169C(?) Karte statt der vorigen intel onboard 100mbit
    , auf meinem Linvdr installiert..
    Scheint auch zu laufen, streamen geht ,ssh geht.
    ABER, der Linvdr wird nicht mehr im Finder angezeigt (benutze OSX)?
    Sprich ich kann nicht mehr auf meine Sambamounts zugreifen.
    ich hab keine Ahnung was ich machen kann, es scheint ja alles richtig zu laufen?

    Hab es gelöst
    die runvdr sieht jetzt so bei mir aus


    if [ $USE_INTERNAL_IR != "yes" ]; then
    #setserial /dev/ttyS1 uart none
    loadmodule lirc_serial io=0x2f8 irq=3
    $BINDIR/lircd
    else


    #setserial /dev/ttyS1 uart none oder #setserial /dev/ttyS0 uart none, scheint ihm egal zu sein.(?)
    Hauptsache
    loadmodule lirc_serial io=0x2f8 irq=3
    steht in der Runvdr wenn du den Com2 nutzen willst.

    Ich habe einen neuen VDR gebastelt.
    Dabei habe ich (da sehr ähnliche boards) einfach die Festplatte vom alten VDR Rechner in den neuen übernommen.
    Läuft auch, bis auf die FB.
    Ich benutze Atric Rev.4 im neuen VDR, hatte aber auch schon ein Atric 4 im alten.
    Daher sollte die alte remote.conf/lirc.conf doch passen?
    Der einzige Unterschied ist das ich nun den internen Com Port benutze, statt wie vorher den externen.
    Ich habe auch ein spezielles Scenic Kabel für den internen Com2 Port geliefert bekommen.
    Die Anschlüsse sollten richtig sein.
    Muss ich meinem VDR irgendwie sagen wo der der Com Port ist, kann das die Ursache sein?
    Anlernen ging wunderbar, incl ein und auschalten, nur lirc geht noch nicht.
    In der Wiki steht:
    Ändern des COM Ports.
    Adresse und Interrupt des seriellen Anschlusses werden direkt in /etc/modules.conf, bzw. wenn /etc/modprobe.d/lirc existiert, sind die Änderungen dort vorzunehmen.
    Für /dev/ttyS0 (COM1 - Standardwerte).
    alias char-major-61 lirc_serial
    options lirc_serial irq=4 io=0x3f8
    Für /dev/ttyS1 (COM2 - Standardwerte).
    alias char-major-61 lirc_serial
    options lirc_serial irq=3 io=0x2f8
    Ein vorhandener setserial Eintrag mit ttyS0 ist durch ttyS1 zu ersetzen.
    Anschliessend die Abhängigkeiten der Module aktualisieren, dazu
    depmod
    aufrufen, lircd und lirc_serial neu laden.


    Jedoch wo ist /etc/modules.conf bei meinem Linvdr?
    Ich konnter nur die Runvdr ändern, (s0 zu s1), bring jedoch nichts
    das sagt logread zu lirc
    Jan 24 21:15:26 linvdr user.warn kernel: lirc_dev: IR Remote Control driver registered, at major 61
    Jan 24 21:15:26 linvdr user.warn kernel: lirc_serial: no version for "lirc_unregister_plugin" found: kernel tainted.
    Jan 24 21:15:27 linvdr user.info kernel: lirc_serial: auto-detected active high receiver
    Jan 24 21:15:27 linvdr user.warn kernel: lirc_dev: lirc_register_plugin: sample_rate: 0

    Oh das ist sehr nett, werde mir dann mal eine Digitus DN-1011 aus der bucht holen.
    Die hatt auch nen 8169S, das wird das gleiche sein.
    nochmals danke, ich bin immer erstaunt was ihr (wir) hier leistet.

    Danke für die Antworten.
    Das hört sich ja so an als könnte mann den 8169 mal probieren.
    Nur noch ein kurzer einwurf, es gibt ja anscheinend 2 Versionen 8169 und 8169b, die mit b wird wohl neuer sein.
    Macht das einen Unterschied?

    Mich würde mal brennend interessieren ob der 8169 mittlerweile Problemfrei, mit einem Mahlzeit 3.2 Linvdr 0.7 arbeitet?
    Oder gibt es noch andere günstige Karten ausser intel?

    Danke für die hilfe.
    Es ist offensichtlich ein Hardwareproblem.
    Der VDR reagiert sehr sensibel auf den Aufsteliungsort und ob das Gehäuse offen oder zu ist, kann den fehler nicht orten sollte wohl mal neue Harware anschaffen, nutze einen Siemens Scovery mit celeron 566.
    Teilweise wurde wohl der 2. tuner nicht erkannt.
    Jetzt läuft es mit VLC und PES streaming.
    Ich schaffe es zwar mittlerweile einen VDR aufzusetzen, auch die Dateistruktur des Linvdr ist mir langsam geläufiger.
    aber die Log dateien sind mir ein rätsel, macht aber nichts läuft ja wieder, kann ich mich nächtes mal drum kümmern.

    Hallo,
    ich bekomme partout nichts gestreamt.
    Ich möchte mittels streamdev plugin an VLC oder Mplayer streamen.
    Stremdev läuft die conf ist auch an mein Netzt angepasst, ich habe sicherheitshalber zusätzlich explizit meine IP vom MAC reingeschrieben.
    VDRadmin funktioniert auch.
    Aber wenn ich /Applications/VLC.app/Contents/MacOS/VLC http://192.168.2.20:3000/1 im Terminal eingebe, bekomme ich
    main private error: cannot pre fill buffer
    Das bekomme ich auch wenn ich bemi VLC: Nezwerk öfnnen: 192.168.2.20:3000/PES/1 eingebe.
    Wo könnte der fehler liegen?
    Es ist auch egal welchen stream ich nehme PES/PS/TS, einmal hatte ich eine verbindung mit mplayer, aber das bild war sehr langsam und das Bild sehr schnell (unbraucbar).
    Ich nutze einen neuen intel mac mit core2duo
    VDR mit linvdr0.7 mahlzeit.iso

    sieht jetzt so aus


    10 Starte tvmovie2vdr : echo "/usr/bin/tvmovie2vdr.sh" | at now ; echo "tvmovie2vdr gestartet !";


    und geht nicht baer vielleicht gehen ja cron und anacron, das würde ja reichen, aber komisch ist das schon

    anacrontab


    # /etc/anacrontab: configuration file for anacron


    # See anacron(8) and anacrontab(5) for details.


    SHELL=/bin/sh
    PATH=/sbin:/bin:/usr/sbin:/usr/bin


    # These replace cron's entries
    1 5 cron.daily nice run-parts --report /etc/cron.daily
    7 10 cron.weekly nice run-parts --report /etc/cron.weekly
    30 15 cron.monthly nice run-parts --report /etc/cron.monthly


    # format:period delay job-identifier command
    4 10 cron.weekly /opt/tvmovie2vdr/tvm2vdr.sh

    @ mr.pink
    danke
    hier mene rcStart_delayed
    Wenn die OK ist sollte anacron ja laufen.
    Anacrontab poste ich auch nochmal.


    #
    # will be executed 30 seconds after system start
    #
    execute() {
    OLDIFS=$IFS
    IFS=""
    echo $* >/dev/tty13 2>/dev/tty13
    $* >/dev/tty13 2>/dev/tty13
    IFS=$OLDIFS
    }


    . /etc/sysconfig


    if [ x$START_SAMBA = x"yes" ]; then
    execute nmbd
    execute smbd
    fi


    if [ x$START_FTPD = x"yes" ]; then
    execute stupid-ftpd
    fi


    execute /usr/bin/udpd.pl
    execute httpd -c /etc/httpd.conf -p 8000 -h /pub/web


    if [ x$START_DAAPD = x"yes" ]; then
    execute mDNSProxyResponderPosix `getifaddr eth0` squeal `hostname` _daap._tcp. 3689 &
    execute daapd -s 86400 -n `hostname` /pub/mp3 &
    fi


    # cron
    mkdir -p /ramdisk/cron/crontabs
    ROOT_TAB=/ramdisk/cron/crontabs/root
    if [ ! -e $ROOT_TAB ]; then
    echo "# m h dom mon dow command" > $ROOT_TAB
    echo "0-59/5 * * * * convert.pl -q -s" >> $ROOT_TAB
    echo "20 21 * * * tvmovie2vdr.sh" >> $ROOT_TAB
    fi
    crond


    #!/bin/sh
    #
    #/etc/init.d/anacron
    #


    case "$1" in
    start)
    echo -n "Starting Ancron"
    /usr/sbin/anacron -s
    ;;
    *)
    echo "Usage: $0 (start)"
    exit 1
    ;;
    esac


    # noflushd
    if [ x$START_NOFLUSHD = x"yes" ]; then
    execute noflushd -v -n $NOFLUSHD_TIMEOUT $NOFLUSHD_DISKS
    fi
    /sbin/atd

    das steht in meiner commands.conf


    Starte tvmovie2vdr : echo "/opt/tvmovie2vdr/tvmovie2vdr.sh" | at now ; echo "tvmovie2vdr gestartet !";


    @ god_failed
    in diesem verzeichniss (opt....) liegt aber gar keine datei namens tvmovie2vdr.sh?


    habe auch deine zeile schon 1 zu 1 übernommen............nichts, nur über die console ;(

    das kann sein, habe aber zur zeit nur tvmovie2vdr.sh da stehen, statt des pfades.
    Ich dachte bei linvdr reicht das?
    Aber wenn du sagst das soll so sein dann editier ich das auch wieder.
    ich will halt nur das 2 der 3 möglichkeiten funken.
    Also commands.conf
    cron und anacron.
    commands.conf geht schonmal nicht?
    tvmovie2vdr.sh eigeben funktioniert, dann läuft eer ab.

    ich wollte meine Frage hier mal direkt stellen.


    Mr. Pink schrieb:
    6 10 cron.weekly /usr/local/src/tvmovie2vdr/tvm2vdr.sh


    ist diese Zeile auch für linvdr anwendbar, ich denke nein, kann ich unter linvdr nicht einfach als command tvmovie2vdr.sh eintragen, statt des o.g. Pfades, fertig?


    ist die RC5 mit der rcstart_delayed vergleichbar und sind dann o.g. Zeilen in diese einzutragen?


    Kann ich auch einfach 4 10 statt 6 10 eintragen damit er alle 4 lädt?


    Wär nett wenn jemand mir bei meinen dummen Fragen helfen könnte.

    OK, dakne, wie blöd von mir.
    tvmovie2vdr.sh gibt es und sie funktioniert, also cron-tab wird zurückeditiert.


    Aber warum geht die commands.conf nicht?


    Ach ja sollte ich bei anacron dann auch einfach tvmovie2vdr.sh eintragen, statt des pfades der tvm2vdr.sh?


    Fragen über Fragen