Posts by hampelratte

    Vielen Dank für die vielen Tipps. Ich denke, ich werde dann die Dreambox FB nehmen. Die hatte ich sowieso schon ins Auge gefasst, weil mir die Belegung am besten gefallen hat (Menu, Zurück und Farbtasten alle nah am Steuerkreuz). Und wenn der Meister persönlich die auch nutzt, kann das nicht so verkehrt sein ;)
    Bei den Oneforalls bin ich etwas skeptisch, auch wenn die anfangs ganz gut funktionieren. Da hab ich mittlerweile nämlich schon 3 durchgerockt.


    Schönen Vatertag,
    Henrik

    Hallo,


    ich bin auf der Suche nach einer neuen (Infrarot-)Fernbedienung, die eine gute Tastenbelegung für VDR hat. Wenn zusätzlich der Fernseher auch bedient werden kann, wäre das auch sehr toll. Mehr als 30€ möchte ich aber nicht ausgeben. Gibt es da was, was besonders empfehlenswert / populär ist?

    Hallo zusammen,


    seit langem gibt es mal wieder eine neue Version von Lazy Bones mit einer neuen Funktion.
    In dieser Version habe ich mich auf Timer-Konflikte konzentriert:

    • In der Timer-Liste werden Timer mit einem Konflikt mit einem Icon gekennzeichnet
    • Zusätzlich wird der Zeitraum des Konflikts in der Zeile des Timers farblich hervorgehoben. So kann man gut erkennen, welche Timer kollidieren. Diese Funktion kann in den Einstellungen abgeschaltet werden.
    • Für Timer-Konflikte wird versucht, eine Lösung zufinden. Dazu nutzt Lazy Bones die Suche für Wiederholungen von TV-Browser und schlägt eine Lösung in der Zeitleiste vor, falls eine gefunden wurde. Bei Spielfilmen funktioniert das ganz gut. Bei Serien kann es vorkommen, dass Lazy Bones einfach die nächste Folge vorschlägt. Man darf sein Hirn bei der Benutzung dieser Funktion also nicht ausschalten.

    Download über die TV-Browser-Webseite oder direkt im TV-Browser.


    Viele Grüße
    Henrik

    Der Hinweis von schneisa war goldrichtig. In /boot/grub/grubenv stand als saved_entry=Reboot. Vermutlich ist also beim Herunterfahren etwas schiefgelaufen und der Wert nicht zurückgesetzt worden durch den "Wakeup-Reboot-Kernel". Jedenfalls hab ich die Datei gelöscht und jetzt bootet er wieder normal. Ich denke, damit ist der VDR wieder in der Spur und ich kann ihn wieder zusammenschrauben.


    Vielen Dank an alle für die zahlreichen Tipps. Allein wäre ich darauf wohl nie gekommen.


    Viele Grüße
    Henrik

    Was ist denn die default boot option im grub? Evtl. ist da der poweroff Eintrag gewählt. Oder gibts das nicht mehr? Ich kenn das noch aus meinen VDR Anfangszeiten, das war für manche Boards ein workaround damit die richtig aufwachen.


    Das ist natürlich auch noch eine Möglichkeit. Daran hab ich noch gar nicht gedacht. Der VDR benutzt tatsächlich diesen Mechanismus, bei dem er nach dem Herunterfahren noch mal kurz bootet, damit der wakeup richtig funktioniert. Vielleicht ist er da jetzt in einer Schleife. Ich meine, da gäbe es eine Option, dass grub sich die letzte ausgewählte Option merkt und dann beim nächsten Booten wiederverwendet (safe-default oder so). Da werde ich mal nachforschen.


    Argus : In meinem Desktop war komplett andere Hardware, kein Bauteil gleich. Und von USB hab ich mit einer anderen Platte gebootet. Die WD war aber weiterhin angestöpselt. Ich habe da nur die Bootreihenfolge geändert.

    Auch das hab ich noch probiert mit dem Diagnose Tool von WD. Dazu musste ich seit Monaten mal wieder Windows booten ;). Meine Güte, fühlt sich das alles träge an.


    Smart-Werte sind aber auch hier alle OK und der Quicktest hat auch nichts ergeben. Den kompletten Scan hab ich nicht gemacht, weil das Jahre dauert und ich nicht so lange in Windows festhängen möchte. Vielleicht lass ich das mal über Nacht laufen.


    Gegencheck mit Desktop-Platte im VDR hab ich nicht gemacht. Nachdem sich die Platte im Desktop genauso verhält, ist die Sache für mich klar und den Aufwand der ganzen Schrauberei nicht wert.

    Die Systempartition hab ich schon gesichert. Da steckt am meisten Zeit drin. Wenn die Aufnahme-Partition hopps ginge, wäre das zwar schade aber nicht tragisch.


    Ich habe jetzt noch einen fsck nach bad blocks auf die erste Partition gemacht und grub neu installiert. fsck hat nichts gefunden und grub hat ohne Mucken den MBR geschrieben. Hab auch noch mal --force gesetzt für alle Fälle. Hat aber keine Veränderung gebracht. Grub sagt kurz hallo, und dann geht die Kiste aus.


    Wie gesagt, am System hatte ich nichts geändert und das Problem tritt über Nacht auf. Ich gehe jetzt von einem Hardwaredefekt aus, auch wenn ich nicht verstehe, warum die Festplatte ansonsten zu funktionieren scheint.


    Ich bin mir nicht ganz sicher, ob ich als nächstes zu einer HGST oder wieder zu einer WD greifen soll. HGST scheint ja die solideren Platten herzustellen. Aber das ist ein anderes Thema.

    Ui, schon so viele Antwortet. Ich antworte mal der Reihe nach:


    schneisa : Es ist ein yavdr 0.5. Es ist die einzige Platte im System und er versucht auch davon zu booten. Wenn ich die Platte abziehe, kommt die Nachricht vom BIOS, dass er nichts zum Booten gefunden hat.
    MBR kaputt hab ich auch schon gedacht. Hab dann mal grub-install ausgeführt, aber das hat keine Änderung gebracht. Wie gesagt, ich glaube, er kommt gar nicht bis zum Bootloader.


    @chief: Anderes Kabel und verschiedene Ports hab ich probiert. Hatte ich vergessen in meiner Liste.


    mini73 : Ob das Netzteil noch genügend Saft liefert, kann ich nicht sagen. Allerdings funktioniert das System ja, wenn ich von USB boote und da hängt dann ja noch die USB-Platte zusätzlich dran. Netzteil ist ein PurePower von bequiet mit 300 Watt.


    Solemn : Ich suche die grub.cfg mal nach einem Poweroff ab. Heutzutage wird sowas ja generiert und ist dermaßen unübersichtlich, dass es knallt ;)


    Danke schon mal für Eure Antworten. Ich denke, ich teste die Platte heute mal in meinem Desktop und eine vom Desktop im VDR. Dann kann ich vielleicht auch den SATA-Controller ausschließen.


    Viele Grüße
    Henrik


    [Edit: Netzteil hat doch nur 300 Watt, sollte aber trotzdem mehr als genug sein]


    [Nachtrag:

    Code
    1. grub -n 'poweroff\|shutdown\|halt\|reset' grub.cfg

    liefert nur eine Zeile und das ist der Menueintrag "Poweroff''.

    Tag zusammen,


    heute wollte mein VDR plötzlich nicht mehr booten. Bis gestern Abend lief alles einwandfrei. Der Rechner wurde ordnungsgemäß heruntergefahren.


    Folgendes habe ich schon herausgefunden / probiert

    • es scheint an der Festplatte zu liegen
    • nach dem POST, wenn der Bootloader geladen werden sollte, schaltet sich der Rechner aus
    • es sieht so aus, als käme er gar nicht bis zum Bootloader (die typische Ausgabe von grub ist nicht zusehen)
    • wenn ich von USB boote, kann ich die Platte später ohne Probleme mounten
    • smartctl zeigt nichts Auffälliges
    • SATA-Kabel hab ich getauscht und verschiedene Ports ausprobiert
    • ich habe auch den RAM getestet, indem ich beide Riegel einzeln in beiden Slots probiert habe.
    • MBR hab ich neu geschrieben mit grub-install, brachte aber keine Änderung
    • Asus AT3IONT-I Mainboard
    • Western Digital EARS 2TB Platte, einzige Platte im System
    • Netzteil PurePower von bequiet 300 Watt
    • YaVDR 0.5.x


    Ich könnte jetzt noch meinen Desktop aufreißen und die Platte da mal als Boot-Platte testen. Dazu konnte ich mich noch nicht aufraffen ;)


    Hat von Euch einer eine Idee, was da los sein könnte? Bin für jeden Hinweis dankbar, denn son Verhalten hab ich bisher noch nicht gesehen.


    Viele Grüße
    Henrik

    3PO : Das play-Plugin bietet leider kein SVDRP-Kommando zum Starten einer Wiedergabe / Playlist. Da VCH ja komplett außerhalb von VDR läuft, besteht da leider im Moment keine Möglichkeit. Aber vielleicht ist Johns ja gewillt das einzubauen, oder Du machst es selbst und schickst ihm den Patch ;)

    Ich glaube Du verwechselst den osdserver mit SVDRP. Der VDR sollte einen Port aufmachen für den osdserver (2010) und einen für SVDRP (6419). Das kannst Du prüfen mit netstat:

    Code
    1. $ netstat -tpan
    2. (Es konnten nicht alle Prozesse identifiziert werden; Informationen über
    3. nicht-eigene Processe werden nicht angezeigt; Root kann sie anzeigen.)
    4. Aktive Internetverbindungen (Server und stehende Verbindungen)
    5. Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    6. tcp 0 0 0.0.0.0:6419 0.0.0.0:* LISTEN 3790/vdr
    7. tcp 0 0 0.0.0.0:2004 0.0.0.0:* LISTEN 3790/vdr
    8. tcp 0 0 0.0.0.0:3000 0.0.0.0:* LISTEN 3790/vdr
    9. tcp 0 0 0.0.0.0:2010 0.0.0.0:* LISTEN 3790/vdr


    Im Webinterface von VCH dann unter Konfiguration -> osdserver 2010 einstellen und unter Konfiguration -> Wiedergabeliste 6419

    Es müssen halt alle Zeichen, die in XML eine Bedeutung haben, in die entsprechenden Entitäten umgewandelt werden. Bei mir sieht der Eintrag so aus:

    Code
    1. <command name="VCH" confirm="no" execute="echo &quot;curl http://localhost:8080/osdserver &gt;/tmp/vchosd.log 2&gt;&amp;1&quot; | at now" />

    Ne, Java 1.6 ist nur Mindestvoraussetzung, da ich dagegen kompiliere. Ich selbst hab aber auch mit OpenJDK 1.7 und Oracle 1.8 getestet. Das sollte OK sein.
    Hast Du http://host:8080/news aufgerufen, oder wo bekommst Du den Fehler? Mit "Blabla Http Error" kann ich Dir nicht helfen.

    Nach langer Zeit gibt es wieder eine neue Version von VCH. Für die, die VCH nicht kennen: VCH ermöglicht den Zugriff auf die Mediatheken von ARD, ZDF und weiteren Seiten wie z.B. Youtube. Weitere Details, Voraussetzungen und Installationsanleitung gibt es im Wiki.


    Ich habe viele der Parser und Suchmodule der letzten Version repariert und auch unter Haube Vieles aktualisiert. Den Parser für Youtube habe ich komplett neu geschrieben. Er greift jetzt auf das Benutzerkonto zu und ermöglicht den Zugriff auf die eigenen Abos, Favoriten, Wiedergabelisten etc. Ansonsten hat sich an der Funktionalität nichts geändert.


    Die neue Version gibt es hier zum Download: http://www.hampelratte.org/mav…de/berlios/vch/vch/2.0.0/


    Wer bereits eine alte Version genutzt hat, sollte für die neue Version die Quellen für Erweiterungen anpassen unter "Erweiterungen -> Konfiguration"
    Die neue Adresse lautet: http://www.hampelratte.org/maven/releases/repository.xml
    Die alte Adresse http://www.hampelratte.org/maven/repository.xml muss gelöscht werden.


    Feedback ist willkommen.


    Viel Spaß damit,
    Henrik

    P.S: Gibt es schon etwas zum Testen und Rückmelden?


    Theoretisch ja, aber dann müsste ich erst mal eine komplette Version bauen. Und da ich auch an der Projektstruktur Veränderungen ist das im Moment noch etwas aufwändig.


    Benutzt ihr die Suche im OSD oder über das Webinterface?

    Hallo zusammen,


    ich bringe gerade VCH wieder auf einen aktuellen Stand. Ich würde jetzt gern wissen, worauf ich mich konzentrieren soll und würde gerne wissen:

    • Welche Funktionen benutzt ihr? Z.B. Nur Browsen und Streamen, Download, Playlists, Suche
    • Welche Parser benutzt ihr, fehlen euch
    • Sonstige Ideen, Vorschläge?


    Außerdem überlege ich, ob ich eine Scripting-API einbaue, die das Erstellen von Parsern in Script-Sprachen ermöglichen würde. Ich habe schon etwas mit JavaScript und Python herumgespielt und den Parser für Golem.de komplett in JavaScript umgesetzt. Gibt es daran Interesse?


    Bin mal gespannt, ob sich überhaupt jemand meldet, nachdem ich VCH eine ganze Weile vernachlässigt habe ;)