Posts by Schinken

    Obwohl ich durchaus etwas Ahnung von VDR auf einer SuSE habe, bin ich auf der Gen2VDR Installation am AMC-500 meines Vaters ein ziemlicher Newbie.


    Mein Problem: Ich bekomme nicht mal einen Zugriff auf die Shell hin :(
    Das AMC ist per Scart und VGA mit einem Fernseher verbunden, auf beiden Kanälen kann ich nur das Sat-Bild sehen (bei VGA ist es allerdings ziemlich verzerrt). Tastatur ist via USB dran.


    Kann mir jemand weiterhelfen (gern auch mit Hinweis auf Anleitungen), wie ich in so einer Umgebung eine Shell (Konsole/Terminal/...) anzeigen kann? Versuche mit SHIFT-CTRL-F1 oder ähnlichen Kombinationen, wie ich sie von SuSE kenne, haben leider nicht funktioniert.


    Da wir grade dabei sind: mein eigentliches Ziel ist die Installation eines Fritz USB WLAN-Sticks, sind da irgendwelche Showstopper bekannt?


    Danke Euch!

    Nachdem ich mir auch eine dinovo-Tastatur zugelegt habe, würde ich das Thema gern wiederbeleben.


    Ich habe im WWW zwei Anleitungen gefunden, die ganz gut erklären, dass man die Media-Tasten des Keyboards unter Linux nutzen kann (USB-Modus).


    http://www.linux-user.de/ausga…/04/078-dinovo/index.html und http://linux.yes.nu/diNovo/?Page=cGFnZTAx


    Mir ist allerdings leider nicht klar, wie ich die Vorgehensweise bei einem Window-Manager auf den VDR, bei dem ich ja die Codes wie in der Tabelle bei http://www.comptechdoc.org/os/…rks/linux_hlkeycodes.html beschrieben eingeben muss.


    Wäre sehr dankbar, wenn mir da jemand weiterhelfen könnte ...


    Ansonsten noch zwei Kleinigkeiten:
    1. Wie kann ich beim VDR eine Funktion (z.B. Menü) auf zwei Tasten legen (nämlich eine auf der Tastatur und eine auf dem Mediapad)
    2. Wie kann ich beim Mediapad den Num Lock aktivieren?


    Vielen Dank schon mal!

    Hallo zusammen,


    mein VDR besteht aus einem Pentium M 745 (1,8 MHz) auf einem AOpen Board (i855GMEm-LFS). Ansonsten eine Platte, DVD-Rom und Nova-S.


    Da nun mein altes Netzteil abgeraucht ist, hätte ich gerne ein passendes für das System. Lüfterlos wäre grundsätzlich schön weil leise, allerdings ist der Rechner bei mir "etwas" eingebaut. D.h. es ist schon jeweils einige cm Platz zu allen Seiten, die Situation ist aber nicht optimal.


    Ich möchte daher auf eine komplett passive Kühlung verzichten, auch wenn es möglich wäre, was ich so auf dem Board gelesen habe.
    Wenn ich mich richtig informiert habe, sollte ein Netzteil mit ca. 150 Watt eigentlich ausreichend sein. Ich bin leider kein Experte, denke aber, dass 300 Watt übertrieben wären, evtl. auch unwirtschaftlich.


    Ich bin also auf der Suche nach einem Netzteil mit ca. 150 Watt, das dafür etwas leiser zur Sache geht, aber nicht passiv ist, um "frischen Wind ins Gehäuse zu bringen".


    Kann mir da jemand helfen? Ich finde nur interne aktive/passive Netzteile mit >= 300 Watt oder externe mit 60-110 Watt.


    Schon mal Danke für Eure Mühe!

    Hallo Viking,


    ich habe mir den "9/1 Card Reader / Writer" von equip zugelegt.


    Er hat 2 x USB2.0 Anschlüsse, 1 x Firewire, MS, SD/MMC, CF/MD und SM/XD Einschübe und ist 3,5" groß.


    Klappt eigentlich alles ganz gut unter Linux, natürlich auch Hotplug-fähig, wobei die genaue Behandlung natürlich von der verwendeten Software abhängt (gibt zwei verschiedene Verfahren, Suse setzt in den aktuellen Distri's eines ein, dass ich noch nicht kannte. Habe leider die Namen vergessen.)

    Hallo zusammen,


    ich suche einen internen Kartenleser für meinen VDR, mit den üblichen Formaten (MemoryStick, SD/MMC, CompactFlash, ...).


    Kann ich da viel falsch machen in Sachen Kompatibilität mit Linux?


    Gibt es ein paar gute Empfehlungen?


    Vielen Dank,
    Christof

    Sehr schön, freut mich dass es klappt. Kann mich noch haargenau an das Gefühl erinnern, als ich damals zuerst die schlechte Nachricht und dann nach Tagen endlich die gute Nachricht auf dem Bildschirm gelesen habe :)


    Ironie des Schicksals: Wollte heute meine Daten vom RAID5 auf eine neue Platte schieben, die läuft aber nur auf neuem Board. Was passiert natürlich: eine der Partitionen ist wieder "unten" (im Sinne des event counters), darf auch wieder manuell reparieren ...


    Höchstwahrscheinlich lags bei mir am alten Netzteil, das war zu unterdimensioniert.


    So, jetzt noch ein schönes WE, gehe jetzt zum Wise Guys-Konzert :)

    Hallo geronimo,


    erst mal ein wenig Aufmunterung für Dich, ich hatte mit Linux Software RAID5 auch schon einige Probleme, auch ein größeres, bei dem auf den ersten Blick 2 von 4 Platten "weg" waren. Jetzt die gute Nachricht: das habe ich wieder hinbekommen.


    Dummerweise ist das schon länger her und ich habe mir keine Notizen gemacht ... :( Allerdings gibt's noch zwei "Spuren" im Web:
    http://www.spinics.net/lists/raid/msg03502.html
    http://vdrportal.de/board/thread.php?threadid=5827


    Meine Erfahrung mit RAID5 sagt mir bis jetzt, dass nach einem Ausfall (auch Hardware, bei mir war oft Strom weg) meistens nicht wirklich was an den Daten kaputt ist, sondern an den Metadaten der Raid-Infos ... Darum kann man meist wieder manuell alles zusammenstöpseln. Dummerweise passierte mir das ständig, mit dem Ergebniss, dass immer eine RAID-Platte neu syncen muss, was lange dauert und sehr gefährlich ist, weil das RAID dann total im Eimer ist, wenn dann zusätzlich wirklich mal eine Platten-HW abraucht ... Ehrlich gesagt habe ich mich daher dazu entschlossen, das RAID rauszuwerfen und täglich ein Backup (das ich unter Kontrolle habe) auf einen zweiten Plattensatz zu fahren, als Ersatz für das RAID.


    Dummerweise ist sowohl mein Server als auch mein VDR gerade im Umbau, weshalb ich kein Linux mehr zur Verfügung habe, also nichts ausprobieren kann.


    Deshalb mein erster Tip: Lies Dir mal die obigen Threads durch, vielleicht hilft das schon.


    Mein Ansatz damals war:
    [list=1]
    [*]Rausfinden, welche Platte "wirklich defekt" war (entweder, weil die Daten korrupt sind, oder weil die Hardware im Eimer ist)
    [*]Meistens war bei mir nur nach einem Stromausfall das RAID ausser sync, also konnte ich eine von den beiden "kaputten" Platten wieder dazunehmen, weil sie nur einen falschen event counter hatte
    [*]Das Raid ohne sie starten, und zwar mit Gewalt ("force")
    [*]Das ganze dann aber nur lesend, also RAID nicht neu aufbauen/resyncen, auch das Filesystem zum anschließenden Test nur lesend mounten!
    [*]Wenn die letzte Platte keine wirklichen Hardware-Probleme hatte, wieder hinzufügen (hotadd)
    [/list=1]


    So, hoffe das hilft für's erste, schreib mal, wie's Dir so geht ...

    Hallo zusammen,


    ich suche eine leise aber trotzdem recht starke Hardware für meinen neuen VDR.


    Ich habe mir aus den Informationen hier im Board folgendes "komponiert":

    • Silverstonetek LC 06 Gehäuse (vorne einen Einlasslüfter, hinten zwei Auslass, die sollte man anscheinend evtl. durch leisere ersetzen)
    • Pentium M 745 (1.8GHz)
    • Passives 300W Netzteil
    • FF + Budget Haupauge Nova


    Da ich bisher nur mit Systemen gearbeitet habe, bei denen Lüfter kein Problem waren, wollte ich abschließend noch mal nachfragen:


    1. Kann ich den Pentium M in der Konfiguration passiv betreiben? Wenn ja, kennt jemand einen guten Kühlkörper?


    2. Reicht das Netzeil (300W, passiv, z.B. auch von Silverstonetek)?


    3. Reicht der Luftstrom im Gehäuse für das Ganze (inkl. 2 DVB-S), weil es ja nicht das größte ist?


    4. Als Board hatte ich an ein AOpen i855GMEm-LFS gedacht, entspricht microATX (Board) in irgendeiner Weise Mini-ITX (Gehäuse)?


    Schon mal vielen Dank,
    Christof

    Hallo zusammen,


    ich bräuchte Eure Hilfe, nachdem ich jetzt ca. 4 Stunden lang gegoogelt habe aber nirgendwo eine definitive Zusage für einwandfreie Funktionalität gefunden habe.


    Ich suche ein Motherboard (schön wäre Sempron, Sockel 754, ASUS, muss aber alles nicht sein) das mit seinem on-board SATA-Controller HotPlug unter SUSE ermöglicht (Version egal, nehme dann die passende. wird wahrscheinlich ein 9.x sein?). Wenn möglich sollte Linux direkt auf eine SATA-Platte installierbar sein. RAID ist mir wurscht, werde wenn dann nur Linux-Software-Raid benutzen.


    Kann mir jemand eine definitiv funktionierende Kombination nennen? Eventuell noch irgendwelche Erfahrungen mit Hotplug-fähigen Wechselrahmen?


    Wenn das mit den Chipsätzen auf den MBs Probleme macht, vielleicht ein einfacher (i.e. billiger) Controller, der gut unterstützt wird?


    Schon mal vielen Dank im Voraus!

    Sorry, dass ich da meinen Senf dazugeben muss:


    Es gibt durchaus einen Grund, das Ergebnis des booleschen Ausdrucks quasi indirekt abzufragen: die Übersichtlichkeit.


    Einer unserer Kunden fordert in seinen Programmierrichtlinien (Java) explizit, keine anderen Abfragen zu verwenden. Obwohl ich zuerst skeptisch war, habe ich mich dran gewöhnt ...


    Falls Du was anderes gemeint hattest ... D'oh! ;)


    Ich hab's bei mir nochmal mit weiteren DVD probiert (alle als ISO auf der Platte), es wird definitiv nur die erste Tonspur abgespielt, alle weiteren nicht.


    In meinem Fall war gerade die erste Deutsch, die kam, sobald ich auf englisch oder französisch ging, war stille, dann wieder deutsch => Ton, dann wieder englisch => Still :) Also während der Wiedergabe gewechselt.


    Verwendet habe ich diesmal das DVDPlugin aus dem CVS vom 31.03.


    Vielleicht hilft die Meldung von inschenjr mit der Kombination 1.3.14 und 0.3.5?

    Ich habe gestern sowohl tvm2vdr als auch VDRAdmin bei mir installiert.


    tvm2vdr läuft per Cron Job um 5:00 morgens, der Admin sollte um 6:00 neu starten, damit das EPG neu eingelesen wird.


    Heute früh war der VDR aus, ein Blick ins Logfile zeigt, das das jemand "angefordert" hat.


    Code
    1. Apr 1 05:00:01 linux /usr/sbin/cron[5408]: (root) CMD ( cd /usr/local/src/tvmovie2vdr && ./tvm2vdr.sh)
    2. Apr 1 05:00:03 linux vdr[4686]: connect from 127.0.0.1, port 33819 - accepted
    3. Apr 1 05:00:03 linux vdr[4686]: Power button pressed
    4. Apr 1 05:00:03 linux vdr[4686]: next timer event at Fri Apr 1 19:05:00 2005
    5. Apr 1 05:00:03 linux vdr[4686]: confirm: Taste dr374cken um Shutdown abzubrechen
    6. Apr 1 05:00:03 linux vdr[5437]: Text2Skin: message display update thread started (pid=5437, tid=294917)
    7. Apr 1 05:00:03 linux vdr[4686]: closing SVDRP connection
    8. Apr 1 05:00:09 linux vdr[5437]: Text2Skin: message display update thread ended (pid=5437, tid=294917)
    9. Apr 1 05:00:09 linux vdr[4686]: confirmed
    10. Apr 1 05:00:09 linux vdr[4686]: executing '/usr/local/bin/vdrshutdown 1112375100 50691 4 "Verliebt in Berlin" 1'

    Verliebt in Berlin ist auch ein Timer, aber so wie es aussieht, kommt der Shutdown kurz nach Start von tvm2vdr.


    Weiss jemand, ob tvm2vdr oder VDRAdmin den Befehl zum Shutdown mit einem Parameter absetzen, der hier dann wohl falsch zugeordnet wurde?

    Also das geht auch direkt mit dem DVD-Plugin.


    Entweder indem Du den Link für dein DVD-Laufwerk manuell auf das ISO setzt oder (etwas komfortabler) über das DVDSelect-Plugin, das genau das für Dich macht, nachdem Du es per OSD dazu überredet hast ;)

    Du kannst den Daten-Strom, der ZU einem bestimmten Rechner geschickt wird, beeinflußen.


    Das geht mit einem sogenannten Traffic Shaper. Funktioniert folgendermassen: Du richtest den Traffic Shaper als eine neues virtuelles Netzwerk-Interface (z.B. eth1) ein, das aber auf das vorhandene Interface (z.B. eth0) verweist


    Dann stellst du die Default-Routen so ein, dass der Verkehr, der verlangsamt werden soll, über das virtuelle Interface geht.


    Jetzt kannst Du über ein Steuerungsprogramm jederzeit die Begrenzung für den Traffic Shaper ändern, z.B. nur 64k pro Sekunde o.ä.


    Für Dich würde das bedeuten, dass Du auf Server und Nicht-VDR-Rechner die Bandbreite begrenzen müsstest. Ist der Nicht-VDR auch ein Linux-Rechner?


    Alternative wäre ein (intelligenter) Router im Netz, der von sich aus eine Bandbreitenbegrenzung integriert hat. Ein Bekannter setzt einen Windows-Server mit AVM-Software dafür ein, kenne aber leider keine Details ...

    Ich habe in meiner /usr/local/bin/runvdr folgendes eingebaut:

    Code
    1. export LC_CTYPE="de_DE@euro"

    Dann klappt es. Bist Du sicher, dass Du die richtige Variable an der richtigen Stelle setzt?


    Gib doch einfach mal mit

    Code
    1. export | grep LC_CTYPE

    den Inhalt der Variablen aus, kurz bevor vdr gestartet wird. Oder Alternativ:

    Code
    1. export | grep utf

    , falls es noch irgendwo anders steht ...

    Bitte nicht steinigen, nach einem Neutstart klappt wieder alles wie gewohnt. Ich lieeeeeeeeeeebe Windows ;) :(


    Trotzdem, eins muss ich es noch loswerden: Ich bin immer wieder sehr (positiv) über die Reaktionen hier im Forum überrascht, wenn jemand ein (sei es noch so dummes oder kleines) Problem hat. Respekt ... :]

    wirbel : ja, DSL-Router, allerdings sollten dadurch Windows und Linux gleichermaßen betroffen sein


    Personal Firewall ist auch aus, Windows Firewall nicht aktiv ...


    DOS-FTP meldet:

    Code
    1. C:\>ftp ftp.avm.de
    2. > FTP: connect :Unbekannte Fehlernummer
    3. ftp>


    Komisch, da muss irgendwas anderes nicht stimmen, ich kann nicht mal meinen eigenen FTP-Server im Intranet erreichen ...