Posts by TimUx

    Hi Thomas,
    ein Problem konnte ich mitlerweile eingrenzen bzw beheben.


    Ich habe auch Hyperion auf dem RPI am laufen.
    Wenn ich hyperion nicht mit dem VDR stoppe, weil ich z.B. die Hintergrundbeleuchtung vom TV eingeschaltet und via APP bedienen möchte, startet der VDR anschließend nicht mehr während noch Hyperion aktive ist und steigt mit dem "Segmentation fault" aus.


    Stoppe ich Hyperion immer mit dem VDR und lasse es auch inaktive, taucht das Problem nicht mehr auf, VDR Startet, hyperion startet, alles gut.
    Ich vermute mal, dass hier der Grabber in die Suppe Spuckt.


    Das Problem, dass ich die Einstellung "wie Video" nicht mehr nutzen kann, habe ich nachwievor und kann es auch reproduzieren.
    Ich schau mal, wie ich im MLD da aussagekröftige Logs und Backtraces heraus bekomme.


    Gruß Timo

    Hallo zusammen,
    ich habe vermutlich ein ganz ähnliches Problem.


    Code
    1. Jul 8 22:52:47 (none) user.err vdr: [10016] rpihddevice: [EGL] failed to create window surface: bad native window!
    2. Jul 8 22:52:47 (none) user.err vdr: [10016] rpihddevice: [EGL] failed to set surface attributes: bad surface!
    3. Jul 8 22:52:47 (none) user.err vdr: [10016] rpihddevice: [EGL] failed to connect context to surface: bad match!
    4. Jul 8 22:52:57 (none) user.err vdr: [9995] rpihddevice: [OpenVG] cannot allocate pixmap of 1784px x 1004px, clipped to 0px x 0px!
    5. Jul 8 22:52:57 (none) user.err vdr: [10016] rpihddevice: [OpenVG] failed to allocate 0px x 0px pixel buffer!
    6. Jul 8 22:52:57 (none) user.err vdr: [10016] rpihddevice: [OpenVG] CreatePixelBuffer error: no context
    7. Jul 8 22:52:57 (none) user.err vdr: [9995] rpihddevice: [OpenVG] failed to create pixmap! (allocation failed)


    Der VDR steigt dann mit einem "Segmentation fault" aus.


    Außerdem funktioniert bei mir die Einstellung für die Auflösung "wie Video" nicht mehr.
    Wenn ich dies einstelle, startet der VDR auch nicht mehr und meldet "Floating point exception"


    Mein System:


    RPI2
    MLD 5.1 Testing


    Ich müsste Claus mal fragen, welche Firmware Version und welche rpihddevice Version aktuell im MLD Testing eingesetzt wird.
    Meistens aber immer die aktuellste Version.


    Gruß Timo

    Hallo,
    auch von mir, besten Dank für das Plugin.


    Leider bekomme ich es mit einem RPI2 und dem rpihddevice noch nicht ans rennen.


    Erste Fehlschläge wießen auf ein zu altes POCO hin, also habe ich aus einem PPA ein poco 1.6 installiert.


    Danach sieht zumindest die Library jetzt schön aus, mit Cover und allem drum und dran.


    Sobald ich einen Film abspielen möchte, funktioniert dies aber nicht, TV Bild kommt zurück und folgendes ist im Log zu finden.


    Code
    1. Dec 10 17:09:02 (none) user.err vdr: [2804] [plex]LoadStartList Response Not Valid
    2. Dec 10 17:09:02 (none) user.err vdr: [2804] [plex]LoadStartList failed!


    Also genau das gleiche verhalten, wie mit einem alten POCO.


    Hätte da jemand eine Idee?


    Danke & Gruß


    Timo

    OK,
    habe mich vielleicht falsch ausgedrückt, habe kein HD+.


    Die privaten HD Sender werden natürlich über die Sky v14 Karte mit entschlüsselt.
    Somit ist kein CI+ nötig. :]


    @seahawk
    Ok, werde mich umorientieren. ;D
    Da hier im thread schon diverse Kombinationen auch mit unterschiedlichen CAMs diskutiert wurde, war ich mir nicht ganz Sicher.
    Wäre es etwas für dieses Forum, wenn ich ein offizielles SKY CAM nutze?


    Danke & Gruß
    Timo

    Hallo zusammen,
    in letzter Zeit ist es hier zwar Ruhig geworden, ich denke aber der Thread ist genau richtig für mein Problem.


    Folgende Konstelation:


    - Ubuntu 14.04.
    - yaVDR testing headless
    - Linux4Media / DD v6.5
    - Flex CI
    - DeltaCAM v2 mit Python 01.91
    - vdr (2.2.0/2.2.0)
    - ddci2 (0.0.13)
    - DD DKMS Treiber v 09.19
    - Sky v14 Karte


    Ansich sieht erst mal alles gut aus. Das CI wird vom ddci2 Plugin erkannt und im VDR angezeigt.



    Ich kann auch auf das CAM Menü zugreifen und mir die Karten Infos Anzeigen lassen.



    Allerdings werden die Sky und HD+ Sender leider nicht entschlüsselt.
    Wenn ich via StreamDev Server oder VNSI via Kodi zugreife, kommt kein Signal an.


    Hierbei ist folgendes im Log zu sehen:



    Packe ich die v14 in meinen Smargo und betreibe es mit diverse Software-Lösungen ?( funktioniert soweit alles.


    Hat jemand eine Idee?


    Danke & Gruß
    Timo

    Besten Dank.


    Den Bluray Part werde ich mal testen.


    Im Grunde würde ein LCD TV mit cec ausreichen, um die volume up/down Funktion zu testen, muss ja kein AMP sein.


    Via cec-client und irecx habe ich schon erfolgreich die Lautstärke meines Tv bzw Amp gesteuert.
    Grundsätzlich müsste es bestimmt möglich sein.


    Ansonsten bin ich es aber erst mal zu Frieden. :]


    Gruß Timo

    OK,
    ich habe es dann ganz anders gelöst aber trotzdem in einem Shell-Script. ;-)
    Ich habe einfach die zwei CEC Commands in mein Start-Skript für den libcecdaemon vor dem start des libcecdaemon gepackt.
    Anschließend startet dann erst der libcec und vdr.


    Was mich jetzt noch interessieren würde, kann ich über cecremote die Lautstärke meine TV oder AMP steuern?
    In meinem jugendlich Leichtsinn hatte ich die Hoffunge, dass ich einfach eine vdrkeymap im global anlege und die Volume+/- Keys vom VDR auf CEC VOLUME_UP/DOWN ummappe.
    Jetzt habe ich aber gesehen, dass die Keymaps eigentlich nur mit einem Player funktioniert, vermutlich auch, weil hier ja die CEC Adresse des zu steuernden Gerätes definiert ist.


    Gibt es eine Möglichkeit das doch irgendwie umzusetzten oder könnte im nächsten Release Vielleicht eine Option eingebaut werden, bei der man sich aussuchen kann, ob die Voluem-Controls KEYs den VDR oder TV steuern?
    Das wäre echt spitze und alle meine Anforderungen wären erfüllt. :D


    Im Moment Kämpfe ich auch noch damit, dass mein Samsung Bluray auf <poweroff>player</poweroff> nicht reagiert.


    Ich muss aber noch mal sagen, echt super Job gemacht!


    Danke & Gruß
    Timo

    Hi Ulrich,
    danke für die Info.


    Da werde ich mir mal etwas zusammen basteln.


    Theoretisch könnte ich es aber auch direkt alles ins xml file schreiben, oder?


    Code
    1. <onstart>
    2. <poweron>TV</poweron>
    3. <poweron>AMP</poweron>
    4. <exec>svdrpsend plug cecremote disc</exec>
    5. <exec>echo "15 70 13 00"|cec-client -s</exec>
    6. <exec>svdrpsend plug cecremote conn</exec>
    7. </onstart>


    Gruß Timo

    Hallo Ulrich,
    Erst mal besten Dank für das Super plugin.


    Im großen und ganzen habe ich das plugin verstanden und erfolgreich in Betrieb.


    Entweder habe ich nichts zu dem Thema gefunden, übersehen oder vielleicht auch einfach nicht verstanden.


    Ich habe die Notwendigkeit, ein bestimmtes Cec command zu meinem Amp zu schicken.


    Tx 15 70 13 00, da sonst der VDR auf meinem Amp als aktive Quelle nicht erkannt wird.
    Kann ich dies irgendwie mit dem cecremote plugin an den Amp senden?


    Theoretisch könnten man es so machen:


    Code
    1. <exec>echo "15 70 13 00"|cec-client -s</exec>


    Sobald ich aber den cec-client verwende, funktioniert das cecremote nicht mehr.


    Danke für deine Infos & Tipps


    Gruß Timo

    Hallo zusammen,
    ich habe da ein kleines Problem mit dem libcec-daemon und meinem Samsung TV.


    Das ganze sieht ähnlich aus, wie in diesem Thread: [url='http://www.vdr-portal.de/board18-vdr-hardware/board13-fernbedienungen/118704-pulse8-usb-cec-nicht-alle-tasten-der-tv-fernbedienung-lassen-sich-belegen/?highlight=libcec']Pulse8 usb-cec: Nicht alle Tasten der TV-Fernbedienung lassen sich belegen[/url]


    Ich habe auf meinem RPI libcec2 Version 2.1.4 und den aktuellen libcec-daemon vom git kompiliert und installiert.
    Grundsätzlich scheint es zu funktionieren.
    Allerdings funktionieren einige Multimedia Tasten (Stop, Play, ...) nicht.


    Wenn ich den libcec-daemon mit -vv starte, werden die Buttons zwar bemerkt, jedoch kein KeyPress durchgeführt.


    Hier mal die Stop-Taste:


    Code
    1. DEBUG - Main::onCecLogMessage(72315 [T]>> 01:42:03)
    2. DEBUG - Main::onCecLogMessage(72316 [D]>> TV (0) -> Recorder 1 (1): deck control (42))
    3. DEBUG - Main::onCecCommand(Command 0->1[ ] 66)


    Das wäre die Play Taste:


    Code
    1. DEBUG - Main::onCecLogMessage(73585 [T]>> 01:41:24)
    2. DEBUG - Main::onCecLogMessage(73586 [D]>> TV (0) -> Recorder 1 (1): play (41))
    3. DEBUG - Main::onCecCommand(Command 0->1[ ] 65)


    und hier die funktionierende SELECT Taste:



    Hat jemand eine Idee, wo in den sourcen ich was drehen muss (uinput.cpp, main.cpp, ...), damit auch diese Taste eine Key Press Aktion ausführen?


    Gruß Timo

    So,
    ich habe mir jetzt irgendwie selber geholfen.


    Nach ein bissel im PPA suchen, habe ich die "vdr packages for OpenELEC devel" gefunden.


    Nachdem hinzufügen zur sourcelist und einem apt-get update && apt-get install vdr-plugin-vnsiserver5, rennt jetzt auch XBMC Gotham mit vnsi5.


    Gruß Timo

    Hallo zusammen,
    ich würde das Thema gerne noch mal aufwärmen.


    Ich habe aktuell VDR Testing mit dem VDR 2.0.4 am rennen und würde jetzt gerne XBMC Gotham samt VNSI5 ans rennen bringen.


    Ich habe mir das ppa von Alex gezogen, es wurde auch ein Update vom XBMC, jedoch wird kein Update vom vdr-plugin-vnsiserver durchgeführt.


    Angeblich ist die Testing 0.9.1 Version neuer, als die aus dem PPA von Alex.



    Also habe ich mal versucht, die Version explizit mitzugeben und er hat ein "Downgrade" durchgeführt.



    Nach einem VDR restart, meckert er aber immer noch rum, dass die VNSI Version nicht stimmt.


    Code
    1. Jan 18 21:56:40 htpc vdr: [4003] VNSI: Client with ID 16 connected: 127.0.0.1:55620
    2. Jan 18 21:56:40 htpc vdr: [4364] VNSI: Welcome client 'XBMC Media Center' with protocol version '5'
    3. Jan 18 21:56:40 htpc vdr: [4364] VNSI-Error: Client 'XBMC Media Center' have a not allowed protocol version '5', terminating client
    4. Jan 18 21:56:40 htpc vdr: [4364] VNSI: cxSocket::read: eof, connection closed
    5. Jan 18 21:56:41 htpc vdr: [4003] VNSI: Client with ID 16 seems to be disconnected, removing from client list


    So wie es aussieht wird auch noch der vnsiserver3 geladen, liegt es vielleicht daran?


    Code
    1. root@htpc:/var/lib/vdr/plugins# ps -ef|grep vnsiserver
    2. vdr 3897 1 6 21:55 ? 00:00:27 /usr/bin/vdr -v /srv/vdr/video.00 -c /var/lib/vdr -L /usr/lib/vdr/plugins -r /usr/lib/vdr/vdr-recordingaction -s /usr/lib/vdr/vdr-shutdown.wrapper -E /var/cache/vdr/epg.data -u vdr -g /tmp --port 6419 --lirc=/var/run/lirc/lircd -w 0 -Pxine -r -Pxvdr -t 10 -Pskinpearlhd --epgimages=/var/cache/vdr/epgimages -Pquickepgsearch -Pepgsearch -f /usr/bin/svdrpsend -Ptext2skin -Plive --port=8008 --ip=0.0.0.0 --log=INFO --epgimages=/var/cache/vdr/epgimages -Pepg2vdr -Pvdrmanager -p 6420 -P phantom -Pextrecmenu -Pstreamdev-server -Prestfulapi --port=8002 --ip=0.0.0.0 --epgimages=/var/cache/vdr/epgimages --channellogos=/usr/share/vdr-channellogos -Pdbus2vdr --shutdown-hooks=/usr/share/vdr/shutdown-hooks --shutdown-hooks-wrapper=/usr/share/vdr-plugin-dbus2vdr/shutdown-wrapper --upstart -Pepgsearchonly -Pwirbelscan -Pchannellists -Pconflictcheckonly -Pnoepg -Piptv -Pfemon -Pmenuorg -Pvnsiserver3 -t 10 -Pstreamdev-client -Pmarkad -Pdynamite


    Bei einem vdr -V taucht das Plugin auch nirgends auf.



    Hat hier jemand vielleicht eine idee, wie ich weiter kommen könnte?


    Danke & Gruß


    Timo

    OK,
    für mich heißt es dann erst einmal abwarten und Tee trinken.


    Die Android Boxen werden wohl eher kein VDR bekommen.


    Ich denke Raspberry und Co brauchen eher noch eine Generation bis alles flüssig und guter Bildqualität läuft. (HDTV, deinterlace, ... )
    Die Ansätze sind gut doch werden qualitativ meine VDR mit NVIDIA GraKa wohl noch nicht ersetzten können.


    Danke & Gruß
    TimUx

    Hallo zusammen,
    Ich habe schon gesucht aber nicht wirklich etwas zu dem Thema gefunden.
    Vielleicht ist es auch einfach nicht machbar oder total bei den Haren herbei gezogen.


    Es gibt ja mittlerweile eine ganze Reihe an Android TV Sticks/Boxen/Player.
    Je nachdem mit etwas mehr RAM und CPU oder halt auch weniger.


    Ich slebst habe ein MyGica ATV520 zum spielen. < Infos >
    HD Material wird Ohne Probleme abgespielt (auch 1080p), VDR Live TV über XBMC im großen und ganzen auch kein Problem.


    Mittlerweile habe ich für diverse Android TV Boxen auch eine "Standalone XBMC Firmware auf Linux basis" entdeckt.
    Beispiel: Pivos XIOS Media Player


    Da stellt sich mir die Frage, ob es generell Möglich wäre, diese Teile als VDR Clients zu nutzen.
    Sprich Irgendwo ein VDR-Server mit TV Karte(n) und so eine Box mit Linux-Firmware und VDR als Client (epgsync, nfs-client, remoteosd, remotetimers, streamdev-client, svdrpservice,...)
    Was mich am XBMC im moment noch am meisten stört, ist dass die Schnittmarken nicht bearbeitet/berücksichtig werden, deshalb würde ich bei einem Client ungern auf den eigentlichen VDR verzichten.


    Gibt es schon überlegungen in diese Richtung oder vielleicht schon ertse Ansätze/Betas?


    Danke & Gruß


    TimUx