Posts by goldfisch

    Vielen Dank für die Hinweise. Leider erhalte ich noch kein Bild.


    Als Anhang habe ich den vollständigen Log (journalctl -b -l > log.txt) beigefügt.

    Grafikkarte: GeForce GT 730

    lspci -nnk | grep -i VGA -A2

    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208B [GeForce GT 730] [10de:1287] (rev a1)

    Subsystem: ZOTAC International (MCO) Ltd. GK208B [GeForce GT 730] [19da:4360]

    Kernel driver in use: nvidia


    Rechner: ESPRIMO P900

    Mainboard: Fujitsu S26361-D3062-A1

    CPU: Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz


    Hat jemand einen Tipp für mich?


    Vielen Dank!



    Tony

    Files

    • log.txt

      (143.15 kB, downloaded 13 times, last: )

    Hallo,


    ich habe meinen funktionierenden yavdr-ansible


    "apt-get update; apt-get dist-upgrade" ausgeführt (dabei wurde u. A. der Kernel von Kernel 5.08.0-48 auf 5.15.0-46 upgegraded) und anschließend auch das Installationsscript per

    "sudo -H ./install-yavdr.sh" ausgeführt.


    Leider habe ich nun kein Bild mehr ;(. Der Rechner startet, ich sehe den ersten blauen "Yavdr-Bildschirm", dann erscheint der Eingabepromt, dann kommt wieder ein "Yavdr-Bildschirm" auf dem er dann leider stehenbleibt.


    Den Inhalt von /var/log/syslog habe ich als Dateinanhang beigefügt. Hieran kann ich kein Problem erkennen.


    Wie komme ich wieder an ein Bild:/?


    Vielen Dank!


    Tony

    Files

    • syslog.txt

      (15.5 kB, downloaded 11 times, last: )

    Ich vermute die Fehlerursache in dem Log-Eintrag:


    ...

    Apr 3 00:31:32 vdrserver vdr: [1652] live: initial file cache has 82 entries and needs 376715 bytes of data!

    ...


    Ich habe zu diesem Fehler verschiedene Hinweise gefunden (z. B. Live zeigt nur Startseite an und friert bei Bedienung ein) leider aber nirgendwo eine Lösung :/.


    Hat jemand vielleicht Einen Tipp für mich?


    Vielen Dank!

    Tony


    P. S. Da das Thema "yavdr-ansible headless" auf "Proxmox LXC Container" mit Web-Zugriff per vdr-plugin-live vielleicht für mehrere User interessant sein könnte, würde ich - soweit es läuft - eine Beschreibung erstellen.

    Den Zusammenhang verstehe ich aber jetzt auch nicht, was soll das Vorhandensein des SSL Zertifikates mit dem Zugriff ohne https zu tun haben ?

    Da hast Du recht. Um alle sonstigen Fehlerursachen auszuschließen habe ich nochmals alles neu installiert. Beim ersten Versuch per http hatte ich möglicherweise nicht die korrekte IP. Das würde das Verhalten erklären. Jetzt klappt aber der Zugriff per Firefox mit http und https.



    Und noch eine Anmerkung: NFS und unprivilegierter Container geht soweit ich weiß auch nicht. Und würde auch kein Sinn machen, weil die User ID aus Sicht des Hosts keinem User zuzuordnen sind.

    Ich habe die Installation hier auf einem privilegierten Container (Unprivilegierter Container: nein) erstellt. NFS brauche ich nicht. Ich habe NFS bei den Features des LXC-Containers ausgewählt, da ansonsten die Installation bei autofs meckert.

    Hallo,

    Code
    1. sudo openssl req -new -x509 -keyout /var/lib/vdr/plugins/live/live-key.pem -out /var/lib/vdr/plugins/live/live.pem -days 9999 -nodes -batch
    2. sudo chown -R vdr:vdr /var/lib/vdr/plugins/live

    Gruss

    Wolfgang

    Vielen Dank, damit erscheint die Fehlermeldung nicht mehr und ich kann mich beim vdr-plugin-live am Client per Firefox anmelden. In der Weboberfläche erhalte ich jedoch den Hinweis: Kann Infobox nicht aktualisieren. Es wird auch kein Sender und keine Aufnahme angezeigt.


    In der /var/log/syslog | grep live steht:

    Apr 3 00:31:32 vdrserver vdr: [1652] loading plugin: /usr/lib/vdr/plugins/libvdr-live.so.2.4.6

    Apr 3 00:31:32 vdrserver vdr: [1652] live: INFO: validating server ip '0.0.0.0'

    Apr 3 00:31:32 vdrserver vdr[1652]: INFO: validating live server ip '0.0.0.0'

    Apr 3 00:31:32 vdrserver vdr: [1652] initializing plugin: live (2.3.1): Live Interactive VDR Environment

    Apr 3 00:31:32 vdrserver vdr: [1652] starting plugin: live

    Apr 3 00:31:32 vdrserver vdr: [1652] live: initial file cache has 82 entries and needs 376715 bytes of data!

    Apr 3 00:31:32 vdrserver vdr: [1663] live: INFO: attempt to listen on ip = '0.0.0.0'


    Wenn ich auf der Weboberfläche im Menü andere Reiter anklicke stürzt der VDR ab und startet neu (vollständiger /var/log/syslog siehe Dateianhang.



    Vielen Dank für Euere Tipps



    Tony

    Files

    • syslog.txt

      (9.05 kB, downloaded 100 times, last: )

    Hallo,


    ich würde gerne auf meinem headless (Keller) - VDR das Live-Plugin zum Laufen bringen. Leider klappt das nicht.


    Vielleicht habe ich ansible hier falsch verstanden, aber ich habe das Plugin bereits in die group_vars/localhost eingetragen:


    ...

    vdr_plugins:

    - vdr-plugin-devstatus

    - vdr-plugin-markad

    - vdr-plugin-live

    ...


    Es wurde aber nicht mit installiert ;(.


    Wenn ich per apt-get install -f vdr-plugin-live installiere klappt die Installation, es läuft aber nicht :wand.


    Wenn ich http://ip-des-vdrservers:8008 eingebe erhalte ich nur eine Netzwerk Zeitüberschreitung.


    In der /var/log/syslog steht:


    ...

    Apr 2 18:12:06 vdrserver vdr: [4424] live: INFO: attempt to listen on ip = '0.0.0.0'

    Apr 2 18:12:06 vdrserver vdr: [4424] live: ERROR: Unable to load cert/key (/var/lib/vdr/plugins/live/live.pem//var/lib/vdr/plugins/live/live-key.pem): Datei oder Verzeichnis nicht gefunden

    ...


    Das klingt nach einem fehlendem Zertifikat - oder? Woher bekomme ich das?


    Vielen Dank!



    Tony

    Da du die headless-Session in der Konstellation vermutlich nicht brauchst (die kann man z.B. für den Automount von Datenträgern über udiskie nutzen), kannst du die Rolle im Playbook auch auskommentieren (https://github.com/yavdr/yavdr…/yavdr07-headless.yml#L15).

    Vielen Dank für den Hinweis. Mit diesem Tipp und folgenden Schritten läuft die Installation nun durch.


    1. In Proxmox privilegierten LXC Container erstellen (Unprivilegierter Container: nein)


    2. Features: hier habe ich alle ausgewählt (sonst meckert autofs später, vermutlich reichen auch alle, die mit Netzwerk zu tun haben)


    3. Vorbereitung (sonst meckert später die Installation). -> dieser Schritt wird nicht benötigt. Vielen Dank an seahawk1986

    apt install cloud-init


    4. Installation gem. Doku

    apt install git

    git clone https://github.com/yavdr/yavdr-ansible

    cd yavdr-ansible


    5. Anpassung der Konfiguration:

    host_vars/localhost individuell anpassen


    6. Als LXC-Container unter Proxmox müssen in der yavdr07-headless.yml noch folgende Dinge deaktiviert werden:

    # - headless-session # set up a headless systemd user session

    , e.g. for udiskie

    # - grub-config


    Ansonsten läufti die Installation nicht fehlerfrei durch.


    7. Umsetzung der geänderten Konfiguration:

    sudo -H ./install-yavdr-headless.sh



    Mein einziges Problem ist nun, dass das vdr-plugin-live nicht funktioniert. Hierzu habe ich einen eigenen Thread (yavdr-ansible - vdr-plugin-live) gestartet.


    Vielen Dank!



    Tony

    Was ist für dich 'die Lösung' ?


    Du versuchst ein vier Jahre nicht gewartetes und nie wieder unzudatendes Paket neu zu installieren, ich rate dir davon ab.

    O. K. Vielen Dank fürs "auf die Sprünge" helfen. Jetzt habe ich es erst kapiert, dass damit gemeint war, w-scan aus der group_vars/localhost auszukommentieren.


    Leider läuft damit die Installation auch noch nicht fehlerfrei durch.

    Hallo,


    ich möchte gerne meinen headless Keller-VDR mit yavdr-ansible neu installieren. Leider bricht das "./install-yavdr-headless.sh" mit dieser Fehlermeldung ab:


    ...

    TASK [headless-session : enable services for the user session] **************************************************************************************************************************************************************************************************************************************************************

    failed: [localhost] (item=tmux.service) => {

    "ansible_loop_var": "item",

    "changed": false,

    "cmd": "/bin/systemctl --user",

    "item": "tmux.service",

    "rc": 1

    }


    STDERR:


    Failed to connect to bus: Datei oder Verzeichnis nicht gefunden




    MSG:


    Failed to connect to bus: Datei oder Verzeichnis nicht gefunden

    failed: [localhost] (item=udiskie.service) => {

    "ansible_loop_var": "item",

    "changed": false,

    "cmd": "/bin/systemctl --user",

    "item": "udiskie.service",

    "rc": 1

    }


    STDERR:


    Failed to connect to bus: Datei oder Verzeichnis nicht gefunden




    MSG:


    Failed to connect to bus: Datei oder Verzeichnis nicht gefunden


    RUNNING HANDLER [Start VDR] *************************************************************************************************************************************************************************************************************************************************************************************************


    PLAY RECAP ******************************************************************************************************************************************************************************************************************************************************************************************************************

    localhost : ok=75 changed=6 unreachable=0 failed=1 skipped=8 rescued=0 ignored=0


    Leider verstehe ich nicht, was mir das sagen soll. Die Installation erfolgt auf Proxmox auf einem priviligierten LXC Container.


    Hier noch die group_vars/localhost



    Vielen Dank!



    Tony

    Hallo,


    vielen Dank für die vielen guten Tipps. Ich bin zwischenzeitlich einen kleinen Schritt weiter. Nachdem ich sowohl eine channels.conf als auch systemctl enable wait-for-dvb@${ADAPTER_NR}.service direkt in der group_vars/all gesetzt habe, und anschließend per "sudo -H ./install-yavdr.sh" neu gebaut habe erhalte ich


    a) das OSD (immer)

    b) zeitweise ein Fernsehbild, das aber irgendwann einfriert (teilweise kann ich noch umschalten).


    Ich habe deshalb verschiedene Ausgabeplugins ausprobiert:


    • vdr-plugin-softhddevice -> Fernsehbild friert nach Umschalten ein, OSD geht (vollständige /var/log/syslog siehe Anhang)
    • vdr-plugin-softhddevice-ffmpeg-2.8-> Fernsehbild friert nach Umschalten ein, OSD geht
    • vdr-plugin-xineliboutput -> VDR startet nicht wegen folgender Fehlermeldung:
    Code
    1. Dec 16 20:24:07 vdr3 systemd[1390]: Started start vdr-sxfe as vdr frontend.
    2. Dec 16 20:24:07 vdr3 systemd[1821]: vdr-sxfe.service: Failed to execute command: No such file or directory
    3. Dec 16 20:24:07 vdr3 systemd[1821]: vdr-sxfe.service: Failed at step EXEC spawning /usr/bin/vdr-sxfe: No such file or directory
    4. Dec 16 20:24:07 vdr3 systemd[1390]: vdr-sxfe.service: Main process exited, code=exited, status=203/EXEC
    5. Dec 16 20:24:07 vdr3 systemd[1390]: vdr-sxfe.service: Failed with result 'exit-code'.
    6. Dec 16 20:24:08 vdr3 systemd[1390]: vdr-sxfe.service: Scheduled restart job, restart counter is at 1.
    7. Dec 16 20:24:08 vdr3 systemd[1390]: Stopped start vdr-sxfe as vdr frontend.


    Meine SAT-Karte hat zwei Anschlüsse. Ich habe aber nur ein SAT-Kabel angeschlossen. Kann dies das Problem verursachen?



    Hat jemand vielleicht noch Tipps für mich, wie ich zu einem dauerhaften Fernsehbild komme?

    Vielen Dank!



    Tony

    Files

    • Syslog.txt

      (24.11 kB, downloaded 101 times, last: )
    Quote

    Und auch dem VDR als /var/lib/vdr/channels.conf mit passenden Rechten untergeschoben (kann man auch von Playbook machen lassen: https://github.com/yavdr/yavdr…/focal/group_vars/all#L44

    Die Rechte hatte ich angepasst:



    Sorry - hatte vergessen zu erwähnen, dass ich auch das Warten auf die DVB-Tuner per "systemctl enable wait-for-dvb@$1.service; systemctl enable wait-for-dvb@$2.service" eingestellt hatte

    Auch nach einem Restart von VDR erhalte ich leider kein Bild.

    Vielen Dank - ich glaube, die richtigen Treiber werden geladen - oder?


    nvidia-smi


    lsmod|grep nvidia

    nvidia_uvm 36864 0

    nvidia 10584064 56 nvidia_uvm

    drm 491520 3 nvidia



    modinfo nvidia

    Hallo,


    nach der Installation von yavdr-ansible bleibt leider mein Bildschirm schwarz. Der VDR läuft aber.



    Mein Vorgehen bei der Installation:

    • Zunächst Ubuntu 20.04 Server Installation (vom ISO) + apt-get update + apt-get dist-upgrade
    • yavdr07.yml ohne Veränderungen
    • Installation ohne Fehlermeldungen
    • channels.conf erstellt per w_scan -f s -s S19E2 > channels.conf




    Hardware:


    • NVIDIA Corporation GT218 [GeForce 210]
    • DVBSky S952 Ver2.0a


    Hier meine bisherigen Findings:


    service vdr status


    lspci -nnk | grep -i VGA -A2



    glxinfo | grep "OpenGL core profile version string"

    Error: unable to open display


    tail -f /var/log/syslog | grep softhddev

    bei gleichzeitigem service vdr start

    -> Hier gibt es Rückmeldungen, die ich nicht interpretieren kann.


    ps -aux | grep vdr



    Leider weiß ich nun nicht mehr weiter.


    Kann mir hier irgendjemand einen Tipp geben?



    Viele Grüße


    Tony