Posts by ollo

    Hi mtron,


    das ist ja goil - habe mir nach dieser Anleitung ffmpeg selber gebaut und kann nun mit vielen fps (30..90) auf dem RasPi transcodieren :tup


    ffmpeg -c:v mpeg2_mmal -i /srv/vdr/video/some.rec/00002.ts -vf yadif=0 -c:v h264_omx -c:a copy -b:v 1500k filme/test.mp4

    ffmpeg version N-91046-g974eb4aaaa Copyright (c) 2000-2018 the FFmpeg developers   built with gcc 6.3.0 (Raspbian 6.3.0-18+rpi1+deb9u1) 20170516   configuration: --arch=armhf --target-os=linux --enable-gpl --enable-omx --enable-omx-rpi --enable-nonfree --enable-mmal --prefix=/usr/local --enable-libx264 --enable-libx265

    ...

    frame= 2516 fps= 41 q=-0.0 Lsize=   21964kB time=00:01:41.53 bitrate=1772.0kbits/s dup=7 drop=0 speed=1.66x


    Gruß, ollo

    Hi Kibu,


    TS und MP4 sind Container Formate, die Audio und Video (und andere) Pakete enthalten koennen. Diese lassen sich recht einfach von TS nach MP4 umkopieren, auch auf einem RasPi:


    ffmpeg -i datei.ts -vcodec copy -acodec copy datei.mp4


    Falls Du wirklich umcodieren willst, geht das auf dem RasPi eventuell per omxtx in Hardware:


    https://github.com/dickontoo/omxtx


    Gruss, ollo

    Problem erkannt und gebannt :strike1


    Ich habe hier 2 verschiedene libEGL installiert. Eine kommt aus dem libegl1-mesa package (libEGL.so) und eine aus dem libraspberrypi0 package (libbrcmEGL.so). Im Makefile des rpihddevice wird bei LDLIBS "-lEGL" verwendet. Das habe ich auf "-lbrcmEGL" geändert und neu gebaut - schon funzt es wieder :strike2 Offenbar kommen sich die 2 libs sonst in die Quere.


    Gruß, ollo

    Hallo,


    ich habe neulich auf Raspbian Stretch aktualisiert und seit dem Probleme mit der OSD Darstellung des rpihddevice - es kommt keins. Im syslog ist folgendes dazu zu finden:



    Die Videoausgabe funktioniert jedoch prima. Offenbar hat sich was an den EGL/OpenVG libs geändert!?? Gibt es dafür schon eine Lösung?


    Danke & Gruß, ollo

    mikeM - prima, darauf hätte ich auch kommen können :wand Offenbar hat es die Tastatur gehimmelt. Ohne bootet der PC durch bis zur Passwortabfrage und dort fängt er jetzt an zu spinnen sobald ich die Tastatur wieder anschließe. Auch ein USB Adapter für den PS2 Anschluss der Tastatur hilft da nicht ;(


    wirbel & 3PO - das war auch mein erster Gedanke, der PC hängt aber 24/7 am Netz und sollte somit unabhängig von der Batterie sein. Die BIOS Daten hat er sich ja auch gemerkt.


    Danke, ollo

    Hallo,


    mein Desktop PC bootet plötzlich nur noch ins BIOS. Jedesmal erscheint unaufgefordert "Prepare to enter Setup...", also genau das, was man beim drücken von "Entf" beim Booten erreicht. Ein komplettes Rücksetzen des BIOS hat nix gebracht. Die Platten werden alle erkannt, sowohl IDE als auch SATA am primären und sekundären Controller, es wird aber ums Verrecken nicht von den angeschlossenen Drives gebootet.


    Es handelt sich um ein ein altes Gigabyte AM3 Motherboard (GA-MA78GM-S2H) mit AMD Phenom II X6 1055T CPU. Wat nuh?


    Danke & Gruß, ollo

    Hallo,


    ich habe genau die Konfiguration am Laufen - Wetek Play als VDR Server unter Ubuntu und RPi1 bzw. RPi3 als Client (hier auch Ubuntu bzw. Rasbian). Die Aufnahmen landen per NFS auf der NAS, die von beiden gemountet wird. Funzt wunderbar bis auf die bekannten Schwächen der DVB-S2 Tuner - hin und wieder Artefakte, aber sehr wenige ca. 1x pro Stunde oder noch weniger. Die Play läuft 24/7, die Clients nach Bedarf, die NAS legt sich zwischendurch schlafen. Die VDRs am Server und Clients habe ich selber gebaut bzw. z.T. auf eTobi zurückgegriffen.


    Mit OE bzw. LE auf der Play bin ich nie warm geworden - obwohl ein Kombibetrieb als 24/7 VDR Server mit gelegentlicher Smart-Clientfunktion am WoZi TV schon was hätte...


    Gruß, ollo

    Hallo Andreas,


    ... das ist ganz schwer zu sagen. Ich habe mal Valgrind auf den VDR angesetzt, aber nix finden können. Ich benutze folgende Plugins:


    vdr -d -Pdummydevice -Pepgsearch -Plive -Pstreamdev-server -Psvdrposd


    Allerdings kann das Problem auch von ganz anderer Seite stammen - dem kernel vielleicht (3.10.94) bzw. die Treiber für den AmLogic SOC? Jedenfalls wird der Swap nie verwendet, nach Nutzung von "apt-get dist-upgrade" ist viel Speicher weg und wird nicht wieder freigegeben. Außerdem gibt es ab einem gewissen low-memory Stand Fehlermeldungen im syslog:

    Quote

    May 17 19:54:28 weplay kernel: [1374554.115231@1] balance_pgdat end zone=1, pgdat_is_balanced=0
    May 17 19:54:28 weplay kernel: [1374554.115446@1] balance_pgdat, nr_reclaimed=10
    May 17 19:54:28 weplay kernel: [1374554.115493@1] balance_pgdat end zone=1, pgdat_is_balanced=0
    May 17 19:54:28 weplay kernel: [1374554.115657@1] balance_pgdat, nr_reclaimed=25

    Gruß, ollo

    ... und hier mal mein headless server auf der Wetek Play (armhf) bei Aufnahme & Stream einer Sendung auf WDR-HD:


    Code
    1. top - 20:33:45 up 13 days, 22:28, 1 user, load average: 3,52, 3,12, 2,81
    2. Tasks: 87 total, 3 running, 84 sleeping, 0 stopped, 0 zombie
    3. %Cpu0 : 9,4 us, 30,9 sy, 4,2 ni, 41,0 id, 1,7 wa, 0,0 hi, 12,8 si, 0,0 st
    4. %Cpu1 : 1,4 us, 62,5 sy, 1,7 ni, 32,1 id, 2,4 wa, 0,0 hi, 0,0 si, 0,0 st
    5. KiB Mem: 821300 total, 539300 used, 282000 free, 146864 buffers
    6. KiB Swap: 524284 total, 0 used, 524284 free. 140008 cached Mem
    7. PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    8. 21100 tom 20 0 409152 189848 6140 S 50,5 23,1 2724:53 vdr


    Allerdings frisst irgendwas Speicher, wenn auch sehr langsam. Nach 2..3 Wochen braucht's einen Reboot :rolleyes:


    Gruß, ollo

    Danke Thomas!


    Vielleicht zieht ja e-Tobi mit/nach und baut uns ein neues armhf Packet?! Im Repo ist ja noch Version 1.0.0. Wie kann man Tobias erreichen?


    Mein Versuch den Stand vom git "out-of-tree" zu bauen funktionierte zwar, jedoch beim Laden kommt:



    Code
    1. Apr 23 19:02:57 raspi3 vdr: [4846] loading plugin: /usr/lib/vdr/plugins/libvdr-rpihddevice.so.2.2.0Apr 23 19:02:57 raspi3 vdr: [4846] ERROR: /usr/lib/vdr/plugins/libvdr-rpihddevice.so.2.2.0: undefined symbol: vcsm_lock



    Danke & Gruß, ollo