Posts by Unimatrix0

    Seit ich die von Dir genannten Einträge in der advancedsettings.xml drinn habe funktionieren sowohl Internet-Radio-Streams (getestet hab ich nur das Icecast-Addon, weil Shoucast ja momentan nicht geht) sowie auch Playlisten wieder.

    Hi Asshep, hi Forum!


    Ich kenne das Problem auch.
    Dein Workaround funktioniert übrigens bei mir, asshep, danke dafür.
    Ich hab noch einen anderen "Workaround" gefunden.
    Habe schon seit längerem, durch ein Forum so einen Eintrag in der .asoundrc drinn, der dazu da ist, dass die Dynamik etwas komprimiert wird, sprich, ich schau eben auch Nachts mal gern einen Film, ohne das Ganze Haus dabei zu wecken.
    Die muss um Home-Verzeichnis liegen und sieht bei mir so aus:


    Wenn ich nun in XBMC/System/System/Audio-Hardware das Audio Ausgabegerät auf Benutzerdefiniert stelle und eine Zeile darunter "ladcomp" (ohne Anführungszeichen) eingebe, dann hab ich das Problem mit dem Abspielen der Musik nicht.
    Natürlich ist das nicht brauchbar um Musik zu hören, ist ja auch eher für Filme gedacht gewesen, aber ich dachte, ich erwähne es hier trotzdem mal. Vielleicht bringt es ja jemand auf die richtige Spur, wo der Fehler liegen könnte.
    Gruss Ux0

    Wollte das eben auch testen, doch bei mir scheiterts immer schon am Anfang.


    Weiss jemand was da falsch läuft ?

    Hi Omek!


    Als ich mich vor einigen Wochen damit beschäftigte,hatte ich die selben Probleme. Damals konnt ich jedoch mit dem SVN Repo Installer 1.7.5 noch was sehen (Schriften) und auch einige Plugins/Scripte erfolgreich installieren. (z.B. Apple Movie Trailers, VideoDevil). Viele Sachen gingen aber einfach nicht oder führten zu Hängern/Fehlern/Abstürzen.
    Bin schonmal froh, nicht der Einzige zu sein und dass sich pingpong die Sache anschauen will, wenn er wieder zurück ist.


    Etwas was ich auch immer mal wieder versucht habe, war XBMC mit --external-python oder sogar (wie jetzt gerade) mit --enable-external-libraries zu konfigurieren und anschl. make.
    Die Ergebnisse waren jedoch so unterschiedlich, dass ich nichts kontretes dazu sagen kann, ausser, dass es vielleicht ein Versuch wert sein könnte.


    Viel Glück oder noch etwas Geduld
    Unimatrix0

    Quote

    Originally posted by lemming71


    Hmmm.. ist es dann von extern möglich zu erfahren welches Programm der Server gerade zeigt? Wenn ja, dann könnte man dies ja dazu nutzen das gerade laufende anzufordern und damit eine Umschaltung verhindern.
    Wäre das realisierbar und wenn ja, wie?


    svdrpsend.pl CHAN
    zeigt den aktuell eingestellten Sender auf dem VDR, wenn das hilft.

    Hi borge,


    um gleich auf deinen letzten Satz zu antworten: es geht beides.
    Da sich bisher noch kein linvdr-ler gemeldet hat: am besten schaust mal auf deinem System obs da schon ein mencoder installiert ist.
    Wenn ja, was kann der?
    Die Ausgabe von: mencoder -ovc help
    wäre z.B. interessant.
    Aber vorerst müsst dann noch das mit dem port 3000 und der Kanalliste bei dir funken. Hallo Linvdrler helft uns mal bitte ein Wenig auf die Sprünge an was das noch liegen könnte. :-) Dazu fällt mir auch nix mehr ein im Moment.


    Gruss
    Unimatrix0


    Edit und Nachtrag: Never touch a running system möcht ich nur noch auf den Weg mitgeben. Habs auch schon oft schmerzlich erfahren müssen. Wenn nicht weiter kommst fragst lieber nochmal speziell bei den linvdr-lern hier im Forum nach.

    Sorry aber ich glaub nicht, dass ein 450er reicht. Ich hab einen alten Laptop, Celeron 650er, der reicht leider auch nicht ganz für den unveränderten Stream, der vom Sat kommt. Da ist dann die Sache mit dem externremux.sh sehr praktisch. Ich lass die Auflösung/Datenrate etwas runterrechnen, schon gehts.
    Als Player ist dann VLC sehr praktisch.


    Eine andere Möglichkeit wär noch, dem 450er eine FF-Karte oder DXR3 zu verpassen und dort ebenfalls VDR zu installieren, als reiner Streaming-Client. Dann sollten die 450 MHz noch lange genug sein.
    Hast nicht zufällig noch sowas rumliegen, oder ?
    Wobei das ist auch nicht so ne tolle Lösung. Die DXR3 zickt leider recht oft (jedenfalls meine) und die FF's sind einfach zu teuer für sowas.

    Hallo Borge,


    freut mich dass es doch noch (mehr oder weniger) geklappt hat.
    Schon komisch dass bei dir die Kanalliste auf port 3000 nicht kommt.
    Für den MediaClient ist das allerdings nicht wirklich wichtig. Ist für mich oft einfach eine schnelle Art, zu schauen ob Streamdev erreichbar istl.
    Da ich linvdr nicht gut kenne, weiss ich nicht ob da ev. eine Firewall blockt oder an was das noch liegen könnte.


    Zum Streamtyp: Der ist ja auch nur für Http-verbingungen relevant. Da nehm ich normalerweise PES oder PS bzw. Extern (eine tolle Sache übrigens!).
    Falls dich das genauer interessieren sollte, findest du in der Readme zum Streamdev und im VDRWiki mehr infos.


    Läuft denn bei Dir nun alles, was mit dem VDRClient zusammen hängt ?

    Hallo borge


    Tönt für mich etwas nach fehlendem Eintrag in der streamdevhosts.conf.
    Wenn Du auf der Windows-Kiste einen Browser startest und dort:
    http://vdrip:port
    (wobei bei mir vdrip=192.168.1.200 und port=3000 ist)
    in der Adresszeile eingibst und enter drückst...kommt da eine Kanalliste ?
    Sollte kommen, wenn nicht, schau mal die besagte Datei an und trage dort die IP deines Win-Rechners oder dein gesamtes subnet ein. Danach VDR neu starten und nochmals mit dem Browser testen ob nun die Kanalliste kommt.


    Des weiteren mal innerhalb von VDR in den Settings/Plugins/Streamdev schauen ob da "VDR-zu-VDR Server starten" auch aktiviert wurde.


    Viel Glück
    Unimatrix0

    rdnzl
    Leider keine Neuigkeiten. Ich habs auch nicht mehr gross versucht.
    Aber ich hab auf einer 2. Kiste mal wieder x-vdr unter Kanotix getestet. Ist einfach super das Script von Zulu! Da funktioniert Playlist (und das meiste andere auch), wie erwartet.


    Da ich vor 3 1/2 Jahren mit Linux und VDR angefangen habe und immmer noch mit dem selbern System arbeite - das inzwischen gespickt mit fehlern sein dürfte - überleg ich mir nun, ob ich nicht mal alles neu machen soll.


    Hoffe es kommt doch noch Licht in diese Angelegenheit.

    viking
    Ich würd Deinen Patch gerne testen :)
    Edit: hab ihn gefunden, thx
    Edit29876493: Leider der selbe Fehler auch mit deinem Patch. :-( Sorry
    Kann sein, dass ich was falsch gemacht habe, bin müde jetzt, werde morgen nochmal schauen.


    rdnzl
    Kommt Zeit kommt Rad...ähh Rat.
    Ich vermute wir machen beide den selbern Fehler.
    Da wir wahrscheinlich beide bisher den BP verwendeten, haben wir wohl auch beide das Pluginpaket von Frank benutzt und somit eine auf BP-Abgestimmte Version vom Playlist-Plugin. Welches zwar mit Ext.Patch kompliliert, aber nicht mehr läuft. Edit: Das ist wahrscheinlich Quatsch...war nur so ne Idee. Da aber mir Viking's Patch das selbe passiert...hmm die Sache ist Mysteriös :evil:

    Bei VDR-1.4.5 mit BigPatch funktioniert das Plugin bei mir. (Patch hab ich den letzten erhältlichen genommen und die (nicht wenigen) Rejects von Hand nachgetragen)
    Bei VDR-1.4.5 mit Extensions Patch V.10 kommt es auch bei mir zum genannten Fehler.


    Plain vanilla hab ich nicht getestet.


    Ich würde eine Weiterentwicklung, dieses nützlichen Plugins gerne sehen.


    d) mute


    Auch mir würde sowas nervlich manchmal gut tun. Vor allem wenn man bei der Aufnahme einschläft und dann irgendwann durch zu laute Werbung wieder geweckt wird. :motz2

    Sorry für die Frage, falls es schon beantwortet wurde, jedoch hab ich vergeblich nach einer Antwort gesucht.
    Wie ist es mit dem:

    Code
    1. make[1]: Entering directory `/usr/local/src/vdr-1.4.1-1/PLUGINS/src/mp3ng-0.0.9a'
    2. g++ -fPIC -g -O2 -Wall -Woverloaded-virtual -c -D_GNU_SOURCE -DVDRVERSNUM=10401 -DHAVE_IMLIB2 -DHAVE_SNDFILE -DHAVE_VORBISFILE -I../../../include bitmap.c
    3. bitmap.c: In static member function `static bool cMP3Bitmap::Available(const
    4. std::string&, int, int, int, int)':
    5. bitmap.c:96: `access' undeclared (first use this function)
    6. bitmap.c:96: (Each undeclared identifier is reported only once for each
    7. function it appears in.)
    8. make[1]: *** [bitmap.o] Fehler 1
    9. make[1]: Leaving directory `/usr/local/src/vdr-1.4.1-1/PLUGINS/src/mp3ng-0.0.9a'


    gibt es da schon Abhilfe für ?
    Wäre echt froh das geile Plugin auch mal durch den kompiler zu bekommen. ;(