Posts by mamomoz

    Hallo,

    ich nutzte softhddrm.


    Was muss ich einstellen, wenn libplacebo aktiviert werden soll?

    LIBPLACEBO ?=1

    oder

    LIBPLACEBO_GL ?=1


    oder beides?


    Was gibt es beim bauen von libplacebo zu beachten?


    Gruß

    Hallo,

    das hilft Dir jetzt nicht wirklich, aber ich nutze softhddrm mit kernel 5.4.81. Läuft top.

    Ich hatte dann mal Kernel 5.10.3 ausprobiert, da lief der Ton extrem asynchron zum Bild. > 2 Sekunden

    Im Log kam die Meldung "ERROR: 1 TS packet(s) not accepted in Transfer Mode".

    Vermutlich muss das Plugin noch auf den neusten Kernel angepasst werden.

    Gruß

    moz

    Woran kann das liegen?

    Ich antworte mir mal selbst: Weil es die Dateien banner1..2...3 eben nicht gibt in den Verzeichnissen zur Serie. Sie werden nicht mehr über Schnittstelle geholt, da sich die Schnittstelle geändert hat.


    Allerdings sind meist die Dateien poster1..2..3 vorhanden auch bei den Serien.

    Wem das vorerst reicht kann diesen Patch anwenden. (ist im übernächsten Post enthalten)

    Er er bewirkt, dass die Variable {posterpath} gefüllt wird im Skindesigner-Skin beim Kanalwechsel (displaychannel.xml),

    So lassen sich zur Serie zumindest die passenden Poster anzeigen.


    Bei mir sieht das dann so aus:


    Hallo,

    ich wollte in der ruhigen Zeit mal dieses Thema angehen. Wie oben erwähnt läuft dieses Dreigespann bei mir.

    EPGD scrapt Filme und Serien, die Dateien werden auch vom Plugin Scraper2vdr auf den VDR übertragen. (var/cache/vdr/scraper2vdr)

    Sowohl der movies-Ordner als auch der series-Ordner sind prall gefüllt.

    Allerdings werden im skindesigner nur Poster von Filmen angezeigt beim Umschalten. Serien werden trotz Einbindung in displaychannel.xml nicht angezeigt.

    Das Problem existiert in allen Skins.


    Meine erste Frage wäre: Läuft bei Euch die Anzeige von FIlmpostern und Serienbannern korrekt beim Umschalten? Oder hatte oder hat jemand das gleiche Problem?


    In bin bei den Plugins und epgd auf der neusten Version.

    Danke

    Ich rate jetzt mal, dass das vom nicht lesbaren Logo kommt (wg. "OSD size changed"). Kannst Du mal probieren, ob der Fehler noch kommt wenn Du in den Plugin-Einstellungen "Logo zeigen" auf Nein stellst?

    Leider nein. Er stürzt nach wie vor ab:

    Logos Aus.

    OSD mit GPU-Unterstützung = JA ( gesetzt in setup.conf

    Start VDR

    Hauptmenü aufrufen:

    Code
    1. Aug 30 18:04:53 RPI3-VDR vdr: [1078] rpihddevice: [OpenVG] failed to allocate -343937834px x -257953376px pixel buffer!
    2. Aug 30 18:04:53 RPI3-VDR vdr: [1078] rpihddevice: [OpenVG] CreatePixelBuffer error: illegal argument
    3. Aug 30 18:04:53 RPI3-VDR vdr: [1044] rpihddevice: [OpenVG] failed to create pixmap! (allocation failed)

    Moin !

    Funktioniert auf dem Raspi mit rpihddevice nur mit "OSD mit GPU-Unterstützung = Nein".


    Beim Umschalten auf "Ja" kommt:

    Code
    1. Aug 26 16:43:19 RPI3-VDR vdr: [1013] OSD size changed to 1920x1080 @ 1
    2. Aug 26 16:43:19 RPI3-VDR vdr: [1047] rpihddevice: cOvgThread() thread reset
    3. Aug 26 16:43:19 RPI3-VDR vdr: [1047] rpihddevice: [OpenVG] failed to allocate 0px x 0px pixel buffer!
    4. Aug 26 16:43:19 RPI3-VDR vdr: [1047] rpihddevice: [OpenVG] CreatePixelBuffer error: illegal argument
    5. Aug 26 16:43:19 RPI3-VDR vdr: [1013] rpihddevice: [OpenVG] failed to create pixmap! (allocation failed)

    dann aktiviere bitte mal in den Einstellungen -> Plugins -> skinElchiHD -> Kanal-Anzeige das "Schreiben der Logomeldungen ins Syslog", dann kannst Du im Syslog sehen was er versucht zu laden


    Ok so wird das geloggt:


    Code
    1. Aug 22 16:29:01 RPI3-VDR vdr: [604] skinElchiHD: no logo found for "Das Erste HD" (I-1-1019-10301) in /LOGOS_3


    In /LOGOS_3 liegt die Datei:

    Code
    1. -rw-r--r-- 1 root root 4206413 Aug 22 15:21 Dasding - Dark.png
    2. -rw-r--r-- 1 root root 4204917 Aug 22 15:21 Dasding.png
    3. -rw-r--r-- 1 root root 413 Aug 22 15:21 Das Erste - Dark.svg
    4. -rw-r--r-- 1 root root 862 Aug 22 15:21 Das Erste HD - Dark.svg
    5. -rw-r--r-- 1 root root 859 Aug 22 15:21 Das Erste HD.svg
    6. -rw-r--r-- 1 root root 410 Aug 22 15:21 Das Erste.svg
    7. -rw-r--r-- 1 root root 9076 Aug 22 15:21 Das Frankfurter Fernsehen.svg

    versuche mal, ob's damit gefixed wird:

    Das beschneidet zwar die Scroll-Länge, sollte jedoch bei noch nicht all zu langen Strings nicht auffallen



    Das klappt, Danke


    Aber er zeigt keine Channellogos an, obwohl Verzeichnis korrekt mitgegeben. DIe svg-Logos heißen so: Beispiel: Das Erste HD.svg

    Moin,

    für den Raspi mit rpihddevice muss man die GPU-Unterstützung abschalten sonst crasht vdr mit:


    Code
    1. Aug 22 14:50:58 RPI3-VDR vdr: [626] setting current skin to "ElchiHD"
    2. Aug 22 14:50:58 RPI3-VDR vdr: [626] loading /CONF/themes/ElchiHD-default.theme
    3. Aug 22 14:50:58 RPI3-VDR vdr: [626] OSD size changed to 1920x1080 @ 1
    4. Aug 22 14:50:58 RPI3-VDR vdr: [626] saved setup to /CONF/setup.conf
    5. Aug 22 14:50:58 RPI3-VDR vdr: [626] OSD size changed to 1920x1080 @ 1
    6. Aug 22 14:50:58 RPI3-VDR vdr: [626] rpihddevice: [OpenVG] cannot allocate pixmap of 8448px x 44px, maximum size is 2048px x 2048px!

    Was ich mich schon lange frage: kann man diese Myriaden von <softhddevice Abkömmlingen> aka {va-api, vdr-plugin-softhddevice-vpp_support_hevc, vdr-plugin-softhddevice-vdpau-vaapi-cuvid, vdr-plugin-softhddevice-FooBar} endlich mal wieder zu einem einzigen zusammenführen?


    Hallo. also ich bin dankbar, dass es hier Leute gibt die ihre private Zeit in diese Entwicklungen stecken. Ist halt kein kommerzielles Produkt, und auf Initiative von Freiwilligen angewiesen. Die Vielfalt/Redundanz die dabei entsteht muss man dann in Kauf nehmen und selber versuchen den Überblick zu behalten. Daher würde ich mich mit so einer Kritik ein wenig zurückhalten oder eben selber aktiv werden.